Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: Автозаполнение полей при выборе значения в другом поля в 1С 8.2 Управляемое приложение

Есть документ ЗаказКлиента, при его заполнении в режиме отладки вбиваются данные о клиенте, товарах с ценами и сумма к оплате формируется в поле ИтоговаяСумма .
Есть документ ПриходДенежныхСредств (клиент платит за товар), заполняется так: выбираем клиента, потом этот заказ, и есть ещё поле СуммаКОплате, которое должно заполняться автоматически при выборе Заказа (т.е. ИтоговаяСумма из заказа должна как то заполняться в поле СуммаКОплате), но не могу сделать так, прошу помощи, заранее спасибо большое).
Ответ: rfnfof, на поле Заказ событие ПриИзменении:
1C
1
2
3
4
5
6
7
8
9
&НаКлиенте
Процедура ЗаказПриИзменении(Элемент)
 Объект.СуммаКОплате = ПолучитьЗначениеРеквизитаНаСервере(Объект.Заказ, "ИтоговаяСумма ");
КонецПроцедуры
 
&НаСервере
Функция ПолучитьЗначениеРеквизитаНаСервере(Источник, Реквизит)
 Возврат Источник[Реквизит];
КонецФункции
Вопрос: Присвоить значения одного поля ввода другому полю в 1С:8.2 Управляемое приложение

Подскажите пожалуйста, у меня есть на форме в 1С 8.2 поля для ввода данных. Необходимо после ввода данных в одно поле присвоить это значение другому полю на форме программным способом (другими словами скопировать автоматически текст из одного поля в другое). Заранее спасибо за ваши советы.
Ответ: Спасибо, работает
Вопрос: Экспортная процедура в модуле управляемого приложения

В книге написано:
Экспортируемые переменные, процедуры или функции модуля управляемого приложения (у которых в заголовке указано ключевое слово Экспорт)
будут доступны:
■ в неглобальных клиентских общих модулях с установленным свойством Клиент (управляемое приложение);

Как вызвать экспортную процедуру модуля управляемого приложения из Общего модуля?
Ответ: И еще если изменять свойства общего модуля среду выполнения, нужно закрыть и заново открыть общий модуль, чтобы был доступ к экспортным процедурам Модуля управляемого приложения. Без этого синтаксическая ошибка.
Вопрос: Как при выборе значения в поле ввода ограничить список выбора для типа "Справочник"?

Одно из полей табличной части документа задано типом СправочникСтатьиЗатрат. При выборе элемента в соответствующем поле ввода по умолчанию появляется форма выбора, где можно выбрать любой элемент из этого справочника. А необходимо наоборот, ограничить список выводимых для выбора значений, наложив определенные условия. Как можно это реализовать?
Ответ:
Спасибо за информацию. У меня такая же задача, правда получилось немного по другому. Вместо ФормаВыбора.СправочникСписок.Отбор, ФормаВыбора.Отбор, на СправочникСписок ругается. И еще, когда открывается список справочника, установленный отбор зашит жестко, при этом другие отборы дополнительно, можно устанавливать, (что хорошо). Теперь новая задача, ищу как отсортировать элементы в открывшейся форме по коду, есть предложения?

Процедура ТПНоменклатураТипПоУлТипПоУЛПрисвоитьНачалоВыбора(Элемент, СтандартнаяОбработка)
СтандартнаяОбработка = Ложь;
пПВХТипПоУпаковочномуЛисту=ПланыВидовХарактеристик.СвойстваОбъектов.НайтиПоНаименованию("Тип по упаковочному листу");
ФормаВыбора = Справочники.ЗначенияСвойствОбъектов.ПолучитьФормуВыбора(,Элемент);
ФормаВыбора.Отбор.Владелец.ВидСравнения = ВидСравнения.Равно;
//(тут СправочникСписок - это название твоего табличного поля на форме выбора справочника, так что оно может быть другим в твоём случае)
ФормаВыбора.Отбор.Владелец.Использование = Истина;
ФормаВыбора.Отбор.Владелец.Значение = пПВХТипПоУпаковочномуЛисту;
ФормаВыбора.Открыть();
КонецПроцедуры
--- Объединение сообщений, 24 мар 2016 ---
Нашел
ФормаВыбора.Порядок.Установить("Код");
уже после открытия формы
Вопрос: Сделать интерфейс управляемого приложения из обычного

Приветствую, Форумчане!

Имеется приложение скажем "Розница" 2.0 1с8.2 обычное.

Возможно ли сделать из него интерфейс как у управляемого приложения.

В свойствах конфигурации поставил в "Основной режим запуска" - управляемое.

Захожу в подсистемы, но они не редактируются
Ответ: Ukraina, Можно.
Просто снимите с поддержки те объекты, что будете править.
Ну и учитывайте, что интерфейс то можно сделать, но без переписывания форм на управляемые все равно полноценно работать не получится.
Вопрос: Печать штрихкода в самописном управляемом приложении

Приветствую, Форумчане!

Самописная конфигурация, 1с8.2, управляемое приложение.

Очень простая форма, вводится некоторые данные и при записи генерируется штрих код на основе номера документа. Генерация штрихкода проходит нормально (Поле "Кодировка")

Создал Макет и сделал как ранее в обычном приложении: вставил объект 1с:Печать штрихкодов (элемент). Далее в теле кода добавил:

Шапка.Рисунки.ШК.Объект.Сообщение = Кодировка;
		Шапка.Рисунки.ШК.Объект.ТекстКода = Кодировка
		Шапка.Рисунки.ШК.Объект.КонтрольныйСимвол = Прав(Кодировка,1);


Результат ничего не дал... Почитал, нашел ссылки, что нужно вытаскивать что-то из УТ11 и вставлять что-то в самописное произведение. Типа в 8.2 и 8.3 всё сделано по-другому.

Может есть более простой способ? Ну трудно верится, что с каждой новой версией платформы 1с усложняет жизнь программистам :-(

Пробовал даже шрифт подменить в поле Макета, но халява не прошла...

Посоветуйте словом или грамотный ресурс, где просто и спокойно описан метод печати штрихкода в данной ситуации.
Ответ:
Ukraina
Посоветуйте словом или грамотный ресурс, где просто и спокойно описан метод печати штрихкода в данной ситуации.
на мисту ходил? инфостарт читал?

- тема про торговое оборудование. Можно туда написать свой опіт чтобі другие тоже знали.
- раздел по управляемым формам 8.2 и 8.3.
- тема про штрихкод.

(лень было оформлять гипертекстовыми ссылками).
Вопрос: УФ.Выбор значения из списка. Ошибка при передачи с клиента на сервер.

Доброго времени суток!
8.3.6.
Не можете помочь.Есть проблема с УФ.
При выборе значения из списка появляется ошибка.
Понимаю, что передаю на сервер не то. Но как сделать не могу понять

Ошибка передачи данных между клиентом и сервером. Значение недопустимого типа.
по причине:
Ошибка преобразования данных XDTO:
Запись значения свойства 'param':
    форма: Элемент
    имя: {
по причине:
Ошибка отображения типов:
Отсутствует отображение для типа 'ЭлементСпискаЗначений'



&НаКлиенте
Процедура АдресаВыгрузкиНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    
    СтандартнаяОбработка = Ложь;
    
    Список=СписокАдресаВыгрузки(Объект.ДатаНачала,Объект.ДатаОкончания,Объект.Организация);
    СписокВыбора = Новый СписокЗначений;

    Для Каждого Сп из Список.Адреса Цикл
        СписокВыбора.Добавить(Сп.Значение,Сп.Представление);
    КонецЦикла;
    
    ДопПараметры = Новый Структура;
    ОписаниеОповещения = Новый ОписаниеОповещения("ВыборСписокАдресаВыгрузки",ЭтаФорма,ДопПараметры);
    ПоказатьВыборИзСписка(ОписаниеОповещения,СписокВыбора);

    КонецПроцедуры

Процедура ВыборСписокАдресаВыгрузки(Элемент, Параметры) Экспорт
    
    Если Элемент <> Неопределено  Тогда 
        Объект.АдресаВыгр<p class="indent">узки = Элемент.Значение; 
        
        Сообщить(Элемент.Значение);
    КонецЕсли;   

КонецПроцедуры

 &НаСервереБезКонтекста
 Функция СписокАдресаВыгрузки(ДатаНачала,ДатаОкончания,Организация)
     
    Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |    ДополнительныеСведения.Значение КАК Адрес
        |ИЗ
        |    РегистрСведений.ДополнительныеСведения КАК ДополнительныеСведения,
        |    Документ.РеализацияТоваровУслуг.Услуги КАК РеализацияТоваровУслугУслуги
        |ГДЕ
        |    ДополнительныеСведения.Объект=РеализацияТоваровУслугУслуги.Номенклатура
        |    И ТИПЗНАЧЕНИЯ(ДополнительныеСведения.Объект) = ТИП(Справочник.Номенклатура)
        |    И ДополнительныеСведения.Свойство.Наименование=&ДопСвед
        |    И НЕ РеализацияТоваровУслугУслуги.Ссылка.ПометкаУдаления
        |    И РеализацияТоваровУслугУслуги.Ссылка.Организация = &Организация
        |    И РеализацияТоваровУслугУслуги.Ссылка.Дата МЕЖДУ &ДатаНачала И &ДатаОкончания
        |СГРУППИРОВАТЬ ПО ДополнительныеСведения.Значение
        |УПОРЯДОЧИТЬ ПО ДополнительныеСведения.Значение";
    Запрос.УстановитьПараметр("ДопСвед", "Выгрузка_адрес_сайта (Номенклатура)");
    Запрос.УстановитьПараметр("ДатаНачала", НачалоДня(ДатаНачала));
    Запрос.УстановитьПараметр("ДатаОкончания", КонецДня(ДатаОкончания));
    Запрос.УстановитьПараметр("Организация", Организация);
    
    Выборка = Запрос.Выполнить().Выбрать();
    
    Список = Новый СписокЗначений;    
    СтруктураДанные = Новый Структура();
    СтруктураДанные.Вставить("Адреса", Список);
    
    Пока Выборка.Следующий() Цикл
        Список.Добавить(Выборка.Адрес,Выборка.Адрес);
    КонецЦикла;
    Возврат СтруктураДанные;
    
КонецФункции
Ответ: Сделал так,получилось.

&НаКлиенте
Процедура ВыборСписокАдресаВыгрузки(Элемент, Параметры) Экспорт
    
    Если Элемент <> Неопределено  Тогда 
        ЗаписатьАдрес( Элемент.Значение); 
        Объект.АдресаВыгрузки=Элемент.Значение; 
    КонецЕсли;   
КонецПроцедуры

&НаСервере
Процедура  ЗаписатьАдрес(Значение)
         Объект.АдресаВыгрузки= Значение;
КонецПроцедуры
Вопрос: v7: Перехват выбора значения в модальном режиме

Привет всем !

При выборе значения элемента на форме документа использованы две штатные процедуры "ПриНачалеВыбораЗначения" и "ОбработкаВыбораЗначения", которые по идее работают только в немодальном режиме ...

В связи со спецификой понадобилось обработать документ в модальном режиме: код в "ПриНачалеВыбораЗначения" сработал - вызвался журнал с определенными параметрами, а вот "ОбработкаВыбораЗначения" не взлетела -
в неё тупо не попадает ...

Может кто-нить подскажет выход из ситуации? Заранее благодарю.
Ответ: ()Ещё раз спасибо - открывать форму Журнала модально - очень нежелательно - хотя бы из-за огран.размеров окна: при множестве значимых колонок это очень неудобно.

P.S. маленькое неудобство - после выбора элемента документа из Журнала (оно пустым/прежним отображено будет) обязательно на Ентер ткнуть надо, чтобы функция "ПриИзмененииЭлемента" отработала ...
Вопрос: Выбор значения в зависимости от типа движений

Всем привет!
Пытаюсь собрать свою конфигурацию. 1С 8.3 В управляемом приложении
Документ РКО. Форма документа.

ФирмаА

Поле ввода "ТипРКО" Тип ПеречислениеСсылка.ТипыРасходИзКассы
ТипыРасходИзКассы: ОплатаПоставщику, НаРасчСчет, ВыдачаВДругуюКассу

Поле ввода "Аналитика" Составной тип СправочникСсылка.Поставщики, ПеречислениеСсылка.РасчСчетаФирмаА, ПеречислениеСсылка.КассыФирмыА, ПеречислениеСсылка.КассыФирмыБ

1. Нужно чтобы при выборе из списка ТипРКО, напимер ОплатаПоставщику, сразу открывался справочник Поставщики,
и при выборе поставщика заполнялось поле Аналитика.
а при выборе НаРасчСчет открывался список РасчСчетаФирма, и аналогично заполнялось поле Аналитика.
2. Нужно чтобы при проведении РКО с ТипомРКО ВыдачаВДругуюКассу и Аналитикой КассыФирмыБ (КассаФирмыБ), автоматом создавался, заполнялся и проводился документ ПКО КассыФирмыБ с Типом ПКО ИзКассыФирмыА, с Аналитикой КассыФирмыА (КассаФирмыА).

Помогите с кодом пожалуйста...
Ответ: Спасибо огромное!
Работает!
А я где то вокруг да около бродил...
Со 2 частью действительно наверное не стоит. Это я из лени... думаю зачем лишнее движение делать...

Добавлено через 9 часов 54 минуты
А ещё один вопрос можно...
Нужно получить результат:

Вот этого как записать? Тн.ТоварКоэффициент он подчиненый Объект.Товары.Товар.Коэффициент

1C
1
2
3
4
5
6
7
8
9
10
&НаКлиенте
Процедура ТоварыМетровПриИзменении(Элемент)
    РассчитатьТоннаж();
КонецПроцедуры
 
&НаКлиенте
Процедура  РассчитатьТоннаж()
    Тн=Элементы.Товары.ТекущиеДанные;
    Тн.Тонн=Тн.ТоварКоэффициент*Тн.Метров;
КонецПроцедуры
Вопрос: Выбор значения в элемент формы

Доброго всем дня
Продолжаю вникать в управляемые формы. Итак, задача.
Есть управляемая форма со списком (формируется запросом). Пишу ее вызов:

&НаКлиенте
Процедура ПриНачалеВыбораДоговораПоКонтрагенту(Элемент,СтандартнаяОбработка,Организация,Контрагент,ВидДоговора) Экспорт
    СтандартнаяОбработка=ложь;
    форма=ПолучитьФорму("ОбщаяФорма.ВыборДоговораПоКонтрагентуУпр",,Элемент);
    форма.Организация=Организация;
    форма.Контрагент=Контрагент;
    форма.ВидДоговора=ВидДоговора;
    Результат=форма.ОткрытьМодально();
    //Если ЗначениеЗаполнено(Результат) Тогда

    //    Элемент.Значение=Результат;

    //КонецЕсли;

КонецПроцедуры

Данная процедура будет вызываться в обработчике события ПриНачалеВыбора в поле ввода.
Вопрос. Раньше у Элемента обычной формы было Значение. У элемента управляемой формы его нет. Куда передать выбранное значение (т.е. как написать закомментированный кусок кода)?
Ответ: () Параметры отбора и другие параметры заполняются автоматически по соответствию имён реквизитов структуры.
Остальные реквизиты надо заполнять в процедуре модуля открываемой формы ПриСозданииНаСервере.
Из преимуществ:
Вызов немодальный т.е. будет работать в браузере например.
Параметры заполняются автоматически в простых случаях.
Ну ещё там что есть пусть коллеги скажут.