Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: Ут 11.3 Алкоголь - настройка даты запрета редактирования

Решение, скорее всего тривиально, но не могу разобраться как решить проблему штатными средствами.

Дата запрета установлена на вчерашний день. При проведении новой сборки товаров вываливается ругань на задание на расчет себестоимости, датируемой началом этого месяца.

В расширенных настройках установки даты запрета редактирования можно указать только разделы учета, т.е. нельзя выбрать конкретный регистр или документ.
Скорее всего я чего-то не знаю про правильную настройку запрета редактирования.

Как разрулить ситуацию, когда сегодня проводимый документ хочет изменить документы, находящиеся в границе запрета редактирования?

Будет здорово, если просто получу совет, где и что можно покурить на эту тему.
Ответ: () Не ясен смысл даты запрета редактирования, если не дает проводить документы открытого периода?
Тогда проще создать свою систему запрета редактирования, добавить подписки нужным документам и проверять можно ли их менять в данном периоде.
Вопрос: Дата запрета редактирования регламентированной отчетности

Доброго всем дня.

Возник вопрос с установкой даты запрета редактирования данных. А именно с установкой даты запрета для регламентированной отчетности. (вопрос именно той отчетности которая сдана). Стандартная установка даты запрета не помогает, т.к. программа всё равно позволяет изменять отчеты который были уже сданы.

Сейчас вопрос именно с 1С:УПП 1.3 (но я думаю, это не принципиально, т.к. такая настройка наверно во всех конфигурациях должна присутствовать)

Подскажите пожалуйста как сделать дату запрета изменения регламентированной отчетности? (какие вообще варианты есть)
Ответ: В КА если пользователь не включен в группу пользователей, то до пятой точки дата запрета.
Вопрос: УТ 10.3 дата запрета редактирования не ставится

Доброе утро, помогите разобраться..

Вручную ставлю дату запрета редактирования на вчера например. Удалила все в регистре. Установила. То есть в регистре ГраницыЗапретаРедактирования есть 3 записи автоматически: 1 общая - все пусто, дата=вчера, и 2 по организациям - заполнена организация, пользователь пусто, дата пусто  

В ПриНачалеРаботыСистемы пытаюсь считать СоответствиеГраницЗапрета = ПараметрыСеанса.ГраницыЗапретаИзмененияДанных.Получить(), вместо соответствия возвращает Неопределено.

и когда при открытии документа проверяется дата, тоже соответствие Неопределено...

почему такое может быть? может что-то сбила установкой даты запрета вручную?
Ответ: могут параметры сеанса не заполниться из-за чего то? где можно бы глянуть?
Вопрос: Дата запрета редактирования ЗУП

Всем привет!
Можно ли в 1с ЗУП сделать доступной Дату запрета редактирования только для определенных пользователей не снимая с остальных Полные Права..При снятии полных прав пропадают другие нужные функции
Ответ: () какими свойствами?
Вопрос: Даты запрета редактирования

Добрый день. Я совсем новичок.И есть такой вопрос. Работаю в 8.3 Предприятие. Каким вообще образом устанавливаются даты запрета редактирования документов,с чего начать, где и что прописывать? Помогите,пожалуйста. На просторах интернета ничего по толку найти не могу.
Ответ: Belestrik, либо как константу её устанавливать, либо через регистр сведений, а дальше уже ссылаться на неё при открытие/проведение документов и т.д.
Вопрос: Бух 3.0 Роль для даты запрета редактирования

А какая роль отвечает за возможность изменять дату запрета редактирования?

Надо точечно убрать именно эту возможность (Бух 3.0.60.46), но никакой похожей роли не вижу.
Ответ: () да, нашлась такая роль. Видимо, недавно появилась. Всё, спасибо большое.
Вопрос: дата запрета редактирования

УТ 10.3, файловая

В глобальном модуле обычного приложения в процедуре ПриНачалеРаботыСистемы написан этот код, чтобы в регистре ГраницыЗапретаИзмененияДанных менять даты на вчерашнюю. Есть записи типа "Организация - Все пользователи - 14.12.17"

Даты собственно в регистре и меняются, но при этом спокойно можно поменять какой-то старый док.. что может такое быть?

При установке через Сервис-Установка даты запрета изменения данных для одного пользователя интерактивно установить не дает, пишет ошибку типа такая запись в регистре уже есть (та которая с "все пользователи")

Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
                   |    ГраницыЗапретаИзмененияДанных.Организация,
                   |    ГраницыЗапретаИзмененияДанных.ГраницаЗапретаИзменений
                   |ИЗ
                   |    РегистрСведений.ГраницыЗапретаИзмененияДанных КАК ГраницыЗапретаИзмененияДанных
                   |ГДЕ
                   |    ГраницыЗапретаИзмененияДанных.ГраницаЗапретаИзменений < &ГраницаЗапретаИзменений"; 

    ГраницаЗапретаИзменений =  ТекущаяДата() - 86400;  //60*60*24=86400 1день, 60*60*48=172800 2 дня, 60*60*72=259200 3 дня

    Запрос.УстановитьПараметр("ГраницаЗапретаИзменений", ГраницаЗапретаИзменений);
    
    РезультатЗапроса = Запрос.Выполнить();
    Выборка = РезультатЗапроса.Выбрать();
    
    Если Не РезультатЗапроса.Пустой() Тогда
    
        Пока Выборка.Следующий() Цикл
            Сообщить(""+Выборка.Организация);
        КонецЦикла;
        
        НаборЗаписей = РегистрыСведений.ГраницыЗапретаИзмененияДанных.СоздатьНаборЗаписей(); 

        НаборЗаписей.Прочитать(); 
        Для каждого Запись Из НаборЗаписей Цикл 
            Запись.ГраницаЗапретаИзменений = ГраницаЗапретаИзменений; 
        КонецЦикла; 
        НаборЗаписей.Записать();
    КонецЕсли;
Ответ: () я же запуталась.. про полные права знаю, под кассиром заходила. а сейчас этот кусок вставила в чистую ДЕМО УТ 10.3.45.2 и под менеджером например вообще не заходит, ошибка:

{МодульОбычногоПриложения()}: Ошибка при вызове метода контекста (Записать)
        НаборЗаписей.Записать();
по причине:
Нарушение прав доступа!

логично впринципе, но почему тогда заходило в рабочей базе, не демо, видимо там изменены права как то..

но а как вот для случая с демо тогда можно было бы исправить ситуацию? может не так прописать как то? регламентным не выйдет
Вопрос: Доступность формы документа в зависимости от Даты запрета редактирования

Дата запрета должна работать следующим образом, документ могут открыть, но не могут отредактировать. Форма должна быть только для просмотра!
А то, что я сделал - не подходит
1C
1
2
3
4
5
6
Процедура ПодпискаНаСобытие1ПередЗаписью(Источник, Отказ, РежимЗаписи, РежимПроведения) Экспорт
       константа = константы.ДатаЗапретаРедактирования.Получить();
    Если Константа < ТекущаяДата() Тогда
отказ = истина;
КонецЕсли;
КонецПроцедуры
Ответ: Спасибо! все получилось
Вопрос: БП 3.0.41.51, не работает дата запрета изменения данных

БП 3.0.41.51, не работает дата запрета изменения данных

что там, у меня у одного такая проблема? в 41.52 не исправлено
Ответ: может там "распространить дату запрета на пользователей с толстыми правами?
Вопрос: установка даты запрета по дате

Добрый день
Нашел в инете кусок кода, который автоматически ставит дату запрета изменения данных по дням. Как и что изменить чтобы запрет ставился не по дням а в конкретные дни, например, середина и конец месяца?
Код:
Попытка
КоличествоДней = 1;
ДатаУстановки = НачалоДня(ТекущаяДата()) - (60*60*24*1);
НаборЗаписей = РегистрыСведений.ГраницыЗапретаИзмененияДанных.СоздатьНаборЗаписей();
Запись = НаборЗаписей.Добавить();
//Запись.Организация = Организация;
//Запись.Пользователь =ТекПользователь;
Запись.ГраницаЗапретаИзменений = НачалоДня(ДатаУстановки);
НаборЗаписей.Записать();
Исключение
Сообщить(ОписаниеОшибки());
КонецПопытки;
Ответ:
Вы в синтксис-помощнике почитайте про НачалоМесяца() и КонецМесяца(), думаю сразу отпадут такие вопросы.
Эти функции возвращают граничную дату в зависимости от даты, которую в них передаете. ТекущаяДата() - это текущаяя дата, соответственно если использовать НачалоМесяца(ТекущаяДата()), тогда функция вернет 01.12.2016 00:00:00