Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: Добавить несколько строк в тч

День добрый. Есть обработка которая загружает из excel данные в тч документа. Проблема в том что загружает она одну запись , а нужно несколько, вот код:

1C
1
2
3
4
5
6
7
8
Начисления = НовДок.Начисления.Добавить();
                        
    Начисления.ФизЛицо = Справочники.ФизическиеЛица.НайтиПоНаименованию(НовСтр.ФизЛицо);
                    
        Если  НовСтр.Начисление= "23" Тогда
                        ОсновныеНачисления.ВидРасчета   = ПланыВидовРасчета.ОсновныеНачисленияОрганизаций.НайтиПоКоду("000011");
                        ОсновныеНачисления.ВидРасчета   = ПланыВидовРасчета.ОсновныеНачисленияОрганизаций.ОкладПоДням;
                    КонецЕсли;
При таком коде добавляет только "ОкладПоДням", хотя должен еще один вид расчета добавиться. Как это исправить? Пробовал циклом, итог "итератор значения не определён"
Ответ: Briolin, В этом фрагменте:
1C
1
2
3
4
Если  НовСтр.Начисление= "23" Тогда
                        Начисления.ВидРасчета   = ПланыВидовРасчета.ОсновныеНачисленияОрганизаций.НайтиПоКоду("000011");
                        Начисления.ВидРасчета   = ПланыВидовРасчета.ОсновныеНачисленияОрганизаций.ОкладПоДням;
                    КонецЕсли;
Что-то лишнее Либо НайтиПоКоду либо ОкладПоДням (выводиться будет только ОкладПоДням)
Чтобы добавлялось две строки нужен Цикл. Что-то типа:
1C
1
2
3
4
5
6
7
8
9
Для Каждого НовСтр ИЗ Строки Цикл
Начисления = НовДок.Начисления.Добавить();
Начисления.ФизЛицо = Справочники.ФизическиеЛица.НайтиПоНаименованию(НовСтр.ФизЛицо);
Если  НовСтр.Начисление= "23" Тогда
Начисления.ВидРасчета   = ПланыВидовРасчета.ОсновныеНачисленияОрганизаций.ОкладПоДням;
ИначеЕсли НовСтр.Начисление= "код начисления" Тогда
Начисления.ВидРасчета   = ПланыВидовРасчета.ОсновныеНачисленияОрганизаций.НайтиПоКоду("000011");
КонецЕсли;
КонецЦикла;
Более конкретно не подсказать, надо видеть больше кода
Вопрос: УТ11, КА2 как добавить несколько телефонов, адресов эл почты в партнере

Всем - привет!

У (партнера)контрагента несколько телефонов. На вкладке Адреса, телефоны только одна строка для ввода телефона.
Удивился, зашел в конфигуратор, увидел, что для контактной информации есть табличная часть. Своей обработкой заполнил несколькими телефонами эту табличную часть, захожу в партнера - появилось несколько полей с телефонами.

Вопрос: где кнопка, которая позволяет в пользовательском режиме добавить контрагенту несколько телефонов, адресов эл. почты и проч? Книжки читал - не нашел как добавить несколько телефонов...

Спасибо!
Ответ: Спасибо, утащил к себе в кладовочку
Вопрос: Разбить одну тч на несколько таблиц

Здравствуйте.
Есть такая задача .

Табличная часть документа в ней несколько строк в которых указаны товары по разным организациям

например:

1- орг1
2 - орг2
3 орг 3
4 орг1

Мне нужно
или
1) при обходе формировать тз по каждой организации
или
2) вариант без формирования таблиц значений если это возможно .
--- Объединение сообщений, 11 дек 2015 ---
Как это можно сделать ?
Ответ:
НОмадИрк,у - сейчас посмотрю эти методы .
ПавлВС,у - Хочу к коде получать выборку по каждой из организаций указаной в тч
если там организация указана 2жды то 2 строки в выборке и тд.
Т.е я заранее не знаю какие организации сколько их - есть ли строки с одинаковыми организациями или все организации различны .
Вопрос: Групповое заполнение строк табличной части.

Добрый день. Уважаемые форумчане помогите с кодом не могу доделать редактирование табличной части документа. Например пользователь выделил через ctpl или shift несколько строк, и одновременно поменял статус (Кнопка утвердить) выделенных строк.

Кнопкой Утвердить я получаю значение которое хочу проставить в колонке утвердить.
&НаКлиенте
Процедура Утвердить(Команда)
ПараметрыФормы= Новый Структура("ЗакрыватьПриВыборе",Истина);
ОткрытьФорму("Перечисление.Утвердить.ФормаВыбора",ПараметрыФормы,Элементы.Реестр)
КонецПроцедуры


Для одного элементы это делается так

&НаКлиенте
Процедура РеестрОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
Элементы.Реестр.ТекущиеДанные.Утвердить=ВыбранноеЗначение
КонецПроцедуры


А как это сделать для массива выделенных строк. Вроде задача простая, а решить не могу. 1C 8.3 Управляемое приложение

Вложения:

  • Размер файла:
    89,9 КБ
    Просмотров:
    3
Ответ:
ААААА!!. Работает. Ты не представляешь как мне помог. Спасибо.
Вопрос: Печатная форма. Как изменить ширину одной строки

Всех приветствую. Не ругайте сильно, первый раз делаю свою печатную форму с нуля, появилась необходимость подвинуть несколько строк, не трогая формат остальных.
З.ы. гуглить пробовал, наверно плохо искал... времени мало, может кто тут поможет...
Ответ: () смотря , что ты хочешь сделать - как расплывчато вопрос задаешь

выдели всю строку - кликни правой кнопкой мыши по заголовку (там где циферка) - высота строк...
экспериментируй.
или просто зажми мышь и растяни строку
Вопрос: Добавить программно элемент на форму

Доброго дня форумчане. Пытаюсь программно добавить несколько элементов на форму, точнее - вставить новые элементы между существующими, предварительно увеличив высоту формы. Т.е. я удлиняю форму, затем сдвигаю вниз существующие элементы, которые должны располагаться под моими новыми элементами, затем добавляю новые элементы и задаю им привязку. Все бы ничего, но только вот проблема: высоту формы я увеличил, но не могу задать верхнюю границу самому нижнему элементу - командной панели документа. 1С будто продолжает думать, что высота формы прежняя и не позволяет опустить элемент ниже. Если я добавляю тот же код изменением высоты командной панели в каком-нибудь обработчике (какой-нибудь кнопки), то верхняя граница успешно меняется, а вот в процедуре ПриОткрытии - хоть убей, меняться не хочет, хотя высота формы меняется. Получается, что в ПриОткрытии я не могу сдвинуть элемент ниже, а уже после открытия - могу; будто ПриОткрытии хоть и позволяет изменять размер формы, но не позволяет размещать элементы на новом пространстве формы.
Ответ:
Добавлю от себя . Легче всего сделать так: Размещаешь на форме элемент, смотришь его его размеры, смотришь привязку - те которые автоматом создались, копипастишь их в свой код и вуаля . Естественно не сохраняя на форме элемент.
Вопрос: Как распределить сумму по нескольким строкам

Доброго дня. Подскажите алгоритм распределения суммы оплат. Скажем есть 4 строки с суммами:
150
100
300
250

Нужно чтобы когда вбиваешь сумму 500 1с сама раскидала в таком порядке:
150 - 150
100 - 100
300 - 0
250 - 250
Ответ: () смысл в этом распределении? Покупатель в платежке всегда пишет назначение платежа по счету номер такой-то. Поэтому нужно привязывать к тем счетам, которые перечислены.
Вопрос: Как выполнить результат запроса, добавив новую строку в документ?

Процедура ПолучитьНеОбработанныхКонтрагентовНаСервере()
    
    Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |    СведенияОбОбзвоне.Период КАК Период,
        |    СведенияОбОбзвоне.Регистратор КАК Регистратор,
        |    СведенияОбОбзвоне.НомерСтроки КАК НомерСтроки,
        |    СведенияОбОбзвоне.Активность КАК Активность,
        |    СведенияОбОбзвоне.Менеджер КАК Менеджер,
        |    СведенияОбОбзвоне.Контрагент КАК Контрагент,
        |    СведенияОбОбзвоне.КонтактноеЛицо КАК КонтактноеЛицо,
        |    СведенияОбОбзвоне.РезультатОбзвона КАК РезультатОбзвона,
        |    СведенияОбОбзвоне.ДатаПерезвона КАК ДатаПерезвона,
        |    СведенияОбОбзвоне.ТипЗвонка КАК ТипЗвонка
        |ИЗ
        |    РегистрСведений.СведенияОбОбзвоне КАК СведенияОбОбзвоне
        |ГДЕ
        |    (СведенияОбОбзвоне.РезультатОбзвона = ЗНАЧЕНИЕ(Перечисление.РезультатыОбзвона.ЗапланированЗвонок)
        |            ИЛИ СведенияОбОбзвоне.РезультатОбзвона = ЗНАЧЕНИЕ(Перечисление.РезультатыОбзвона.ОтправленоКП))
        |    И СведенияОбОбзвоне.ДатаПерезвона = &ДатаПерезвона";
    
    Запрос.УстановитьПараметр("ДатаПерезвона", Объект.Дата);
    Запрос.УстановитьПараметр("Менеджер", Объект.Менеджер);
    
    РезультатЗапроса = Запрос.Выполнить();
    
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        НоваяСтрока = Объект.ТабличнаяЧасть.Добавить();
        Объект.ТабличнаяЧасть.Записать();
    КонецЦикла;


КонецПроцедуры


______________________________________________________
при нажатии кнопки на форме, для для действия которой был выполнен этот запрос, не появляется новая строка
_______________________________________________________
заранее спасибо за подсказки
Ответ: () У меня волосы на голове шевелятся от вашего поста.
Вопрос: Проблема текущей строкой таблицы в управляемой форме

Столкнулся с ужасным глюком в таблице формы. Интерфейс Такси 8.3, послдений релиз, тонкий клиент.
Изначально требуется несколько раз перезаполнять таблицу в форме и запоминать каждый раз выбранную строку. Таблица привязана к одноименному реквизиту формы с идентичными реквизитами
При каждом перезаполнении визуально проблем не замечаю, но когда пытаешься обратиться к свойству "Элементы.ТабличнаяЧасть.ТекущаяСтрока", то в это свойство накручивается число добавленных ранее строк, которые давно уже удалены, поскольку каждый раз для реквизита используется метод "Загрузить"... Пробовал и очищать реквизит - ситуация та же. пока форму не закроешь, залипают несуществующие строки.
Кто-то пробовал с этим бороться?
Ответ: Хотя да, туплю же, может быть и число...
Вопрос: У поставщика несколько артикулов у вроде бы одного товара

Ввожу ПТиУ, у поставщика одно и то же наименование товара (сравнила уже в экселе) сегодня с одним артикулом, завтра с другим... у нас вообще свой артикул, который очень нужен...
Задваивать номенклатуру не хочется, но при этом и занести куда-то информацию о номенклатуре поставщика надо, завтра снова будет это же поставлять. И желательно это найти в базе.
Попробовала использовать регистр сведений Номенклатура поставщика, там вроде бы можно добавить много полей, но по факту не могу добавить вторую строку со вторым артикулом. Получается, что все равно две номенклатуры создавать? а завтра пять?

пс в самом регистре сведений можно для одной номенклатуры назначить разные артикулы и разные названия, но для разных поставщиков, а мне надо для одного и того же...

УТ 10.3, может я не включила где-то какую-то галку?
Ответ: () Доп реквизиты(profit)