Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: Как работает метод свернуть для ТЗ?

У меня есть ТЗ в ней два столбца (Объект,параметр) в ней есть одинаковые значения Объекта,как мне посчитать с помощью свернуть количество одинаковых записей?
Ответ: Konstantan,
1C
1
2
3
4
5
6
7
8
9
10
11
12
  Запрос.Текст = 
    "ВЫБРАТЬ
    |   КонтактнаяИнформация.Объект,
    |   КонтактнаяИнформация.Представление,
    |   1 КАК Запись
    |ИЗ
    |   РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация
    |";
    
     
    ТЗ = Запрос.Выполнить().Выгрузить();
    ТЗ.Свернуть("Объект, Представление", "Запись");
Вопрос: Как работают методы НачалоМесяца() и КонецМесяца?

Как работают методы НачалоМесяца() и КонецМесяца?Объясните пожалуйста?
Ответ:
Сообщение от Konstantan
Как работают методы НачалоМесяца() и КонецМесяца?Объясните пожалуйста?
Вопрос: Как обойтись без метода Свернуть() для подсчет уникальных строк в ТЗ

1C
1
2
3
4
    ТЗ.Колонки.Добавить("Колзаписей");
    ТЗ.Колонки.Добавить("ДлинаАдреса");
    ТЗ.ЗаполнитьЗначения(1,"Колзаписей");
    ТЗ.Свернуть("Объект,Представление,ДлинаАдреса","Колзаписей");
Как сделать тоже самое но без Свернуть?
Ответ: Konstantan, что запрос с группировкой?
восемнадцать.
Вопрос: Некорректно работает метод ПроверитьВывод()

Доброго всем времени суток. Печатаю ценники все красиво все хорошо. Проверяю помещается ли новый ценник на этой страницы методом ПроверитьВывод(), если нет то делаю горизонтальный разрыв и переношу новый ценник на новую страницу если помещается то вывожу на эту страницу. Проблема в чем для первой страницы он делает разрыв раньше чем нужно, т.е. остается еще место для двух рядов ценников, но он переносит на новую страницу. А начиная со второй страницы все красиво.

P.S.
HELP ..java script:emoticon(':aua:', 'smid_5')

Вот код

Код:
Если НЕ ЗначениеЗаполнено(Организация) Тогда
Предупреждение("Не выбрана организация!");
Возврат;
КонецЕсли;

ТабДокумент                       = Новый ТабличныйДокумент;
ТабДокумент.АвтоМасштаб           = Истина;
ТабДокумент.ОриентацияСтраницы    = ОриентацияСтраницы.Портрет;
ТабДокумент.ПолеСверху            = 0;
ТабДокумент.ПолеСлева             = 5;
ТабДокумент.ПолеСнизу             = 0;
ТабДокумент.ПолеСправа            = 5;
ТабДокумент.ТолькоПросмотр        = Истина;
ТабДокумент.ОтображатьГруппировки = Ложь;
ТабДокумент.ОтображатьЗаголовки   = Ложь;
ТабДокумент.ОтображатьСетку       = Ложь;

Макет                             = ПолучитьМакет("Ценник");
ОбластьЦенника                    = Макет.ПолучитьОбласть("Строка|Столбец");

ДатаПечати = РабочаяДата;

ТекСтолбец = 0;
ТекСтрока  = 0;
МассивВыводимыхОбластей = Новый Массив;
Для Каждого СтрокаТаблицы Из Товары Цикл
Если СтрокаТаблицы.Печать Тогда
Для Тмп = 1 По СтрокаТаблицы.Количество Цикл
ОбластьЦенника.Параметры.Заполнить(СтрокаТаблицы);
ОбластьЦенника.Параметры.НоменклатураНаименование        = СокрЛП(СтрокаТаблицы.Номенклатура.Наименование);
ОбластьЦенника.Параметры.ЕдиницаНаименование             = СтрокаТаблицы.ЕдиницаИзмерения;
ОбластьЦенника.Параметры.Цена                            = ОбщегоНазначения.ФорматСумм(СтрокаТаблицы.Цена, , "00");
ОбластьЦенника.Параметры.ДатаПечати                      = ДатаПечати;
ОбластьЦенника.Параметры.Организация                     = Организация;
ОбластьЦенника.Параметры.Код                             = СтрокаТаблицы.Номенклатура.Код;

МассивВыводимыхОбластей.Очистить();
МассивВыводимыхОбластей.Добавить(ОбластьЦенника);

Если НЕ ТабДокумент.ПроверитьВывод(МассивВыводимыхОбластей) Тогда
ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц();
КонецЕсли;


Если ТекСтолбец = 0 Тогда
ТабДокумент.Вывести(ОбластьЦенника);
Иначе
ТабДокумент.Присоединить(ОбластьЦенника);
КонецЕсли;

ТекСтолбец = ТекСтолбец + 1;

Если ТекСтолбец = 5 Тогда
ТекСтрока  = ТекСтрока + 1;
ТекСтолбец = 0;
КонецЕсли;

КонецЦикла;
КонецЕсли;
КонецЦикла;

ТабДокумент.Показать();

Ответ:
Поняла премного благодарствую
--- Объединение сообщений, 18 сен 2017 ---
С-П обчиталась, не выходила полная картина.
Вопрос: Свернуть таблицу значений

Добрый день как мне свернуть таблицу значений вот такую..
МНЕ нужно как то сначало объединить
ОбъединенаяНоменклатура=краткое наимен+ объем

а потом свернуть по ОбъединенаяНоменклатура
наименование -справочник номенклатура
объем -строка
краткоенаим -строка
признакгруппы -булево
признак3 -строка



Ответ:
В запросе сложнее. Зависит от исходных данных. От типов данных. Конкатенация в запросе возможно лишь методов Выразить (**** как Строка) Но значения ссылочного типа не преобразуются. Чисто наименования, то в принципе можно. Что мешает попробовать?
Вопрос: значки в правом углу формы свернуть,развернуть,закрыть

Я создала форму в конфигураторе . У нее нет значков в правом углу формы свернуть,развернуть,закрыть. Какие свойства нужно установить , чтобы эти значки появились.
Ответ:
В конфигураторе их и не будет видно, они появятся только в пользовательском режиме.
Вопрос: ДокументВыборка.Ссылка.ПолучитьОбъект() возвращает ссылку, а не объект

Битый час уже бьюсь. Если в вкратце то выглядит все так.
Ссылка рабочая. Цикл и условие работают. Только метод ПолучитьОбъект выдает ссылку а не объект.
1с 8.3 конфиг УТ 10.3. Запускаю на толстом клиенте.

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
Выборка = Документы.РеализацияТоваровУслуг.Выбрать();
Пока Выборка.Следующий() Цикл
          Счетчик = Счетчик+1;
          Сообщить(Строка(Счетчик)+")"+Выборка.Ссылка+" --- "+Ссылка);
          Если Выборка.Ссылка = Ссылка Тогда
              
        ВозвращаемыйОбъект=Выборка.Ссылка.ПолучитьОбъект();
        Сообщить( Тип(ВозвращаемыйОбъект) );
        Сообщить("Выполнилось!");
        Прервать;
        КонецЕсли;
    
    КонецЦикла;
Выдает

1)Реализация товаров и услуг 00000000002 от 07.10.2016 0:49:10 --- Реализация товаров и услуг 00000000001 от 07.10.2016 21:43:46
2)Реализация товаров и услуг 00000000003 от 07.10.2016 0:50:58 --- Реализация товаров и услуг 00000000001 от 07.10.2016 21:43:46
3)Реализация товаров и услуг 00000000001 от 07.10.2016 21:43:46 --- Реализация товаров и услуг 00000000001 от 07.10.2016 21:43:46

И выдает ошибку. "Тип не определен (Реализация товаров и услуг 00000000001 от 07.10.2016 21:43:46)

В мануале конечно прочитал, что метод возвращает неопределенный тип, если объекта уже не существует. Но он существует. Он же сам мне его параметр выдает.

Если надо подробней описал в прикрепленном ворде.

Добавлено через 10 часов 6 минут
Хм все разобрался. Выдает объект. Похоже я не понял как работает метод Тип(). Ну да ладно.
Ответ:
Сообщение от MakcNmyc
Похоже я не понял как работает метод Тип().
это конструктор типа
Вопрос: Выгрузка из DBF Ошибка при вызове метода контекста (ПолучитьЗначениеПоля)

Доброго времени суток!
Похоже вопрос изъезженный, но читал и всё-равно ничего не понял.
Нужно выгрузить данные из DBF. Названия колонок всегда меняются, поэтому привязываюсь к названию полей.
Код:
ВыбФайл = Новый Файл(ДанныеПоФайлу.ПутьКФайлу);
Если НЕ ВыбФайл.Существует() Тогда
   Сообщить("Файл не существует!");
   Возврат;
КонецЕсли;        
       
ФайлДБФ  = Новый XBase;
ФайлДБФ.Кодировка = КодировкаXBase.OEM;
Попытка
   ФайлДБФ.ОткрытьФайл(ДанныеПоФайлу.ПутьКФайлу);
Исключение
   Сообщить("Ошибка открытия файла!");
   Возврат;
КонецПопытки;       
         
ФайлДБФ.Первая();
Пока Не ФайлДБФ.ВКонце() Цикл
   НоваяСтрока = Материалы.Добавить();
   КодМатериала = ФайлДБФ.ПолучитьЗначениеПоля(ДанныеПоФайлу.КодМатериала);
   НоваяСтрока.Номенклатура = Справочники.Номенклатура.НайтиПоКоду(СокрЛП(КодМатериала));
              
   ФайлДБФ.Следующая();
КонецЦикла;
на ФайлДБФ.ПолучитьЗначениеПоля(ДанныеПоФайлу.КодМатериала) ошибка
Заранее спасибо!
--- Объединение сообщений, 27 июл 2016 ---
атас какой-то, то работает, то нет
Ответ:
Работает ? Ну, замечательно
Вопрос: Ошибка "метод обработчика не найден"

Дословно:
{Обработка.КонвертацияОбъектовИнформационныхБаз.МодульОбъекта(3862)}: ВНЕШНЕЕ СОЕДИНЕНИЕ: {Обработка.КонвертацияОбъектовИнформационныхБаз.МодульОбъекта(7744)}: Ошибка при вызове метода контекста (ПолучитьОбъект)
СозданныйОбъект = СсылкаНаОбъект.ПолучитьОбъект();
по причине:
При подписке ОбновитьИННИндивидуальногоПредпринимателя на событие ПриЗаписи произошла ошибка. Метод обработчика события ПриЗаписиСправочникаФизическиеЛицаОбновитьИННИП не найден.
ВызватьИсключение СтрокаСообщения;
=====
Синхронизация ЗУП 3.0 - БУХ 3.0.
Не могу понять, куда копать.
Ответ:
Все оказалось проще. В списке подписок типовой бухгалтерии ОбновитьИННИндивидуальногоПредпринимателя присутствует отсылка на метод ПриЗаписиСправочникаФизическиеЛицаОбновитьИННИП, но самого метода в конфе нет. Достаточно оказалось нажать на лупу, заглушка метода создалась, все заработало.
Вопрос: Ошибка при вызове метода контекста(Послать)

Всем привет. Чето ни как не разберусь, пробую отправить электронку выдает "Ошибка при вызове метода контекста(Послать): Неизвестная ошибка (SMPT error code 503)". На ящике яндекса стоят галочкиIMAP и POP3

Код 1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
&НаСервере
Функция СформироватьПрофиль()
    
    Профиль = Новый ИнтернетПочтовыйПрофиль;
    
    Профиль.Пользователь = "ххххх";
    Профиль.Пароль = 77777;
    
    Профиль.АдресСервераSMTP = "smtp.yandex.ru";
    Профиль.ПортSMTP = 465;
    Профиль.ИспользоватьSSLSMTP = Истина;
    
    Возврат Профиль;
    
КонецФункции
 
&НаСервере
Функция СформироватьСообщение()
    
    Сообщение = Новый ИнтернетПочтовоеСообщение;
    
    Сообщение.Тема = "Тест";
    Сообщение.Важность = ВажностьИнтернетПочтовогоСообщения.Высокая;
    Сообщение.Отправитель = "хххххх@yandex.ru";
    Текст = "Тест";
    Сообщение.Тексты.Добавить(Текст, ТипТекстаПочтовогоСообщения.ПростойТекст);
    Сообщение.Получатели.Добавить("ххххх@mail.ru");
    
    Возврат Сообщение;
    
КонецФункции
 
&НаСервере
Функция ОтправитьПисьмо()
    
    Профиль = СформироватьПрофиль();
    Сообщение = СформироватьСообщение();
    
    Почта = Новый ИнтернетПочта;
    Попытка
        Почта.Подключиться(Профиль);
                Почта.Послать(Сообщение);
        Сообщить("Удачно");
    Исключение
        Текст = ОписаниеОшибки();
        Сообщить(ОписаниеОшибки());
    КонецПопытки;
    
КонецФункции
Ответ:
Цитата Сообщение от Dethmontt Посмотреть сообщение
Обычно это этот же пользователь
Да? не знал об этом... нуна попробовать

Добавлено через 1 час 32 минуты
Усе работает