Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: не работают пункты меню "Разделы" (Верхнее меню)

Добрый день.
Перестали работать пункты верхнего меню (разделы), например нажимаешь продажи, а вот отчет по продажам не открывается. Правда на некоторых рабочих местах всё ок.

Проблемное рабочее место: Windows 7, 1С:Предприятие 8.3 (8.3.6.2390) SQL, Вид - панель разделов, Внешний вид - формы в закладках. В безопасности IE добавлены about:security_1cv8 и about:security_1cv8c. Домена нет.

Клиента переставлял, кеши чистил.
Ответ:

Если нажать тут один из пунктов ничего не происходит. А должно меню убраться и открыться окно.
Если включить еще "Вид - панель навигации и действий", все хорошо. А только с "Вид - панель разделов" не работает.
Вопрос: Закрыть пункт "Изменить форму" в УФ

Всем привет.
Возможно ли убрать пункт "Изменить форму" из меню "Еще" в управляемых формах. Желательно для определенной роли и с сохранением права редактирования документа.
И еще — как можно для определенной роли запретить менять дату документа?

УТ 11.3, если что.
Ответ: А зачем убирать "Изменить форму..."?
Как убрать, например, смотри форму "Документы.АвансовыйОтчет.ИтогоПоВалютам". Грохаешь типовую командную панель формы и делаешь ее замену без страшной команды.
Или делаешь расширение, в котором перекрываешь процедуру МодификацияКонфигурацииПереопределяемый.ПриСозданииНаСервере, где проверяешь, что у формы есть этот пункт командной панели и делаешь его недоступным.

Запрещать изменять дату документа можно кучей способов, например, через механизм дат запрет редактирования.
Вопрос: СРОЧНО! Как из дочернего узла сделать главный или сделать не распределенной

Здравствуйте!


1С Предприятие 8.2.

Накрылся главный узел (первичная база?) распределенной БД. Без возможности восстановления.

Имеется дочерний узел от этой БД.

Как из дочернего узла сделать главный или сделать не распределенную БД.

Короче надо получить корневую бызу, можно без свойства, что она распределенная.

Заранее спасибо.
Ответ:
trew
Папа Игорь,

Создать обработку и выполнить код:

Процедура КнопкаВыполнитьНажатие(Кнопка)
	
	ПланыОбмена.УстановитьГлавныйУзел(Неопределено);

КонецПроцедуры


Спасибо. Сделал. Но в базе (дочерней) в плане обмена так и остались эти узлы (главный и дочерний).

Что сделал не так?
Вопрос: Как сделать ссылку реквизита табличной части справочника

Я недавний пользователь 1с. И я решил сделать на нём диплом (Библиотека). В процессе возник вопрос над которым мучаюсь второй день: Как сделать ссылку реквизита табличной части справочника, на реквизит другого справочника (не реквезит табличной части а именно реквизит справочника, Хотя если покажите и это буду благодарен так как тоже в общем то понадобиться). Когда я делаю через обычную ссылку у меня выводит только стандартные реквизиты (Наименование и Код), а те которые мне нужны не выводит почему-то. Если кому нужны скриншоты моей проблемы сделаю по вашему запросу.
Ответ:
Сообщение от rung15
Если кому нужны скриншоты моей проблемы сделаю по вашему запросу.
Да, сделайте, пожалуйста.
Ибо процитированное предложение, единственное понятное из Вашего сообщения.
Вопрос: Не получается сделать продажу товара по характеристикам

В регистр сведений "Остатки товаров" с помощью документа "ПриходнаяНакладная" добавляется товар с определенными свойствами (свойство и вид свойства, например: товар - Бумага. свойство - цвет. Вид свойства - белый). Соответственно, в расходной накладной должна быть сделана продажа ПО СВОЙСТВУ (белая бумага отдельно, красная - отдельно). Проблема в том, что никак не получается составить запрос для того, чтобы это реализовать... Какой-то бардак получается...

Гуру 1С! Прошу Вашей помощи! Пытаюсь сделать уже очень долго, а результата - ноль.

Вот код процедуры "ОбработкаПроведения" для Расходной накладной:

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
Процедура ОбработкаПроведения(Отказ, Режим)
 
    //ПЕРВЫЙ ЗАПРОС НА ДОБАВЛЕНИ В РЕГИСТР "ОстаткиТоваров"
 
    //{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
 
    Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |   РасходнаяНакладнаяТовары.Номенклатура,
        |   СУММА(РасходнаяНакладнаяТовары.Цена) КАК Цена,
        |   СУММА(РасходнаяНакладнаяТовары.Количество) КАК Количество,
        |   МАКСИМУМ(РасходнаяНакладнаяТовары.Сумма) КАК Сумма,
        |   РасходнаяНакладнаяТовары.Свойство КАК Свойство,
        |   РасходнаяНакладнаяТовары.ЗначениеСвойства КАК ЗначениеСвойства
        |ПОМЕСТИТЬ ТоварыТЧ
        |ИЗ
        |   Документ.РасходнаяНакладная.Товары КАК РасходнаяНакладнаяТовары
        |
        |СГРУППИРОВАТЬ ПО
        |   РасходнаяНакладнаяТовары.Номенклатура,
        |   РасходнаяНакладнаяТовары.Свойство,
        |   РасходнаяНакладнаяТовары.ЗначениеСвойства
        |;
        |
        |////////////////////////////////////////////////////////////////////////////////
        |ВЫБРАТЬ
        |   ТоварыТЧ.Номенклатура,
        |   ТоварыТЧ.Цена,
        |   ТоварыТЧ.Количество,
        |   ТоварыТЧ.Сумма,
        |   ЕСТЬNULL(ОстаткиТоваровОстатки.КоличествоОстаток, 0) КАК КоличествоОстаток,
        |   ЕСТЬNULL(ОстаткиТоваровОстатки.СтоимостьОстаток, 0) КАК СтоимостьОстаток,
        |   ОстаткиТоваровОстатки.Свойство,
        |   ОстаткиТоваровОстатки.ЗначениеСвойства
        |ИЗ
        |   ТоварыТЧ КАК ТоварыТЧ
        |       ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.ОстаткиТоваров.Остатки(
        |               &Дата,
        |               Номенклатура В
        |                   (ВЫБРАТЬ
        |                       ТоварыТЧ.Номенклатура
        |                   ИЗ
        |                       ТоварыТЧ КАК ТоварыТЧ)) КАК ОстаткиТоваровОстатки
        |       ПО ТоварыТЧ.Номенклатура = ОстаткиТоваровОстатки.Номенклатура
        |           И ТоварыТЧ.ЗначениеСвойства = ОстаткиТоваровОстатки.ЗначениеСвойства
        |           И ТоварыТЧ.Свойство = ОстаткиТоваровОстатки.Свойство";
 
    Запрос.УстановитьПараметр("Дата", Дата);
 
    Результат = Запрос.Выполнить();
 
    ВыборкаДетальныеЗаписи = Результат.Выбрать();
 
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        Если ВыборкаДетальныеЗаписи.КоличествоОстаток < ВыборкаДетальныеЗаписи.Количество Тогда
Сообщить("Не хватает "+ВыборкаДетальныеЗаписи.Номенклатура+" в количестве "+ (ВыборкаДетальныеЗаписи.КоличествоОстаток));
Отказ = Истина;
Движения.Продажи.Записывать = Ложь;
Движения.ОстаткиТоваров.Записывать = Ложь;
Продолжить;
КонецЕсли;
 
        
        
        Движение = Движения.ОстаткиТоваров.Добавить();
        Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
        Движение.Период = Дата;
        Движение.Номенклатура = ВыборкаДетальныеЗаписи.Номенклатура;
        Движение.Количество = ВыборкаДетальныеЗаписи.Количество;
        Движение.Стоимость = ВыборкаДетальныеЗаписи.Сумма;
        Движение.Свойство =   ВыборкаДетальныеЗаписи.СвойствоНаименование;
        Движение.ЗначениеСвойства =    ВыборкаДетальныеЗаписи.ЗначениеСвойстваНаименование;
 
 
        Движение2 = Движения.Продажи.Добавить();
        Движение2.Период = Дата;
        Движение2.Номенклатура =   ВыборкаДетальныеЗаписи.Номенклатура.ВидНоменклатуры;
        Движение2.Контрагент = Контрагент; 
        Движение2.Количество = ВыборкаДетальныеЗаписи.Количество;
        Движение2.Сумма = ВыборкаДетальныеЗаписи.Сумма;
        Движение2.Свойство =   ВыборкаДетальныеЗаписи.СвойствоНаименование;
        Движение2.ЗначениеСвойства =    ВыборкаДетальныеЗаписи.ЗначениеСвойстваНаименование;
 
    КонецЦикла;
 
    //}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
 
 
 
 
    //ВТОРОЙ ЗАПРОС НА ДОБАВЛЕНИЕ В РЕГИСТР "ПРОДАЖИ"
    Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |   РасходнаяНакладнаяУслуги.Номенклатура,
        |   СУММА(РасходнаяНакладнаяУслуги.Цена) КАК Цена,
        |   СУММА(РасходнаяНакладнаяУслуги.Количество) КАК Количество,
        |   МАКСИМУМ(РасходнаяНакладнаяУслуги.Сумма) КАК Сумма
        |ИЗ
        |   Документ.РасходнаяНакладная.Услуги КАК РасходнаяНакладнаяУслуги
        |ГДЕ
        |   РасходнаяНакладнаяУслуги.Ссылка = &Ссылка
        |
        |СГРУППИРОВАТЬ ПО
        |   РасходнаяНакладнаяУслуги.Номенклатура";
 
    Запрос.УстановитьПараметр("Ссылка", Ссылка);
 
    Результат = Запрос.Выполнить();
 
    ВыборкаДетальныеЗаписи = Результат.Выбрать();
 
     //Сообщить (ВыборкаДетальныеЗаписи.КоличествоОстаток);
 
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        
            Движение = Движения.Продажи.Добавить();
            Движение.Период = Дата;
            Движение.Номенклатура =   ВыборкаДетальныеЗаписи.Номенклатура.ВидНоменклатуры;
            Движение.Контрагент = Контрагент;
            Движение.Количество = ВыборкаДетальныеЗаписи.Количество;
            Движение.Сумма = ВыборкаДетальныеЗаписи.Сумма;
    КонецЦикла;     
    
    
       Движения.ОстаткиТоваров.Записывать = Истина;
       Движения.Продажи.Записывать = Истина;

Буду благодарен, если поможете! Надо сдать в ближайшее время, а я вообще в таком бардаке не могу ничего разобрать.
Прикрепляю файл конфигурации на всякий случай:
Ответ:
Сообщение от polax
Эникей, Ну ладно. Посмотрел и сделал. Посмотрите Обработку проведения в Приходной и расходной накладных, Параметры выбора и связи параметров выбора в ТЧ Товары обоих документов, Исправил регистры сведений Цена и Цена поставщиков. Не стал разбираться с ошибкой, просто заремировал ваше ПриИзменении Номенклатуры в расходной. То что вы хотели, зависимость от характеристики в вашей базе работает. Учет остатков по характеристикам тоже работает. НО. Это не должно стать системой, все-таки делайте сами с подсказками, но сами (кстати ваша последняя база нерабочая, закрывает программу, сделал на своей выгрузке). Теперь на что обратите внимание (не стал разбираться и делать, сами справитесь):
1. Какая-то беда с Приходными, при любом перепроведении устанавливается текущая дата а не остается дата первого проведения
2. Не рассчитываются суммы документов автоматом.
3. Цены поставщиков фиксируются, а вот цены продажи нет (нет движений по РС ЦеныНоменклатуры)
4. Учтите в базе, что НЕ вся номенклатура может учитывается по характеристикам. Нужны какие-то настройки номенклатуры где указывать нужны или нет характеристики.
Огромнейшее спасибо!
Да, я понимаю, что я должен был сделать это самостоятельно... Мне самому не нравится, когда просят "сделай за меня"... Но тут просто уже выхода у меня не было. Я уже начинаю недолюбливать эту систему, хотя в начале курса вообще подумал, что было бы неплохо стать "программистом" 1С... Ну блин, ладно у меня не получилось. Я действительно долго возился с этим - никакого результата, окей - я тупой. Пошел к преподу - он практически целую пару просидел около меня, тыкал на все кнопки подряд - никакого результата. Что за херня? Мне кажется, что сам препод чего-то не понимает в этой системе...

Было бы больше времени у меня, я бы, конечно, разобрался. Если было бы нужно - переделал бы с нуля документы (приход/расход) и регистры... Но сейчас уже просто нет времени. По другому предмету мы в командах пишем игру, и это сложно, круто и интересно, поэтому интерес к 1С у меня перебился)) Да и времени стало не хватать)))

Еще раз Вам огромнейшее спасибо!
Вопрос: Как сделать перерасчет в оплате за воду 1С 7.7: Комунальные услуги?

Как сделать перерасчет в оплате за воду 1С 7.7: Комунальные услуги? Не типовая конфигурация, тариф на воду меняется 21 июнья как сделать перерасчет?
Ответ: Как сделать перерасчет в оплате за воду 1С 7.7: Абонотдел? Не типовая конфигурация, тариф на воду меняется 21 июня как сделать перерасчет?
Вопрос: как сделать такой РИБ

Например, есть обычная схема РИБ, т.к. 4 рабочих места, один главный узел, остальные вспомогательные, например №1(основной), №2,3,4(вспомогательные).
Насколько я понял для того, чтоб данные попали из №2 в №4 необходимо сделать обмен сначала между №2->№1, а потом только №1->№4, а как сделать, чтоб был возможен обмен напрямую №2->№4?
Ответ:
в 1С на пальцах показать не прокатывает например мне надо в УТ 10.3 изменить структуру РИБ, но я не нашел где это можно сделать, как установить новый главный узел, где это?
Вопрос: Как сделать свой макет для отчета

Имеется отчет. Данные берутся на основе запроса на скрине. Необходимо сделать шапку отчета не ту, которая создается по умолчанию, и поместить данные в определенные столбцы. Вопрос, как это сделать
Ответ: John_Locke, создавайте Области в Табличном документе. Для вывода полей в таблицу создайте область-строку(будете заполнять ее и выводить в цикле обхода выборки запроса), в полях которой заданы определенные Параметры для заполнения.
Далее создаете Табличный документ, получаете созданный макет, его области и выводите в табличный документ поочередно области макета с заполненными параметрами.
Пользуйтесь Синтакс-помощником 1С, там очень много примеров.

А вообще лучше (и быстрее) делать отчеты в СКД, такую шапку там тоже можно сделать.
Вопрос: Как сделать, что бы документ не мог быть проведен дважды?

Народ, что не правильно, нужно сделать, чтобы документ не проводился дважды. То есть, если он проведен, то перепроводить его нельзя было бы.Учебная база.Вот то что я сделал :
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
Запрос = Новый Запрос;
        Запрос.Текст = "ВЫБРАТЬ
                       |    ОстаткиТоваров.Регистратор КАК Регистратор
                       | ИЗ
                       |    РегистрНакопления.ОстаткиТоваров КАК ОстаткиТоваров
                       | ГДЕ  ОстаткиТоваров.Регистратор = &Регистратор";
        
        Запрос.УстановитьПараметр("Регистратор",Ссылка);               
        РезультатЗапроса = Запрос.Выполнить();
        Если  Не РезультатЗапроса.Пустой() Тогда 
            Сообщить("Товар уже был оприходован, повторное проведение не возможно");
            Возврат;
        КонецЕсли;
Ответ: Ясно, как это сделать?
Вопрос: Мобильная платформа. Сделать и сохранить фото на карту памяти

Здравствуйте!

Возник вопрос как в мобильной версии сделать и сохранить фото на карту памяти? На первый вопрос ответил, а вот как сохранить фотку? Может кто поможет разобраться? Версия мобильной платформы 8.3.10.51.
Код:

&НаКлиенте
Процедура Фотка(Команда)
    
    #Если МобильноеПриложениеКлиент Тогда

        
        Если СредстваМультимедиа.ПоддерживаетсяФотоснимок(ТипКамерыУстройства.Задняя) Тогда
            Данные = СредстваМультимедиа.СделатьФотоснимок();
            Если Данные = Неопределено Тогда
                Сообщение = Новый СообщениеПользователю;
                Сообщение.Текст = "Фотоснимок не сделан";
                Сообщение.Сообщить();
            Иначе
                ДанныеДД = Данные.ПолучитьДвоичныеДанные();
                РасширениеФайла = Данные.РасширениеФайла;
                //Отражение картинки в форме.

                АдресХР  = ПоместитьВоВременноеХранилище(ДанныеДД, Новый УникальныйИдентификатор);
                СсылкаНаКартинку = АдресХР;

                
                ПоместитьФотоНаСервере(ДанныеДД, РасширениеФайла);
                
            КонецЕсли;    
        Иначе
            Сообщение = Новый СообщениеПользователю;
            Сообщение.Текст = "Фотоснимок не поддерживается";
            Сообщение.Сообщить();
        КонецЕсли;    
        
    #КонецЕсли    

        
КонецПроцедуры

&НаСервере
Процедура ПоместитьФотоНаСервере(ДанныеДД, РасширениеФайла)
    
    
    ИмяФайла = "//storage/extSdCard/DCIM/Camera/" + Формат(ТекущаяДата(),"ДФ=yyyyMMdd_HHmmss");

    НФ = Новый Файл("//storage/extSdCard/DCIM/Camera/");

    Если НФ.Существует() Тогда
        
        Если НФ.ЭтоКаталог() Тогда
            
            ДанныеДД.Записать(ИмяФайла + "." + РасширениеФайла);
            
        КонецЕсли;
        
    Иначе
        
        Сообщить("Нет каталога");
        
    КонецЕсли;    
    
КонецПроцедуры
Ответ: Путь к карте памяти может быть разным.
Я бы сделал где настройку. Юзер один раз выбирает каталог в которым сохраняются фото. В дальнейшем все фотки туда льются