Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: Открытие формы внешнего отчета

Добрый день.
Понимаю, что вопрос уже много где обсуждался, но ни один способ не помог((
Мне нужно в поле ввода на неуправляемой форме внешнего отчета при нажатии кнопки выбора открыть форму этого же отчета, но уже управляемую. Далее выбрать нужное значение и поместить его в поле вода формы из которой было произведено открытие.

Первая проблема - открыть форму.
Ответ:
Спасибо им, конечно, что написали, все же думал, может есть какая лазейка. Такие ситуации обычно происходят когда в одной базе работает несколько разработчиков и действия не всегда согласовываются, тем более что конфа стара как мир и переписана в хлам))
ВСе равно всем огромнейшее спасибо за участие, в итоге делаю новую форму))
Вопрос: Как вывести внешний отчет на панель инструментов без конфигуратора?

Добрый день! подскажите пожалуйста срочно надо но никак не могу найти, надо вывести внешний отчет сохраненный в конфигурации (УПП) на панель инстурментов, захожу в Сервис - Настройка - Команды, а дальше не знаю куда ткнутся , подскажите пожалуйста
Ответ:
Можно... Добавить кнопку --- Настройки --- переходим на вкладку Команды --- выбираем категорию Конфигурация --- Находим в командах Отчеты и добавляем на панель.
Также и обработки добавляются!
Вопрос: Пропали параметры во внешнем отчете

Добрый день! После обновления ЗУП 3.1 на релиз 3.1.4.167 пропали параметры во внешних отчетах. Исчезла кнопка заполнения документа Данные для расчета зарплаты внешней обработкой. Подскажите, как можно решить данные проблемы? Заранее огромной спасибо.
Ответ: () Меня интересует вопрос: каким образом сейчас нужно определять внешние отчеты. они все перестали работать
Вопрос: Внешний отчет не открывается

Бывало у кого-нибудь такое: добавил в базу УТ10.3 внешний отчет, но он не открывается, щелкаешь по нему - ничего не происходит. Так-то он рабочий и через файл-открыть - работает.
Ответ: () Уверен, а не думаю. Ибо во внешних отчетах идёт вызов ПолучитьФорму(). А у тебя её нет
Вопрос: Консоль СКД и внешний отчет

1С:Предприятие 8.3 (8.3.11.2954)
Управление торговлей, редакция 11.2 (11.2.2.116)
Вхлам перепиленая конфа, но не в этом суть.

Консоль запросов и Консоль СКД показывают одно, но когда переносишь тот же запрос с теми же настройками во внешний отчет, то результат другой.

Консоль:
Отчет:

Кэш чистил.

Кто сталкивался? Что за магия? Весь день бьюсь, перепроверил и заново переделал уже раз 10.
Ответ: () Типа где запоминается в базе, что раньше были запросы кривые и потом всегда их подсовывает по наименованию отчета?
Вопрос: Параметры внешнего отчета

Всем доброго времени суток!
Платформа: 1С:Предприятие 8.3 (8.3.10.2699)
Конфигурация: Управление нашей фирмой, редакция 1.6 (1.6.12.4)


Есть такой отчёт "Анализ заказа покупателя". Я взял и сохранил его, из конфигурации, как внешний отчёт.
Добавил обработчики регистрации внешнего отчета.

Когда открываю ЗаказыПокупател --> Отчеты то я вижу свой отчёт в списках отчётов. Но когда его выбираю, то он у меня пустой, хотя типовой отчет сразу формирует отчет, на основании заказа, из которого была вызвана Отчеты.
Не могу найти, где передается этот параметр.
Ответ:
Отчёт работает с общей формой ФормаОтчетаУНФ. Я отладчиком посмотрел, там в обработчике ПриСозданииНаСервере(), есть переменная Параметры.
Вот собственно в неё попадают разные параметры. Из внутреннего отчета, есть параметр Контекст, а из внешнего нету. Я правда пока не могу понять, откуда изначально берутся эти параметры.
Вопрос: БУХ 3.0 и внешний отчет

Есть БУХ 3.0 (3.0.34.18), типовая-претиповая.
Взял в ней отчет: ВедомостьАмортизацииОСБухгалтерскийУчет и сохранил на диск.

Подпилил до состояния, чтобы его можно было подключить в качестве внешнего отчета. Подключил.

При попытке запустить отчет получаю ошибку:

{ОбщийМодуль.БухгалтерскиеОтчетыВызовСервера.Модуль(2319)}: Поле объекта не обнаружено (ВедомостьАмортизацииОСБухгалтерскийУчет1)
МенеджерОтчета = Отчеты[БухгалтерскиеОтчетыКлиентСервер.ПолучитьИдентификаторОбъекта(Форма)];

Собственно вопрос: внешние отчеты теперь совсем свою самостоятельность потеряли или надо как-то сказать настройками(в коде обработки), что это таки внешний отчет и пытаться запускать отчет, включенный в конфигурацию, не надо?
Ответ:
Здравствуйте, подскажите, пожалуйста, как сделать достаточно. Вот хочу такой подключить.
Пробовал закомментировать вызов БухгалтерскиеОтчетыВызовСервера.ПриСозданииНаСервере(ЭтаФорма, Отказ, СтандартнаяОбработка);
там другая ошибка выходит

Вложения:

  • Размер файла:
    38,6 КБ
    Просмотров:
    2
Вопрос: Некорректно подключается внешний отчет

Сделал внешний отчет на СКД, в модуле отчета добавил:

Функция СведенияОВнешнейОбработке() Экспорт

  ПараметрыРегистрации = Новый Структура;
  ПараметрыРегистрации.Вставить("Вид", "ДополнительныйОтчет");
  ПараметрыРегистрации.Вставить("Наименование", "Расчетсебестоимости");
  ПараметрыРегистрации.Вставить("Версия", 2.0);
  ПараметрыРегистрации.Вставить("БезопасныйРежим", Ложь);
  ПараметрыРегистрации.Вставить("Информация", "АльтернативныйРасчетСебестоимости на основе валовой прибыли");
  ПараметрыРегистрации.Вставить("ВерсияБСП", "1.2.1.4");
  ТаблицаКоманд = ПолучитьТаблицуКоманд();
  ДобавитьКоманду(ТаблицаКоманд, "Открыть", "ОткрытьОтчет", "ОткрытиеФормы", Истина);
  ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);
  Возврат ПараметрыРегистрации;

КонецФункции

Функция ПолучитьТаблицуКоманд()

  Команды = Новый ТаблицаЗначений;
  Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
  Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
  Возврат Команды;

КонецФункции

Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")

  НоваяКоманда = ТаблицаКоманд.Добавить();
  НоваяКоманда.Представление = Представление;
  НоваяКоманда.Идентификатор = Идентификатор;
  НоваяКоманда.Использование = Использование;
  НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
  НоваяКоманда.Модификатор = Модификатор;

КонецПроцедуры


Регистрирую отчет через Администрирование - Дополнительные отчеты и обработки.
Проблема в том, что после добавления отчета его не видно в указанном разделе.
Посмотрев имеющий другой внешний отчет заметил разницу в форме настройки отчета (см.скриншоты):

К сообщению приложен файл. Размер - 63Kb
Ответ: в справочнике внеш. обработок/отчетов всегда был хелп с описаловом что должно быть
Вопрос: Формируется пустой внешний отчет в ЗУП

Добрый день всем. В продолжение темы .
ЗУП 3.1, релиз 3.1.4.116.
Типовой отчет "УнифицированнаяФормаТ2" сохранен как внешний отчет. При выполнении формируется пустой отчет. Просьба помочь исправить. Картинки прилагаются:


Ответ: () Да,тоже пустой. Исходя из прошлой подобной темы,добавила форму отчета. Процедуру из модуля менеджера типового отчета не стала переносить,потому что не нашла ее вызов в модуле формы.
Вопрос: Доступ пользователя к внешним отчетам

Добрый день! Помогите, пожалуйста, разобраться! Есть два пользователя Иванов и Петров, которые имеют одинаковые права, которые задаются через справочник "Пользователи" + имеют одинаковые настройки дополнительных прав + имеют две одинаковые роли (Пользователь + Роль1). И что мы имеем, пользователь Иванов может сформировать внешний отчет, а Пользователь Петров - нет.
При этом, если пользователю Петрову подключить Роль 2, то он тоже может формировать этот отчет, но мне не нужно давать ему эту Роль2, где "собака зарыта"?
Вот ошибка, которую выдает отчет:
{Отчет.УниверсальныйОтчет.МодульОбъекта(86)}: Ошибка при вызове метода контекста (Вывести)
ПостроительОтчета.Вывести(ТабличныйДокумент);
по причине:
Ошибка выполнения запроса
по причине:
The user doesn't have appropriate rights to execute a database operation.
Ответ:
Я и не знала о них, да реально была в этом проблема! Спасибо большое!!!!!!