Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: Как сделать отбор в фоме выбора по значанию реквизита в табличной части?

Есть форма выбора справочника. В объекте справочника есть табличная часть с определенными реквизитами. Как сделадать отбор в форме выбора по значению реквизита табличной части?
Ответ:
Я прошу прощения не совсем четко сформулировал. Я открываю форму выбора программно.
Если отбор сделать по реквизиту то делаю так:

Код:
Процедура КнопкаВыполнитьНажатие(Кнопка)
    ФормаВыбора = Документы.ПлатежноеПоручениеИсходящее.ПолучитьФормуВыбора();
    Если ЗначениеЗаполнено(ФизЛицо) Тогда
        ФормаВыбора.Отбор.ФизЛицо.Значение      = ФизЛицо;
        ФормаВыбора.Отбор.ФизЛицо.Использование = Истина;
    КонецЕсли;
    ФормаВыбора.Открыть();
КонецПроцедуры
А если не просто по реквизиту, а по реквизиту табличной части?
Вопрос: Реквизит табличной части, длинный текст

Привет, всем)

Конфигурация своя) учусь.

И так. Есть документ Х на котором располагается табличная часть с реквизитами "НазваниеКниги", "КраткоеОписание". У него есть форма документа.

Вот при заполнении реквизита табличной части "КраткоеОписание" чаще всего текст бывает достаточно большим(не влезает в область видимости). Редактировать такой текст очень неудобно, но представление всего этого должно быть именно таким(нельзя отказаться от табличной части).

Как можно решить эту проблему, можно ли, например, приНачалеРедактирования этого реквизита выводить диалоговое окно какое то,куда можно вводить этот текст, а так же этот текст будет отображаться весь и его можно редактировать? Или еще какие  варианты есть
Ответ: желательно пример кода) или как искать хотя бы...
Вопрос: Как сделать ссылку реквизита табличной части справочника

Я недавний пользователь 1с. И я решил сделать на нём диплом (Библиотека). В процессе возник вопрос над которым мучаюсь второй день: Как сделать ссылку реквизита табличной части справочника, на реквизит другого справочника (не реквезит табличной части а именно реквизит справочника, Хотя если покажите и это буду благодарен так как тоже в общем то понадобиться). Когда я делаю через обычную ссылку у меня выводит только стандартные реквизиты (Наименование и Код), а те которые мне нужны не выводит почему-то. Если кому нужны скриншоты моей проблемы сделаю по вашему запросу.
Ответ:
Сообщение от rung15
Если кому нужны скриншоты моей проблемы сделаю по вашему запросу.
Да, сделайте, пожалуйста.
Ибо процитированное предложение, единственное понятное из Вашего сообщения.
Вопрос: Как обратиться к реквизиту табличной части документа? (управляемая форма 1С 8.3.11)

Привет Всем

Опыта разработки в 1С 8.3 пока мало поэтому прошу совета

Есть документ с табличной частью РазмернаяСетка с реквизитами ШаблонГруппы (строка) и Размер (Справочник ХарактеристикиНоменклатуры)

ШаблонГруппы заполняется запросом (заполяются размеры из регистра сведений) рядом в колонке Размер приходится заполнять вручную те же самые размеры только из справочника

хотелось бы циклом заполнить колонку Размер тем более что наименования полностью совпадают, как мне обратится к реквизиту табличной части РазмернаяСетка?

Через Объект.РазмернаяСетка.Размер говорит что поле не обнаружено? подскажите как правильно реализовать процедуру?



Процедура ЗаполнитьШаблонНаСервере()

 

Запрос = Новый Запрос;      Запрос.Текст =             "ВЫБРАТЬ

|      РазмерыВозрастнойГруппы.ХарактеристикаНоменклатуры.Наименование КАК ШаблонГруппы

|ИЗ

|      РегистрСведений.РазмерыВозрастнойГруппы КАК РазмерыВозрастнойГруппы

|ГДЕ

|      РазмерыВозрастнойГруппы.ЦелеваяГруппа = &ЦелеваяГруппа

|

|УПОРЯДОЧИТЬ ПО

|      РазмерыВозрастнойГруппы.ПорядокВСписке";
Запрос.УстановитьПараметр("ЦелеваяГруппа", Объект.НоменклатураГП.Состав[0].ЦелеваяГруппа);
Объект.РазмернаяСетка.Загрузить(Запрос.Выполнить().Выгрузить());   

ТЗ=Запрос.Выполнить().Выгрузить();

Для Каждого Стр из ТЗ цикл

ЗначениеШаблона=Стр.ШаблонГруппы;

Объект.РазмернаяСетка.Размер = ЗначениеШаблона;

КонецЦикла;

 

КонецПроцедуры
С Уважением Дамир
Ответ: Круто все заработало Спасибо
Вопрос: Индексация реквизита табличной части документа

Включил индексацию реквизита табличной части Номенклатура документа УстановкаЦенНоменклатуры. 1с запустилась очень быстро, такое впечатление, что индексирование не было выполнено.

Вопрос: как запустить индексацию?
Ответ: () Как только команду DDL подал так и преступает
Вопрос: ТолькоПросмотр для реквизита табличной части документа

Надо открывать элемент справочника Номенклатура из табличной части документа в режиме только просмотр. Если для колонки табличной части установить свойство ТолькоПросмотр, то колонка в табличной части просто не реагирует на клик мышки, не появляется кнопка просмотра. Как можно открыть элемент справочника из табличной части в режиме только просмотр?
Ответ: () Перебирай все реквизиты и устанавливай им отдельно свойство ТолькоПросмотр = Истина.
Для команд и еще чего-то нужно будет установить Доступность = Ложь.
Вопрос: конвертация из запроса во входящие данные табличной части документа, что ни так?

Добрый день! Подскажите, пожалуйста что я делаю ни так? Буду очень благодарна. Ситуация следующая есть две базы УТ10 и БУХ8.2 между ними настроен обмен. В УТ номенклатура ведется по сериям,а в бух надо выгрузить, без серий(как бы объединенную. И вот при выполнении обмена выдается ошибка:
ПКО = ПоступлениеТоваровУслуг (Документ: Поступление товаров и услуг)
ПКС = 2 (--> Номенклатура)
Объект = Поступление товаров и услуг ГК000000112 от 01.07.2016 16:45:53 (Документ объект: Поступление товаров и услуг)
СвойствоПриемника = Номенклатура (СправочникСсылка.Номенклатура)
ОписаниеОшибки = Поле объекта не обнаружено (Номенклатура)
ПозицияМодуля = Обработка.ОбменДаннымиXML.МодульОбъекта(8335)
КодСообщения = 67

Код:
Запрос= Новый Запрос;
Запрос.Текст="ВЫБРАТЬ
+ Code
| ПоступлениеТоваровУслугТовары.Ссылка,
| ПоступлениеТоваровУслугТовары.Номенклатура как Номенклатура,
| ПоступлениеТоваровУслугТовары.ЕдиницаИзмерения,
| СУММА(ПоступлениеТоваровУслугТовары.Количество) КАК Количество,
| ПоступлениеТоваровУслугТовары.КоличествоМест,
| ПоступлениеТоваровУслугТовары.Коэффициент,
| СУММА(ПоступлениеТоваровУслугТовары.Сумма) КАК Сумма,
| ПоступлениеТоваровУслугТовары.Цена,
| ПоступлениеТоваровУслугТовары.СтавкаНДС,
| СУММА(ПоступлениеТоваровУслугТовары.СуммаНДС) КАК СуммаНДС
|ИЗ
| Документ.ПоступлениеТоваровУслуг.Товары КАК ПоступлениеТоваровУслугТовары
|ГДЕ
| ПоступлениеТоваровУслугТовары.Ссылка = &Ссылка
|
|СГРУППИРОВАТЬ ПО
| ПоступлениеТоваровУслугТовары.Ссылка,
| ПоступлениеТоваровУслугТовары.ЕдиницаИзмерения,
| ПоступлениеТоваровУслугТовары.КоличествоМест,
| ПоступлениеТоваровУслугТовары.Коэффициент,
| ПоступлениеТоваровУслугТовары.Номенклатура,
| ПоступлениеТоваровУслугТовары.Цена,
| ПоступлениеТоваровУслугТовары.СтавкаНДС";

Запрос.УстановитьПараметр("Ссылка", Объект.Ссылка);
Выгрузка=Запрос.Выполнить().Выгрузить();

ВходящиеДанные = Новый Структура("Товары");
ВходящиеДанные.Товары= Новый ТаблицаЗначений;
ВходящиеДанные.Товары.Колонки.Добавить("Номенклатура");
ВходящиеДанные.Товары.Колонки.Добавить("ЕдиницаИзмерения");
ВходящиеДанные.Товары.Колонки.Добавить("Количество");
ВходящиеДанные.Товары.Колонки.Добавить("КоличествоМест");
ВходящиеДанные.Товары.Колонки.Добавить("Коэффициент");
ВходящиеДанные.Товары.Колонки.Добавить("Сумма");
ВходящиеДанные.Товары.Колонки.Добавить("Цена");
ВходящиеДанные.Товары.Колонки.Добавить("СтавкаНДС");
ВходящиеДанные.Товары.Колонки.Добавить("СуммаНДС");

Для каждого ТекСтрока Из Выгрузка Цикл
НовСтрока  = ВходящиеДанные.Товары.Добавить();
НовСтрока.Номенклатура = ТекСтрока.Номенклатура;
НовСтрока.ЕдиницаИзмерения = ТекСтрока.ЕдиницаИзмерения;
НовСтрока.Количество = ТекСтрока.Количество;
НовСтрока.КоличествоМест = ТекСтрока.КоличествоМест;
НовСтрока.Коэффициент = ТекСтрока.Коэффициент;
НовСтрока.Сумма = ТекСтрока.Сумма;
НовСтрока.Цена = ТекСтрока.Цена;
НовСтрока.СтавкаНДС = ТекСтрока.СтавкаНДС;
НовСтрока.СуммаНДС = ТекСтрока.СуммаНДС;

КонецЦикла;
ВыгрузитьПоПравилу(Объект, ,ВходящиеДанные, ,"ПоступлениеТоваровУслуг");
Ответ:
Откройте ПКО "ПоступлениеТоваровУслуг" и посмотрите соответствует ли табличная часть "Товары" с колонками таблицы значений Вами созданной в ПВД. У табличной части должен стоять флаг Входящие данные. У реквизитов тч не должен стоять.
Вопрос: Открыть форму выбора с отбором по реквизитам табличной части

Добрый день, есть документ реализация, в табличной части товары есть реквизит документПоступление,
при выборе документа поступления необходимо открыть форму списка с отбором по табличной части Товары по реквизиту номенклатура текущей строки.
Обычные формы. чёт не пойму как такое организовать.
Ответ: Ссылка в списке и запросом все ссылки на документы где есть данный товар
Вопрос: Условие на номенклатуру из табличной части документа в запросе 1с 77

Всем доброго дня!! Делаю отчет в 7ке - вывожу данные из документов (из шапки), и нужно условие - на номенклатуру из табличной части, подскажите синтаксис, заранее благодарю.
Ответ: Mixmaister666,

Если вам нужны агрегатные функции по реквизитам шапки, то не взлетит.
7ка, если в запросе у вас участвуют реквизиты табличной части, делает запрос к таблице табличной части документа с джойном к таблице шапки. Реквизиты шапки будут дублировать в каждой строке. Если в запросе нет агрегатной функции по реквизиту шапки - всё нормально, результат запроса свернётся по группировкам. Если есть, по каждому такому реквизиту шапки значение помножится на количество строк в документе.
Вопрос: Как получить значение реквизита одного справочника и перенести их в реквизит табличной части другого

Добрый день, очень сильно нужна помощь....

Есть справочник "ВидыУслуг", реквизит "Тариф"

Есть справочник "ЛицевыеСчета", и табличная часть "Услуги" с реквизитом "Тариф"

Как получить значение реквизита "ВидыУслуг" справочника "ЛицевыеСчета" и перенести их в реквизит "Тариф" табличной части "Услуги" другого справочника "ЛицевыеСчета"?

если ссылаться просто на справочник то совсем не то...
через отбор вообще пусто...

Прошу в поиск не посылать, т.к. своими усилиями перепробовала все что только можно... Успехов 0.

платформа 8.2

Буду очень рада любой помощи....
Ответ: alex1248, Дааааа!)))) Спасибо огрооомное)))))) после стольких мучений!!))))) Волшебник))))
Именно то чего я так то, чего я так долго добивалась!)))))