Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: ЕГАИС товар от разных заводов с одинаковым штрих-кодом

Обратился ко мне клиент, который навводил в базе кучу разной номенклатуры под одинаковые алкоголь с одинаковым штрих-кодом, но разных заводов, из-за того что в егаисе при привязке к одной номенклатуре не проходило "подтверждение". В последних версиях эту проблему как-то исправили? Судя по форумам в 16 и начале 17 году такая проблема обсуждалась. Но потом стихла.
Заранее спасибо за информацию об этой ситуации.
Ответ: "это не проблема,"
они рассказали, что сначала привязали разные карточки егаис к одной номенклатуре (по конфигурациия нет какого ограничения по  выбору номеклатуры как я понимаю), но потом им стали звонить поставщики что не проходит на их стороне что-то в егаис. С тех пор они стали на каждый вариант (завод) создавать отдельную номенклатуру. С учетом что в ут по коду не дает одинаковый штрих-код создавать они там все остатки намешали.

Вот тут обсуждалось, но как-то не понятно, все такая же ситуация, или что-то поменялось.

Вопрос: v7: Как подключить ШТРИХ-МИНИ-ФР-К в ТиС 7,7

В общем база древняя, в том плане что ее не обновляли лет 15 как минимум. И обновить в данный момент соответственно нереально. Чтоб не было лишних вопросов объясню коротенько: ТиС эту используют на производстве. Почему именно ТиС мне не ведомо, но ТиС не простая, а переписанная в соответственно лет 15 назад. кто ее переписывал сейчас найти нереально, да и сам он наврядли все тонкости вспомнит случись чудо и найди мы его.
Так вот к этой ТиС нужно подключить ШТРИХ-МИНИ-ФР-К. Что для этого предпринять? С какого боку вообще подойти к этому?
Ответ: () да есть я его куда только не скопировал.
Но блин затупил я всё таки...
Подключился ФР к базе. После ребута компа :(
Вопрос: Мини-ККМ

Добрый день! Подскажите, пожалуйста, кто работал с Мини-ККМ, есть ли в ней возможность печатать чеки от двух организаций? Чеки на возврат
Ответ: () да, верно
Вопрос: Обработка заполнения справочника контрагентами из эксель

Добрый день. Пишу обработку по УТ 10,3. Задача такова-из имеющегося xml документа перенести контрагентов-покупателей в базу ут.
В обработке прописал процесс считывания данных из экселя... Затем помещаю данные в ТабЗнач и выношу на форму, чтоб проверить, всё ли считалось... Как сделать процедуру по считыванию данных из ТабЗнач и обработку этих данных? Начал писать функцию по созданию нового элемента справочника, но необходимо ссылаться на табзнач для получения значений...

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
Процедура ПрочитатьНажатие(Элемент)
        
    //подключаемся к эксел
    Попытка
        Excel = Новый COMОбъект("Excel.Application");
        Excel.WorkBooks.Open(ИмяФайла);
        Состояние("Обработка файла Microsoft Excel...");
    Исключение
        Сообщить("Ошибка при открытии файла с помощью Excel! Загрузка не будет произведена!");
        Сообщить(ОписаниеОшибки());
        Возврат;
    КонецПопытки;
        
    Попытка 
        //Открываем необходимый лист
        Excel.Sheets(1).Select();  // лист 1, по умолчанию  
    Исключение
        //Закрываем Excel
        Excel.ActiveWorkbook.Close();   
        Excel = 0;
        Сообщить("Файл "+Строка(ИмяФайла)+" не соответствует необходимому формату! Первый лист не найден!");
        ОтменитьТранзакцию();
        Возврат;
    КонецПопытки;   
    
    //Получим количество строк и колонок.
    //В разных версиях Excel получаются по-разному, поэтому сначала определим версию Excel
    Версия = Лев(Excel.Version,Найти(Excel.Version,".")-1);
    Если Версия = "8" тогда
        ФайлСтрок   = Excel.Cells.CurrentRegion.Rows.Count;
        ФайлКолонок = Макс(Excel.Cells.CurrentRegion.Columns.Count, 27);
    Иначе
        ФайлСтрок   = Excel.Cells(1,1).SpecialCells(11).Row;
        ФайлКолонок = Excel.Cells(1,1).SpecialCells(11).Column;   
    Конецесли;
    
     //создание колонок табличного документа  
    ТабЗнач = Новый ТаблицаЗначений;
    ТабЗнач.Колонки.Добавить("Завод"); 
    ТабЗнач.Колонки.Добавить("Имя"); 
    ТабЗнач.Колонки.Добавить("НазваниеФирмы");
    ТабЗнач.Колонки.Добавить("КППОбъекта");
    ТабЗнач.Колонки.Добавить("КодРегиона"); 
    ТабЗнач.Колонки.Добавить("Регион"); 
    ТабЗнач.Колонки.Добавить("ПИндекс");
    ТабЗнач.Колонки.Добавить("Город");
    ТабЗнач.Колонки.Добавить("Улица");
    ТабЗнач.Колонки.Добавить("НомерДома");
    ТабЗнач.Колонки.Добавить("Дополнение");
    ТабЗнач.Колонки.Добавить("Телефон");
    
    //считываем первую строку и генерируем колонки
    Для НС = 2 По ФайлСтрок Цикл 
        НоваяСтрока = ТабЗнач.Добавить();
        НоваяСтрока.Завод = Excel.Cells(НС, 1).Value;
        НоваяСтрока.Имя = (Excel.Cells(НС, 2).Value); //проверка на наличие контрагента. Это грузополучатели    
        НоваяСтрока.НазваниеФирмы = (Excel.Cells(НС, 4).Value); //это контрагенты - плательщики
        НоваяСтрока.КППОбъекта = Excel.Cells(НС, 9).Value;
        НоваяСтрока.КодРегиона = Excel.Cells(НС, 12).Value;
        НоваяСтрока.Регион = Excel.Cells(НС, 13).Value;
        НоваяСтрока.ПИндекс = Excel.Cells(НС, 14).Value;
        НоваяСтрока.Город = Excel.Cells(НС, 15).Value;
        НоваяСтрока.Улица = Excel.Cells(НС, 16).Value;
        НоваяСтрока.НомерДома = Excel.Cells(НС, 17).Value;
        НоваяСтрока.Дополнение = Excel.Cells(НС, 18).Value; //проверять на наличие
        НоваяСтрока.Телефон = Excel.Cells(НС, 19).Value;
    КонецЦикла;
          
     // Закрыть COM соединение для экономии памяти
     Excel.Application.Quit();
     
     //поместить считанные данные в форму обработки
     ЭлементыФормы.Таблица.Значение = ТабЗнач;
     ЭлементыФормы.Таблица.СоздатьКолонки();
     
     
     
 КонецПроцедуры
PS. Стандартная обработка не подходит, уже выяснил опытным путём...
Ответ: Nenaviju1C, Всё, разобрался)))
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
Процедура КнопкаВыполнитьНажатие(Кнопка)
    // Вставить содержимое обработчика.
КонецПроцедуры
 
Процедура ИмяФайлаНачалоВыбора(Элемент, СтандартнаяОбработка)
    
    ДиалогВыбора = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
    ДиалогВыбора.Заголовок = "Выберите файл";
    
    Если ДиалогВыбора.Выбрать() Тогда
        ИмяФайла = ДиалогВыбора.ПолноеИмяФайла;
    КонецЕсли;
    
КонецПроцедуры
 
Процедура ПрочитатьНажатие(Элемент)
        
    //подключаемся к эксел
    Попытка
        Excel = Новый COMОбъект("Excel.Application");
        Excel.WorkBooks.Open(ИмяФайла);
        Состояние("Обработка файла Microsoft Excel...");
    Исключение
        Сообщить("Ошибка при открытии файла с помощью Excel! Загрузка не будет произведена!");
        Сообщить(ОписаниеОшибки());
        Возврат;
    КонецПопытки;
        
    Попытка 
        //Открываем необходимый лист
        Excel.Sheets(1).Select();  // лист 1, по умолчанию  
    Исключение
        //Закрываем Excel
        Excel.ActiveWorkbook.Close();   
        Excel = 0;
        Сообщить("Файл "+Строка(ИмяФайла)+" не соответствует необходимому формату! Первый лист не найден!");
        ОтменитьТранзакцию();
        Возврат;
    КонецПопытки;   
    
    //Получим количество строк и колонок.
    //В разных версиях Excel получаются по-разному, поэтому сначала определим версию Excel
    Версия = Лев(Excel.Version,Найти(Excel.Version,".")-1);
    Если Версия = "8" тогда
        ФайлСтрок   = Excel.Cells.CurrentRegion.Rows.Count;
        ФайлКолонок = Макс(Excel.Cells.CurrentRegion.Columns.Count, 27);
    Иначе
        ФайлСтрок   = Excel.Cells(1,1).SpecialCells(11).Row;
        ФайлКолонок = Excel.Cells(1,1).SpecialCells(11).Column;   
    Конецесли;
    
     //создание колонок табличного документа  
    ТабЗнач = Новый ТаблицаЗначений;
    ТабЗнач.Колонки.Добавить("Завод"); 
    ТабЗнач.Колонки.Добавить("Имя"); 
    ТабЗнач.Колонки.Добавить("НазваниеФирмы");
    ТабЗнач.Колонки.Добавить("КППОбъекта");
    ТабЗнач.Колонки.Добавить("КодРегиона"); 
    ТабЗнач.Колонки.Добавить("Регион");     
    ТабЗнач.Колонки.Добавить("ПИндекс");
    ТабЗнач.Колонки.Добавить("Город");
    ТабЗнач.Колонки.Добавить("Улица");
    ТабЗнач.Колонки.Добавить("НомерДома");
    ТабЗнач.Колонки.Добавить("Дополнение");
    ТабЗнач.Колонки.Добавить("Телефон");
    
    //считываем первую строку и генерируем колонки
    Для НС = 2 По ФайлСтрок Цикл 
        НоваяСтрока = ТабЗнач.Добавить();
        НоваяСтрока.Завод = Excel.Cells(НС, 1).Value;
        НоваяСтрока.Имя = (Excel.Cells(НС, 2).Value); //проверка на наличие контрагента. Это грузополучатели    
        НоваяСтрока.НазваниеФирмы = (Excel.Cells(НС, 4).Value); //это контрагенты - плательщики
        НоваяСтрока.КППОбъекта = Excel.Cells(НС, 9).Value;
        НоваяСтрока.КодРегиона = Excel.Cells(НС, 12).Value;
        НоваяСтрока.Регион = Excel.Cells(НС, 13).Value;
        НоваяСтрока.ПИндекс = Excel.Cells(НС, 14).Value;
        НоваяСтрока.Город = Excel.Cells(НС, 15).Value;
        НоваяСтрока.Улица = Excel.Cells(НС, 16).Value;
        НоваяСтрока.НомерДома = Excel.Cells(НС, 17).Value;
        НоваяСтрока.Дополнение = Excel.Cells(НС, 18).Value; //проверять на наличие
        НоваяСтрока.Телефон = Excel.Cells(НС, 19).Value;
    КонецЦикла;
          
     // Закрыть COM соединение для экономии памяти
     Excel.Application.Quit();
     
     //поместить считанные данные в форму обработки
     ЭлементыФормы.Таблица.Значение = ТабЗнач;
     ЭлементыФормы.Таблица.СоздатьКолонки();
     
     мФорма = ПолучитьФорму (Справочники.Контрагенты.ПолучитьФормуНовогоЭлемента());
     СозданиеКонтрагента(мФорма);
     
 КонецПроцедуры
 
 
 Процедура СозданиеКонтрагента (мФорма)
     
     Для Каждого СтрокаТаблицы из Таблица  Цикл
      НовыйОбъект = Справочники.Контрагенты.СоздатьЭлемент();
      НовыйОбъект.Наименование = СтрокаТаблицы.НазваниеФирмы;
      НовыйОбъект.НаименованиеПолное = СтрокаТаблицы.НазваниеФирмы;
      НовыйОбъект.ЮрФизЛицо = Перечисления.ЮрФизЛицо.ЮрЛицо;
      НовыйОбъект.КПП = СтрокаТаблицы.КППОбъекта;
      НовыйОбъект.Покупатель = Истина;
        Попытка
           НовыйОбъект.Записать();
       Исключение
           Продолжить;
        КонецПопытки; 
        
      
    КонецЦикла;
      
     
 КонецПроцедуры
Справочник заполнился, но только у каждого контрагента 1я страница.. теперь надо думать. как остальные запонять. Хотя по факту нужно допилить заполнение адресов с проверкой по классификатору
Вопрос: Восстановление последовательности для документа

Здравствуйте, сталкиваюсь с такой задачей впервые. Мной был разработан путевой лист для упп. Который подтягивал начальные остатки по гсм и спидометру из РС при выборе конкретного авто-сама процедура вызывается при событии "При изменении" реквизита автомобиля. столкнулась с проблемой , когда заводят подряд например 1,2,3 п/л, во втором меняют чего-то перепроводят, то естесно сбиваются начальные остатки в других п/л, даже если их перепровести, т.к. заново в каждом надо будет выбирать машину-получить по ней нач.остатки, проводить и браться за следующий. Хотелось бы как то автоматизировать это. Подскажите идею, каким образом можно было бы это реализовать.
Ответ:
Цитата Сообщение от fenlork Посмотреть сообщение
Хотелось бы как то автоматизировать это. Подскажите идею, каким образом можно было бы это реализовать.
Все расчеты делать при проведении. Создать последовательность, восстановление которой решит проблему.
Вопрос: Мини-склад конфигурация

Доброе утро господа,ни у кого не завалялась конфигурация простенькая?пишу диплом и времени на разработку своего проекта просто нет. Делаю по металлургическому складу,думаю любая простенькая подойдет для описания в дипломе.
Ответ:
Сообщение от Volodka1488
ни у кого не завалялась конфигурация простенькая
Только если у кого-то найдется собственная разработка, с которой он будет согласен безвозмездно поделиться
Типовые конфигурации - платные и далеко не "простенькие"...
Вопрос: Мини-библиотека - 1С

Помогите пожалуйста, может у кого готовое есть в версии 8.1? Тема уже обсуждалась,поэтому и спрашиваю. Задание с сайта на версии 7.7
Выручайте,добрые люди...не успеваю...завал полный
Ответ: miros_0571,
Вопрос: 1C мини сервер и РИБ

База развернутая на 1С сервера, поддерживает РИБ с обычными базами?
Ответ: () Всё можно. Используем.
Вопрос: На чем сейчас автоматизируют ресторанный бизнес

Возьмем для примера миниточку. Один фронт и один бэк.
Попался на глаза presto от сбиса, честно впечатлен.
Ответ: В Рязань проникла тоже.

3. iiko
Вопрос: Значение СубконтоДт

Привет Всем
столкнулся с проблемой: на простой форме используется реквизит табличной части "Завод" с типом Справочники.Завод, в модуле объекта документа в процедуре обработке проведения в движениях регистра бухгалтерии используется код:
...
УстановитьСубконто(Движение.СчетДт,Движение.СубконтоДт,2,МестоХранения);
УстановитьСубконто(Движение.СчетДт,Движение.СубконтоДт,3,ТекСтрокаТабличнаяЧасть1.Завод)
...
в журнале операций в графе СубконтоДТ должно быть значение из табличной части Завод но там просто пустота, что не так?
Ответ:
блин и вправду я затупил, действительно нету , Спасибо огромное...