Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: Настройка сканера Symbol DS4308

Возникла проблема с этим сканером при настройке и очень долго с ним вожусь.
Розница 2.1. Symbol DS4308.

Суть:

Установил ПО с сайта производителя 123Scan, обновил прошивку. Сканер работает в режиме USB HID со стандартным драйвером "1С NativeAPI", но нажимать при продаже каждый раз Alt+F7 не вариант. Сканер не для этого покупался.
Выставление префикса 13(CR) в настройках не помогло.

Хотел залить в него конфигурацию для обработки префиксов и суффиксов, но столкнулся с проблемой. 1С Рознице нужен двойной префикс Alt+F7, а сканер не умеет такие обрабатывать.

Пошел другим путем через CDC ("полная" эмуляция COM). В настройках 1С выставил драйвер "1С COM". В режиме теста все работает. Пишет номер штрих-кода с порта COM3 как и положено, но в режиме РМК все глухо, даже если выбрать вручную пункт "Штрих-код".
Ответ:
Получилось скрестить? Такая же беда. Перебрал кучу вариантов - все дохлые.
Вопрос: Настройка сканера штрих-кода УТ 10.3 RDP

Платформа 8.3.9.2170, конфигурация УТ 10.3 подключение по rdp. На сервере Установил драйвера АТОЛ, обработка обслуживания тоже атоловская, в параметрах драйвер и версия не уставлены и сканер соответственно на работает. Что я делаю не так подскажите пожалуйста?
Ответ: драйвер на сканер я поставил, но в 1с ни версия, ни драйвер не определяются
Вопрос: Настройка сканера штрих-кода

Доброго времени суток!
Имеется сканер штрих-кода f12z.Его нужно подключить к 1с 8.3. Перепробовал самые разнообразные обработки обслуживания,но сканер как работал в обычном режиме так и работает.Пытался найти как его перепрограммировать,чтобы при вводе,сначала вводилась f7(префикс),но так и не нашел.Инструкция пользователя,со штрих-кодами настройки полностью на китайском и на других языках её нет.Может кто сталкивался,с такой проблемой,подскажите пожалуйста!
Ответ: автор выкл :)
Вопрос: v7: Настройка сканера штрихкода

Ребят, тут такая проблема, в тесте сканер определился как СОМ5, все нормально. Захожу в 1С, параметры-на вкладке "Сканер" доступны только СОМ1-СОМ4, больше нема.. что я упустил?
Ответ: может тут в 1С проблема, а не в драйверах? ведь количество портов в системе не от драйвера зависит
Вопрос: Подключение Сканера ШК (разрыв клавиатуры) к самописной конфе (упр.формы)

Доброго времени суток!!! Ребята, спасайте...

Есть самописная конфигурация на упр. формах и сканер ШК, который работает только в разрыв клавиатуры. Необходимо подключить к конфе.
Так, как метод подключения через назначение "Сочетание клавиш" по префиксу (")") не работает по РДП, пытаюсь подключить обработчик событий. Тестировал на стандартной конфигурации УТ3.1 украина(упр.формы, настройка сканера шк как клавиатуры), работало шикарно. Как сделать здесь, ума не приложу.
Что сделано:
В модуль Управляемого приложения добавлен следующий код.

"&НаКлиенте
Перем Драйвер;
ПриНачалеРаботыСистемы
Попытка 
        ПрогИД="AddIn.Scanner";
        ПодключитьВнешнююКомпоненту(ПрогИД);
        Драйвер = Новый (ПрогИД);
        Сообщить("Компонента для сканера штрих-кодов загружена!");
    Исключение
        Сообщить ("Невозможно подключить внешнюю компоненту!");
    КонецПопытки;
    
    Попытка 
        ВерсияИзДрайвера = Драйвер.ПолучитьНомерВерсии();
    Исключение
        Сообщить ("Невозможно определить версию драйвера!");
    КонецПопытки;
    
    Если Лев(СокрЛП(ВерсияИзДрайвера), 5) <> "8.0.8" Тогда 
        
        Сообщить("Версия драйвера "+ВерсияИзДрайвера+""); 
        
        //Сообщить ("Версия драйвера не поддерживается. Требуемая версия компоненты 1С:Сканер ШК - 8.0.8!");

    КонецЕсли;
    
    Если Драйвер.Подсоединить("Сканер штрихкода") <> 0 Тогда
        Сообщить ("Ошибка (1) при подключении устройства!");
    КонецЕсли;
    
    //при подключении USB-сканера с эмуляцией COM-порта указывать порт 5 в свойствах виртуального COM-порта в диспетчере устройств


    //сканер настроить - префикса нет, суффикс - CR


    Драйвер.БитДанных  = 8;
    Драйвер.Порт       = 0;
    Драйвер.Скорость   = 9600;
    Драйвер.СтопБит    = 0;
    Драйвер.СтопСимвол = 13//CR - carriage return

    
    Драйвер.Префикс = 40;
    Драйвер.ПрефиксСтрока = "(";      
    
    Драйвер.ИмяСобытия = "ПолученШтрихкод";
    
    Если Драйвер.Занять(1) = 0 Тогда
        Драйвер.УстройствоВключено = 1;
        Драйвер.ПосылкаДанных      = 1;
        Драйвер.ОчиститьВход();
        Драйвер.ОчиститьВыход();
        Сообщить("Сканер подключен и готов к работе!");
        Если Драйвер.УстройствоВключено <> 1 Тогда
            //Отключить();


            Драйвер.УстройствоВключено = 0;
            Драйвер.Освободить();
            Драйвер.Отсоединить();
            Сообщить ("Ошибка (2) при подключении устройства!");
        КонецЕсли;
    Иначе
        //Отключить();


        Драйвер.УстройствоВключено = 0;
        Драйвер.Освободить();
        Драйвер.Отсоединить();
        Сообщить ("Ошибка (3) при подключении устройства!");
    КонецЕсли;
"
Работает, пишет все ок.
далее в этом же модуле добавлены процедуры
"
Процедура ПередЗавершениемРаботыСистемы(Отказ)
    
    Если Драйвер <> Неопределено Тогда 
        Драйвер.УстройствоВключено = 0;
        Драйвер.Освободить();
        Драйвер.Отсоединить();
    КонецЕсли;
    
    
    Режим = РежимДиалогаВопрос.ДаНет;
    Текст = "Закрыть программу?";
    Ответ = Вопрос(Текст, Режим, 0);
    Если Ответ = КодВозвратаДиалога.Нет Тогда
        Отказ = истина;
    КонецЕсли;
КонецПроцедуры

&НаКлиенте
Функция ОбработатьСобытие(Данные) Экспорт
    ШтрихКод = Данные;
    Драйвер.ПосылкаДанных = 0;
    Возврат СокрЛП(ШтрихКод);
КонецФункции

&НаКлиенте
Функция СобытиеОбработано() Экспорт
    Драйвер.ПосылкаДанных = 1;
КонецФункции"
Фактически весь код модуля перечислен, но внешнее событие не работает в модуле документа
Ответ: а все оказалось банальнее, чем я думал...
В модуле управляемого приложения не было процедуры ОбработкаВнешнегоСобытия(Источник, Событие, Данные).

При сканировании, выполняется код этой процедуры, а потом переходит в модуль открытого документа в ВнешнееСобытие(Источник, Событие, Данные).

Спасибо всем за внимание и подсказки/советы.

За аналог была взята статья:
Вопрос: Не корректно работает сканер в рабочем месте работника склада 1с:ERP

Конфигурация ERP 2.2.3.196, тоже самое видел и в КА 2.2 (точно релиз не помню). Есть ТСД cipherlab 9200, по rdp подключается к базе. Сканер ТСД работает как клавиатура с использованием драйвера 1с (nativeapi).

Проблема: в рабочем месте работника склада не происходит подключение сканера как внешнего оборудования и он работает только как клавиатура, т.е. внешних событий не генерируется. Чтобы убедиться, что проблема не в ТСД я попробовал запустить рабочее место работника склада так же через rdp на ПК с использованием ручного проводного сканера, подключенного в разрыв клавиатуры. И что я получил: в документах внешнее событие есть, всё прекрасно сканируется, в рабочем месте кладовщика нет, и это под одним и тем же пользователем в одном сеансе 1с! Полез в код, оказалось, что в документах и рабочем месте кладовщика за подключение сканера отвечают совершенно разные процедуры. У формы рабочего места работника склада есть реквизит ИспользоватьПодключаемоеОборудование. Если его значение Ложь, то подключение оборудования не происходит, однако нигде нет инициализации этого реквизита (видимо должен быть равен значению соответствующей функциональной опции). Этот реквизит инициализуется в процедуре подключения оборудования в формах документов, но как я уже писал выше, в форме работника склада используются другие процедуры.

Попробовал сделать внешнюю обработку из рабочего места работника склада и прописать реквизиту формы ИспользоватьПодключаемоеОборудование значение Истина. И о чудо! Сканер подключился и стало срабатывать внешнее событие.

Что это? Жуткий косяк 1с или я чего-то не понимаю?
Ответ: () Ну естественно включена, иначе как у меня проводной сканер в документах может внешнее событие вызывать? Суть то в том, что сканер в документах вызывает внешнее событие, а в рабочем месте работника склада нет. Это на одном ПК, под одним пользователем ОС, под одним пользователем 1с, в одном сеансе 1с, а это значит, что используются для подключения сканера одна и та же настройка справочника подключаемое оборудование! И рабочее место соответственно это тоже одно и то же.
Вопрос: Сканер штрихкода Gryphon gd4400 глюкнул

Сканером модели gryphon gd4400 была из инструкции прочитана настройка в виде qr кода "select usb alternate key encoding" после чего сканер дважды пикнул и перешел в режим. На сканере мигает индикатор зеленым цветом и ничего не помогает.
При долгом нажатии на кнопку ничего не пищит.

Кто нибудь сталкиался с данной проблемой?
Ответ: Есть же утилиты от производителя - можно подрубить к компу и залить нужные настройки
Вопрос: Сканер штрихкодов

Всем доброго времени суток!
Платформа: 8.3.6.2390
Конфигурация: УТ 11.2.106

База находится на сервере. К этому серверу подключаются пользователи с разных мест.
Пользователи заходят в 1С, по "Аутентификация операционной системы"
Каждый пользователь прописывается в домене и заходит под своей доменной учетной записью.
Для каждого нового пользователя, приходится, каждый раз, проделывать, одну и туже операцию по добавлению возможности работать со сканером штрихкодов (COM разъем).
1.Приходится заходить в 1с, под администратором через CMD, доменная учётная запись при этом пользователя.
2.Запускаем обработку - "Подключение и настройка оборудования". Выбираем Сканер штрихкода -- Создать. Добавляем драйвер оборудования и настраиваем его.
Теперь заходим в 1С, под пользователем и сканер штрихкодов работает. Но стоит, на этом же компьютере, зайти под другим пользователем, как требуется всё это делать по новой, иначе сканер штрихкода не работает.
Кто-нибудь сталкивался с таким?
Как сделать, чтобы на данном компьютере, один раз поставив драйвер и настроив всё в 1С, под другими пользователями сканер штрихкодов, продолжал работать, без дополнительных манипуляций?
Ответ:
Можно попробовать настроить сканер в разрыв клавиатуры. Работа драйвера, вроде бы, никак не привязана к пользователю.
Вопрос: v7: Подключение сканера USB

Где-то меня не было видимо когда это всё разжевали и забыли, а я на com портах с костылями всякими сидел.
Извините, но очень надо, теперь USB сканеры все.
1с ТиС 7,7. Загрузил дрова ДТО 6. Прописал в настройках 1с Scaner1C.dll, Scaner45. Появилось подключение по клавиатурному входу.
Но не читает первую цифру, и она не ноль.
В блокноте всё нормально читает. После сброса на дефолт считывает один, два раза правильно, а потом снова или первую не читает или вообще ерунду пишет.
Сканеры пробовал разные, эффект один. Значит проблема в 1с где-то.
Ответ: Вааще не реально найти настройку префикса к этому сканеру, я думаю. NTEUMM NT-2020
Вопрос: Отвалился сканер Datalogic qw2100

Здравствуйте уважаемые форумчане!
Такая проблема уже возникала, но никак не вспомню как я ее решал, дело было с год назад:
1С:Розница 2.1.9.20 перестал работать сканер штрих кодов Datalogic quick scan lite qw2100.
Захожу в настройки оборудования>сканер>Настроить> и та-дам: Установленная на компьютере версия драйвера устарела! Необходимо обновление до версии: 8.1.5.1
Ничего не устанавливалось, не обновлялось, сканер не отключался. Теперь не могу понять что могло послужить причиной  — просто принимали товар когда это случилось.
В каком направлении копать?
Обновление конфы пока-что не рассматриваю.
Сканер подключен через эмулятор COM порта
Ответ: Забыл добавить, вместо требуемой установил последнюю версию 1С:Сканер штрихкода (COM) 8.1.7.9
Не могу понять почему он тухнет, может просто напросто железка приказала долго жить, а  "Установленная на компьютере версия драйвера устарела! Необходимо обновление до версии: 8.1.5.1 " там висело но я не видел и оно никак не мешалось?