Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: В макете обработки ВНЕШНЕЙ печатной формы "Строки на разных языках"

В макете обработки ВНЕШНЕЙ печатной формы  редактор "Строки на разных языках" добавить языки. КАК? Сейчас есть два.
Ответ: Импортировал в конфигурацию, экспортитровал из конфы. Появились языки, заданные в метаданные - общие - языки
Вопрос: Не переводит строку в зависимоси от локализации языка

Добрый день! ТехДок=НСтр("ru='ДСТУ ГОСТ 32885:2016(ГОСТ 32885-2014,IDT)ТУ У 35.2-32258888-574:2008';uk='ДСТУ ГОСТ 32885:2016(ГОСТ 32885-2014,IDT)ТУ У 35.2-32258888-574:2008'");я переключаю на украинский не хочет,только в одном варианте на русском,что может быть?
Ответ: () Ну тогда без явного указания второго параметра не взлетит
Вопрос: Вьетнамский язык в 1С

День добрый, товарищи! Подскажите такой вот момент:
делаю печатные формы, в которых фигурирует вьетнамский язык.
При использовании, например, arial, все ок. Но! Заказчику милее arial narrow, а именно этот шрифт почему-то вместо символов Ợ, Ồ и других всяких О и Е ставит нечитаемые символы, так же и на печать выводит.
Может, кодировку поменять?
Можно ли это сделать, не внося строки в файл с кодировкой? Перевод с русского на вьетнамский и так сильно тормозит формирование п.ф., не хотелось бы использовать этот вариант.
Ответ: () кодировка тут ни при чем, вы работаете в unicode. Нужно попытаться найти самый свежий Arial Narrow, где отрисованы все необходимые вам символы. Я сталкивался с подобным на примере грузинского и армянского языков - в распространенных шрифтах вроде Tahoma в Windows XP символы рисовались квадратами, а в таком же шрифте, взятом с семерки, все работало. Кстати, замена часто используемого шрифта может быть не очень тривиальным делом - их файлы плохо освобождаются виндой.
Вопрос: Поиск символов в строке

Всем привет.
имеются строки вида:

1. 72-574 L3,0 ШАЙБА РЕГУЛИРОВОЧНАЯ
2. 800.00.1925.0287 IIгр. ШПИЛЬКА
3. 90-1911-1066 ШВЕЛЛЕР N12 L=2400
4. 8-1930-823 СЕТКА N045 ГОСТ 6613-53
5. 8-1910-248 L1,2 ШАЙБА

Так как некоторые "не внимательные" (тут можно подставить любое матерное слово) пользователи не всегда во время замечают свою раскладку на клаве, то появилась необходимость проверить действительно ли слова на русском языке в этих строчках написаны на русском.
Как Вы заметили буржуйские символы могут находится в любом месте строки и при этом быть нужными, а проверять нужно именно такие части строк как:

1. ШАЙБА РЕГУЛИРОВОЧНАЯ
2. гр ШПИЛЬКА
3. ШВЕЛЛЕР
4. СЕТКА ГОСТ
5. ШАЙБА

если есть у кого какие идеи, наработки или видели где тему похожую, то подскажите позязя)

Добавлено через 1 час 2 минуты
извиняюсь поспешил) решение найдено, тему мона закрыть, удалить и придать анафеме)
Ответ: не, по Вашему примеру первая же строка попадёт в набор

1. 72-574 L3,0 ШАЙБА РЕГУЛИРОВОЧНАЯ

даже если часть строки "ШАЙБА РЕГУЛИРОВОЧНАЯ" состоит из кирилицы
чтобы получить требуемые записи нуно будет поделить строку на части, например "по пробелу", проверить каждую получившуюся строчку на присутствие кирилици и тока потом можно применить Вашу конструкцию к каждой отобранной строке.

но, всё равно мерси за не безразличие)
Вопрос: Особенности 1С. Сравнение с Си подобными языками

Добрый вечер, нужна помощь знающих людей) Пишу диплом, и есть у меня задача сравнить 1с например с си подобным языком.
И описать особенности 1с.

Я аж прям теряюсь, что от меня тут хотят увидеть
поделитесь мыслями, что здесь лучше всего осветить.
мне это надо оформить в виде 2-ух слайдов:
1- сравнение с си подобными
2- особенности 1с

P.s. проще написать программу, чем всё эту бумажную ерунду.
Ответ: Вот, к примеру, нашел
Сравнивать Си и 1С не корректно, слишком у них разное назначение.

По общим требованиям к языкам программирования, Си просто порвет 1С. 1С не является настолько универсальной системой программирования.
Платформа 1С - это по сути готовый фреймворк для быстрой разработки и модификации учетных программ, со встроенным скриптовым языком.
Вопрос: Можно ли на языке 1С написать прикладную программу которая будет работать без платформы?

Можно ли на языке 1С написать произвольную прикладную программу которая будет работать без платформы 1с предприятие? Например программу для математических расчетов. Чтобы запускать не из под платформы, а отдельный файл ехе например.

Прошедшим летом попадалась информация, что каким-то умельцам это удалось.

Если это возможно, то как это сделать?
Ответ:
Сообщение от barsik123
Можно ли на языке 1С написать произвольную прикладную программу которая будет работать без платформы 1с предприятие? Например программу для математических расчетов. Чтобы запускать не из под платформы, а отдельный файл ехе например.
А зачем что-то писать на 1С не для нужд 1С-а? Есть куча других, более симпатичных (на мой взгляд, разумеется), языков программирования для этих нужд.
Вопрос: Особенности 1С. Сравнение с Си подобными языками

Добрый вечер, нужна помощь знающих людей) Пишу диплом, и есть у меня задача сравнить 1с например с си подобным языком.
И описать особенности 1с.

Я аж прям теряюсь, что от меня тут хотят увидеть
поделитесь мыслями, что здесь лучше всего осветить.
мне это надо оформить в виде 2-ух слайдов:
1- сравнение с си подобными
2- особенности 1с

P.s. проще написать программу, чем всё эту бумажную ерунду.
Ответ: Вот, к примеру, нашел
Сравнивать Си и 1С не корректно, слишком у них разное назначение.

По общим требованиям к языкам программирования, Си просто порвет 1С. 1С не является настолько универсальной системой программирования.
Платформа 1С - это по сути готовый фреймворк для быстрой разработки и модификации учетных программ, со встроенным скриптовым языком.
Вопрос: Функция: СформироватьЗаголовокДокумента на национальном языке

Приветствую, Форумчане!

Добавил в "Общие" - "Языки" - Туркменский.

В документе "Реализация Товаров и Услуг" в Синоним выбрал Лупу и в раздел "Туркменский" вбил соответствующее название на туркменском.

Требуется сформировать название документа через функцию "СформироватьЗаголовокДокумента" с выводом на туркменском.

СтрокаЗаголовка = НазваниеДокумента + " № " + 
ОбщегоНазначения.ПолучитьНомерНаПечать(ДокументОбъект, глСписокПрефиксовУзлов)	
+ ПереводСтроки + "от " + Формат(ДокументОбъект.Дата, "ДЛФ=DD");


Подозреваю, что нужно использовать "Формат", но какой синтаксис?
Ответ: В смысле. пользователю назначен в настройках туркменский язык.
Вопрос: Какой язык программирования выучить в паре к 1С: Java или Python

Здравствуйте. Программирую на 1С уже более 5 лет.Всю жизнь мечтал быть обычным программистом, но так уж жизнь сложилась, что стал программистом 1С. Уйти с этой области не могу, так как она обеспечивает меня на нормальном уровне финансово. Сменить область понятное дело не могу, так как на текущий уровень дохода я не смогу несколько лет выйти - с учетом семьи и ипотеки это не допустимо.
Но я все равно собрался и хочу освоить на приемлемом уровне какой-нибудь другой язык программирования: отсеял всех осталось два кандидата: Python и Java. Основные задачи для которых мне он нужен: написание не больших программок для windows по мере их необходимости + текущая задача: используя предоставленный API одного из сайтов сбор необходимой информации с него и анализ - 1С тут не подходит вообще. В свое время учил C++ и C# - поэтому в курсе что такое ООП программирование.
Основные плюсы Java: если мало ли все-таки когда-нибудь решу с 1С уйти то Java мне кажется будет в выйгрыше он. + джава это все таки джава. Скорость.
Основные плюсы Python: возможно написать web-сайт. Битрикс не признаю, ну а PHP не вижу смысла для меня- у него не достаточная область охвата. Одного веб мне мало. Скорость разработки по сравнению с Джава.
Что посоветуете?
Ответ:
Сообщение от MonteKristo
а ведь язык это всего лишь инструмент, я думаю когда не видишь и не представляешь в голове, что ты хочешь создавать, то и выбирать инструмент бесполезно.
золотые слова
Вопрос: Автогруппировка строк. Работа над ошибками.

Здравствуйте, не кидайте сильно камнями, помогите исправить ошибки при построении макета с группировками.
1. ИтогПоВид почему-то подбивается в самом конце как общий итог.
2. Над шапкой формируется строка с суммами, происхождение которых мне до сих пор неизвестно...
Чессслово, я просто не понимаю как это работает логически и в какой последовательности нужно группировать. Я готов получить любую оценку моих умственных способностей, но прошу - объясните, научите!! или посоветуете литературу для идиотов)

Код ниже, спасибо заранее....

ТабДок = Новый ТабличныйДокумент;
Макет = Отчеты.ОтчетПоРаботам.ПолучитьМакет("Макет");
ТабДок.НачатьАвтогруппировкуСтрок();
Шапка = Макет.ПолучитьОбласть("Шапка");
Шапка.Параметры.Владелец = Владелец;
Шапка.Параметры.НачДата = Формат(НачПериода,"ДФ=dd.MM.yy");
Шапка.Параметры.КонДата = Формат(КонПериода,"ДФ=dd.MM.yy");
ТабДок.Вывести(Шапка);
Запрос = Новый Запрос;
Запрос.Текст = "
|ВЫБРАТЬ
|    СчетаИАктыОстаткиИОбороты.Владелец,
|    СчетаИАктыОстаткиИОбороты.Заказчик,
|    СчетаИАктыОстаткиИОбороты.ВыписанАкт,
|    СчетаИАктыОстаткиИОбороты.ВидУслуги КАК ВидУслуги,
|    СчетаИАктыОстаткиИОбороты.НачДата,
|    СчетаИАктыОстаткиИОбороты.КонДата,
|    СчетаИАктыОстаткиИОбороты.Наименование,
|    СчетаИАктыОстаткиИОбороты.СтоимостьКонечныйОстаток КАК Стоимость,
|    СчетаИАктыОстаткиИОбороты.НалогКонечныйОстаток КАК Налог,
|    СчетаИАктыОстаткиИОбороты.ВыручкаКонечныйОстаток КАК Выручка,
|    СчетаИАктыОстаткиИОбороты.ВыручкаМенеджераКонечныйОстаток КАК ВыручкаМенеджера
|ИЗ
|    РегистрНакопления.СчетаИАкты.ОстаткиИОбороты КАК СчетаИАктыОстаткиИОбороты
|ГДЕ
|    СчетаИАктыОстаткиИОбороты.Дата МЕЖДУ &НачПериода И &КонПериода
//|    И СчетаИАктыОстаткиИОбороты.Владелец = &Владелец

|    И СчетаИАктыОстаткиИОбороты.ВыписанАкт = &флВыписанАкт
|ИТОГИ
|    СУММА(Стоимость),
|    СУММА(Налог),
|    СУММА(Выручка),
|    СУММА(ВыручкаМенеджера)
|ПО
|    ОБЩИЕ,
|    ВидУслуги";
//Запрос.УстановитьПараметр("Владелец",Владелец());    

Запрос.УстановитьПараметр("НачПериода",НачалоДня(НачалоМесяца(НачПериода)));
Запрос.УстановитьПараметр("КонПериода",КонецДня(КонецМесяца(КонПериода)));
Запрос.УстановитьПараметр("флВыписанАкт",Истина);
Выборка = Запрос.Выполнить().Выбрать();    
Строка = Макет.ПолучитьОбласть("Строка");
СтоимостьИтог = 0;
ВыручкаИтог = 0;
ОплатаИтог = 0;
Ном = 0;
ИтогПоВид = "";
Пока Выборка.Следующий() Цикл
Если Выборка.ТипЗаписи() = ТипЗаписиЗапроса.ИтогПоГруппировке Тогда
Если ИтогПоВид <> "" Тогда
ТабДок.Вывести(ИтогПоВид,1,,Ложь);
КонецЕсли;
Итог = Макет.ПолучитьОбласть("Подвал");
//Итог.Параметры.ИтогоВидУслуги = "ИТОГО ПО " + Выборка.ВидУслуги;

Итог.Параметры.СтоимостьИтог = Выборка.Стоимость;
Итог.Параметры.ВыручкаИтог = Выборка.Выручка;
Итог.Параметры.ОплатаИтог = Выборка.ВыручкаМенеджера;
ОбластьВид = Макет.ПолучитьОбласть("Вид");
ОбластьВид.Параметры.ВидУслуги = Выборка.ВидУслуги;
ТабДок.Вывести(ОбластьВид,1,,Ложь); Ном = 0;
Продолжить;
КонецЕсли;
Строка.Параметры.Заказчик  = Выборка.Заказчик;
Строка.Параметры.Наименование = Выборка.Наименование;
Строка.Параметры.Период = Формат(Выборка.НачДата,"ДФ=dd.MM.yy") + ?(ПустоеЗначение(Выборка.НачДата) ИЛИ ПустоеЗначение(Выборка.КонДата),""," - ") + Формат(Выборка.КонДата,"ДФ=dd.MM.yy");
Строка.Параметры.Стоимость = Выборка.Стоимость;
Строка.Параметры.Выручка = Выборка.Выручка-Выборка.Налог; 
Строка.Параметры.Оплата = Выборка.ВыручкаМенеджера;
Ном = Ном+1;
Строка.Параметры.Ном = Ном;
ТабДок.Вывести(Строка,2,,Ложь);
СтоимостьИтог = СтоимостьИтог + Выборка.Стоимость;
ВыручкаИтог = ВыручкаИтог + Выборка.Выручка;
ОплатаИтог = ОплатаИтог + Выборка.ВыручкаМенеджера;
КонецЦикла;
Если ИтогПоВид <> "" Тогда
ТабДок.Вывести(ИтогПоВид);
КонецЕсли;
ТабДок.ЗакончитьАвтогруппировкуСтрок();
ОбластьИтог = Макет.ПолучитьОбласть("Подвал");
//ОбластьИтог.Параметры.ИтогоВидУслуги = "ИТОГО";

ОбластьИтог.Параметры.СтоимостьИтог = СтоимостьИтог;
ОбластьИтог.Параметры.ВыручкаИтог = ВыручкаИтог;
ОбластьИтог.Параметры.ОплатаИтог = ОплатаИтог;
ТабДок.Вывести(ОбластьИтог);
ТабДок.АвтоМасштаб = Истина;
ТабДок.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
Табдок.ОтображатьЗаголовки = Ложь;
Табдок.ОтображатьСетку = Ложь;
ТабДок.Показать();
Ответ: () Потому что выводит по количеству строк все правильно, а по содержанию - они просто много раз дублируются