Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: Обновление конфигурации не завершено

Клиент-серверный вариант. После обновления и входа в программу программа не может завершить обновление ИБ. Пишет, что переход не завершен, работа пользователей ограничена, хотя всё работает нормально. Если эту же базу выгрузить в файловый режим, то все нормально.
Ответ:
ну так там же и можно посмотреть что она (обработка) не завершила
Вопрос: УТ 10.3 обновление (выкидывает и тд)

Поднимаю 10.3.18.3 последовательно до последнего релиза, с которого можно было бы перенести отстатки в УТ11.
Запускаю конфигуратор, обновление. Конфигуратор видит файл обновления, но при запуске из конфигуратора из проги выкидывает. Пишет Программа "1cv8" не работает, Вин закроет эту программу....
Прекращена работа программы....

Перезапускаю конфигуратор, в итоге один раз из пяти, обновление все таки проходит, но потом когда открываю уже саму базу, рабочую, то из нее тоже выкидывает. Один раз не выкинет, 5 раз выкинет.
WTF? Куда копать?
Спасибо.

И еще: после обновления захожу в рабочую базу, а там:
"Переход с версии 10.3.28 на версию 10.3.19.2 конфигурации УТ 10.3
не поддерживается!
Переход возможен только с версий ... 10.3.18, 10.3.19
Предварительно нужно обновиться на одну из перечисленных версий"
И потом окно: "Не выполнено обновление инф. базы! Завершить работу системы?"

Ну, я ведь и перехожу с 10.3.18 на 10.3.19
При чем тут вообще 10.3.28? Откуда это? Это что за даунгрейд такой? С 28 релиза на 19?

Захожу в инфу о программе, там: 10.3.19.2
Захожу в настройки параметров учета, там Номер версии конфигурации: 10.3.28.1

Пошли обновы. Выкидывать пока перестало, уже 5 релизов прошло. С чем было связано, непонятно.
Ответ:
Конфигуратор сам видит файл обновления, я жму на него, начинается обновление.
Потом выскакивает таблица Обновление, с двумя окнами: справа Основная конфа, слева Новая. Жму выполнить.
Выскакивает Настройка правил поддержки. Оставляю всё по умолчанию. Жму ОК. Запускается объединение.
Потом окно: Объединение конфигураций завершено.
Иду в Сервис. Запускаю 1С Предприятие.
Спрашивает: Обновить конфу баз данных? Говорю -да. Идет сохранение конфигурации.
Появляется окно: Реорганизация информации, Изменения в структуре информации конфы. Жму Принять. Идет принятие изменений.
Запускается рабочая база.
Пишет:
"Переход с версии 10.3.28 на версию 10.3.19.2 конфигурации УТ 10.3
не поддерживается!"
"Не выполнено обновление инф. базы! Завершить работу системы?"
Но, при этом, в инфе о программе, версия уже новая.


Неактивна кнопка "меню Конфигурация - Обновить конфигурацию базы данных"

ПС: стал обновляться из 8.3, выкидывать перестало, обновления ставятся без проблем.
Вопрос: Хочется узнать методику обновления на несколько релизов типовой ине типовой конфы

Хочется узнать вашу методику обновления на несколько релизов типовой конфы
Недавно пришлось обновлять розницу 1.0 на 2.2. и тут захотелось узнать как другие делают обновление конфы на n релизов

1. В конфигураторе через меню «Конфигурация – Поддержка – Настройка поддержки» проверяем номер версии конфигурации поставщика.
Если версия подходящая, то прямо оттуда по кнопке «Сохранить в файл» выгружаем файл .cf
2. Создаю пустую бд, в конфигураторе нажимаем загрузить конфигурацию и выбираем выгруженный .cf файл
3.обновляем в пустой бд до нужно релиза и сохраняем в .cf файл
4. Запускаем старую БД
5.Через меню «Конфигурация – Поддержка - Обновить конфигурацию - Выбор файла обновления» указываем путь к нашему .cf-нику с последним релизом конфигурации поставщика.
6.Проверяем, чтобы обработка обновления базы запустилась и выполнилась без ошибок

я так делаю но мб есть более надежный метод
Ответ:
и далеко не типовая, а отраслевая на основе типовой:

Суть не меняет - шагать по таблице обновлений и читать идущие с обновлениями инструкции по обновлению + инструкции в интернете

Не хочется вручную это делать, найди и скачай "обновлятор 1С"

Это вопрос не вообще, а об обновлении отраслевой конфигурации на основе 1С:Розница с версии 1.0 через промежуточную конфигурацию
Имеет смысл курить инструкции по обновлению "1С : Розница"
  • Переход с 1С:Розница 1.0 на 1С:Розница 2.2. Практическое руководство
Да, а когда обновление настолько "несколько", что перешагивает через первую или второе число версии конфигурации, то имеет смысл уже читать общие идеи по подготовке данных по переносу, например, из УТ 10.3 в 11.0
  • %appdata%\1C\1cv8\tmplts\1c\trade\11_3_4_227\Переход с других конфигураций\Conv10_3.txt"
    (поменять 11_3_4_227 на любую другую установленную версию УТ предыдущего релиза)

    • Сделать резервные копии баз
    • Закрыть все кассовые смены,
    • завершить все обмены и синхронизации,
    • завершить (а то и отключить) все регламентные процедуры.
    • Проверьте информационную базу на предмет наличия непроведенных и незавершенных документов
    • Завершите все операции прихода и перемещения по ордерным схемам.
    • Обработать уже загруженные ТТН ЕГАИС
    • не должно быть отрицательных остатков товаров по складам и организациям
    • изучить интернет на предмет наличия предыдущего опыта
Вопрос: Обновление Розница 2.2.6

При установке онлайн-кассы спецы обновили товарищу Розница 2.0.4.5 до 2.2.6.33. После этого при запуске 1С выскакивает сообщение о незавершенности процесса обновления (). Спецы утверждают, что "все ОК, просто закрывайте это окошко и работайте спокойно!". Однако, дальнейшие обновления не устанавливаются... Нажатие на кнопочку "Выполнить процедуры обработки данных" приводит к сообщению () о выполнении 10 процедур из 17. Следующие обновления по-прежнему не ставятся. Нажатие на ссылку "...(10 из 17)" вываливает таблицу с перечнем процедур и результатами их выполнения (10 "вып", 2 "ошибка" и 5 "не выполнялось") ().
Вопрос: что это за беда и как с ней бороться?
PS рецепт из темы "" не помог.
Ответ:
Сумел все-таки завершить все процедуры обновления! ()
Однако дальнейшие обновления так и не проходят... ()
Нашел чистую базу 2.2.6.33. Выгружаю из своей (обновленной "спецами" от 2.0.4.5 до 2.6.33) данные и пытаюсь загрузить их в "чистую"...
Облом!!! "Неверный формат файла выгрузки"! () Как такое может быть? Одна и та же обработка (ВыгрузкаЗагрузкаДанныхXML83.epf с ИТС "Конвертация данных 2.1.8.2") работает и при выгрузке, и при загрузке!!!
Вопрос: Обновление РИБ Розница 2.0 на Розница 2.2

Доброго времени суток уважаемые форумчане!
Проблема в следующем: не обновляются узлы на новую конфигурацию...

В общем есть Розница 2.0 и 7 узлов магазинов. Розница значительно допилена.
Подготовил обновление на Розница 2.2, написал соответствующие правила. В тестовой связке по правилам данные ходят, нет проблем.
Проблема в следующем, сегодня обновил центральный узел. Обновление делал через полную загрузку cf-ки. Загрузилась, центральный узел обновился. Обмен на выгрузку из центральной БД запустился и прошел удачно.
Открываю магазин, который ещё на 2.0. Запускаю загрузку и она отваливается на "ПрочитатьИзменения", узел магазина не обновляется. А так как узел привязан к центральной, то руками обновить его не получается.

Собственно вопрос, как обновить данную связку? Где допустил ошибку, что делаю не так? Слышал, что можно как-то отвязывать\привязывать к главному узлу. Как это сделать(обработку не получается скачать, если у кого есть киньте пожалуйста)?
У кого есть опыт решения подобных проблем, поделитесь пожалуйста
Ответ: ну копии сперва сделайте и обмены завершите )
Вопрос: Зависло при динамическом обновлении конфигуратор

Добрый день!
Версия 8.3.9 Заменил в макете двоичный файл на другой (Word), динамически обновил, все ок! за минут 5 обновилось. Потом надо было еще раз заменить и вот конфигуратор завис на реструктуризаци, висит уже часа 1,5. В диспечере ресурсы по нулям. т.е. завис. Принудительно завершить страшновато. Что бы не получилось как тут:

Что посоветуете ?
Ответ: Я обычно папку 1с-а чищю после демонического обновления.
Вопрос: сзв_м не переехало после обновления с 2.0 на 3.0

Добрый день!

Подскажите, кто-нибудь сталкивался с такой ситуацией:

Обновлял типовую БП Проф 2.0 до 3.0

После обновления документов СведенияОЗастрахованныхЛицахСЗВ_М в базе обнаружено не было, позднее все старые отправленные отчеты обнаружились в УдалитьСведенияОЗастрахованныхЛицахСЗВ_М.

Вопрос в том как их перенести в правильные доки, ведь пользователи их не видят. Где найти типовое правило?
Ответ: Тогда зачем другие регламентированные отчеты переехали?

Во вторых по последней СЗВ-М был не завершен цикл обмена
Вопрос: Как вывести результат в документ по процедуре Завершить

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
&НаСервере
Процедура ВпередНаСервере()
    Объект.ТекущийВопрос=Объект.ТекущийВопрос+1;
    ПолучитьТекущийВопрос();
КонецПроцедуры
 
&НаКлиенте
Процедура Вперед(Команда)
    Элементы.Назад.Доступность=Истина;
    Если Объект.ТекущийВопрос>=Объект.КолличествоВопросов-1 Тогда
        Элементы.Вперед.Доступность=Ложь;
        Элементы.Завершить.Доступность=Истина;
    КонецЕсли;
    ВпередНаСервере();
    ВывестиТекущийВопрос();
КонецПроцедуры
 
&НаСервере
Процедура НачатьНаСервере()
    
    Объект.ТекущийВопрос=1;
    ПолучитьТекущийВопрос();
КонецПроцедуры
 
&НаКлиенте
Процедура Начать(Команда)
    Если Объект.КолличествоВопросов>0 Тогда
        Элементы.Назад.Доступность=Ложь;
        Элементы.Вперед.Доступность=Истина;
        НачатьНаСервере();
        ВывестиТекущийВопрос();
    КонецЕсли;
    Элементы.Начать.Доступность=Ложь;
КонецПроцедуры
 
&НаКлиенте
Процедура ВывестиТекущийВопрос()    
    Элементы.ВыборОтвета.СписокВыбора.Очистить();
    м=1;
    Для каждого Стр из Объект.ВариантыОтветов Цикл
    Элементы.ВыборОтвета.СписокВыбора.Добавить(м,Стр.Ответ);
    м=м+1;
    КонецЦикла;
КонецПроцедуры
 
 
&НаСервере
Процедура ПолучитьТекущийВопрос()
    Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |   Вопросы.Наименование,
        |   Вопросы.ПравильныйОтвет,
        |   Вопросы.ВариантыОтветов.(
        |       Ответ
        |   )
        |ИЗ
        |   Справочник.Вопросы КАК Вопросы
        |ГДЕ
        |   Вопросы.Владелец = &Дисциплина
        |   И Вопросы.НомерВопроса = &НомерВопроса";
    
    Запрос.УстановитьПараметр("Дисциплина", Объект.Дисциплина);
    Запрос.УстановитьПараметр("НомерВопроса", Объект.ТекущийВопрос);
    
    РезультатЗапроса = Запрос.Выполнить();
    
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        Объект.Вопрос=ВыборкаДетальныеЗаписи.Наименование;
        Варианты=ВыборкаДетальныеЗаписи.ВариантыОтветов.Выгрузить();
        Объект.ВариантыОтветов.Загрузить(Варианты);
        Объект.ПравильныйОтвет=ВыборкаДетальныеЗаписи.ПравильныйОтвет;
    КонецЦикла;
КонецПроцедуры
 
&НаКлиенте
Процедура Назад(Команда)
    Элементы.Вперед.Доступность=Истина;
    Если Объект.ТекущийВопрос<=2 Тогда
        Элементы.Назад.Доступность=Ложь;
    КонецЕсли;
    НазадНаСервере();
    ВывестиТекущийВопрос();
КонецПроцедуры
 
&НаСервере
Процедура НазадНаСервере()
     Объект.ТекущийВопрос=Объект.ТекущийВопрос-1;
    ПолучитьТекущийВопрос();
КонецПроцедуры
 
&НаКлиенте
Процедура Завершить(Команда)
    ЗавершитьНаСервере();
КонецПроцедуры
 
&НаСервере
Процедура ЗавершитьНаСервере()
    
КонецПроцедуры
 
&НаКлиенте
Процедура ВыборОтветаПриИзменении(Элемент)
    ВыборОтветаПриИзмененииНаСервере();
КонецПроцедуры
 
&НаСервере
Процедура ВыборОтветаПриИзмененииНаСервере()
    Ст=Объект.Ответы.Получить(Объект.ТекущийВопрос-1);
    Ст.ОтветСтудента=Объект.ВыборОтвета;
    Ст.ПравильныйОтвет=Объект.ПравильныйОтвет;
 
    КонецПроцедуры
 
&НаКлиенте
    Процедура ДисциплинаПриИзменении(Элемент)
        ДисциплинаПриИзмененииНаСервере();
    КонецПроцедуры
 
&НаСервере
    Процедура ДисциплинаПриИзмененииНаСервере()
        Запрос=Новый Запрос;
        Запрос.Текст=
        "ВЫБРАТЬ
        |   Вопросы.Ссылка
        |ИЗ
        |   Справочник.Вопросы КАК Вопросы
        |ГДЕ
        |   Вопросы.Владелец = &Владелец";
        Запрос.УстановитьПараметр("Владелец",Объект.Дисциплина);
        РезультатЗапроса=Запрос.Выполнить();
        ВыборкаДетальныеЗаписи=РезультатЗапроса.Выбрать();
        Объект.КолличествоВопросов=ВыборкаДетальныеЗаписи.Количество();
        Для м=1 по Объект.КолличествоВопросов Цикл
            Объект.Ответы.Добавить();
            КонецЦикла;
    КонецПроцедуры
Ответ: Дмитрий666666, если я правильно поняла, то у вас в документе есть табличная часть Ответы с полями "ОтветСтудента" и "ПравильныйОтвет". В этом случае можно обойти табличную часть, сравнивая значения ответов. Вызов серверной процедуры не обязателен.
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
&НаКлиенте
Процедура Завершить(Команда)
 ПравОтветы = 0;
 Для Каждого ТекСтрока Из Объект.Ответы Цикл
   Если ТекСтрока.ОтветСтудента = ТекСтрока.ПравильныйОтвет Тогда
     ПравОтветы = ПравОтветы + 1;
   КонецЕсли;
 КонецЦикла;
 ВсегоВопросов = Объект.Ответы.Количество();
 Процент = ПравОтветы / ВсегоВопросов * 100;
 
 Если Процент < 50 Тогда
  Оценка = 2;
 ИначеЕсли Процент >= 50 и Процент < 80 Тогда 
  Оценка = 3;
 Иначе
//разберитесь, что вы выше про оценки написали)
 КонецЕсли;
 
 Сообщение = Новый СообщениеПользователю();
 Сообщение.Текст = НСтр("ru = 'Ваша оценка = ' ") + Оценка;
 Сообщение.Сообщить();
 
КонецПроцедуры
Вопрос: Транзакция не завершена

Добрый день! может кто подскажет, в журнале регистрации все транзакции со статусом "Не завершена". платформа 8.3.10.2505. 1с собран в кластере. сервер бд ms sql2008 r2 10.50.1600.1
Ответ: проблемы пока нет, через некоторое время, они становятся - завершенными. хочется понять, почему такое происходит, раньше такого не было
Вопрос: Обновление 1С:УПП из командной строки

Добрый день.
Появилась необходимость обновлять 1С ночью, из командной строки. Команду нашли, оттестировали на обновлении конфигурации нашими изменениями. Однако в случае выхода нового релиза УПП, как утверждает ответственный за обновление сотрудник, необходим тестовый запуск 1С из конфигуратора в режиме 1С:Предприятия (Сервис/1С:Предприятие). Недавно, когда забыли сделать этот тестовый запуск, имели проблемы: на пользовательских машинах при запуске появлялось сообщение о проведении обновления (хотя оно было выполнено), а затем возникала ошибка на самых разных местах, где всё работало ранее нормально. Помогла очистка кэша у пользователей.
Вопрос - при обновлении со сменой версии релиза из командной строки как нам быть с тестовым запуском? Нужен ли он? И если нужен, как его сделать?
PS Запуск 1С после обновления НЕ из конфигуратора с полными правами в описанном выше случаене помог.
Ответ: () Вообще такого термина как "тестовый запуск" в УПП или 1С нет.
При обновлении на новый релиз, в момент первого запуска на типовой УПП открывается окно проверки легальности обновления. При подтверждении легальности запускаются обработки обновления.
Если у вас при смене релиза окно проверки легальности не открывается, нужно пытать вашего программиста на тему, как запускаются обработки обновления в вашей доработанной базе.