Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: Нет доступа к свойствам табличного документа

Конфигурация Автоматизированный сервисный центр 2.7 (на базе УТ).
Печатаю из ЗаказаПокупателя печатную форму. Под моим пользователем не доступны свойства табличного документа, а под другими пользователями доступно.

Подскажите где и какие задать настройки пользователя чтобы у меня был доступ к свойствам табличного документа?
Ответ: Нашел в дополнительных правах пользователя в справочнике Пользователи и далее перейти значение дополнительных прав пользователя.

Ветку можно закрывать.
Вопрос: Свойство "защита" в поле табличного документа

всем привет.
как поставить защиту на ячейку и / или область табличного документа.
или как-то иначе запретить редактирование данной области/ ячейки.
свойство "защита", установленное в конфигураторе ни на что не влияет, как мне показалось.
Ответ: аааа
вовсе не отпали бы
что тогда значит и какой смысл имеет установка свойства защита в истина на область.
при отключенной защита у всего табличного документа.
и включенной защита у ячейки?

Добавлено через 1 минуту
другой вариант
область выкл.
табл док выкл.
ячейка вкл ---???
третий вариант
табдок вкл, область выкл, ячейка вкл.
/////////////////
получается область ни на чте не влияет?
//////////
з.ы. спасибо за сообщение.
Вопрос: Загрузка данных из табличного документа. (УТ 11, ввод остатков, количество)

Здравствуйте, профессионалы!

Можете ли подсказать, никак не справлюсь с одной ошибкой.
У меня УТ 11.3, при загрузке табличной части документа «Ввод остатков товаров» всё загружается, но поле «Количество» не воспринимается как число, хотя все числа прописываюся!

В результате, если открыть документ "Ввод остатков товаров", еоторый заполнен обработкой "Загрузка данных из табличного документа", на каждую ячейку «Количество», при проведении документа, выскакивает ошибка: «Обнаружено нулевое количество при пересчете товара в единицу хранения в строке N списка товары». (Хотя количество прописывается)

Как победить эту ошибку?

Все остальные поля заполняются корректно.
Ответ:
Есть поле "Количество единиц хранения", поставил "=1"
Теперь, при проведении документа, на каждую строку ругается "После округления количество товара будет равно 10 шт в строке 1 списка "Товары", при этом погрешность составляет 9 шт, что привышает максимальную погрешность 0 шт"

Может поставить Кол. единиц хранения = количеству товара?
--- Объединение сообщений, 13 дек 2017 ---
УРА!!!
Помогло!!!

Поставил в поле "Количество единиц хранения" тип "Вычислить" и выражение "Результат = ТекстыЯчеек.Получить(2)", где 2 - это номер колонки из загружаемой таблицы с количеством товара.

Всем СПАСИБО!!!

************* Дополнительно ******************

Возник ещё один вопрос.
Т.к. он в ту же тему, не стал создавать новую.

Надо подгрузить штрих-коды к товарам по остаткам, какой обработкой это проще сделать?

В обработке "Загрузка данных из табличного документа" не нашел (может плохо искал?)

Подскажите, кто знает?
---------------------------------------------------------
Опять же сам отвечаю (Нашел)

В обработке "Загрузка данных из табличного документа" раздел "Регистры сведений" есть "Штрихкоды номенклатуры"
Вопрос: Рисунок табличного документа

Всем здравствуйте! Имею 2 файла с картинками. Нужно получить один файл, наложив одну картинку на другую. И по возможности в формате jpg. Я же решаю задачу так:
1) Создаю табличный документ и в него добавляю 2 рисунка, загружая их из файлов
2) Располагаю один рисунок поверх другого
3) Записываю область табличного документа с рисунками в файл формата PDF (за неимением другой возможности в 1С)
4) А дальше можно формат pdf преобразовать в jpg через фотошоп
Можно ли это как-то проще сделать и как? А результат меня всё же не устраивает - у рисунков есть линии вдоль контура. И при наложении рисунков друг на друга, их видно. Так, видна белая линия у верхнего рисунка по горизонтали и вертикали, и линия вокруг главного рисунка (скриншот открытия pdf файла прилагаю в файле "Картинка.JPG").
Если можно исправить мой код, чтобы не было линий, то прошу подсказать, пожалуйста.

Код:
ТабДок=Новый ТабличныйДокумент;
ТабДок.ОтображатьСетку=ложь;
КартинкаГлавная=Новый Картинка(ПутьККартинке);
КартинкаСверху=Новый Картинка(ПутьККартинке);    РисГлавный=ТабДок.Рисунки.Добавить(ТипРисункаТабличногоДокумента.Картинка);
РисГлавный.ГраницаСверху=ложь;
РисГлавный.ГраницаСлева=ложь;
РисГлавный.ГраницаСнизу=ложь;
РисГлавный.ГраницаСправа=ложь;   
РисСверху=ТабДок.Рисунки.Добавить(ТипРисункаТабличногоДокумента.Картинка);
РисСверху.ГраницаСверху=ложь;
РисСверху.ГраницаСлева=ложь;
РисСверху.ГраницаСнизу=ложь;
РисСверху.ГраницаСправа=ложь;
ИндексГлавный=ТабДок.Рисунки.Индекс(РисГлавный);
ИндексСверху=ТабДок.Рисунки.Индекс(РисСверху);   
ТабДок.Рисунки[ИндексГлавный].Картинка=КартинкаГлавная;
ТабДок.Рисунки[ИндексСверху].Картинка=КартинкаСверху;   
ТабДок.Рисунки[ИндексГлавный].Расположить(ТабДок.Область("R1C1:R16C8"));    ТабДок.Рисунки[ИндексСверху].Расположить(ТабДок.Область("R1C1:R8C4"));
ТабДок.Область("R1C1:R16C8").ВысотаСтроки=5;
ТабДок.Область("R1C1:R16C8").ШиринаКолонки=5;    ТабДок.ПолучитьОбласть("R1C1:R16C8").Записать(СохранятьВПапку+"\Картинка.pdf",ТипФайлаТабличногоДокумента.PDF);

Вложения:

  • Размер файла:
    108 КБ
    Просмотров:
    13
Ответ:
Так макета-то табличного документа у меня нет. Я всё делаю программно: и картинки создаю, и табличный документ, а потом располагаю картинки в областях ТабДока.
Вопрос: Количество строк табличного документа

Помогите пожалуйста подсчитать кол-во строк табличного документа!!!
Получаю с формы с поля ввода текст, вывожу его на печать. Если текст не помещается на 1 страницу, получается не очень хорошо. хотел бы подсчитать количество строк, чтобы сделать фиксированный вывод строк на одну страницу.
Процедура Печать(Элемент)
ТабДок = Новый ТабличныйДокумент;
Макет = Документы.СлужебнаяЗаписка.ПолучитьМакет("Печать");
Шапка=Макет.ПолучитьОбласть("Шапка");
ТабДок.Вывести(Шапка);
ТекстСЗ=Макет.ПолучитьОбласть("ТекстСЗ");
//параметр, в который подставляется значение поля ввода.
ТекстСЗ.Параметры.Заполнить(ЭтотОбъект);
//необходимо подсчитать количество строк перед выводом,
ТабДок.Вывести(ТекстСЗ);
Подвал=Макет.ПолучитьОбласть("Подвал");
ТабДок.Вывести(Подвал);
ТабДок.ОтображатьСетку = Ложь;
ТабДок.Защита = Ложь;
ТабДок.ТолькоПросмотр = Ложь;
ТабДок.ОтображатьЗаголовки = Ложь;
ТабДок.ПовторятьПриПечатиСтроки=(ТабДок.Области.Шапка);
ТабДок.Показать();
КонецПроцедуры
Ответ:
Интересует как можно влиять на количество печатаемых на листе строк. К примеру есть указать в ручную количество строк меньшее чем есть в табличном документе <code>(ТабДок.ВысотаТаблицы=7</code> получим сообщение об ошибке «Поле объекта недоступно для записи (ВысотаТаблицы) ТабДок.ВысотаТаблицы=7;». В моем пробном примере в ВысотаТаблицы было 8. В типовых конфигурациях можно встретить такое
Выводится макет с табличной частью на четыре листа при этом табличная часть не заполняет всю таблицу
Вопрос: Сумма ячеек в табличном документе

Добрый день!возникла проблема с реализацией задани 4 по экзамену на специалиста.Создал справочник "Отделы",там макет,который в итоге выгрузил в табличный документ этого же справочника.Табличный документ по строкам состоит из доходных и расходных показателей предприятия,а колонки из нескольких месяцев.ТолькоПросмотр=Ложь.Как мне прописать,что бы в ячейке сумма доходов суммировались все доходы по месяцам,т.е сумма колонки,также расходы, и вывести разность этих ячеек.
Кроме коннекта с Excel есть иные варианты?
Ответ:
Что за ?! а что мешает запрос выгрузить в таблицу значений, провести необходимые сравнения, вычисления и т.д. а уж потом таблицу значений выгрузить в табличный документ?
Вопрос: Авто-ширина колонки в поле табличного документа

8.1.
Есть поле табличного документа на форме. туда вывожу макет.
Колонка в макете стоит с автошириной , но это не работает. (это бага или так и должно быть?)
Вручную установить ширину области колонки после вывода могу, но это как-то странно, да и ширина там как я понимаю это не просто максимальная длина выводимых строк.
Макет - простой. строка заголовка и строка таблицы.
Как лучше поступить чтоб это обойти?
Выводимые строки могут быть совсем разной длины а перенос некрасиво в данном случае выглядит (строк много).
спасибо.
Ответ:
Паля
8.1.
Есть поле табличного документа на форме. туда вывожу макет.
Колонка в макете стоит с автошириной , но это не работает. (это бага или так и должно быть?)
Вручную установить ширину области колонки после вывода могу, но это как-то странно, да и ширина там как я понимаю это не просто максимальная длина выводимых строк.
Макет - простой. строка заголовка и строка таблицы.
Как лучше поступить чтоб это обойти?
Выводимые строки могут быть совсем разной длины а перенос некрасиво в данном случае выглядит (строк много).
спасибо.
Понекрофильствую.
"Между сообщениями прошло более 1 года".

В типовых в модуле отчет УниверсальныйОтчет в цикле перебираются строки табличного документа, заполминается ширина текста и потом устанавливается ширина столбца.
Вопрос: Нумерация табличного документа не с начала 8.2

Добрый день.
У табличного документа есть колонтитул, [&НомерСтраницы] - выводит номер страницы. Можно как-нибудь начать нумеровать страницы не с 1-ой?
Ответ:
Alex.Ru
Но принтеры бывает разные, трудно рассчитать где ставить разрыв страницы.
У табличного документа есть метод ПроверитьВывод(), в параметр которого помести выводимую область.
Возвращает ИСТИНА, если область вмещается на текущую страницу, ЛОЖЬ если нет.
Я делал так:

МассивОбластей = Новый Массив;
МассивОбластей.Добавить(СтрокаТаблицы);
МассивОбластей.Добавить(ОбластьПодписей);

Если НЕ ТабличныйДокумент.ПроверитьВывод(МассивОбластей) Тогда
    ТабличныйДокумент.ВывестиГоризонтальныйРазделительСтраниц();
    НомерСтраницы = НомерСтраницы+1;
    ВерхнийКолонтитул.Параметры.НомерСтраницы = НомерСтраницы;
    ТабличныйДокумент.Вывести(ВерхнийКолонтитул);
    ТабличныйДокумент.Вывести(ЗаголовкиТаблицы);
    ...
КонецЕсли;
ТабличныйДокумент.Вывести(СтрокаТаблицы);
...
Вопрос: Вывод горизонтального разделителя в табличном документе

Есть форма справочника, на форме расположен табличный документ.Нужно при установке курсора на определённую ячейку и при нажатии на кнопку на форме выводить после ячейки горизонтальный разделитель.

&НаКлиенте
Процедура ВставитьГоризонтальныйРазделитель(Команда)
    ВставитьГоризонтальныйРазделительНаСервере(ТабДокПроектДокумента,ТабДокПроектДокумента.ТекущаяОбласть.Имя);
КонецПроцедуры

&НаСервере
Процедура ВставитьГоризонтальныйРазделительНаСервере(ТабДок,Ячейка)
ТабДок.ТекущаяОбласть = ТабДок.Область(Ячейка);
ТабДок.ВывестиГоризонтальныйРазделительСтраниц();    
КонецПроцедуры

вот что есть на данный момент,но не отрабатывает,видимо чего-то не хватает
Ответ:
    ТабличныйДокумент = Новый ТабличныйДокумент;
    
    Данные = ПолучитьИзВременногоХранилища(АдресХранилища);
    
    ИмяФайлаВременное = ПолучитьИмяВременногоФайла("mxl");
    
    Данные.Записать(ИмяФайлаВременное);
    ТабличныйДокумент.Прочитать(ИмяФайлаВременное);   

    
    
    Формулы.Очистить();
    Для Итератор = 1 По Число(ТабличныйДокумент.Область(1,1,1,1).Текст) Цикл
        
        
        ТекЛист = "Лист"+Итератор;          
        
        НовыйЛист = ЭтаФорма[ТекЛист];
        
        НовыйЛист.Очистить();            
        
        //На случай если есть группировки в сохраненном табличном документе сначала выводим все а потом удаляем ненужные (По другому ни как)        

        НовыйЛист.Вывести(ТабличныйДокумент);
        Если НовыйЛист.Область(ТекЛист).Верх > 1 Тогда
            НовыйЛист.УдалитьОбласть(НовыйЛист.Область(1,,НовыйЛист.Область(ТекЛист).Верх-1),ТипСмещенияТабличногоДокумента.ПоВертикали);
        КонецЕсли;  
        
        Если НовыйЛист.Область(ТекЛист).Низ <> НовыйЛист.ВысотаТаблицы Тогда
            НовыйЛист.УдалитьОбласть(НовыйЛист.Область(НовыйЛист.Область(ТекЛист).Низ+1,,НовыйЛист.ВысотаТаблицы),ТипСмещенияТабличногоДокумента.ПоВертикали);
        КонецЕсли;         
                
        НовыйЛист.Область(ТекЛист).КонецСтраницы = Ложь; 
        НовыйЛист.Область(ТекЛист).Имя = "";



Вот этот код работает у меня
Вопрос: Табличный документ в веб-клиенте

Доброго времени суток! При вызове метода "Показать()" табличного документа в режиме веб-клиента появляется ошибка "Процедура или функция с указанным именем не определена (StrSplit)". Не подскажете, в чём может быть дело? Спасибо
Ответ: () А точно П.ТабДок это табличный документ?