Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: Нужен пример XML с Актами Об оказании услуг (реализация) формата EnterpriseData к БП 3.0

Приветствую всех!
У кого-нибудь есть  пример XML с Актами Об оказании услуг (реализация) формата EnterpriseData к БП 3.0 ?

Нужно для создании выгрузок актов из нашего биллинга в нашу же 1С.
Ответ: Не, теги корявые, с ошибками распознало.
Вопрос: Выгрузка в формате EnterpriseData

Поделитесь обработкой (кодом) для выгрузки произвольных данных в формат EnterpriseData.

Поясню: есть самописная конфа, из которой требуется однократно выгрузить данные в типовую БП. Городить обмен и изучать КД3 не очень хочу... В бухгалтерии есть кнопка "Загрузка данных EnterpriseData". Как программно подготовить файл, чтобы загрузить его через эту кнопку?
Ответ: () На ИТС документация по БСП
Вопрос: Проведение документа «Оказание услуги» по двум регистрам

Указав стоимость материала и в файле оказание услуги и проведя его выводится странная стоимость в регистре Стоимость материалов. Подскажите пожалуйста что не так, делаю по книге Радченко.
Ответ: картинки не грузятся, инета нету
но рискну предположить, что ты неверно списал что-то.
если есть два учетных регистра и оба остаточные, то списывать из них можно только то что может быть и получено из них.
/////////
з.ы. конечно можно списать вообще все как хочешьи если тебе говорят спиши - бери расписку и списывай
к примеру может получиться ситуация осталось ноль тапок на сумму минус 350 тыщ рублей.
Вопрос: Учет расхода материалов при оказании услуг

Добрый вечер!
Фирма оказывает услуги, при этом происходит расход материалов для обеспечения этих услуг. Клиенту предоставляется счет и акт только на услуги. Как правильно в УТ 11 вести учет используемых материалов?
Ответ:
Никак, УТ не умеет считать расход материалов при оказании услуг. Нужна как минимум БУХ.
Вопрос: v7: Печать актов по 2 экземпляра на листе с линией разрыва.

Добрейшего времени суток. Вот такой вопрос возник, можно ли программно узнать выставлена ли печать 2-х документов (актов оказания услуг) на одной страницы, и, если выставлена, печатать разделительную линию отрыва. А то говорят клиенты с курьерами нервенные все стали и рвут как ни попадя :)
Ответ: Чтобы вывести на печать секцию с линией отрыва, эту команду нужно прописать в процедуре печати.

Чтобы процедура печати выполняла эту строку кода в зависимости от установок, нужно их считывать.

Обратимся к СП.
ЭкземпляровНаСтранице(<?>)
Синтаксис:
ЭкземпляровНаСтранице(<Колво>)
Назначение:
Определить количество печатаемых экземпляров на странице. Возвращает: текущее числовое значение количества печатаемых экземпляров на странице (на момент до исполнения метода).
Параметры:
<Колво> - число печатаемых экземпляров на странице. Может принимать значения:
1 - один экземпляр на странице
2 - два экземпляра на странице
0 - автоматический режим размещения двух экземпляров на странице исходя из размеров документа.

Поскольку программно узнать значение параметра возможно, с этой стороны проблем нет.

Хуже другое- обычно печатные формы актов заточены для вывода на целой странице, поэтому печатную форму понадобиться доработать.

Можно обойтись и масштабированием, если клиенты согласны жрать такие акты.Команду на уменьшение масштаба можно выводить тоже по результатам считывания параметра ЭкземпляровНаСтраницу.
Вопрос: Как программно добавить проводку в док оказания услуг

Добрый день! Док оказания услуг необходимо,чтобы если есть акцизный сбор в доке формировалась проводка
сч702 на 6418 пункт акциз
Ответ: () открыть глобальный модуль и посмотреть описание процедуры глПроводка() подозреваю, что некоторыми параметрами, которые передаются в процедуру, будут значения субконт
Вопрос: Перенос остатков из БП 3 в БП 3 через универсальный формат EnterpriseData

Хочу перенести остатки из БП в БП используя EnterpriseData, вроде бы в правилах соответствующие ПОДы есть, в связи с этим вопрос, как эти ПОДы затолкать в план обмена.
Ответ: () Счета не задваивает, даже не знаю, что я делаю не так. Короче, решил проблему радикально, взял за основу обработку перехода с БП на ERP она юзает универсальный формат из конфигурации, добавил недостающие функции в обработке получения и изменил состав ПОД для принятых. Вроде бы что-то выгрузилось, но в номенклатуре и контрагентах появились битые ссылки вида "объект не найден" на днях раскурю в чём причина о результате отпишусь. На демках вроде нормально выгрузилось.
Вопрос: Требуется помощь с реализацией

1С:Предприятие 8.3 Управление торговлей 10.3.
Есть два счета (предоплата за услуги и окончательный расчет). В процессе привязки этих двух счетов на одну реализацию (акт об оказании услуг) произошел то-ли какой-то сбой, то-ли из за "кривых рук". При этом реализация № 427 от 09.10.2017 стала №00000000001 от 09.10.0201. Можно ли как-то исправить ситуацию и вернуть реализации к первоначальному номеру и дате. При любой попытке открыть или изменить документ выводится сообщение "Поле объекта не обнаружено (ИспользоватьСкидкиПоКоличеству Товара)", а в служебных сообщениях "Не указаны параметры учетной политики управленческого учета на 9 октября 0201г.". Пока единственное, что приходит на ум это установить пометку на удаление реализации и создать новую, но как присвоить новой реализации именно номер 427. С уважением, Святослав.
Ответ:
Номер акта в 1С должен остаться, т.к. уже подписаны бумажные варианты с заказчиком.
Вопрос: Недоступна ТЧ док. Акт расхождения после реализации

Недоступна ТЧ док. Акт "расхождения после реализации", дата запрета редактирования не установлена, подскажите почему это может происходить
Ответ: Скорей всего программно ограничено, может Видимость=Ложь
Вопрос: Оптимизация проведения документа

Доброе утро, уважаемые программисты :-)
При разработке конфигурации в 1С 8.2 столкнулась со следующей ситуацией. У меня есть документ "Заявка", в котором присутствует реквизит "Статус" со значениями, взятыми из перечислений "Назначен", "Выполняется", "Выполнено", "Не выполнено". Поскольку я новичок в этом деле и это моя первая разработка, все значения реквизитов для каждой заявки приходится менять вручную. Статус заявки при проведении документа фиксируется в соответствующем регистре сведений "Статус заявки".
Помимо этого с заявкой связаны документы "ЗаказМатериаловДляВыполненияУслуги" и "АктОказанияУслуг". Подскажите, пожалуйста, как сделать, чтобы при записи "Заказа материалов" (его движения ни в одном из созданных регистров не отражаются) движения документа "Заявка" перепизасывались с соответствующим изменением реквизита "Статус" на "Назначено", и при проведении док-та "Акт оказания услуг" (регистр накопления "Услуги") статус в док-те "Заявка" менялся на "Выполнено".
Вот модули объектов всех документов

Заявка:
Код 1C
1
2
3
4
5
6
7
8
Процедура ОбработкаПроведения(Отказ, Режим)
   // регистр СтатусЗаявки
   Движения.СтатусЗаявки.Записывать = Истина;
   Движение = Движения.СтатусЗаявки.Добавить();
   Движение.СрокИсполнения = СрокИсполнения;
   Движение.Исполнитель = Исполнитель;
   Движение.Статус = Статус;
КонецПроцедуры
Заказ материалов для оказания услуги:
Код 1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
Процедура ОбработкаЗаполнения(ДанныеЗаполнения, СтандартнаяОбработка)
   
   Если ТипЗнч(ДанныеЗаполнения) = Тип("ДокументСсылка.ЗаявкаНаОказаниеПлатныхУслуг") Тогда
      Исполнитель = ДанныеЗаполнения.Исполнитель;
      ДокументОснование = ДанныеЗаполнения.Ссылка;
      Для Каждого ТекСтрокаТабличнаяЧасть1 Из ДанныеЗаполнения.ТабличнаяЧасть1 Цикл
         НоваяСтрока = ТабличнаяЧасть1.Добавить();
         НоваяСтрока.Услуга = ТекСтрокаТабличнаяЧасть1.ВидУслуги;
      КонецЦикла;
   ИначеЕсли ТипЗнч(ДанныеЗаполнения) = Тип("ДокументСсылка.ЗаявкаНаОказаниеБесплатныхУслуг") Тогда
      Исполнитель = ДанныеЗаполнения.Исполнитель;
      ДокументОснование = ДанныеЗаполнения.Ссылка;
      Для Каждого ТекСтрокаТабличнаяЧасть1 Из ДанныеЗаполнения.ТабличнаяЧасть1 Цикл
         НоваяСтрока = ТабличнаяЧасть1.Добавить();
         НоваяСтрока.Услуга = ТекСтрокаТабличнаяЧасть1.ВидУслуги;
      КонецЦикла;
   КонецЕсли;
КонецПроцедуры
Акт оказания услуг:
Код 1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
Процедура ОбработкаПроведения(Отказ, Режим)
   // регистр Услуги
   Движения.Услуги.Записывать = Истина;
   Для Каждого ТекСтрокаТабличнаяЧасть1 Из ТабличнаяЧасть1 Цикл
      Движение = Движения.Услуги.Добавить();
      Движение.Период = Дата;
      Движение.ВидУслуги = ТекСтрокаТабличнаяЧасть1.ВидУслуги;
      Движение.Исполнитель = Исполнитель;
      Движение.Количество = ТекСтрокаТабличнаяЧасть1.Количество;
   КонецЦикла;
КонецПроцедуры
 
Процедура ОбработкаЗаполнения(ДанныеЗаполнения, СтандартнаяОбработка)
   Если ТипЗнч(ДанныеЗаполнения) = Тип("ДокументСсылка.ЗаявкаНаОказаниеПлатныхУслуг") Тогда
      Инициатор = ДанныеЗаполнения.Заказчик;
      Исполнитель = ДанныеЗаполнения.Исполнитель;
      ДокументОснование = ДанныеЗаполнения.Ссылка;
      Для Каждого ТекСтрокаТабличнаяЧасть1 Из ДанныеЗаполнения.ТабличнаяЧасть1 Цикл
         НоваяСтрока = ТабличнаяЧасть1.Добавить();
         НоваяСтрока.ВидУслуги = ТекСтрокаТабличнаяЧасть1.ВидУслуги;
         НоваяСтрока.Количество = ТекСтрокаТабличнаяЧасть1.Количество;
      КонецЦикла;
   ИначеЕсли ТипЗнч(ДанныеЗаполнения) = Тип("ДокументСсылка.ЗаявкаНаОказаниеБесплатныхУслуг") Тогда
      Инициатор = ДанныеЗаполнения.Заказчик;
      Исполнитель = ДанныеЗаполнения.Исполнитель;
      ДокументОснование = ДанныеЗаполнения.Ссылка;
      Для Каждого ТекСтрокаТабличнаяЧасть1 Из ДанныеЗаполнения.ТабличнаяЧасть1 Цикл
         НоваяСтрока = ТабличнаяЧасть1.Добавить();
         НоваяСтрока.ВидУслуги = ТекСтрокаТабличнаяЧасть1.ВидУслуги;
         НоваяСтрока.Количество = ТекСтрокаТабличнаяЧасть1.Количество;
      КонецЦикла;
   КонецЕсли;
   
КонецПроцедуры
Спасибо! С уважением, грустный студент :-)

Добавлено через 1 час 27 минут
Поняла, что нужно Заказ и Акт сделать также регистраторами для регистра "Статус заявки", но что делать дальше, не понимаю.
Ответ: Подскажите, а как переменные объявить, которые используются в листинге "При открытии"

Добавлено через 1 минуту
Начала так, наверное, неправильно

Добавлено через 41 секунду
Начала так, наверное, неправильно
Код 1C
1
2
3
4
5
6
7
8
9
10
11
12
    Процедура ПриОткрытии(Отказ)
    
 
Если ЭтоНовый() Тогда
        Перечисления=Перечисления.ПолучитьОбъект();
        РегистрыСведений=РегистрыСведений.ПолучитьОбъект();
   ЗначениеСтатусЗаявки = Перечисления.Статус.Назначен;
Иначе
   СтруктураСтатуса = РегистрыСведений.СтатусЗаявки.Получить(Новый Структура("Заявка", Ссылка));
   ЗначениеСтатусЗаявки = СтруктураСтатуса.Статус;
КонецЕсли;
КонецПроцедуры
Добавлено через 13 минут
Для док-тов ЗаказМатериалов и Акт тоже создавать поля? Реквизиты не нужны?

Добавлено через 3 часа 31 минуту
Сделала, спасибо за советы! )