Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: Очень простой вопрос по запросу.

всем ку.

нужно вытащить первую (по дате исполнения) задачку по бизнес-процессу (бп). Т.к. в бп может несколько раз выпадать одна и таже задача, запрос выводит несколько. А нужно только первую по времени выполнения.

Сильно не ругайте за запрос.

ВЫБРАТЬ ПЕРВЫЕ 500
    аДокументооборотКорпоративныйДокумент.Ссылка КАК ДокументСсылка,
    ЗадачаКорпоративногоПроцесса.Ссылка КАК ЗадачаСсылка,
    аДокументооборотКорпоративныйБизнесПроцесс.ТочкаВозвратаВВышестоящийПроцесс
ИЗ
    РегистрСведений.аДокументооборотСсылкиПроцессов КАК аДокументооборотСсылкиПроцессов
        ЛЕВОЕ СОЕДИНЕНИЕ Документ.аДокументооборотКорпоративныйДокумент КАК аДокументооборотКорпоративныйДокумент
        ПО аДокументооборотСсылкиПроцессов.Объект = аДокументооборотКорпоративныйДокумент.Ссылка
        ЛЕВОЕ СОЕДИНЕНИЕ Задача.ЗадачаКорпоративногоПроцесса КАК ЗадачаКорпоративногоПроцесса
        ПО аДокументооборотСсылкиПроцессов.БизнесПроцесс.Ссылка = ЗадачаКорпоративногоПроцесса.БизнесПроцесс.Ссылка
        ЛЕВОЕ СОЕДИНЕНИЕ БизнесПроцесс.аДокументооборотКорпоративныйБизнесПроцесс КАК аДокументооборотКорпоративныйБизнесПроцесс
        ПО аДокументооборотСсылкиПроцессов.БизнесПроцесс = аДокументооборотКорпоративныйБизнесПроцесс.Ссылка
ГДЕ
    аДокументооборотКорпоративныйБизнесПроцесс.ВидКорпоративногоПроцесса.Наименование = "Sub - Approval by A party 1 (2014 10 02)"
    И аДокументооборотКорпоративныйБизнесПроцесс.ТочкаВозвратаВВышестоящийПроцесс.Наименование = "Сргласование Бух"
    И ЗадачаКорпоративногоПроцесса.Наименование ПОДОБНО "%Согласование бухгалтерией%"
Ответ: () ПЕРВЫЕ 1
Вопрос: Задачка по xml

Всем привет
задачка дурацкая, ни разу с иксэмэль не работал, подозреваю что это просто типа хтмл, но как обычно в инете куча воды от а-ля сеошников по хмл чтобы никто не догадался.
Собственно вот вопрос:

<?xml version=”1.0”?>
<root>
<element attribute=”…”/>
</root>

Что необходимо записать вместо “…”, чтобы при считывании программно считать значение
He said “Hello, World”

/////////
какой именно атрибут элемента нужен?
"наименование" какое -нить?
как его описать?
тут же все не по русски , или где почитать про это чтобы по русски и просто как он и есть на самом деле?
Ответ: Gokusa, документация, примеры на инфостарте в количествах
Вопрос: Задачка про скобочки

всем привет.
каочи давно давно решал чета задачку про
имеем строку с цыфрами и символами плюс минус умножить.
нужно так расставить скобочки, чтобы получить в итоге максимум или минимум вычислив строку.
///////////
как решить не представляю.
вернее вроде представляю, но чета мозг не варит.
Ответ: ну чо - кому чо пришло, на моск? ))
Вопрос: Тестовые задачки вашему вниманию

Всем доброго времени!
Предлагаю вашему вниманию три тестовые задачки!
В этой обработке также содержится вариант их решения.
Предлагаю обсудить имеющийся вариант на предмет ошибок или неправильного толкования условия задач.
Интересно услышать ваши мнения и, конечно же, ваши варианты решений!


Ответ: о, с адресом предыдущего своего поста промахнулся.
- он, конечно, был написан в ответ на ()
Вопрос: Задачка по оплате в КА 2

Такая задачка появилась. Надо отслеживать факты оплаты по заказам и добавлять эти заказы в список для рассылки типа "ваш заказ №такой-то был оплачен" и прикрепленная печатная форма заказа. И после этого либо вручную, либо автоматически в определенное время рассылка срабатывала, а список "оплаченных" документов очищался, чтобы второй раз не шла рассылка. (ну или галочка появлялась, что уже было отправлено и не надо второй раз отправлять)

Думал, возможно при проведении документа приходника по безналу или по кассе, но при оплате "по договору" она вручную производит зачет оплаты, вот и думаю, как лучше такую вещь оформить.
Ответ: () Тогда буду смотреть, как он в КА реализован. Надеюсь оно там есть)
Вопрос: Возможно ли решение задачки запросом?

Собсно задача такая, есть простенький регистр сведений, измерения "Номенклатура" и "ЕдиницаИзмерения", ресурсы "Количество, ВесНетто, ВесБрутто, Объем". Надо выбрать ПО ОДНОЙ (произвольной) записи с каждой имеющейся номенклатурой. Ясно, что единиц измерения может быть несколько, но в том то и задача, чтобы взять первую попавшуюся ЕДИНСТВЕННУЮ единицу измерения... Некрасивые варианты с использованием перебора лежат на поверхности, а можно ли сделать подобное запросом? Просто не первый раз напарываюсь на подобную задачку и всегда решал ее некрасиво :-( . Вдруг да есть красивое решение...
Ответ: ()() Сработало! Спасибо!!!
Вопрос: Решение задачки по ЗУП.

Сама задачка

Задание 3.14
Для работников подразделения применяется следующая система оплаты труда: работникам выплачивается основной заработок исходя из месячной тарифной ставки за фактически отработанные часы + ежемесячная премия в размере 5% от выручки подразделения за прошлый месяц. Премия выплачивается пропорционально отработанному в прошлом месяце времени.

Настройте описанную систему оплаты труда. Поясните, как назначить и начислить работникам вознаграждение при такой системе оплаты труда.


ТЕПЕРЬ ВОПРОС, как можно вытянуть время за прошлый месяц? Есть идеи?
Ответ: Интересно. Найдете правильный ответ -отпишитесь. Я за показатель.
Вопрос: УФ: очень(!) медленная выборка из ДанныеФормыКоллекция

На управляемой форме документа расположена ТЧ Расходы. В этой ТЧ 10000 строк - много, но не очень, бывает и побольше. Из формы по кнопке вызывается процедура:

&НаКлиенте
Процедура Рассчитать()

    Н = 1;
    Для Каждого СтрокаДФ Из Объект.Расходы Цикл
        Н = Н + 1;
    КонецЦикла;

КонецПроцедуры

И эта процедура очень сильно тормозит. Замерил отладчиком - на 139 вызовов строки "Для Каждого СтрокаДФ Из Объект.Расходы Цикл" ушло 10 секунд времени. Походу, при каждом повторе цикла происходит какой-то неявный серверный вызов? Тогда как оптимизировать обход всей ТЧ? Если процедуру вызывать "&НаСервере", то накладные расходы при передаче контекста на сервер из-за большого объема ТЧ тоже велики - около 3 секунд, поэтому я и не хочу передавать вызов на сервер, все нужные данные, по идее(?), должны находиться на клиенте - ТЧ Расходы. Как сделать максимально быстрый обход всей ТЧ на клиенте?
Ответ: ()!!
Вопрос: Очень долгая загрузка данных(граница)

Здравствуйте!
Сделали границу, выгрузили, файлы получились очень большими(по 120мб), по сравнению с теми, что делали обычно(5-25мб). Поставил загрузку границы в филиалах, в тоге уже почти сутки грузится. В половине филиалов загрузилось часа 4 назад, в половине до сих пор тянет :( С чем это может быть связано ?
Ответ: Все понял, спасибо
Вопрос: Обработка результата запроса. Очень нужен дельный совет

Добрый день дорогие форумчане))) !!!
Всех с наступившим новым годом!!!

Очень нужна любая помощь в следующем:

Есть задача по условию которой, при входе в систему, должна производиться проверка пользователя, является ли он администратором. Если является, то доп. проверки к этому пользователю не применяются. (Администратор - соответствующий булевский реквизит на форме элемента справочника "Пользователи"). Предполагал решить задачу след. образом:

Написать функцию которая будет сравнивать имя текущего пользователя с наименованиями элементов из справочника "Пользователи" у которых реквизит "Администратор" = Истина и если совпадение найдено, тогда возврат истина если нет ложь.

Попытался реализовать это следующим запросом:

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
Функция ПроверкаПользователяАдмин(ИмяПользователя)Экспорт
Запрос = Новый Запрос;
Запрос.Текст = 
"Выбрать
| Пользователи.Наименование
| ИЗ
| Справочник.Пользователи Как Пользователи
|Где
| Пользователи.Администратор = &Установлен";
Запрос.УстановитьПараметр("Установлен", Истина);
РезультатЗапроса = Запрос.Выполнить();
ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
Если ИмяПользователя = ВыборкаДетальныеЗаписи.Наименование тогда
возврат истина
иначе
возврат ложь
КонецЕсли;
КонецЦикла;
 
КонецФункции
Но данная функция всегда возвращает ложь даже если имена пользователя совпадают.
Консолью запросов проверял, запрос отбирает всех нужных пользователей.
Проверял код отладкой, Выборка Детальные записи, содержит только 1-й элемент отбора т.е. если по результату запроса отбираются Администратор и Администратор1, то выборка хранит в себе только 1-е значение. Помогите пожалуйста заставить работать эту функцию.
За ранее безмерно благодарен!!!
Ответ:
Сообщение от enduromen
Поправить код нужно следующим образом:
Молодчик, начал думать!!!

Но к сожалению опять не в ту строну

Если уж и оставлять вариант с поиском по "Наименованию" то лучше пусть запрос сразу возвращение нужне значение без перебора массива
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
Функция ПроверкаПользователяАдмин(ИмяПользователя) Экспорт
    
    ВозвращаемоеЗначение = Ложь;    
    
    Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |   Пользователи.Администратор КАК Флаг
        |ИЗ
        |   Справочник.Пользователи КАК Пользователи
        |ГДЕ
        |   Пользователи.Наименование = &ИмяПользователя";
        
    Запрос.УстановитьПараметр("ИмяПользователя", ИмяПользователя);    
    
    Выборка = Запрос.Выполнить().Выбрать();
        
    Если Выборка.Следующий() Тогда
         ВозвращаемоеЗначение = Выборка.Флаг;
    КонецЕсли;
 
    Возврат ВозвращаемоеЗначение;
 
КонецФункции