Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: Один элемент иерархического справочника в нескольких группах запросом

Коллеги.
Не знаю, баян это или нет, но в поиске ничего путевого не нашел. Можно ли как-то извернуться и сделать так, чтобы в запросе к иерархическому справочнику один элемент появлялся в нескольких группах? То есть ИТОГИ ПО Что-то_там ТОЛЬКО ИЕРАРХИЯ и элемент в иерерхии в нескольких местах? Такое вообще как-то возможно сделать?
Ответ: () "Полученное дерево нужно будет обработать функцией для удаления лишних дублей"
Вопрос: 1с 8.3 отображение иерархического справочника в форме списка

Добрый день. Говорю сразу, я еще учусь 1С, поэтому не сильно пинайте если задаю глупые вопросы.

Постановка задачи такая: есть иерархический справочник Номенклатура (иерархия групп и элементов), в форме списка нужно вывести две таблицы: в первой - только группы, во второй - необходимо отобразить элементы и группы, подчиненные выбранной группе из первой таблице.

С первой таблицей (ИерархияНоменклатуры) разобралась, группы все выводятся. А вот, с отображением во второй таблице (Список) проблемы (с написанием программного кода, пока затруднения). Почитав статьи сделала так, но идет какое-то зацикливание и программа просто вылетает
Подскажите как это исправить и сделать правильно

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
&НаКлиенте
Процедура ИерархияНоменклатурыПриАктивизацииСтроки(Элемент)
    Группа = Элементы.ИерархияНоменклатуры.ТекущаяСтрока;
Если НЕ Группа.Пустая() Тогда
   ОтборПоИерархииНоменклатуры(Группа);
КонецЕсли;
КонецПроцедуры
 
&НаСервере
Процедура  ОтборПоИерархииНоменклатуры(Группа)  
    Запрос = Новый Запрос;
    Запрос.Текст = 
      "ВЫБРАТЬ
|    Номенклатура.Код, 
|    Номенклатура.Наименование КАК Наименование,
    
|ИЗ 
|    Справочник.Номенклатура КАК Номенклатура
 
|ГДЕ 
|    Номенклатура.Родитель = &Группа";
 
    Запрос.УстановитьПараметр("Родитель", Группа);
    Результат = Запрос.Выполнить(); 
    Выборка = Результат.Выбрать();
  
    Список.Отбор.Ссылка.ВидСравнения = ВидСравнения.ВСписке; 
    Список.Отбор.Ссылка.Использование = истина; 
    Список.Отбор.Ссылка.Значение.Очистить();
    Список.ИерархическийПросмотр=Ложь;
    
    Пока Выборка.Следующий() Цикл   
        Список.Отбор.Ссылка.Значение.Добавить(Выборка.Ссылка);   
    КонецЦикла; 
 
КонецПроцедуры
Ответ: Пока сделала так, чтобы не отображались группы. В итоге выводятся все элементы подчиненной группы и подгрупп. (Для наглядности прилагаю скрины, на первом - как было, на втором - после доп. отбора)
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
&НаКлиенте
Процедура ИерархияНоменклатурыПриАктивизацииСтроки(Элемент)
     Список.Отбор.Элементы.Очистить();
    
    ТекущаяСтрока = Элементы.ИерархияНоменклатуры.ТекущиеДанные;
    Если  ТекущаяСтрока <> Неопределено Тогда
        ТекущаяГруппа = ТекущаяСтрока.Ссылка;
        ЭлементОтбора = Список.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));    
        ЭлементОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Ссылка");   
        ЭлементОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.ВИерархии;
        ЭлементОтбора.ПравоеЗначение = ТекущаяГруппа;   
    
    //Скрываем группы
        ЭлементОтбора2 = Список.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    ЭлементОтбора2.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("ЭтоГруппа");
    ЭлементОтбора2.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
    ЭлементОтбора2.Использование = Истина;
    ЭлементОтбора2.РежимОтображения = РежимОтображенияЭлементаНастройкиКомпоновкиДанных.Недоступный;
    ЭлементОтбора2.ПравоеЗначение = Ложь;
    КонецЕсли;
КонецПроцедуры
Вопрос: ФормаВыбора иерархического справочника с отборами

1. Есть иерархический справочник "Контрагенты" (содержит много папок и элементов)

2. В документе есть реквизит "Контрагент", при выборе контрагента открывается ФормаВыбора контрагентов (Динамический список) с произвольным запросом (в этом запросе на контрагентов наложено условие, к примеру под условие попадает 5 контрагентов из 100). ВАЖНО, ЧТО ВОЗМОЖНО ВЫБИРАТЬ КАК ЭЛЕМЕНТЫ, ТАК И ГРУППЫ

3. В итоге пользователь увидит кучу папок, из которых только 1-2 в своей иерархии содержат контрагентов, которые попали под условие, остальные же будут просто пустыми.

Как сделать, чтобы в ФормеВыбора остались только те ветви иерархии, которые содержат найденных контрагентов?
Ответ: и как же пользователь ГРУППУ ВЫБЕРЕТ, ЕСЛИ ТЫ ИХ СКРОЕШЬ!?
Вопрос: Иерархический справочник: различная длина кода в зависимости от уровня

Имеется иерархический справочник (иерархия элементов). Количество уровней иерархии 2. Код-Строка. Возможно ли сделать так, чтобы на первом уровне иерархии код элемента состоял из 2-х символов, а на втором - из 3-х?
Пример
01Стройплощадка
001Подготовка площади
Ответ: В справочнике Нумерация - В пределах подчинения
При записи элемента УстановитьНовыйКод(<Префикс>)

Или свой реквизит, который будет служить вместо кода.
Вопрос: Выбор группы вместо элемента в справочнике

Привет!
Как в справочнике выбрать группу а не элемент другого справочника ? и записать
Ответ:
Вопрос: Запрос- подчиненные элементы в справочнике

пытаюсь найти все элементы которые содержат подчиненные элементы в справочнике
но выдает ошибку "неверные параметры в иерархии"
Код:
ВЫБРАТЬ
    Номенклатура.Ссылка КАК Ссылка,
    Номенклатура.Наименование КАК Наименование
ИЗ
    Справочник.Номенклатура КАК Номенклатура
ГДЕ
    Номенклатура.Ссылка  В ИЕРАРХИИ (Номенклатура.Родитель)
Ответ:
ВЫБРАТЬ РАЗЛИЧНЫЕ
Родитель.Представление КАК Представление
ИЗ
Справочник.Номенклатура
ГДЕ
НЕ Родитель = ЗНАЧЕНИЕ(Справочник.Номенклатура.ПустаяСсылка)
И НЕ ЭтоГруппа
Вопрос: Иерархический справочник

Всем привет!

Как создать предопределённый элемент в иерархическом справочнике?.. И как к нему потом обращаться?
У меня было два справочника - Контрагенты и Проекты. Но потом возникли проблемы с тем, чтобы связывать эти два справочника. Потому я решила их объеденить, что логично, наверное.
Теперь у меня иерархический справочник Контрагенты, и у каждого контрагента есть проекты.
Как в каждом контрагенте создать предопределённый элемент?.. И как к нему потом обращаться? Так же, как обычные предопределённые элементы?
Ответ: Тамика,
Вопрос: получение по одному элементу из группировки

Вопрос. Запросом формируем таблицу вида
группа | какое то значение| элемент справочника.
Задача запросом выбрать по одному элементу из каждой группы.
Где Группа это текстовое поле.

Как можно это сделать запросом?
Ответ: 2, спс. не совсем то. но направление подходит.
вопрос закрыт.
Вопрос: Отбор групп и элементов в справочнике, платформа 8.2

Простая запись:
Форма.СправочникСписок.Отбор.Реквизит.Установить(ЗначениеРеквизита);

к сожалению устанавливает отбор только по элементам, а мне надо чтобы и группы то же отображались согласно отбору, это реально?
Ответ:
Знать бы как сюда скриншот поместить.
Могу так пояснить:
Сервис -> Дополнительные отчеты и обработки -> Дополнительные внешние отчеты.
Откруывется окно, где есть "группы", которые не имеют отношения к отчетам, а к относятся к иерархии обработок.
Раздражает, особенно когда много этих групп.
Изменил реквизит "ВидОбработки" в справочнике "ВнешниеОбработки", сделал чтобы он распространялся не только на элементы, но и на группы то же.
Не помогло.
Поэтому и вопрос возник.

Грубо так: открываем отчеты - элементы только отчеты, а группы и "отчеты" и "обработки". Ну и наоборот. Надо как-то "неправильные" группы спрятать.
Вопрос: ERP 2 аналог справочника номенклатурная группа(Бухгалтерия 3.0)

Здравствуйте, подскажите пожалуйста как называется справочник номенклатурная группа в ERP? Спасибо.
Ответ: () ТС производство не упоминал.