Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: v7: Ошибка Переменная не определена, как исправить

Доброго времени.
Подскажите пожалуйста из за чего появляется ошибка Переменная не определена, что на нее влияет?
это значит что она не прописана в таблице значений или в запросе не прописана? или может просто не правильно прописана?
Ответ: Включай уже логику. Если ты подгрузила это поле в запросе, то уже не нужны никакие справочники.

Я это и имела ввиду,я извиняюсь. за то что могу не правильно говорить терминологию, это все не опытность.

У меня вопрос созрел, если в запросе все 3 СПР есть в Справочник.Объект, но именно ИстФин не подтягивается, то в чем может быть проблема?

или лучше будет написать в запросе через LEFT JOIN?
Вопрос: Ошибка в процедуре: не считается сумма

Код 1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
Процедура РассчитатьСумму(СтрокаТабличнойЧасти) Экспорт
    СтрокаТабличнойЧасти.Сумма = СтрокаТабличнойЧасти.Количество * СтрокаТабличнойЧасти.Цена; 
КонецПроцедуры
 
 
 
Процедура ДокументСписокКоличествоПриИзменении(Элемент)
     СтрокаТабличнойЧасти = Элементы.Документ.ТекущиеДанные;
    РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
КонецПроцедуры
 
Процедура ДокументСписокЦенаПриИзменении(Элемент)
       СтрокаТабличнойЧасти = Элементы.Документ.ТекущиеДанные;
    РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
КонецПроцедуры
 
выдает ошибку программы
 
Процедура РассчитатьСумму(СтрокаТабличнойЧасти) Экспорт
    СтрокаТабличнойЧасти.Сумма = СтрокаТабличнойЧасти.Количество * СтрокаТабличнойЧасти.Цена; 
КонецПроцедуры
 
 
 
Процедура ДокументСписокКоличествоПриИзменении(Элемент)
     СтрокаТабличнойЧасти = <?>Элементы.Документ.ТекущиеДанные;
    РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
КонецПроцедуры
 
Процедура ДокументСписокЦенаПриИзменении(Элемент)
       СтрокаТабличнойЧасти = <?>Элементы.Документ.ТекущиеДанные;
    РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
КонецПроцедуры
Добавлено через 6 минут
{Документ.Прибыль.Форма.ФормаВыбора(9,28)}: Переменная не определена (Элементы)
СтрокаТабличнойЧасти = <<?>>Элементы.Документ.ТекущиеДанные;
{Документ.Прибыль.Форма.ФормаВыбора(4,5)}: Переменная не определена (РаботаСДокументами)
<<?>>РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
{Документ.Прибыль.Форма.ФормаВыбора(10,5)}: Переменная не определена (РаботаСДокументами)
<<?>>РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
Ответ: У вас полный бардак.
У вас нет в документах табличной части.
У вас нет формы документа, есть только форма выбора.
Вы расположили процедуры в форме Выбора, а не в форме документа.
Когда у общего модуля стоит галочка Глобальный перед его процедурами не нужно указывать имя общего модуля. (РассчитатьСумму, а не РаботаСДокументами.РассчитатьСумму).

1. Создайте табличную часть у документов
2. Создайте форму документа.
3. Перенесите туда процедуры из формы выбора.
Вопрос: Переменная не определена

Добрый день!
Я только начинаю изучать 1С, читаю книгу Радченко "Практическое пособие разработчика. Примеры и типовые приемы". Создал по книге 2 документа (ПриходнаяНакладная и ОказаниеУслуги), в модуле ПриходнаяНакладная написано следующее:

Код:
Процедура МатериалыКоличествоПриИзменении(Элемент)

СтрокаТабличнойЧасти = ЭлементыФормы.Материалы.ТекущиеДанные;
//
РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);


КонецПроцедуры

Процедура МатериалыЦенаПриИзменении(Элемент)

СтрокаТабличнойЧасти = ЭлементыФормы.Материалы.ТекущиеДанные;

// 

РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
КонецПроцедуры>> (Аналогично и для др. документа)

Также создал общий модуль под названием "РаботаСДокументами" со след. текстом:

<<Процедура РассчитатьСумму(СтрокаТабличнойЧасти) Экспорт

СтрокаТабличнойЧасти.Сумма = СтрокаТабличнойЧасти.Количество * СтрокаТабличнойЧасти.Цена;

КонецПроцедуры
При попытке создать документ выдает следующее:

<<{Документ.ОказаниеУслуги.Форма.ФормаДокумента(5,2)}: Переменная не определена (РаботаСДокументами)
<<?>>РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
{Документ.ОказаниеУслуги.Форма.ФормаДокумента(11,2)}: Переменная не определена (РаботаСДокументами)
<<?>>РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
>>

Цель: автоматически вычислять "Сумма" в документе при изменении при изменении "Количество" или "Цена".

Все делал по книге, помогите плиз разобраться, в чем дело.
Ответ:
Здравствуйте. Вот решил заняться учением программированию в 1С.
Все бы хорошо шло, да вот есть ошибочка. И никак не могу ее понять, помогите кто знает.
За ранее благодарен.
Вот сама ошибка,которую мне выдает.

{Документ.ОказаниеУлсуги.Форма.ФормаДокумента(51,2)}: Переменная не определена (РаботаСДокуметами)
<<?>>РаботаСДокуметами.РассчитатьСумму(СтрокаТабличнойЧасти);

А вот и процедура в которой возникает ошибка.

Процедура ПереченьНоменклатурыНоменклатураПриИзменении(Элемент)
СтрокаТабличнойЧасти=ЭлементыФормы.ПереченьНоменклатуры.ТекущиеДанные;
СтрокаТабличнойЧасти.Цена=РаботаСоСправочниками.РозничнаяЦена(Дата,Элемент.Значение);
РаботаСДокуметами.РассчитатьСумму(СтрокаТабличнойЧасти);
КонецПроцедуры
Вопрос: Ошибка: Переменная не определена РаботаСДокументами

В 1C я новичок, и мне выдали задание на практику. Почти все сделал, но 1C выдает ошибки, что не объявлены переменные (выделены жирным курсивом). Как их исправить, я не знаю. Испробовал множество вариантов, и ни к какому результату придти не смог. Прошу помощи при решении этих проблем.
Ошибки и код представлены ниже ↓

Кликните здесь для просмотра всего текста
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
&НаКлиенте
Процедура ПереченьНоменклатурыКоличествоПриИзменении(Элемент)
    СтрокаТабличнойЧасти = Элементы.ПереченьНоменклатуры.ТекущиеДанные;
[B][I]РаботаСДокументами[/I][/B].РассчитатьСумму(СтрокаТабличнойЧасти);      //Проверка: Тонкий клиент
КонецПроцедуры
 
&НаКлиенте
Процедура ПереченьНоменклатурыЦенаПриИзменении(Элемент)
СтрокаТабличнойЧасти = Элементы.ПереченьНоменклатуры.ТекущиеДанные;
[B][I]РаботаСДокументами[/I][/B].РассчитатьСумму(СтрокаТабличнойЧасти); //Проверка: Тонкий клиент
КонецПроцедуры
 
&НаКлиенте
Процедура ПереченьНоменклатурыНоменклатураПриИзменении(Элемент)
    // Получить текущую строку табличной части.
СтрокаТабличнойЧасти = Элементы.ПереченьНоменклатуры.ТекущиеДанные;
// Установить цену.
СтрокаТабличнойЧасти.Цена = [B][I]РаботаСоСправочниками[/I][/B].РозничнаяЦена(       //Проверка: Тонкий клиент
Объект.Дата, СтрокаТабличнойЧасти.Номенклатура);
// Пересчитать сумму строки
[B][I]РаботаСДокументами[/I][/B].РассчитатьСумму(СтрокаТабличнойЧасти); //Проверка: Тонкий клиент
КонецПроцедуры
 
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    Если Параметры.Отбор.Свойство("Мастер") Тогда
        ПрограммныйОтбор = Истина;
        ПолеОтбора = Новый ПолеКомпоновкиДанных("Мастер");
        Параметры.Отбор.Свойство("Мастер", ЗначениеОтбора);
    КонецЕсли
КонецПроцедуры
 
&НаКлиенте
Процедура ПриОткрытии(Отказ)
    Если ПрограммныйОтбор = Истина Тогда
ПрограммныеНастройки = [B][I]Список[/I][/B].КомпоновщикНастроек.ФиксированныеНастройки; //Проверка: Тонкий клиент
Для Каждого ЭлементНастроек Из ПрограммныеНастройки.Отбор.Элементы Цикл
Если ЭлементНастроек.ЛевоеЗначение = ПолеОтбора Тогда
ПрограммныеНастройки.Отбор.Элементы.Удалить(ЭлементНастроек);
КонецЕсли;
КонецЦикла;
Настройки = [B][I]Список[/I][/B].КомпоновщикНастроек.Настройки; //Проверка: Тонкий клиент
ЭлементОтбора =
Настройки.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
ЭлементОтбора.ЛевоеЗначение = ПолеОтбора;
ЭлементОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
ЭлементОтбора.ПравоеЗначение = ЗначениеОтбора;
[B][I]Список[/I][/B].КомпоновщикНастроек.ЗагрузитьНастройки(Настройки); //Проверка: Тонкий клиент
КонецЕсли;
КонецПроцедуры
 
&НаКлиенте
Процедура ПередЗакрытием(Отказ, ЗавершениеРаботы, ТекстПредупреждения, СтандартнаяОбработка)
    Если ПрограммныйОтбор = Истина Тогда
Настройки = [B][I]Список[/I][/B].КомпоновщикНастроек.Настройки; //Проверка: Тонкий клиент
Для Каждого ЭлементНастроек Из Настройки.Отбор.Элементы Цикл
Если ЭлементНастроек.ЛевоеЗначение = ПолеОтбора Тогда
Настройки.Отбор.Элементы.Удалить(ЭлементНастроек);
КонецЕсли;
КонецЦикла;
[B][I]Список[/I][/B].КомпоновщикНастроек.ЗагрузитьНастройки(Настройки); //Проверка: Тонкий клиент
КонецЕсли;
КонецПроцедуры
 
Процедура ОбработкаПроверкиЗаполнения(Отказ, ПроверяемыеРеквизиты)
Индекс = ПроверяемыеРеквизиты.Найти("ПереченьНоменклатуры.НаборСвойств");
Если Индекс <> Неопределено Тогда
ПроверяемыеРеквизиты.Удалить(Индекс);
КонецЕсли;
Индекс = 0;
Для Каждого ТекСтрокаПереченьНоменклатуры Из [B][I]ПереченьНоменклатуры[/I][/B] Цикл  //Проверка: Сервер
Если ТекСтрокаПереченьНоменклатуры.Номенклатура.ВидНоменклатуры =
Перечисления.ВидыНоменклатуры.Материал Тогда
Если Не ЗначениеЗаполнено(ТекСтрокаПереченьНоменклатуры.НаборСвойств)
Тогда                                    
Сообщение = Новый СообщениеПользователю();
Сообщение.Текст = "В строке " + Строка(Индекс+1) +" списка Перечень номенклатуры не заполнена колонка Набор свойств";
Сообщение.Поле = "ПереченьНоменклатуры[" + Строка(Индекс)
+ "].НаборСвойств";
Сообщение.УстановитьДанные(ЭтотОбъект);
Сообщение.Сообщить();
Отказ = Истина;
КонецЕсли;
КонецЕсли;
Индекс = Индекс + 1;
КонецЦикла;
КонецПроцедуры
Ответ: Сталкивался с подобным. Решение:

1) Проверить стоят ли галочки "Сервер" и "Вызов сервера" в свойствах общего модуля.
2) Проверить все ли функции внутри общего модуля экспортные.

1C
1
2
3
Функция НазваниеФункции(Параметры) экспорт
              ...
КонецФункции
Вопрос: 1С 8,3 Ошибка: Переменная не определена

Доброго времени суток
Нужна помощь в коде
Начал Изучать 1с нужно в расходном документе сделать чтоб документ не проводился и выдавалось собщение с остатком товара
ну пытался вот что получилось
Код 1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
Движения.ОстаткиНоменклатуры.Записывать = Истина;
    Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |   МАКСИМУМ(ЕСТЬNULL(ОстаткиНоменклатурыОстатки.КоличествоОстаток, 0)) КАК Остатки,
        |   РосходнаяНакладнаяТовары.Номенклатура,
        |   МАКСИМУМ(РосходнаяНакладнаяТовары.Количество) КАК Количество,
        |   ОстаткиНоменклатурыОстатки.ВидУслуги
        |ИЗ
        |   Документ.РосходнаяНакладная.Товары КАК РосходнаяНакладнаяТовары
        |       ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.ОстаткиНоменклатуры.Остатки(&МоментВремени, ) КАК ОстаткиНоменклатурыОстатки
        |       ПО РосходнаяНакладнаяТовары.Номенклатура = ОстаткиНоменклатурыОстатки.Номенклатура
        |ГДЕ
        |   ОстаткиНоменклатурыОстатки.ВидУслуги = &ВидУслуги
        |
        |СГРУППИРОВАТЬ ПО
        |   РосходнаяНакладнаяТовары.Номенклатура,
        |   ОстаткиНоменклатурыОстатки.ВидУслуги";
    
    Запрос.УстановитьПараметр("ВидУслуги", ВидУслуги);
    Запрос.УстановитьПараметр("МоментВремени", МоментВремени());
    
    РезультатЗапроса = Запрос.Выполнить();
    
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    
    Пока Выборка.Следующий() Цикл
        
        Если Выборка.Количество > Выборка.Остатки Тогда
            Сообщение = Новый СообщениеПользователю;
            Сообщение.Текст = "Не зватает товара""" + Выборка.Номенклатура
            + """, из необходимых " + 
            Выборка.Количество + " в наличии осталось " + 
            Выборка.КоличествоОстаток;
            Сообщение.Сообщить();
        
            Отказ = Истина;
            Движения.ОстаткиНоменклатуры.Записывать = Ложь;
        КонецЕсли;
 
        КонецЦикла;
    
    
    Для Каждого ТекСтрокаТовары Из Товары Цикл
        Движение = Движения.ОстаткиНоменклатуры.Добавить();
        Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
        Движение.Период = Дата;
        Движение.Номенклатура = ТекСтрокаТовары.Номенклатура;
        Движение.ВидУслуги = ВидУслуги;
        Движение.Склады = Склады;
        Движение.Количество = ТекСтрокаТовары.Количество;
    КонецЦикла;

А вот такая ошибка
Сообщение.Текст = "Не зватает товара""" + <<?>>Выборка.Номенклатура + """, из необходимых " + Выборка.Количество + " в наличии осталось " + Выборка.КоличествоОстаток; (Проверка: Сервер)
{Документ.РосходнаяНакладная.МодульОбъекта(34,93)}: Переменная не определена (Выборка)
Сообщение.Текст = "Не зватает товара""" + Выборка.Номенклатура + """, из необходимых " + <<?>>Выборка.Количество + " в наличии осталось " + Выборка.КоличествоОстаток; (Проверка: Сервер)
{Документ.РосходнаяНакладная.МодульОбъекта(34,139)}: Переменная не определена (Выборка)
Сообщение.Текст = "Не зватает товара""" + Выборка.Номенклатура + """, из необходимых " + Выборка.Количество + " в наличии осталось " + <<?>>Выборка.КоличествоОстаток; (Проверка: Сервер)

Помогите кто может до завтра надобно здать задание!!!!!
Ответ:
Сообщение от ТрисТан
РОздуплился ПоСинтаксису
На очереди семантика.
Вопрос: Переменная не определена (НомерСправкиА)

Добрый день.

1С:Предприятие 8.3 (8.3.10.2561)
Розница, редакция 2.2 (2.2.6.33) типовая.
Режим Файловый
РИБ по магазину, типовые правила обмена.
Мой уровень - Пользователь.

Не так давно обновил платформу и конфигурацию до последних релизов. После обновления обмен проходил без ошибок. Через некоторое время, при записи и проведения документа "Поступление товаров" получил сообщение об ошибке, что информационная база повреждена, закрыть или перезапустить. Перезапуск не помог, ошибка повторялась. Запустил Конфигуратор, выполнил "Тестирование и Исправление" по всем пунктам, вначале выбрав "Создавать объекты", далее выполнил повторно "Очищать и Удалять".
Запустил в режиме 1С предприятие, ошибки при сохранении и проведении документа не возникает. Но перестал работать обмен. Из Главного узла создал новый начальный образ, результат тот же, получаю сообщение об ошибке. В Главном узле выполнял ТиС и заново создавал образ - все та же ошибка.

Прошу помощи в решении проблемы:
При выполнении синхронизации и получении данных получаю ниже указанную ошибку.

Код:
Ошибка инициализации модуля: Справочник.Справки2ЕГАИС.МодульОбъекта
по причине:
{Справочник.Справки2ЕГАИС.МодульОбъекта(18,25)}: Переменная не определена (СправкаА)
    Если ЗначениеЗаполнено(<<?>>СправкаА) И НЕ ПустаяСтрока(НомерСправкиА) Тогда
{Справочник.Справки2ЕГАИС.МодульОбъекта(19,93)}: Переменная не определена (СправкаА)
        Если ВРег(СокрЛП(НомерСправкиА)) <> ВРег(СокрЛП(ОбщегоНазначения.ЗначениеРеквизитаОбъекта(<<?>>СправкаА, "РегистрационныйНомер"))) Тогда
{Справочник.Справки2ЕГАИС.МодульОбъекта(18,53)}: Переменная не определена (НомерСправкиА)
    Если ЗначениеЗаполнено(СправкаА) И НЕ ПустаяСтрока(<<?>>НомерСправкиА) Тогда
{Справочник.Справки2ЕГАИС.МодульОбъекта(19,20)}: Переменная не определена (НомерСправкиА)
        Если ВРег(СокрЛП(<<?>>НомерСправкиА)) <> ВРег(СокрЛП(ОбщегоНазначения.ЗначениеРеквизитаОбъекта(СправкаА, "РегистрационныйНомер"))) Тогда

Открываю Модуль объекта, вижу, что везде где ошибка, переменная называется "Справка1", а не "СправкаА".

Код:

#Если Сервер Или ТолстыйКлиентОбычноеПриложение Или ВнешнееСоединение Тогда

#Область ОбработчикиСобытий

Процедура ОбработкаПроверкиЗаполнения(Отказ, ПроверяемыеРеквизиты)
   
    МассивНепроверяемыхРеквизитов = Новый Массив;
    МассивНепроверяемыхРеквизитов.Добавить("Наименование");
   
    Если ДополнительныеСвойства.Свойство("ЗагрузкаДанныхИзЕГАИС") Тогда
        МассивНепроверяемыхРеквизитов.Добавить("НомерСправки1");
        МассивНепроверяемыхРеквизитов.Добавить("АлкогольнаяПродукция");
    КонецЕсли;
   
    ОбщегоНазначения.УдалитьНепроверяемыеРеквизитыИзМассива(ПроверяемыеРеквизиты, МассивНепроверяемыхРеквизитов);
   
    Если ЗначениеЗаполнено(Справка1) И НЕ ПустаяСтрока(НомерСправки1) Тогда
        Если ВРег(СокрЛП(НомерСправки1)) <> ВРег(СокрЛП(ОбщегоНазначения.ЗначениеРеквизитаОбъекта(Справка1, "РегистрационныйНомер"))) Тогда
            ОбщегоНазначенияКлиентСервер.СообщитьПользователю(НСтр("ru = 'Номер справки 1 не совпадает с выбранной справкой.'"),,,, Отказ);
        КонецЕсли;
    КонецЕсли;
   
КонецПроцедуры

Процедура ПередЗаписью(Отказ)
   
    Если ОбменДанными.Загрузка Тогда
        Возврат;
    КонецЕсли;
   
    Если ПустаяСтрока(Наименование) Тогда
        Наименование = РегистрационныйНомер;
    КонецЕсли;
   
КонецПроцедуры

#КонецОбласти

#КонецЕсли

Ответ:
Форумов много, везде разные правила. Не знал, что можно самому поставить "РЕШЕНО".
Спасибо.
Вопрос: Не определен режим работы файлового хранилища.

Есть база на Postgesql, есть бекап сделанный так:

@ECHO OFF
SET cTime=%TIME: =0%

SET PathUtil="C:\Program Files (x86)\PgAdmin3\1.22.1\bin\"
SET Datebase=buh
SET Server=localhost
SET Port=5432
SET User=postgres
SET FileBackup=D:\backup_1c\%Datebase%_%DATE:~-4%%DATE:~3,2%%DATE:~0,2%_%cTIME:~0,2%%TIME:~3,2%%TIME:~6,2%.sql
SET PGPASSWORD=Server2012

%PathUtil%pg_dump -v -c -h %Server% -p %Port% -U %User% -d %Datebase% -f %FileBackup%

EXIT

Восстанавливаю
"C:\Program Files\PostgresPro 1C\9.4\bin\psql.exe" -h localhost -U postgres -d buh_restore14122017 -f D:\buh_20171214_030000.sql

базу на сервере создавал

createdb -T template0 имя_БД

но при добавлении на сервер 1с вываливается ошибка: Не определен режим работы файлового хранилища.
Соответственно ни в предприятие ни в конфигуратор не попасть.

Подскажите, с чем связана данная ошибка и как ее побороть?
Ответ: Грусть печаль... Никто не знает...
Вопрос: Глобальная переменная не определена ...

Всем привет!
Конфа УПП для Казахстана 1.3.15.5
Платформа 8.3.9.2309
Режим: клиент-серверный.

Наткнулся на такой баг, не могу понять в чем дело..

Ситуация такая: при проведении самописного документа создается типовой  документ. Процедура создания/перезаполнения находиться в общем привилегированном модуле, и вызывается в обработке проведения самописного дока. Все нормально, но вылетают ошибки, когда из самописного дока создается типовое "Перемещение ТМЗ":

{Документ.ПеремещениеТоваров.МодульОбъекта(2681,82)}: Переменная не определена (глСписокПрефиксовУзлов)
    Шапка.Параметры.НомерДокумента = ОбщегоНазначения.ПолучитьНомерНаПечать(Ссылка, <<?>>глСписокПрефиксовУзлов);
{Документ.ПеремещениеТоваров.МодульОбъекта(3079,77)}: Переменная не определена (глСписокПрефиксовУзлов)
    Шапка.Параметры.Номер = ОбщегоНазначения.ПолучитьНомерНаПечать(ЭтотОбъект, <<?>>глСписокПрефиксовУзлов); 
{Документ.ПеремещениеТоваров.МодульОбъекта(2698,29)}: Процедура или функция с указанным именем не определена (ПолучитьТаблицуСтоимостиТоваров)
        ТаблицаСтоимости        = <<?>>ПолучитьТаблицуСтоимостиТоваров(Ссылка);            
{Документ.ПеремещениеТоваров.МодульОбъекта(2728,13)}: Процедура или функция с указанным именем не определена (ПолучитьСтоимостьТовара)
                Сумма = <<?>>ПолучитьСтоимостьТовара(ТаблицаСтоимости,

Ошибку " Переменная не определена (глСписокПрефиксовУзлов)" я еще могу понять, но какого фига не найдены функции в модуле дока?
но это еще не все.. прикол в том, что таких проблем нет с доком "Оприходование ТМЗ"! Доки типовые не меняли, процедура общая. Что не так?
Ответ: Разобрался...
В общем нифига модули не типовые... были добавлены функции печати самописных печаток,где было обращение к глобальной переменной и эти функции находились не в клиентской части модуля! ) Всем спасибо!
Вопрос: Переменная не определена (ЭтоПособиеЗаСчетФСС)

Обновляется без ругательств, а при проверке модулей в новом релизе выдаёт ошибку
ПланВидовРасчета.ОсновныеНачисленияОрганизаций.Форма.ФормаВидаРасчета.Форма(247,8)}: Переменная не определена (ЭтоПособиеЗаСчетФСС)
Если <<?>>ЭтоПособиеЗаСчетФСС Тогда (Проверка: Толстый клиент (обычное приложение))
Однако старый релиз
Если ЭтоПособиеЗаСчетФСС Тогда
Оно работает, сверил через глобальный поиск, все записи сходятся, даже неходятся в тех же модулях, а не работает новый релиз, точнее ругается
Что в таких случаях делается? Спасибо
Ответ: () Привыкай. Это Миста. () Дал неплохой совет: проверь форму, в которой ошибка. Иногда бывает, что парус поставили криво.
Вопрос: Переменная не определена (ОбработкаТабличныхЧастей)

создал копированием новый документ в УАТ.
теперь в модуле менеджера ругается 
Переменная не определена (ОбработкаТабличныхЧастей)
            <<?>>ОбработкаТабличныхЧастей.РассчитатьСуммуНДСТабЧасти(ТекСтрока, ЭтотОбъект); (Проверка: Сервер)

Подписки установил идентичные, основной объект формы выбран новый документ. Кажется все проверил, но ошибка остается.
По f12 в документе-доноре попадаю в общий модуль, в новом - соответственно нет. Пробую под полными правами.
Ответ: похоже в защищенном модуле определено.
ОбработкаТабличныхЧастей. ссылается на другой общий модуль.
Прописал явно, решено.