Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: Получения остатков на каждый день

как получить остатки на каждый день?
есть запрос

ВЫБРАТЬ
    НАЧАЛОПЕРИОДА(ДОБАВИТЬКДАТЕ(&НачалоПериода, ДЕНЬ, aa.a * 1000 + bb.b * 100 + cc.c * 10 + dd.d), ДЕНЬ) КАК Период
ПОМЕСТИТЬ ДНИ
ИЗ
    (ВЫБРАТЬ
        0 КАК a
    
    ОБЪЕДИНИТЬ
    
    ВЫБРАТЬ
        1
    
    ОБЪЕДИНИТЬ
    
    ВЫБРАТЬ
        2
    
    ОБЪЕДИНИТЬ
    
    ВЫБРАТЬ
        3
    
    ОБЪЕДИНИТЬ
    
    ВЫБРАТЬ
        4
    
    ОБЪЕДИНИТЬ
    
    ВЫБРАТЬ
        5
    
    ОБЪЕДИНИТЬ
    
    ВЫБРАТЬ
        6
    
    ОБЪЕДИНИТЬ
    
    ВЫБРАТЬ
        7
    
    ОБЪЕДИНИТЬ
    
    ВЫБРАТЬ
        8
    
    ОБЪЕДИНИТЬ
    
    ВЫБРАТЬ
        9) КАК aa
        ПОЛНОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
            0 КАК b
        
        ОБЪЕДИНИТЬ
        
        ВЫБРАТЬ
            1
        
        ОБЪЕДИНИТЬ
        
        ВЫБРАТЬ
            2
        
        ОБЪЕДИНИТЬ
        
        ВЫБРАТЬ
            3
        
        ОБЪЕДИНИТЬ
        
        ВЫБРАТЬ
            4
        
        ОБЪЕДИНИТЬ
        
        ВЫБРАТЬ
            5
        
        ОБЪЕДИНИТЬ
        
        ВЫБРАТЬ
            6
        
        ОБЪЕДИНИТЬ
        
        ВЫБРАТЬ
            7
        
        ОБЪЕДИНИТЬ
        
        ВЫБРАТЬ
            8
        
        ОБЪЕДИНИТЬ
        
        ВЫБРАТЬ
            9) КАК bb
        ПО (ИСТИНА)
        ПОЛНОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
            0 КАК c
        
        ОБЪЕДИНИТЬ
        
        ВЫБРАТЬ
            1
        
        ОБЪЕДИНИТЬ
        
        ВЫБРАТЬ
            2
        
        ОБЪЕДИНИТЬ
        
        ВЫБРАТЬ
            3
        
        ОБЪЕДИНИТЬ
        
        ВЫБРАТЬ
            4
        
        ОБЪЕДИНИТЬ
        
        ВЫБРАТЬ
            5
        
        ОБЪЕДИНИТЬ
        
        ВЫБРАТЬ
            6
        
        ОБЪЕДИНИТЬ
        
        ВЫБРАТЬ
            7
        
        ОБЪЕДИНИТЬ
        
        ВЫБРАТЬ
            8
        
        ОБЪЕДИНИТЬ
        
        ВЫБРАТЬ
            9) КАК cc
        ПО (ИСТИНА)
        ПОЛНОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
            0 КАК d
        
        ОБЪЕДИНИТЬ
        
        ВЫБРАТЬ
            1
        
        ОБЪЕДИНИТЬ
        
        ВЫБРАТЬ
            2
        
        ОБЪЕДИНИТЬ
        
        ВЫБРАТЬ
            3
        
        ОБЪЕДИНИТЬ
        
        ВЫБРАТЬ
            4
        
        ОБЪЕДИНИТЬ
        
        ВЫБРАТЬ
            5
        
        ОБЪЕДИНИТЬ
        
        ВЫБРАТЬ
            6
        
        ОБЪЕДИНИТЬ
        
        ВЫБРАТЬ
            7
        
        ОБЪЕДИНИТЬ
        
        ВЫБРАТЬ
            8
        
        ОБЪЕДИНИТЬ
        
        ВЫБРАТЬ
            9) КАК dd
        ПО (ИСТИНА)
ГДЕ
    aa.a * 1000 + bb.b * 100 + cc.c * 10 + dd.d <= РАЗНОСТЬДАТ(&НачалоПериода, &КонецПериода, ДЕНЬ)

ИНДЕКСИРОВАТЬ ПО
    Период
;

////////////////////////////////////////////////////////////////////////////////

ВЫБРАТЬ
    Движения.Период КАК Период,
    Движения.Склад,
    Движения.Номенклатура,
    Движения.КоличествоКонечныйОстаток,
    Движения.КоличествоКонечныйОстаток * Движения.Номенклатура.ЕдиницаХраненияОстатков.Литраж КАК Литраж
ПОМЕСТИТЬ ВТ_ОборотТовара
ИЗ
    РегистрНакопления.ТоварыНаСкладах.ОстаткиИОбороты(&НачалоПериода, &КонецПериода, ДЕНЬ, , Склад.ТипСклада <> ЗНАЧЕНИЕ(перечисление.типыСкладов.виртуальный) {(Склад = &Склад) КАК Склад, (Номенклатура = &Номенклатура) КАК Номенклатура}) КАК Движения

ИНДЕКСИРОВАТЬ ПО
    Период
;

////////////////////////////////////////////////////////////////////////////////

ВЫБРАТЬ
    ВТ_Дат.Период КАК Дата_,
    ЕСТЬNULL(Остатки.Склад, ЗНАЧЕНИЕ(справочник.Склады.пустаяСсылка)) КАК Склад,
    ЕСТЬNULL(Остатки.Номенклатура, ЗНАЧЕНИЕ(справочник.Номенклатура.пустаяСсылка)) КАК Номенклатура,
    ЕСТЬNULL(Остатки.КоличествоКонечныйОстаток, 0) КАК КоличествоОстаток,
    ЕСТЬNULL(Остатки.Литраж, 0) КАК Литраж
ИЗ
    ДНИ КАК ВТ_Дат
        ЛЕВОЕ СОЕДИНЕНИЕ ВТ_ОборотТовара КАК Остатки
        ПО ВТ_Дат.Период = Остатки.Период

и когда добавляю в скд и вовожу,получается что на начало периода и конец периода остатки правильные,а посредине периода(если строить по дням) неправильные...
ЧЯДНТ?
Ответ: () Нормально
Вопрос: УПП Учет остатков материалов 2

Добрый день уважаемые.
Снова прошу помощи, в распределении остатков.
Задача следующая:
Есть спецификации, изделие 2500-3000 позиций. Заказчик хочет ввести список изделий с количеством, указать приоритет какая позиция первее и получить отчет, распределяющий остатки по этим изделиям.
Этот его список это план, на большой срок, 3-6 месяцев, поэтому изделий  будет 50-100;
Я уже поднимал этот вопрос здесь, на данный момент у меня реализовано так: я беру остатки, беру список изделий(план) - разузловываю, на один уровень, из результата вычитаю остатки, корректирую остатки, разузловываю на следующий уровень и так до конца, 6-7 уровней.
В таком виде все в порядке, но теперь заказчик хочет болше: у меня в конечном результате, все позиции свернуты, тоесть если материал А встречается в спецификации 3 раза то он у меня всё равно будет одной строкой, тоесть при распределении остатков склада, я распределяю их только между изделиями.
А теперь нужно их расределить ещё и внутри изделия, то есть в моем примере материал А должен быть 3-мя строчками, и задача распределить остаток на эти три строки.
Вот тут я и застрял, в моем алгоритме, я иду от верхнего уровня вниз и на кажом уровне распределяю остатки, встретился мне на уровне 1 материал А - я смотрю, остатки есть, распределяю, но это не правильно, потому что этот материал А есть ещё на уровне 3 и 5 например, причем я точно знаю, что на этом уровне где я сейчас (на первом) он мне понадобится в последнюю очередь.
Правильно было бы, встретив материал А, посмотреть где он есть ещё, и распределить имеющийся остаток - в моём случае между 1, 3 и 5-ым уровнем, и получить, что сначала на уровень 5, потом на 3 и потом на 1.
Но как это реализовать? Находясь на уровне 1, я ещё не дошёл до нижних уровней, и я не знаю, сколько мне понадобится материала А на уровнях 3 и 5.
Помогите пожалуйста советом.
Ответ: () хм, вроде близко, пошёл курить как это реализовать)) спасибо
Вопрос: Запрос к остаткам по двум складам и регистрам накопления.

Доброго времени!
Помогите пожалуйста с запросом. УТ 10.3 8.1
В справочнике "Номенклатура" есть Товар1, и Товар2, который является комплектующей для Товара1. У каждого Товара1 одна комплектующая Товар2.
Весь Товар1 оприходован на складе "Основной склад". Товар этот разбит по группам. Весь Товар2 оприходован на складе "Комплектующие", без разбития на группы.
Комплектующие хранятся стандартно в регистре сведений.
Необходим запрос, который будет выводить список Товара1 с его остатком (пусть даже нулевым) и список комлектующих с их остатками (пусть даже нулевыми).
Т.е. таблица, одна строка которой содержит:
код Товара1/Товар1/Кол-во/код Товара2/Товар2/Кол-во

Первую половину нужной строки вывожу запросом:

ВЫБРАТЬ
Товары.Код КАК Код,
Товары.Ссылка КАК Ссылка,
Остатки.КоличествоОстаток КАК Остаток
ИЗ
Справочник.Номенклатура КАК Товары
ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.ТоварыНаСкладах.Остатки(&Дата, Склад = &Склад) КАК Остатки
ПО Товары.Ссылка = Остатки.Номенклатура
ГДЕ
Товары.Ссылка В ИЕРАРХИИ(&ГруппаНоменклатуры)
И Товары.ЭтоГруппа = ЛОЖЬ


А вот прикрутить сюда вторую нужную половину - беда ((

Без остатка комплектующих запрос получился такой:

ВЫБРАТЬ
Товары.Код КАК Код,
Товары.Ссылка КАК Ссылка,
Остатки.КоличествоОстаток КАК Остаток,
КомплектующиеНоменклатуры.Комплектующая.Код,
КомплектующиеНоменклатуры.Комплектующая
ИЗ
Справочник.Номенклатура КАК Товары
ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.ТоварыНаСкладах.Остатки(&Дата, Склад = &Склад) КАК Остатки
ПО Товары.Ссылка = Остатки.Номенклатура
ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.КомплектующиеНоменклатуры КАК КомплектующиеНоменклатуры
ПО Товары.Ссылка = КомплектующиеНоменклатуры.Номенклатура.Ссылка
ГДЕ
Товары.Ссылка В ИЕРАРХИИ(&ГруппаНоменклатуры)
И Товары.ЭтоГруппа = ЛОЖЬ

Нужно добавить сюда отстаток комплектующих на складе.

Правильно-ли создан запрос и как его довести до ума?
Заранее благодарю за ответы!
Ответ:
Создайте временную таблицу остатков по складам и временную таблицу комплектующих.
Соедините таблицу комплектующих с таблицей остатков по номенклатуре и по комплектующим, поместите во временную таблицу.
Соедините справочник номенклатуры с временной таблицей остатков.
Вопрос: Не вычитаются остатки

Добрый день, Есть два документа , поступление и отгрузка товара , регистр накопления - остатки и отчёт по остаткам, так вот при отгрузке товара в отчёте кол-во товара не уменьшается а наоборот складывается.

Поступление

Кликните здесь для просмотра всего текста
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
Процедура ОбработкаПроведения(Отказ, Режим)    
    //{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
 
    // регистр Остатки Приход
    Движения.Остатки.Записывать = Истина;
    Для Каждого ТекСтрокаПоступ Из Поступ Цикл
        Движение = Движения.Остатки.Добавить();
        Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
        Движение.Период = Дата;
        Движение.ТипТовара = ТекСтрокаПоступ.ТипТовара;
        Движение.Контрагент = Получатель;
        Движение.Склад = Склад;
        Движение.Длина = ТекСтрокаПоступ.Длина;
        Движение.Ширина = ТекСтрокаПоступ.Ширина;
        Движение.Высота = ТекСтрокаПоступ.Высота;
        Движение.Количество = ТекСтрокаПоступ.КоличествоМест;
        Движение.Сумма = ТекСтрокаПоступ.СуммаПозиций;
    КонецЦикла;
 
    //}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
КонецПроцедуры
 
 
Отгрузка
 
Процедура ОбработкаПроведения(Отказ, Режим)
    //{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
 
    // регистр Остатки Расход
    Движения.Остатки.Записывать = Истина;
    Для Каждого ТекСтрокаОтгр Из Отгр Цикл
        Движение = Движения.Остатки.Добавить();
        Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
        Движение.Период = Дата;
        Движение.ТипТовара = ТекСтрокаОтгр.ТипТовара;
        Движение.Контрагент = Покупатель;
        Движение.Склад = Склад;
        Движение.Длина = ТекСтрокаОтгр.Длина;
        Движение.Ширина = ТекСтрокаОтгр.Ширина;
        Движение.Высота = ТекСтрокаОтгр.Высота;
        Движение.Количество = ТекСтрокаОтгр.КоличествоМест;
        Движение.Сумма = ТекСтрокаОтгр.СуммаПозиций;
    КонецЦикла;
 
    //}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
КонецПроцедуры



Отчёт
Кликните здесь для просмотра всего текста
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
ВЫБРАТЬ
    Остатки.ТипТовара,
    Остатки.Контрагент,
    Остатки.Склад,
    СУММА(Остатки.Длина) КАК Длина,
    СУММА(Остатки.Ширина) КАК Ширина,
    СУММА(Остатки.Высота) КАК Высота,
    СУММА(Остатки.Количество) КАК Количество,
    СУММА(Остатки.Сумма) КАК Сумма
ИЗ
    РегистрНакопления.Остатки КАК Остатки
 
СГРУППИРОВАТЬ ПО
    Остатки.ТипТовара,
    Остатки.Контрагент,
    Остатки.Склад
Ответ: Надо брать виртуальную таблицу с остатками на дату:
РегистрНакопления.Остатки.Остатки(&Дата) КАК Остатки
Вопрос: Отчет по минимальным остаткам

День добрый ( заранее извиняюсь если такая тема была но с помощью поиска форума не нашел - или так искал)0). Подзабыл как в 1с8 УТ ред 10.3 снимать отчет с минимальными остатками (где забивать этот мин остаток, в 7-ке это было в карточке номенклатуры) - Помню что создание минимальных остатков в 8ке формируется не так как в 7.7. Кажется надо создавать какой то документ для начала, что бы потом сформировать отчет по ним ( какой из отчетов). И вопрос второй как правильней вести товароучет обычного хозмагазина: Создавать два склада ( допустим , основной и розничный, и доком перемещение при поступлении перемещать с основного на розничный , или просто напрямую поступление на розничный склад? (1й вариант я так понимаю подходит больше при работе с безналом, а второй если безнал отсутствует.?).Заранее благодарен за ответ.
Ответ:
День добрый,
Что такое "минимальный остатки"
Может быть начальные?
Ни в " 8ке", ни "в 7.7" остатки не формруются, это версии платформы.
Остаки формируются кофнигурациями 1С


Создавайте, пожалуйста, отдельную тему на каждый вопрос
Нет понятия "правильней", тем более, в торговых конфигурациях.
Делают - как нужно и как удобнее

а деньги с финансами, а нетовары?
Вы хотите тоько количественный учет?

А, если оплата смешанная? бонусной картой? подарочным сертификатом? то скакого склада будете продавать?
У Вас АТТ, НТТ - автоматизированная, неавтоматизированная торговая точка?
интернет-магазин?
Какая система налогообложения и форма собственности? Одна или совмещение?
Вопрос: 1С7.7 Печать материалов с остатками по складам

Добрый день. Необходимо сделать выгрузку из справочника "материалы", интересуют только материалы с остатком на складе и материалы по которым были обороты за последние 2 года.
В отчете выводить колонки: КодМатериала, Наименование, ЕдИзм, Склад, ОстатокНаСкладе.

1C занимаюсь недавно, так что просьба не ругать за быдлокод)
Почему-то зависает обработка, как будто бесконечный цикл. Подскажите пожалуйста, что не так в моем коде?

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
Процедура Сформировать()
    ДатаНач = ДобавитьМесяц(ТекущаяДата(),-24);  
    
    ТЗМат = СоздатьОбъект("ТаблицаЗначений");
    ТЗМат.НоваяКолонка("Код");   
    ТЗМат.НоваяКолонка("Наименование");
    ТЗМат.НоваяКолонка("ЕдиницаИзмерения");
    ТЗМат.НоваяКолонка("Склад");
    ТЗМат.НоваяКолонка("Остаток");  
    
    СпрМат = СоздатьОбъект("Справочник.Материалы"); 
    СпрМат.ВыбратьЭлементы();  
    Пока СпрМат.ПолучитьЭлемент()=1 Цикл  
        
        БИ = СоздатьОбъект("БухгалтерскиеИтоги");
        БИ.ИспользоватьСубконто(ВидыСубконто.Материалы, СпрМат.Наименование,);
        БИ.ИспользоватьСубконто(ВидыСубконто.МестаХранения,); 
        //БИ.ВключатьСубсчета(-1);
        БИ.ВыполнитьЗапрос(,ТекущаяДата(),"10.1,10.2,10.3,10.4,10.5,10.6,10.7,10.8,10.9",,,1,,"К");  
        Если БИ.СКД("К")>0 Тогда
            БИ.ВыбратьСубконто(ВидыСубконто.МестаХранения);
            Пока БИ.ПолучитьСубконто(ВидыСубконто.МестаХранения)=1 Цикл
                    ТЗМат.НоваяСтрока();
                    ТЗМат.Код = СпрМат.Код;
                    ТЗМат.Наименование = СпрМат.Наименование; 
                    ТЗМат.ЕдиницаИзмерения = СпрМат.ЕдиницаИзмерения;
                    ТЗМат.Склад = БИ.Субконто(1,ВидыСубконто.МестаХранения);
                    ТЗМат.Остаток = БИ.СКД("К");  
            КонецЦикла;   
        Иначе 
            БИ2 = СоздатьОбъект("БухгалтерскиеИтоги");
            БИ2.ИспользоватьСубконто(ВидыСубконто.Материалы, СпрМат.Наименование,);
            БИ2.ВыполнитьЗапрос(ДатаНач,ТекущаяДата(),"10.1,10.2,10.3,10.4,10.5,10.6,10.7,10.8,10.9",,,1,,"К");
            Если БИ2.ДО("К")>0 Тогда
                ТЗМат.НоваяСтрока();
                ТЗМат.Код = СпрМат.Код;
                ТЗМат.Наименование = СпрМат.Наименование; 
                ТЗМат.ЕдиницаИзмерения = СпрМат.ЕдиницаИзмерения;
                ТЗМат.Склад = "";//БИ2.Субконто(1,ВидыСубконто.МестаХранения);
                ТЗМат.Остаток = БИ2.СКД("К");       
            КонецЕсли;  
            
        КонецЕсли;
    КонецЦикла; 
    
    
        //ПЕЧАТЬ    
        Таб = СоздатьОбъект("Таблица");
        Таб.ИсходнаяТаблица("");
        
        Таб.ВывестиСекцию("Шапка");
        
        ТЗМат.ВыбратьСтроки();
        Пока ТЗМат.ПолучитьСтроку()=1 Цикл
            Таб.ВывестиСекцию("Строка");    
        КонецЦикла;  
        
        Таб.ТолькоПросмотр(1);
        Таб.ПараметрыСтраницы(2);
        Таб.ОбластьПечати(1,1,2,5);
        Таб.Опции(0,0,0,0);
        Таб.Показать("");   
    
КонецПроцедуры
Ответ: Может он работает, но очень медленно? Вы на каждую номенклатуру создаете объект БухИтоги? Для чего? Создайте один раз в самом начале и просто зануляйте тогда и после иначе используйте опять же БИ, БИ2 не нужно.
В цикле поставь сообщить (ТЗМат.Остаток); и понаблюдай, идет или зависание. А затем уже смотри, в каком блоке.
Вопрос: Остатки по номенклатуре в заказе УТ 11.3

Привет всем! Есть инет магазин, занимающийся перепродажей товаров от поставщиков, т.е. своих остатков на складе нет, остатки поставщика периодически загружаются из прайса на виртуальный склад поставщика, заказ падает с сайта в 1С с заполненной ТЧ. Возможно ли увидеть остатки по номенклатуре, указанной в заказе, сразу по всем складам поставщиков, в единой форме отчета, без формирования отчета по остаткам по каждой позиции?
Ответ: () Он работает, насколько знаю, в рамках склада, выбранного в заказе в поле склад, а остатки нужны по складам поставщиков.
Вопрос: остатки для группы

Запрос3.Текст = "ВЫБРАТЬ
| ТоварыНаСкладахОстаткиИОбороты.Склад КАК Склад,
| ТоварыНаСкладахОстаткиИОбороты.Номенклатура КАК Номенклатура,
| ТоварыНаСкладахОстаткиИОбороты.КоличествоКонечныйОстаток КАК КоличествоКонечныйОстаток
|ИЗ
| РегистрНакопления.ТоварыНаСкладах.ОстаткиИОбороты(
| &ДатаНачала,
| &ДатаКонца,
| ,
| ,
| Номенклатура в (&Номенклатура)
| И Склад = &Склад
| ИЛИ Склад = &Склад1) КАК ТоварыНаСкладахОстаткиИОбороты
|
|УПОРЯДОЧИТЬ ПО
| Склад,
| Номенклатура,
| КоличествоКонечныйОстаток
|АВТОУПОРЯДОЧИВАНИЕ";

ВыбСклад = справочники.Склады.НайтиПоКоду("000000006");
ВыбСклад1 = справочники.Склады.НайтиПоКоду("000000680");

выбДата = НачалоМесяца(ТекущаяДата());
СледущийДень= КонецДня(выбДата) + 10;

Запрос3.УстановитьПараметр("склад",ВыбСклад);
Запрос3.УстановитьПараметр("склад1",ВыбСклад1);
масНом = ТЧКузнецк.ВыгрузитьКолонку("Наименование");
Запрос3.УстановитьПараметр("Номенклатура",масНом);
Запрос3.УстановитьПараметр("ДатаНачала",выбДата);
Запрос3.УстановитьПараметр("ДатаКонца",СледущийДень);
ВыборкаОстатки = Запрос3.Выполнить().ВЫгрузить();




ТЧ = Новдок.Остатки;
для каждого стрВ из ТЧК цикл
Если стрВ.Группа = истина тогда
//********************************вот тут подскажите что поправить чтобы считало не для номенклатуры а для группы
стр4 = ТЧ.Добавить();
стр4.Наименование = стрВ.Наименование;


Отборост = Новый Структура;
Отборост.Вставить("Номенклатура",стрВ.Наименование);
найдСтроки = ВыборкаОстатки.НайтиСтроки(Отборост);
Для каждого стрОст из найдСтроки Цикл
стр4.ТекущийДень = стрОст.КоличествоКонечныйОстаток;
стр4.СледМесяц = стрОст.КоличествоКонечныйОстаток;

КонецЦикла;
//ОбработкаПрерыванияПользователя();

Иначе
стр4 = ТЧ.Добавить();
стр4.Наименование = СТрВ.Наименование;


Отборост = Новый Структура;
Отборост.Вставить("Номенклатура",стрВ.Наименование);
найдСтроки = ВыборкаОстатки.НайтиСтроки(Отборост);

Для каждого стрОст из найдСтроки Цикл
стр4.ТекущийДень = стрОст.КоличествоКонечныйОстаток;
стр4.СледМесяц = стрОст.КоличествоКонечныйОстаток;

КонецЦикла;
КонецЕсли;
Ответ:
Новдок.Остатки таблица куда помещаются остатки
Вопрос: УТ 11 упр формы Перемещение остатков

Добрый всем вечер, вопрос такой как лучше организовать перенос остатков по номенклатуре.
Имеем: файл номенклатуры
Файл Складов (складсело - складгород).

Необходимо всю номенклатуру из каждого склада села перекинуть на соответствующий ему склад город.
После со всех складов город перекинуть весь остаток по этой же номенклатуре на Главный склад.

Перемещение номенклатуры осуществляю через документы ПеремещенияТоваров.

Мой поярдок действий собираю всю номенклатуру собираю склады из файла, далее собираю остатки по "складамсело" по всей номенклатуре и для каждого склада создаю перемещение товаров. После этого идёт второй заход но уже для складов город.
Дату документов перемещение указывает пользователь на форме.
Планирую также выводить на форму проведенные документы перемещения "складсело", "складгород" и непроведенные все остальные.

Как лучше сделать такой переброс, может я замудрил?
Ответ:
Сообщение от Phil
тип не по правилам распределения организации
К сожалению я не в курсе таких правил...
Делай, двумя (можно и виртуальный склад создать и делать хоть 10-тью) перемещениями и не парься...
Вопрос: Проблема с итогами остатков после сворачивания базы

8.3.8.1652

Много раз делал сворачивание базы, но такое впервые.
Свернул базу на вчера и появилась проблема с получением остатка товаров.

Получаю остатки товара на конец сегодняшнего дня:
ВЫБРАТЬ
    ТоварыНаСкладахОстатки.Номенклатура КАК Номенклатура,
    ТоварыНаСкладахОстатки.ХарактеристикаНоменклатуры КАК ХарактеристикаНоменклатуры,
    ТоварыНаСкладахОстатки.КоличествоОстаток КАК Остаток
ИЗ
    РегистрНакопления.ТоварыНаСкладах.Остатки(
            &Дата,
            Номенклатура В (&Номенклатура)
                И Склад В (&Склад)) КАК ТоварыНаСкладахОстатки

Возвращает: 97
Это неверный остаток

Теперь получаю все движения:

ВЫБРАТЬ
    ТоварыНаСкладах.Номенклатура КАК Номенклатура,
    ТоварыНаСкладах.ХарактеристикаНоменклатуры КАК ХарактеристикаНоменклатуры,
    ТоварыНаСкладах.Количество,
    ТоварыНаСкладах.Регистратор,
    ТоварыНаСкладах.ВидДвижения
ИЗ
    РегистрНакопления.ТоварыНаСкладах КАК ТоварыНаСкладах
ГДЕ
    ТоварыНаСкладах.Номенклатура = &Номенклатура
    И ТоварыНаСкладах.Склад = &Склад

Возвращает:
Корректировка записей регистров 00000000019 от 13.12.2018 23:59:59 - Приход
Чек ККМ 00000000001 от 14.12.2018 10:49:03 - Расход

Вот это верные данные.
Несколько раз через ТиС делал реиндексацию, пересчет остатков и пр. Не помогает.
Такое происходит как на клиент-сервере так и в файловой базе.
В чем может быть причина?
Ответ: ()Процедура называется Тестирование и Исправление. ТиС - это конфигурация Торговля и Склад.