Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: Отчет о синхронизованных документах

Имеется синхронизация через универсальный формат УТ11-БП3.
После синхронизации хочется иметь отчет/список документов, которые были синхронизованы(загружены) в базу.
В типовой реально такое получить, кроме варианта с обходом журнала регистрации? Откуда тащить данные в отчет?
Ответ: () хотя возможно там только то что загрузилось с ошибками, не помню уже...
Вопрос: Отчёт с данными из табличной части

Хочу построить отчёт для документа, часть данных берётся из полей формы, а часть из табличной части этого же документа.

Вот код процедуры

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
 ОблШапка = Макет.ПолучитьОбласть("Шапка");
    Макет = Отчеты.Продажи_за_Период.ПолучитьМакет("Макет");
    Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |   Акт.Номер,
        |   Акт.Дата,
        |   Акт.Описание.(
        |       Артикул,
        |       ЦенаСндс,
        |       КолВоР,
        |       СуммаСндсР
        |   )
        |ИЗ
        |   Документ.Акт КАК Акт
        |ГДЕ
        |   Акт.Дата >= &Начало
        |   И Акт.Дата <= &КонецД";
        
     Запрос.УстановитьПараметр("Начало", Период.ДатаНачала);
     Запрос.УстановитьПараметр("КонецД", Период.ДатаОкончания);
     
    Результат = Запрос.Выполнить();
 
    ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
    ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
    ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
    ОбластьПодвалТаблицы = Макет.ПолучитьОбласть("ПодвалТаблицы");
    ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("Детали");
 
    ТабДок.Очистить();
    ТабДок.Вывести(ОбластьЗаголовок);
    ТабДок.Вывести(ОбластьШапкаТаблицы);
    ТабДок.НачатьАвтогруппировкуСтрок();
 
    ВыборкаДетальныеЗаписи = Результат.Выбрать();
 
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        ОбластьДетальныхЗаписей.Параметры.Заполнить(ВыборкаДетальныеЗаписи);
        ТабДок.Вывести(ОбластьДетальныхЗаписей, ВыборкаДетальныеЗаписи.Уровень());
    КонецЦикла;
 
    ТабДок.ЗакончитьАвтогруппировкуСтрок();
    ТабДок.Вывести(ОбластьПодвалТаблицы);
    ТабДок.Вывести(ОбластьПодвал);
Но при запуске выводит следующее:
Ответ:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
&НаКлиенте
Процедура Сформировать(Команда)
       Сформироватьс()
КонецПроцедуры
 
 
&НаСервере
Процедура Сформироватьс()
    Макет = Отчеты.Отчёт2.ПолучитьМакет("Макет1");
    ОблШапка = Макет.ПолучитьОбласть("Шапка");
    Макет = Отчеты.Отчёт2.ПолучитьМакет("Макет1");
    //{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
 
    Макет = Отчеты.Отчет2.ПолучитьМакет("Макет1");
    Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |   Акт.Номер,
        |   Акт.Дата,
        |   Акт.Описание.(
        |       Артикул,
        |       ЦенаСндс,
        |       КолВоР,
        |       СуммаСндсР
        |   )
        |ИЗ
        |   Документ.Акт КАК Акт";
 
    Результат = Запрос.Выполнить();
 
    ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
    ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
    ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
    ОбластьПодвалТаблицы = Макет.ПолучитьОбласть("ПодвалТаблицы");
    ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("Детали");
    ОписаниеОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ОписаниеШапкаТаблицы");
    ОписаниеОбластьПодвалТаблицы = Макет.ПолучитьОбласть("ОписаниеПодвалТаблицы");
    ОписаниеОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("ОписаниеДетали");
 
    ТабДок.Очистить();
    ТабДок.Вывести(ОбластьЗаголовок);
    ТабДок.Вывести(ОбластьШапкаТаблицы);
    ТабДок.НачатьАвтогруппировкуСтрок();
 
    ВыборкаДетальныеЗаписи = Результат.Выбрать();
 
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        ОбластьДетальныхЗаписей.Параметры.Заполнить(ВыборкаДетальныеЗаписи);
        ТабДок.Вывести(ОбластьДетальныхЗаписей, ВыборкаДетальныеЗаписи.Уровень());
 
        ТабДок.НачатьГруппуСтрок();
        ТабДок.Вывести(ОписаниеОбластьШапкаТаблицы);
        ТабДок.НачатьАвтогруппировкуСтрок();
 
        ОписаниеВыборкаДетальныеЗаписи = ВыборкаДетальныеЗаписи.Описание.Выбрать();
 
        Пока ОписаниеВыборкаДетальныеЗаписи.Следующий() Цикл
            ОписаниеОбластьДетальныхЗаписей.Параметры.Заполнить(ОписаниеВыборкаДетальныеЗаписи);
            ТабДок.Вывести(ОписаниеОбластьДетальныхЗаписей, ОписаниеВыборкаДетальныеЗаписи.Уровень());
        КонецЦикла;
 
        ТабДок.ЗакончитьАвтогруппировкуСтрок();
        ТабДок.Вывести(ОписаниеОбластьПодвалТаблицы);
        ТабДок.ЗакончитьГруппуСтрок();
    КонецЦикла;
 
    ТабДок.ЗакончитьАвтогруппировкуСтрок();
    ТабДок.Вывести(ОбластьПодвалТаблицы);
    ТабДок.Вывести(ОбластьПодвал);
 
    //}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
 
 
    КонецПроцедуры
Вот собрал немного другую. Но не идёт
Вопрос: Отчет по документам в связке

Добрый день. Не подскажите Если я делаю отчет по ПоступлениеДопРасходов и ПоступлениеТоваровУслуг. При формировании отчета выводятся только те документы ПоступлениеТоваровУслуг, у которых есть в структуре ПоступлениеДопРасходов. А как вывести все документы ПоступлениеТоваровУслуг, но если к ним не привязан ПоступлениеДопРасходов чтобы выводилась надпись документ не обнаружен?

Я делаю так:

ВЫБОР
    КОГДА ПоступлениеДопРасходов.Ссылка = NULL
        ТОГДА "Документ не обнаружен"
    ИНАЧЕ ПоступлениеДопРасходов.Ссылка
КОНЕЦ
Ответ: () ну уж извиняйте, как умеем :)
Вопрос: Отчет по реализациям

Сделал вот такой отчет по документам:
Код:
ВЫБРАТЬ
    РеализацияТоваровУслугТовары.Номенклатура КАК Номенклатура,
    РеализацияТоваровУслуг.Организация КАК Организация,
    РеализацияТоваровУслуг.СуммаДокумента КАК СуммаДокумента,
    РеализацияТоваровУслуг.Дата КАК Дата,
    РеализацияТоваровУслуг.Ссылка КАК Ссылка,
    РеализацияТоваровУслуг.ппк_БизнесРегион КАК ппк_БизнесРегион,
    РеализацияТоваровУслуг.Комментарий КАК Комментарий,
    ЕСТЬNULL(Диаметр.Значение, "не указан") КАК Диаметр,
    ВЫБОР
        КОГДА РеализацияТоваровУслугТовары.Характеристика = ЗНАЧЕНИЕ(Справочник.ХарактеристикиНоменклатуры.ПустаяСсылка)
            ТОГДА "не указана"
        ИНАЧЕ РеализацияТоваровУслугТовары.Характеристика
    КОНЕЦ КАК Характеристика,
    ЕСТЬNULL(РеализацияТоваровУслугТовары.Количество, "не указано") КАК Количество,
    РеализацияТоваровУслуг.Менеджер КАК Менеджер
ИЗ
    Справочник.Пользователи КАК Пользователи
        ЛЕВОЕ СОЕДИНЕНИЕ Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслугТовары
            ЛЕВОЕ СОЕДИНЕНИЕ Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
            ПО РеализацияТоваровУслугТовары.Ссылка = РеализацияТоваровУслуг.Ссылка
            ЛЕВОЕ СОЕДИНЕНИЕ Справочник.Номенклатура.ДополнительныеРеквизиты КАК Диаметр
            ПО РеализацияТоваровУслугТовары.Номенклатура = Диаметр.Ссылка
                И (Диаметр.Свойство.Наименование = "Диаметр")
        ПО Пользователи.Ссылка = РеализацияТоваровУслугТовары.Ссылка.Менеджер
ГДЕ
    Пользователи.Ссылка В(&Менеджер)
    И РеализацияТоваровУслуг.Дата <= &ПоСостояниюНа
    И РеализацияТоваровУслугТовары.Номенклатура В ИЕРАРХИИ(&ГруппаНоменклатуры)
Но нужно сделать такой же, чтобы он по регистрам был, вот смотрю теперь на движения документов РеализацияТоваровУслуг и не пойму по какому правильно строить ТоварыКОтгрузке вроде могут быть и внутри организации, а нужно именно продажи. Вот и не понятно.
Ответ:
Спасибо, теперь я понял... походу без документа все-равно не обойтись, просто тут с правами заморочки, на регистры они имеются, а вот на документы не на все.
Вопрос: Изменить значение реквизитов ТЧ документа по событию проведения другого документа

Здравствуйте.В собственной конфе 1С 8.3 есть документ "ОбъектныйГрафик" с ТЧ "Задания". Также есть документ "ИнформационныйЛистокОвыдачеЗадания" с реквизитами: График - ссылка на график.; ВыдающийОтдел, ПринимающийОтдел - СправочникСсылка.Подразделения;Задание -справочникссылка.задания;СрокФактический - Дата....В ТЧ "Задания" документа "ОбъектныйГрафик" те же реквизиты. Мне нужно сделать следующее: при выполнении команды "ПринятьЗадание" формы документа "ИнформационныйЛистокОвыдачеЗадания" найти в ТЧ графика задание, указанное в документе для выбранных выдающего и принимающего отдела и заполнить реквизиты найденной строки ТЧ графика реквизитами документа "ИнформационныйЛистокОвыдачеЗадания", затем конечно записать изменения в графике. Для этого сделал следующее в форме документа "ИнформационныйЛистокОвыдачеЗадания":
Код:
&НаСервере
Процедура ПриЗаписиНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
    // Вставить содержимое обработчика.
    ЗапросНомераЗадания=Новый Запрос;    //получение номера строки ТЧ графика с нужным заданием
    ЗапросНомераЗадания.Текст="ВЫБРАТЬ
                              |    ОбъектныйГрафикЗадания.НомерСтроки КАК НомерЗадания
                              |ИЗ
                              |    Документ.ОбъектныйГрафик.Задания КАК ОбъектныйГрафикЗадания
                              |        ЛЕВОЕ СОЕДИНЕНИЕ Документ.ОбъектныйГрафик КАК ОбъектныйГрафик
                              |        ПО ОбъектныйГрафикЗадания.Ссылка = ОбъектныйГрафик.Ссылка
                              |ГДЕ
                              |    ОбъектныйГрафик.Ссылка = &График
                              |    И ОбъектныйГрафикЗадания.ВыдающийОтдел.Ссылка = &ВыдающийОтдел
                              |    И ОбъектныйГрафикЗадания.Задание.Ссылка = &Задание
                              |    И ОбъектныйГрафикЗадания.ПринимающийОтдел.Ссылка = &ПринимающийОтдел";
    ЗапросНомераЗадания.УстановитьПараметр("График",ТекущийОбъект.ОбъектныйГрафик.Ссылка);
     ЗапросНомераЗадания.УстановитьПараметр("ВыдающийОтдел",ТекущийОбъект.ГруппаВыдающаяЗадание.Ссылка);
      ЗапросНомераЗадания.УстановитьПараметр("Задание",ТекущийОбъект.Задание.Ссылка);
       ЗапросНомераЗадания.УстановитьПараметр("ПринимающийОтдел",ТекущийОбъект.ГруппаПолучающаяЗадание.Ссылка);
    Результат=ЗапросНомераЗадания.Выполнить().Выбрать();
    Пока Результат.Следующий() Цикл
    НомерЗадания=Результат.НомерЗадания;   
КонецЦикла;   
График=Документы.ОбъектныйГрафик.НайтиПоНомеру(ТекущийОбъект.ОбъектныйГрафик.Номер).ПолучитьОбъект();
СтрокаТЧ = График.Задания[НомерЗадания - 1];
СтрокаТЧ.ХарактеристикаЗадания=ТекущийОбъект.ХарактеристикаПолнотыЗаданияПринимающейГруппы;
Если ТекущийОбъект.Статус=Перечисления.СтатусФормыВыдачиЗадания.Утверждена Тогда
СтрокаТЧ.СтепеньВыполнения=ТекущийОбъект.ОценкаПолнотыЗаданияПринимающейГруппы;
СтрокаТЧ.ДатаВыдачиФакт=ТекущийОбъект.СрокФактический;
СтрокаТЧ.СостояниеЗадания=Перечисления.СостояниеЗадания.Выдано;
СтрокаТЧ.Примечание=ТекущийОбъект.Ссылка;
КонецЕсли;
График.Записать();
Если ТекущийОбъект.ГруппаВыдающаяЗадание=Параметрысеанса.Сотрудник.Подразделение И ЗаполненыПоляВыдающейСтороны()=ложь и Не ЗначениеЗаполнено(Объект.ФайлЗадания) тогда
Сообщить("Проверьте заполнение оценки и характеристики полноты задания,комментария выдающей стороны и указание файла задания");
Отказ=Истина;
КонецЕсли;
Если ТекущийОбъект.ГруппаПолучающаяЗадание=Параметрысеанса.Сотрудник.Подразделение И ЗаполненыПоляПринимающейСтороны()=ложь тогда
Сообщить("Проверьте заполнение оценки и характеристики полноты задания и комментария принимающей стороны");
Отказ=Истина;
КонецЕсли;
КонецПроцедуры

команда "ПринятьЗадание":
Код:
&НаСервере
Процедура ПринятьЗаданиеНаСервере()
    // Вставить содержимое обработчика.
    Формазадания=Объект.ссылка.ПолучитьОбъект();
    Формазадания.ОценкаПолнотыЗаданияПринимающейГруппы=100;
    Формазадания.ХарактеристикаПолнотыЗаданияПринимающейГруппы=Перечисления.ХарактеристикаПолнотыЗадания.ВыданоВПолномОбъеме;
Формазадания.СрокФактический=ТекущаяДата();   
//Формазадания.ГлавныйСпециалистПринимающейГруппы=Параметрысеанса.Сотрудник;
    Формазадания.Статус=Перечисления.СтатусФормыВыдачиЗадания.Утверждена;
//ПриЗаписиНаСервере(Ложь,Формазадания,);
ФормаЗадания.Записать(РежимЗаписиДокумента.Проведение,РежимПроведенияДокумента.Неоперативный);
ОтправитьСообщениеОПринятииЗадания();
КонецПроцедуры


&НаКлиенте
Процедура ПринятьЗадание(Команда)
    ПринятьЗаданиеНаСервере();
    ЭтаФорма.Закрыть();
КонецПроцедуры
Если пользователь выполняет команду "ПринятьЗадание", система ругается: Данные были изменены.Сохранить изменения?(да/нет). Если нажимаешь "Да", следующее ругательство:"Данные были изменены или удалены другим пользователем." Что не так? как правильно сделать?
Ответ:
Ну я прочитал это всё.. и зацеплюсь за последнюю фразу "Как правильно сделать?"

А правильно сделать регистр накопления Остатков..

ОбъектныйГрафик будет в этот регистр делать движения с заданиями в приход.. это будут не разобранные задания.

А документ ИнформационныйЛистокОвыдачеЗадания будет делать в этот регистр движение расход.

1) Вы всегда сможете сделать срез по Заданиям которые ещё не приняты в исполнение
2) Вы можете построить отчет по Заданиям, документам их инициализирующим (ОбъектныйГрафик) и по документам которыми они были приняты .

А вы планируете в каждый документ ОбъектныГрафик заходить и смотреть ТЧ Задания и видеть принята задача или нет. А ещё хуже может и отчет по документам написать.
Вопрос: Опубликовать отчет 1с через http сервис

Добрый день , коллеги!

Есть задача опубликовать отчет (табличный документ) через http сервис.

Насколько это сложно, кто нибудь делал? Может быть у кого то есть пример?

Буду крайне благодарен за помощь
Ответ: () Ну я примерно то же самое хотел сказать, только сразу намекнул, как можно правильно решить задачу.
Вопрос: Объединение двух запросов в отчете

Здравствуйте, целый день мучаюсь, помогите с задачкой: делаю отчет, с помощью которого формируются данные по двух документам (РасходнаяНакладная и ПродажаВРозницу), после выбора сотрудников и установке галки на нужном типе отчета формируются необходимые данные, НО! Если я хочу вывести совместный отчет по этим двум документам, то отчет не срабатывает(( Отчет формируется с помощью запросов, как объединить эти два запроса???? Сам отчет приложил.

Ответ: В общем проверил, запросы отрабатывают норм, но не могу вывести данные, если указываю обоих сотрудников (на форме есть два поля Сотрудник (выбирается из справочника Договоров (так надо)) и Сотрудник2 (выбирается из справочника Сотрудники)). Вот код:
Код 1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
    Запрос = СоздатьОбъект("Запрос");
        ТекстЗапроса = 
        "//{{ЗАПРОС(Сформировать)
        |с ВыбНачПериода по ВыбКонПериода;
        |ТекущийДокумент = Документ.РасходнаяНакладная.ТекущийДокумент, Документ.ПродажаВРозницу.ТекущийДокумент;
        |Принято = Документ.РасходнаяНакладная.Договор, Документ.ПродажаВРозницу.Принято;
        |Товар = Документ.РасходнаяНакладная.Товар, Документ.ПродажаВРозницу.Товар;
        |Количество = Документ.РасходнаяНакладная.Количество, Документ.ПродажаВРозницу.Количество;
        |Всего = Документ.РасходнаяНакладная.Всего, Документ.ПродажаВРозницу.Всего;
        |Функция ВсегоСумма = Сумма(Всего);
        |Функция КоличествоСумма = Сумма(Количество);
        |Группировка Принято без групп; 
        |Группировка Товар без групп;
        |Условие(ПустоеЗначение(Принято)=0); 
        |Условие(Товар.ТипНоменклатуры=Перечисление.ТипыНоменклатуры.Товар);
        |"//}}ЗАПРОС
        ;
        
        Если (Сотрудник.Выбран()=1) И (Сотрудник2.Выбран()=1) Тогда
            ТекстЗапроса=ТекстЗапроса+"
            |Условие(Принято=Сотрудник); 
            |Условие(Принято=Сотрудник2);
            |";
        КонецЕсли;
Что необходимо указать в Условии, чтобы вывелись данные по обоим реквизитам Сотрудник и Сотрудник2??

Добавлено через 20 минут
В общем сам додумался, а то чет никто не подсказывает
Сделал следующее и запрос заработал:
Код 1C
1
|Условие(Принято=Сотрудник) ИЛИ (Принято=Сотрудник2);
Вопрос: Создание отчета

Здравствуйте уважаемые форумчане.
Работаю в службе сервиса небольшой организации, занимающейся ремонтом бытовой техники.
Сама недавно прослушала курс бесплатных лекций по интернету, скачала вебинары по программированию 1с8.3. Понимаю конечно, что это капля в море и нужны более серьезные курсы, где проходят темы углубленно, но сейчас хочу испытать себя на ниве программиста - т.е. хочу написать программу для нашего диспетчера, который работает на 7.7, хотя на компе установлена 8.3.
Что надо:
Диспетчер принимает заявки от граждан и заносит их в документ. В документе есть столбцы: адреса, содержание заявки, мастер, отчет мастера и столбец с указанием выполнения заявки(предполагаю булево)
По данному списку документов диспетчер должен сформировать отчет с заявками для каждого мастера с его адресами и содержанием заявок.
И возникает много вопросов, я должна использовать регистр накопления остатки, но ресурс там не использовать, т.к. числовых значений в заявках нет. в отчете использовать СКД или что-то другое и как вывести конечную форму отчета. Для обширного изучения купила учебник Хрусталева, но пока не разобралась. Просмотрела много сайтов в интернете, но все мимо. Может кто-то подскажет алгоритм написания программы или скинет ссылку на интересующие меня вопросы? с Уважением Анна.
Ответ:
Сегодня пролистала Митченко, но это я видела на вебинарах. Что касается моей задачи:
может на наводящие вопросы ответите, а то по существу ничего нет.
1. в документе следующие реквизиты :
- Адрес(СправочникСсылка)
- КонтактныеДанные(Строка(входит номер квартиры и телефон))
- СодержаниеЗаявки(Строка)
- ОтчетМастера(Строка)
- Выполнено (Булево(отметка о выполнении))
2. РегистрНакопленияОстатки --- ?
- Измерения что и в документе и мастер, а Ресурс не нужен
Что вижу на выходе:
в шапке: дата(на день выполнения заявок, ФИО мастера
в табчасти:
тоже, что и документе.
По отчету приблизительно понимаю что надо сделать, но какая-то мелочь не дает окончательно решить. Строки из документа не переносятся в отчет - так понимаю, что решается написанием кода и как выглядит запрос недопонимаю.
Забыла написать:
если установить галочку в документе(выполнено) - в отчете должна пропасть строка с заявкой и появиться в отчете выполненных.
Вопрос: Отчет о начислениях

Добрый день! Точнее... Уже доброй почти ночи.
Такой вопрос.
Есть конфигурация, есть документ НачисленияЗарплат. Есть Регистр актуальных зарплат. Задание такое: сформировать отчет с*колонками* "начислено",*"выплачено",*"конечный*остаток". В связи с этим два вопроса... Первый - поскольку мой регистр копит только данные об актуальных зарплатах, то нужно создать отдельный регистр для начислений, чтобы сформировать из него отчёт потом? И второй вопрос - разъясните, пожалуйста, плюснику и нубу в терминах экономики, что такое "начислено", "выплачено" и "конечный остаток".))
Я так поняла, что "начислено" - это за всё время сколько всего начислено зарплаты сотруднику?
"выплачено" - это сколько выплачено?.. Но тогда в чем разница от "начислено?"
"конечный остаток" - совсем в ступор вводит... Остаток от чего?..
Заранее спасибо всем, кто откликнется.
Ответ: Тамика,
1. Документ Изменение оклада: у вас есть реквизит Дата нового оклада, зачем? В обработке проведения в Период регистра вы проставляете Дату документа.
2. Документ Прием на работу: в задании у вас сказано
Реализовать возможность отражения приема на работу сотрудника с указанием даты приема, должности и суммы оклада.
У вас ни должность, ни оклад в этом документе не указываются.
В документе по заданию должен быть механизм:
В документе должна быть возможность заполнения документа актуальными сотрудниками и их окладами.
У вас его нет.
Вам нужно создать команду в форме документа Начисление зарплаты. Там прописать следующее:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
&НаКлиенте
Процедура Заполнить(Команда)
    ЗаполнитьНаСервере();
КонецПроцедуры
 
&НаСервере
Процедура ЗаполнитьНаСервере()
    Объект.НачислениеЗарплат.Очистить();
    Запрос = Новый Запрос("ВЫБРАТЬ
                          | ДанныеОСотрудникахСрезПоследних.Сотрудник КАК ФИО,
                          | ДанныеОСотрудникахСрезПоследних.Оклад КАК СтавкаЗаМесяц
                          |ИЗ
                          | РегистрСведений.ДанныеОСотрудниках.СрезПоследних(&Период, Состояние = ЗНАЧЕНИЕ(Перечисление.СостоянияСотрудника.ПринятНаРаботу)) КАК ДанныеОСотрудникахСрезПоследних");
    Запрос.УстановитьПараметр("Период", Объект.Дата);                     
    Выборка = Запрос.Выполнить().Выбрать();
    Пока Выборка.Следующий() Цикл
        НовСтрока = Объект.НачислениеЗарплат.Добавить();
        ЗаполнитьЗначенияСвойств(НовСтрока, Выборка);       
    КонецЦикла;
КонецПроцедуры
Здесь мы получаем из виртуальной таблицы СрезПоследних регистра данные об актуальных сотрудниках и их ставки.

2. Документы Начисление и Выплаты и регистр накопления: вы сделали два ресурса регистра накопления. И делаете Приход и Расход в разные ресурсы. Т.е. что у вас получится в итоге: на одном ресурсе сумма будет бесконечно расти, на другом бесконечно уходить в минус. Надо было создать один ресурс - Сумма. И по нему делать и Приход, и Расход. В Этом и суть регистра накопления Остатки. Как вы тогда получите в отчете Кон. остаток? (вы его кстати и не получаете)

3. По заданию:
Реализовать возможность выплаты зарплаты сотрудникам. В документе должна быть функция заполнить по невыплаченной зарплате сотрудников.
Т.е. у вас должна быть табличная часть в документе, как и в Начислении зарплаты(я сделала реквизиты - ФИО, СуммаНачисления, СуммаВыплаты). Далее для заполнения табличной части: создайте кнопку в форме документа Выплата зарплаты. И припишите следующий код:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
&НаКлиенте
Процедура Заполнить(Команда)
    ЗаполнитьНаСервере();
КонецПроцедуры
 
&НаСервере
Процедура ЗаполнитьНаСервере()
    Объект.ВыплатаЗарплат.Очистить();
    Запрос = Новый Запрос("ВЫБРАТЬ
                          | ВзаиморасчётыССотрудникамиОстатки.ФИО,
                          | ВзаиморасчётыССотрудникамиОстатки.СуммаОстаток КАК СуммаНачисления
                          |ИЗ
                          | РегистрНакопления.ВзаиморасчётыССотрудниками.Остатки(&Период, ) КАК ВзаиморасчётыССотрудникамиОстатки");
    Запрос.УстановитьПараметр("Период", Объект.Дата);                     
    Выборка = Запрос.Выполнить().Выбрать();
    Пока Выборка.Следующий() Цикл
        НовСтрока = Объект.ВыплатаЗарплат.Добавить();
        ЗаполнитьЗначенияСвойств(НовСтрока, Выборка);   
        НовСтрока.СуммаВыплаты = НовСтрока.СуммаНачисления; //заполним одинаково, но сумму выплаты смогут менять вручную
    КонецЦикла;
    
КонецПроцедуры
В движения надо записывать именно СуммуВыплаты из ТЧ.

Про отчет сказала выше - нет Кон. Остатка. Плюс включите возможность изменения периода отбора записей: в СКД на вкладке Настройки, ниже Параметры - на дате Начало периода, правой кнопкой мыши - Свойства элемента пользовательских настроек - Включить в состав пользовательских настроек.
Вопрос: Использование расшифровки в отчете СКД

Есть отчет на СКД, хочу для полей данных открывать соответствующие формы объектов. В книге Хрусталевой "Разработка сложных отчетов", показано, что достаточно заполнить поле Расшифровка нужной ячейки макета. Указываю имя переменной расшифровки, в макете группировки выбираю для этой переменной:


Ошибка исполнения отчета
по причине:
Ошибка в выражении
по причине:
Синтаксическая ошибка

Я так думаю дело в том, что пример для УФ, а у меня обычные.
Ответ: По полям Заказчик и Продукция, расшифровку провожу нормально, но в отчете также есть 2 вида документов, которые тоже необходимо расшифровывать. В макете указал Ссылки на документы. В обработке использую такую процедуру:
1C
1
2
3
4
5
6
Процедура РезультатОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка)
    Перем ВыполненноеДействие;
    СтандартнаяОбработка=Ложь;
    Ссылка=ДанныеРасшифровки.Элементы[Расшифровка].ПолучитьПоля()[0].Значение;
    Ссылка.ПолучитьФорму().Открыть();
КонецПроцедуры
При расшифровке 2 первых полей, переменная расшифровки содержит текстовое значение ячейки, с докементами же ей присваиваются какие-то числа, не имеющие ничего общего с номерами документов и, естественно, при открытии формы я получаю ошибку.
Мой Запрос:
T-SQL
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
ВЫБРАТЬ
    МашинноеВремяДокументыПроизводства.Ссылка.Дата КАК Дата,
    МашинноеВремяДокументыПроизводства.Ссылка,
    МашинноеВремяДокументыПроизводства.Ссылка.Смена,
    МашинноеВремяДокументыПроизводства.Ссылка.СчетчикНач,
    МашинноеВремяДокументыПроизводства.Ссылка.СчетчикКон,
    МашинноеВремяДокументыПроизводства.Ссылка.ПечатнаяМашина,
    МашинноеВремяДокументыПроизводства.Ссылка.Номер КАК НомерДокумента,
    МашинноеВремяДокументыПроизводства.Документ,
    МашинноеВремяДокументыПроизводства.Документ.Номер Как НомерНаряда,
    МашинноеВремяДокументыПроизводства.НачалоПриладки,
    МашинноеВремяДокументыПроизводства.КонецПриладки,
    МашинноеВремяДокументыПроизводства.КонецПечати,
    МашинноеВремяДокументыПроизводства.НомерВысечки,
    СУММА(МашинноеВремяДокументыПроизводства.Тираж) КАК Тираж,
    СУММА(МашинноеВремяДокументыПроизводства.Чистый) КАК Чистый,
    СУММА(МашинноеВремяДокументыПроизводства.ПланЧистый) КАК ПланЧистый,
    СУММА(МашинноеВремяДокументыПроизводства.Грязный) КАК Грязный,
    СУММА(МашинноеВремяДокументыПроизводства.ПланГрязный) КАК ПланГрязный,
    СУММА(МашинноеВремяДокументыПроизводства.СкоростьПеч) КАК СкоростьПеч,
    СУММА(МашинноеВремяДокументыПроизводства.Экономия) КАК Экономия,
    СУММА(МашинноеВремяДокументыПроизводства.ЭкономияКв) КАК ЭкономияКв,
    МашинноеВремяДокументыПроизводства.ТиражСнят,
    МашинноеВремяДокументыПроизводства.Заказчик,
    МашинноеВремяДокументыПроизводства.Продукция,
    МашинноеВремяДокументыПроизводства.Ссылка.Печатник,
    МашинноеВремяДокументыПроизводства.Ссылка.Помощник,
    КОЛИЧЕСТВО(РАЗЛИЧНЫЕ РезервМатериала.Материал) КАК МатериалРезерв,
    СУММА(РезервМатериала.Кво) КАК КоличествоРезерв,
    КОЛИЧЕСТВО(РАЗЛИЧНЫЕ МатериалыПоКалькуляции.Материал) КАК МатериалФакт,
    СУММА(МатериалыПоКалькуляции.Количество) КАК КоличествоФакт,
    МашинноеВремяДокументыПроизводства.ВидРаботы,
    МашинноеВремяДокументыПроизводства.Секции
ИЗ
    Документ.МашинноеВремя.ДокументыПроизводства КАК МашинноеВремяДокументыПроизводства
        ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.РезервМатериала КАК РезервМатериала
        ПО МашинноеВремяДокументыПроизводства.Документ = РезервМатериала.Регистратор
        ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.МатериалыПоКалькуляции КАК МатериалыПоКалькуляции
        ПО МашинноеВремяДокументыПроизводства.Документ = МатериалыПоКалькуляции.Калькуляция
            И (МатериалыПоКалькуляции.Материал.Ролевый = ИСТИНА)
{ГДЕ
    (МашинноеВремяДокументыПроизводства.Ссылка.Дата МЕЖДУ &ДатаНач И &ДатаКон)}
 
СГРУППИРОВАТЬ ПО
    МашинноеВремяДокументыПроизводства.Ссылка.Дата,
    МашинноеВремяДокументыПроизводства.Ссылка.Смена,
    МашинноеВремяДокументыПроизводства.Ссылка.ПечатнаяМашина,
    МашинноеВремяДокументыПроизводства.Документ,
    МашинноеВремяДокументыПроизводства.Документ.Номер,
    МашинноеВремяДокументыПроизводства.НомерВысечки,
    МашинноеВремяДокументыПроизводства.ТиражСнят,
    МашинноеВремяДокументыПроизводства.Заказчик,
    МашинноеВремяДокументыПроизводства.Продукция,
    МашинноеВремяДокументыПроизводства.Ссылка.Печатник,
    МашинноеВремяДокументыПроизводства.Ссылка.Помощник,
    МашинноеВремяДокументыПроизводства.ВидРаботы,
    МашинноеВремяДокументыПроизводства.Секции,
    МашинноеВремяДокументыПроизводства.Ссылка,
    МашинноеВремяДокументыПроизводства.Ссылка.СчетчикНач,
    МашинноеВремяДокументыПроизводства.Ссылка.СчетчикКон,
    МашинноеВремяДокументыПроизводства.Ссылка.Номер,
    МашинноеВремяДокументыПроизводства.НачалоПриладки,
    МашинноеВремяДокументыПроизводства.КонецПриладки,
    МашинноеВремяДокументыПроизводства.КонецПечати
 
УПОРЯДОЧИТЬ ПО
    Дата
Показываю МашинноеВремяДокументыПроизводства.Ссылка.Номер и МашинноеВремяДокументыПроизводства.Документ.Номер.

Добавлено через 16 часов 49 минут
Проблему решил, при клике на номерах, в расшифровке показываются какие-то непонятные двузначные числа, но тем менее все работает нормально, если в группировку добавить ссылки на документы.