Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: Формирование отчета на скд остатки материалов в организации на складе 1с 8.3

Помогите, пожалуйста разобраться с запросом. В 1с новичок. Нужно сформировать отчет остатки материалов в организации на складе на СКД. Организация и склад вводятся пользователем через форму отчета, и по введенным значения организации и склада надо вывести отчет.Прилагаю код запроса,сформулированный на СКД. В Отчете ничего не выводится, почему?

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
ВЫБРАТЬ
    ОстаткиТоваровОстаткиИОбороты.Организация,
    ОстаткиТоваровОстаткиИОбороты.Склад,
    ОстаткиТоваровОстаткиИОбороты.Товар,
    ОстаткиТоваровОстаткиИОбороты.КоличествоНачальныйОстаток,
    ОстаткиТоваровОстаткиИОбороты.КоличествоПриход,
    ОстаткиТоваровОстаткиИОбороты.КоличествоРасход,
    ОстаткиТоваровОстаткиИОбороты.КоличествоКонечныйОстаток
ИЗ
    РегистрНакопления.ОстаткиТоваров.ОстаткиИОбороты(
            ,
            ,
            ,
            ,
            Организация = &Организация
                И Склад = &Склад) КАК ОстаткиТоваровОстаткиИОбороты
Ответ: GreenkA, Сейчас посмотрю

Добавлено через 8 минут
Все работает, можно ли настроить что бы при выборе склада, можно было выбирать только тот склад, который относится к выбранной организации? Справочник склад у меня подчинен справочнику Организации

Добавлено через 49 минут
GreenkA, Все разобрался, спасибо
Вопрос: Остатки товаров на складах в ценах поступления

Всем привет!
Необходимо для УТ 11.2 сделать отчет, остатки товаров в закупочных ценах. НО!
Нужно эти остатки выводить в разрезе ГТД. К примеру:
Номенклатура1 - ГТД1 - 12 шт. - 10 руб.
Номенклатура1 - ГДТ2 - 10 шт. - 15 руб.

У кого большой опыт, подскажите по каким регистрам мне собрать такой отчет?
Ответ:
Сделал на подобии стандартного отчета "Контроль номеров ГТД товаров".Там берется регистра накопления ТоварыОрганизаций.ОстаткиИОбороты, ставим период - Авто, тогда доступно поле Регистратор, и по нему выбираем цены поступления.
Вопрос: Перенос остатков по складам из БП 3.0 в УТ 11.3

Добрый день.
Есть заявка о том, что нужно один раз перенести из БП в пустую УТ документы влияющие на остатки по складам. Детальней задачу не могут сформулировать. Прошу подсказать, какие документы нужно отправить в УТ ? Поступление товаров и услуг, реализация товаров и услуг, заказы клиентов ?
С подобной задачей не сталкивался, думаю этот перенос произвести через типовую синхронизацию выбрав необходимые документы.
Ответ:
все приходные и расходные документы, к уже перечисленным это и перемещение и сборка/разборка как минимум. плюс ещё перепутанный товар бывает.
Вопрос: 1С7.7 Печать материалов с остатками по складам

Добрый день. Необходимо сделать выгрузку из справочника "материалы", интересуют только материалы с остатком на складе и материалы по которым были обороты за последние 2 года.
В отчете выводить колонки: КодМатериала, Наименование, ЕдИзм, Склад, ОстатокНаСкладе.

1C занимаюсь недавно, так что просьба не ругать за быдлокод)
Почему-то зависает обработка, как будто бесконечный цикл. Подскажите пожалуйста, что не так в моем коде?

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
Процедура Сформировать()
    ДатаНач = ДобавитьМесяц(ТекущаяДата(),-24);  
    
    ТЗМат = СоздатьОбъект("ТаблицаЗначений");
    ТЗМат.НоваяКолонка("Код");   
    ТЗМат.НоваяКолонка("Наименование");
    ТЗМат.НоваяКолонка("ЕдиницаИзмерения");
    ТЗМат.НоваяКолонка("Склад");
    ТЗМат.НоваяКолонка("Остаток");  
    
    СпрМат = СоздатьОбъект("Справочник.Материалы"); 
    СпрМат.ВыбратьЭлементы();  
    Пока СпрМат.ПолучитьЭлемент()=1 Цикл  
        
        БИ = СоздатьОбъект("БухгалтерскиеИтоги");
        БИ.ИспользоватьСубконто(ВидыСубконто.Материалы, СпрМат.Наименование,);
        БИ.ИспользоватьСубконто(ВидыСубконто.МестаХранения,); 
        //БИ.ВключатьСубсчета(-1);
        БИ.ВыполнитьЗапрос(,ТекущаяДата(),"10.1,10.2,10.3,10.4,10.5,10.6,10.7,10.8,10.9",,,1,,"К");  
        Если БИ.СКД("К")>0 Тогда
            БИ.ВыбратьСубконто(ВидыСубконто.МестаХранения);
            Пока БИ.ПолучитьСубконто(ВидыСубконто.МестаХранения)=1 Цикл
                    ТЗМат.НоваяСтрока();
                    ТЗМат.Код = СпрМат.Код;
                    ТЗМат.Наименование = СпрМат.Наименование; 
                    ТЗМат.ЕдиницаИзмерения = СпрМат.ЕдиницаИзмерения;
                    ТЗМат.Склад = БИ.Субконто(1,ВидыСубконто.МестаХранения);
                    ТЗМат.Остаток = БИ.СКД("К");  
            КонецЦикла;   
        Иначе 
            БИ2 = СоздатьОбъект("БухгалтерскиеИтоги");
            БИ2.ИспользоватьСубконто(ВидыСубконто.Материалы, СпрМат.Наименование,);
            БИ2.ВыполнитьЗапрос(ДатаНач,ТекущаяДата(),"10.1,10.2,10.3,10.4,10.5,10.6,10.7,10.8,10.9",,,1,,"К");
            Если БИ2.ДО("К")>0 Тогда
                ТЗМат.НоваяСтрока();
                ТЗМат.Код = СпрМат.Код;
                ТЗМат.Наименование = СпрМат.Наименование; 
                ТЗМат.ЕдиницаИзмерения = СпрМат.ЕдиницаИзмерения;
                ТЗМат.Склад = "";//БИ2.Субконто(1,ВидыСубконто.МестаХранения);
                ТЗМат.Остаток = БИ2.СКД("К");       
            КонецЕсли;  
            
        КонецЕсли;
    КонецЦикла; 
    
    
        //ПЕЧАТЬ    
        Таб = СоздатьОбъект("Таблица");
        Таб.ИсходнаяТаблица("");
        
        Таб.ВывестиСекцию("Шапка");
        
        ТЗМат.ВыбратьСтроки();
        Пока ТЗМат.ПолучитьСтроку()=1 Цикл
            Таб.ВывестиСекцию("Строка");    
        КонецЦикла;  
        
        Таб.ТолькоПросмотр(1);
        Таб.ПараметрыСтраницы(2);
        Таб.ОбластьПечати(1,1,2,5);
        Таб.Опции(0,0,0,0);
        Таб.Показать("");   
    
КонецПроцедуры
Ответ: Может он работает, но очень медленно? Вы на каждую номенклатуру создаете объект БухИтоги? Для чего? Создайте один раз в самом начале и просто зануляйте тогда и после иначе используйте опять же БИ, БИ2 не нужно.
В цикле поставь сообщить (ТЗМат.Остаток); и понаблюдай, идет или зависание. А затем уже смотри, в каком блоке.
Вопрос: Выгрузка остатков по складу из 10.3 в 11.2?

Приветствую!
При использовании стандартной обработки не могу выгрузить остатки номенклатуры.
Скорее всего из-за этого -
Обнаружен отрицательный остаток на складе "Основной склад" по товару "К......" при выгрузке по правилу: "Собственные товары на складах"

как это можно обойти?
Ответ:
нашел способ!!!
Документ - Корректировка серий и характеристик товара. Делаю на 31.12, а на 01.01 отрицательного остатка нет!

Всем спасибо!
Вопрос: Стоимостная оценка склада в ценах номенклатуры

Здравствуйте. В 1С УТ 8.2 когда делаю отчет "Стоимостная оценка склада в ценах номенклатуры" некоторые позиции номенклатуры количество показывает в 4 раза больше чем в остатках. Если смотреть "Ведомость по товарам на складах" то остатки правильные. Почему так?
Ответ: () смотря какая настройка
Вопрос: Оприходование излишков товаров не ставит остатки на склад. УТ 11.4.

Здравствуйте, уважаемы форумчане. Столкнулись с такой проблемой: Оприходование излишков товаров не ставит остатки на склад.
Т.е. создаем документ в Управление торговлей, редакция 11 (11.4.5.135) (1С:Предприятие 8.3 (8.3.13.1644)) Оприходование излишков товаров на Фирме2(Ф2) на складе2(С2), заполняем шапку, вводим товары, количество (дата 17.12.2018г.). Проводим документ. Снимаем ведомость товара по складам с отбором по складу(с детализацией по регистратору и без нее). Остатки не изменяются, документ в отчете не виден. На другой фирме1(Ф1) и другом складе1(С1), (документ делали раньше дата 01.01.2018г.) все проходит. Причем если сделать начальный ввод остатков с одинаковыми входными данными, остатки появляются и документ в отчете тоже по Ф2 и С2 от 17.12.18). Сразу оговорюсь,что закрытие месяца проведено до февраль 2018г., т.е.рабочий документ по Ф1 и С1 от 01.01.2018 находится в закрытом периоде, а по Ф2/C2 нет. Еще док Ф1/C1 проводился в более ранней версии УТ 11.4.
Вопросы:
1.Почему не отображается и не влияет на остатки документ проведенный Оприходование излишков товаров
2.Какие регистры он должен двинуть, чтобы остатки изменились?
Заранее благодарен за ответ.
Ответ: В настройках скалда не стоит "Использовать ордерную схему" при отражении излишков \ недостач?
Вопрос: Вывод остатков по складам в номенклатуре

Немного доработал динамический список: добавил в него остатки по всем складам,
Теперь стоит задача добавить остатки по каждому складу в отдельности
Общие остатки по складам беру через СвободныеОстаткиОстатки.ВНаличииОстаток
остатки по каждому складу (чтобы не путаться) начал делать через ТоварыНаСкладахОстатки.ВНаличииОстаток
В таком запросе есть два абсолютно одинаковых столбца.
Помогите доработать запрос чтобы ТоварыНаСкладахОстатки.ВНаличииОстаток выводилось только по складу "Склад_1"

ВЫБРАТЬ

СпрНоменклатура.Ссылка КАК Ссылка,
СпрНоменклатура.Код КАК Код,
СпрНоменклатура.Наименование КАК Наименование,
СпрНоменклатура.Артикул КАК Артикул,
СпрНоменклатура.ВидНоменклатуры КАК ВидНоменклатуры,
СпрНоменклатура.ЕдиницаИзмерения КАК ЕдиницаИзмерения,
СпрНоменклатура.СтавкаНДС КАК СтавкаНДС,
СпрНоменклатура.Родитель,
ВЫБОР
КОГДА СпрНоменклатура.ЕстьТоварыДругогоКачества
ТОГДА 4 + ВЫБОР
КОГДА СпрНоменклатура.ПометкаУдаления
ТОГДА 1
ИНАЧЕ 0
КОНЕЦ + ВЫБОР
КОГДА СпрНоменклатура.ИспользованиеХарактеристик = ЗНАЧЕНИЕ(Перечисление.ВариантыИспользованияХарактеристикНоменклатуры.НеИспользовать)
ТОГДА 0
ИНАЧЕ 2
КОНЕЦ
ИНАЧЕ ВЫБОР
КОГДА СпрНоменклатура.ПометкаУдаления
ТОГДА 1
ИНАЧЕ 0
КОНЕЦ + ВЫБОР
КОГДА СпрНоменклатура.ИспользованиеХарактеристик = ЗНАЧЕНИЕ(Перечисление.ВариантыИспользованияХарактеристикНоменклатуры.НеИспользовать)
ТОГДА 0
ИНАЧЕ 2
КОНЕЦ
КОНЕЦ КАК ИндексКартинки,
СвободныеОстаткиОстатки.ВНаличииОстаток КАК Остаток,
СвободныеОстаткиОстатки.ВРезервеСоСкладаОстаток КАК Резерв,
СвободныеОстаткиОстатки.ВНаличииОстаток - СвободныеОстаткиОстатки.ВРезервеСоСкладаОстаток КАК Свободный_Остаток,
СпрНоменклатура.Производитель,
ТоварыНаСкладахОстатки.ВНаличииОстаток
ИЗ
Справочник.Номенклатура КАК СпрНоменклатура
ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.СвободныеОстатки.Остатки КАК СвободныеОстаткиОстатки
ПО (СвободныеОстаткиОстатки.Номенклатура = СпрНоменклатура.Ссылка)
ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.ТоварыНаСкладах.Остатки КАК ТоварыНаСкладахОстатки
ПО (ТоварыНаСкладахОстатки.Номенклатура = СпрНоменклатура.Ссылка)
ГДЕ
НЕ СпрНоменклатура.ЭтоГруппа
{ГДЕ
(СпрНоменклатура.Ссылка В
(ВЫБРАТЬ
Сегменты.Номенклатура
ИЗ
РегистрСведений.НоменклатураСегмента КАК Сегменты
ГДЕ
Сегменты.Сегмент = &СегментНоменклатуры))}
Ответ:
Думаю Вашу задачу можно решить другим путем. Советую ознакомится с бесплатным мастер-классом от Калинкина Сергея
"Вывод произвольных данных в списках без потерь производительности",
Вопрос: Как в 1с создать поле остатки на складе?

Как в 1с Предприятие создать в документах поле остатки на складе в табличной части?
Ответ: Точно также как я выше написал
Вопрос: УФ БП3 Типовой отчет Остатки товаров

Хочу модифицировать СКД-й отчет в Бухгалтерии 3.0. Модифицировал. Объединил через левое соединение с дополнительным регистром в котором хранится серийный номер номенклатуры. Запрос корректен(не выдает ошибок), но не идеален. Не выводит серийный номер.
"ВЫБРАТЬ
    ХозрасчетныйОстатки_КонОст.Счет КАК Счет,
    ХозрасчетныйОстатки_КонОст.Субконто1 КАК Номенклатура,
    ХозрасчетныйОстатки_КонОст.СуммаОстаток КАК Сумма,
    ХозрасчетныйОстатки_КонОст.КоличествоОстаток КАК Количество,
    ХозрасчетныйОстатки_КонОст.Субконто2 КАК Склад,
    ХозрасчетныйОстатки_КонОст.Организация КАК Организация,
    ХозрасчетныйОстатки_КонОст.Подразделение КАК Подразделение,
    СерийныеНомера.СерийныйНомер
{ВЫБРАТЬ
    Счет.*,
    Номенклатура.*,
    Сумма,
    Количество,
    Склад.*,
    Организация.*,
    Подразделение.*}
ИЗ
    РегистрБухгалтерии.Хозрасчетный.Остатки(&КонецПериода, Счет В (&СчетаУчетаСкладИНоменклатура) {(Счет).*}, &СубконтоНоменклатураИСклад, {(Организация).* КАК Организация, (Субконто1).* КАК Номенклатура, (Субконто2).* КАК Склад, (Подразделение).* КАК Подразделение}) КАК ХозрасчетныйОстатки_КонОст
        ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.СерийныеНомера КАК СерийныеНомера
        ПО ХозрасчетныйОстатки_КонОст.Субконто1 = СерийныеНомера.Номенклатура
{ГДЕ
    ХозрасчетныйОстатки_КонОст.СуммаОстаток КАК Сумма,
    ХозрасчетныйОстатки_КонОст.КоличествоОстаток КАК Количество}"
Ответ: Ну а в чем ошибка данного отчета СКД? Я ее не вижу.