Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: БП 3.0.66 (минимальная версия платформы): ошибка 30165249

БП 3.0

С версии БП 3.0.66.47, в описании указана минимальная версия платформы 8.3.12.1685.

На днях вышла очередная версия БП 3.0.66.53, у которой в описании указана такая же минимальная версия платформы 8.3.12.1685. Но в исправленных ошибках БП 3.0.66.53, цитата:
"Ошибка №30165249: В ридми указана неверная версия платформы 8.3.12.1529. Исправлена: Бухгалтерия предприятия версия 3.0.66.53"

Так какая теперь минимальная платформа? Пишут, что ошибка исправлена, но на самом деле это не так!
Ответ: () В tmplts в ReadMe.txt у 3_0_66_47 стоит не ниже 8.3.12.1529, на сайте уже не ниже 8.3.12.1685.
Вопрос: Отладка регламентной операции

Платформа 8.3.7.1790, Бухгалтерия п/п 3.0.43.32

Проблема - отладка пропускает любые точки останова, если проводится документ Регламентная операция. Скажем, есть у меня подписка на событие "ПередЗаписью" для РегистрБухгалтерииНаборЗаписей.Хозрасчетный - корректируются движения по определенным счетам.

Если поставить в обработчике события точку останова, то запись любых документов останавливается, перебрасывает в конфигуратор, все как положено. Кроме регламентной операции - как будто и нет точки останова, но при этом по сформированным проводкам видно, что событие сработало, движения откорректированы.

То же происходит, если поставить точку останова в модуле объекта самой регламентной операции.

Как это побороть?
Ответ:
О! Вот это помогло, только не "Клиенские и внешние соединения", а "Фоновые задания".
Там и правду в списке подключенных предметов отладки появляется фоновое задание, чтоп его.
Вопрос: Не работает отладка файловый вариант

Ситуация такова, что запущенный из конфигуратора клиент отлаживается хорошо, а вот если запустить в пользовательском режиме, а затем в конфигураторе выбрать это подключение в отладку, происходит непонятная для меня вещь:

1) ничего не отлаживается
2) точка останова меняет цвет с красной на серую.
Платформа 8.3.12.1440
Ставил 8.3.11.3133, ситуация не изменилась.

Кто-нибудь сталкивался?
Ответ: Заработало при отладке по http.
Без понятия, в чем дело.
Вопрос: Отладка регламентного задания

Здравствуйте, в базе в серверном варианте на неуправляемых формах на платформе 8.3 последнего релиза имеется регламентное задание. Подскажите, реально ли его отлаживать ? Точка останова в его функции не срабатывает. Как быть?
Ответ:
Нужно еще запустить сервер в режиме отладки.
Вопрос: Отладка внешней обработки 1С 8.3

Здравствуйте. Вчера написал внешнюю обработку и спокойно ставил точку останова и входил в нее в режиме отладки, сегодня уже не могу, при открытии внешней обработки, отладчик в нее не заходит... интересно почему такое может произойти? Кто нибудь подскажет? 1С серверная
Ответ: зайтив отладка-подключение. проверить что стоит галка "искать предметы отладки на удаленном компьютере", в "подключенные предметы отладки" добавить сеанс с сервера, ну и в предприятии в "сервис-параметры" на вкладке "системные" проверить галки
Вопрос: Отладка выполняется криво: Не заходит в процедуры, не выполняет действие "Идти до курсора"

При отладке нажимая F11, не проваливается в процедуру, хотя должна.


После нажатия F11 происходит вот это:


Поставил курсор, выбрал действие идти до курсора, и происходит вот это:


Подскажите, что за хурма?

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
&НаКлиенте
Процедура ВыполнитьЗапрос(Команда)
    ВыполнитьЗапросНаСервере();
КонецПроцедуры
 
&НаСервере
Процедура ВыполнитьЗапросНаСервере()
    // Вставить содержимое обработчика.         //{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
    
    Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |   Номенклатура.Код КАК Код,
        |   Номенклатура.Наименование КАК Наименование,
        |   Номенклатура.ЦенаПокупки КАК ЦенаПокупки,
        |   Номенклатура.ВидНоменклатуры КАК ВидНоменклатуры
        |ИЗ
        |   Справочник.Номенклатура КАК Номенклатура";
    
    РезультатЗапроса = Запрос.Выполнить();
    
    Выборка = РезультатЗапроса.Выбрать();
    
    Пока Выборка.Следующий() Цикл
        // Вставить обработку выборки ВыборкаДетальныеЗаписи
    КонецЦикла;
    
    //}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
    Таблица = РезультатЗапроса.Выгрузить();
 
КонецПроцедуры
Ответ:
Сообщение от Dethmontt
StudentBot, скорее всего отладка на сервере не включена

Добавлено через 34 секунды
как включить отладку на сервере, подскажет гугл
Спасибо!
Вопрос: отладка правил обмена 1с

Доброе времени суток, подскажите плс, как запустить отладку при загрузке данных??

обработка отладки запущена в конфигураторе и через конф. запускается 1С и уже в предприятии открывается файл V8Exchan82.epf для загрузки данных.
что не так я делаю?!
Ответ: Имею в виду отладил саму обработку загрузки, а не обработку для отладки алгоритмов
Вопрос: Сбивется фокус при отладке

При отладке сбивается фокус. Из конфигуратора перепрыгивает в предприятие. Нужно потом опять сделать активным конфигуратор чтоб опять шагать в отладке. Это такой на Windows Server 2008. В чем может быть причина?
Ответ:
Ошибочка вышла. Действительно F10 также как и F11 не правильно шагает по отладке.
Вопрос: ПЛАТФОРМА 1С для обучения. (БЕСПЛАТНО!)

Теперь платформа для обучения бесплатно!

http://online.1c.ru/catalog/free/18610155/

Учебная версия платформы 1С:Предприятия 8.3 – это реально действующая платформа 1С:Предприятия 8 со следующими ограничениями:
  • не может использоваться на предприятии для ведения реального учета пользователями;
  • не может использоваться для сборки дистрибутивов мобильных приложений, предназначенных для дальнейшей публикации и тиражирования;
  • ограничено количество данных:
  • максимальное количество записей в таблицах счетов – 2000;
  • максимальное количество записей в главных таблицах объектов – 2000;
  • количество записей в табличных частях объектов – 1000;
  • количество записей в наборах записей – 2000;
  • количество записей из внешних источников данных – 200;
  • не поддерживается работа в варианте клиент-сервер;
  • не поддерживается работа распределенных информационных баз;
  • не поддерживается COM-соединение;
  • отсутствует возможность использования паролей и аутентификации операционной системы для пользователей;
  • печать и сохранение табличных документов поддерживаются только в режиме «Конфигуратор»;
  • не поддерживается копирование содержимого более чем одной ячейки табличного документа в режиме 1С:Предприятие;
  • не поддерживается работа с хранилищем конфигурации;
  • недоступна функциональность, связанная с поставкой конфигурации;
  • количество одновременных сеансов работы с информационной базой ограничено одним сеансом;
  • значения разделителей задаются значениями по умолчанию для данного типа разделителя.


Для работы учебной версии платформы 1С:Предприятия не требуется программная лицензия или ключ аппаратной защиты.
Архив также содержит мобильную платформу 1С:Предприятия 8, предназначенную для разработки мобильных приложений.
Ответ: Платформа 8.3
Скачивание бесплатное, но после регистрации. Ссылка на платформу http://1c-dn.com/developer_tools/1c_...ining_version/"
Вопрос: Рекомендация обновить версию платформы 1С:Предприятия

Всем доброго времени суток.

При обновлении типовых версий УТП и УПП (Украина), выводится уведомление "Рекомендуется обновить версию платформы 1С:Предприятие". "Текущая версия платформы нерекомендуема..." и т.д.
Текущая версия платформы у нас на предприятии: 8.2.19.102, 8.2.19.130
Новые релизы конфигураций просят версию платформы 1С:Предприятие 8 не ниже 8.3.6.2299.

Подскажите компетентно, кто знает\пробовал, насколько рекомендация обязательна, и насколько безошибочно можно работать далее без перехода на новую платформу?

Я понимаю, что рано или поздно, переход осуществить придется. Но хотелось бы попозже, т.к. на заводе у нас много пользователей и оборудования, и всё оборудование и сервера отлажены, работают (тьфу-тьфу-тьфу =) на нынешней конфигурации ПО.Тем более сроки сейчас оказываются ограничены - 1 апреля новый релиз должен уже работать, т.к. в нем необходимые изменения вступают в силу.
Ответ:
По хорошему - посмотреть (или почитать описание обновления) - какой блок требует 8.3. (если предупреждать начало не сейчас а ранее, то естественно читать описания к предыдущим релизам конфигурации). Если данный блок не используется на предприятии - то обновляться не стоит.
(можно также попробовать написать в поддержку с просьбой конкретизировать, какие именно изменения в новом релизе требуют установки платформы 8.3, но тут неизвестно когда ответят и что ответят).

В общем без необходимости смысла обновлять релиз платформы не вижу.