Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: Проявляется файл обмена РИБ с одними и реквизитами файла

Приветствую, Форумчане!

Был налажен обмен между базами РИБ. Все работало нормально. Отсутствовала связь несколько дней.
Возобновил обмен данными. Обмен пошел, но...

Непонятно почему вдруг откуда не возьмись появляется файл обмена от Филиала:

Message_SY_CO (31.05.2017 18:58) 17 кб

И так в течении всего дня, причем с именно такими реквизитами файла (имя, дата, размер).

На филиале обмен настроен на событие при появлении файла от центра.
Переименовываю или удаляю этот файл. Никакого обмена от Центра не посылаю, но файл с завидной постоянностью появляется...

Как такое может быть??? Что могла случится. Я бы может быть понял, что сбой пошел после прерывания связи, но связь нарушилась 12.06, ну никак не 31 мая, в мае все работало нормально...
Ответ:
Zerro
по чему обмен идет? фтп или почта?


Файловый обмен

Как оказалось, после сбоя в Центре и Филиале остались зарегистрированные для обмена данные..., хотя данные были перенесены...

После зачистки регистрации автообмен заработал нормально
Вопрос: КД Ошибка формата файла обмена при загрузке данных 8.3 ОП -> 8.3 УФ

Вопрос: Почему не принимает данные, сформированные в настройке обмена (но при этом принимает если данные сформировать обработкой обмена)?
Создал правила выгрузки одного элементарного справочника из УТ 10.3.16.1 (обычное приложение, платформа 8.2.19.102) в Самописную (управляемое приложение, платформа 8.3.6.2152)
Настроил в УТ узлы и планы обмена, сделал настройку обмена данными и выгрузил. В файл данных вошло два элемента справочника.
Привожу содержание "ошибочного" XML:
<?xml version="1.0" encoding="UTF-8"?>
<ФайлОбмена ВерсияФормата="2.0" ДатаВыгрузки="2015-09-30T09:03:50" ИмяКонфигурацииИсточника="УправлениеТорговлей" ИмяКонфигурацииПриемника="Конфигурация" ИдПравилКонвертации="fc7e8361-6fbe-42bb-90d4-6ee69b6c1794" Комментарий="">
<ПравилаОбмена>
    <ВерсияФормата>2.01</ВерсияФормата>
    <Ид>fc7e8361-6fbe-42bb-90d4-6ee69b6c1794</Ид>
    <Наименование>СервисДляCRM --&gt; CRM</Наименование>
    <ДатаВремяСоздания>2015-09-28T12:18:38</ДатаВремяСоздания>
    <Источник>УправлениеТорговлей</Источник>
    <Приемник>Конфигурация</Приемник>
    <Параметры/>
    <Обработки/>
    <ПравилаКонвертацииОбъектов>
        <Правило>
            <Код>Направления</Код>
            <Источник>СправочникСсылка.Айсберг_Направления</Источник>
            <Приемник>СправочникСсылка.Направления</Приемник>
        </Правило>
    </ПравилаКонвертацииОбъектов>
    <ПравилаОчисткиДанных/>
    <Алгоритмы/>
    <Запросы/>
</ПравилаОбмена>
<ИнформацияОТипахДанных>
    <ТипДанных Имя="СправочникСсылка.Направления">
        <Код>Строка</Код>
        <ПометкаУдаления>Булево</ПометкаУдаления>
        <Наименование>Строка</Наименование>
        <Родитель>СправочникСсылка.Направления</Родитель>
        <ЭтоГруппа>Булево</ЭтоГруппа>
    </ТипДанных>
</ИнформацияОТипахДанных>
<ДанныеПоОбмену ПланОбмена="МоскваCRM" Кому="CRM" ОтКого="Москва" НомерИсходящегоСообщения="5" НомерВходящегоСообщения="0"/>
<ДанныеПоФоновомуОбмену ПланОбмена="" Кому="0" ОтКого="0" ДобавлениеОбъектовИзФоновогоОбмена="0" КоличествоОбъектовДляФоновогоОбмена="500" ПереданоОбъектовФоновогоОбмена="0"/>
<Объект Нпп="1" Тип="СправочникСсылка.Направления" ИмяПравила="Направления"><Ссылка Нпп="1">
    <Свойство Имя="{КлючПоискаВИБИсточнике}">
        <Значение>{"#",0bd0deec-1479-4cdf-ae4b-f10e71f3205a,111:9ed000248cc4a20411e26f88824de171}</Значение>
    </Свойство>
    <Свойство Имя="{ИмяТипаВИБИсточнике}">
        <Значение>СправочникСсылка.Айсберг_Направления</Значение>
    </Свойство>
    <Свойство Имя="{ИмяТипаВИБПриемнике}">
        <Значение>СправочникСсылка.Направления</Значение>
    </Свойство>
    <Свойство Имя="Код">
        <Значение>000000013</Значение>
    </Свойство>
</Ссылка>
    <Свойство Имя="Наименование">
        <Значение>СВЧ</Значение>
    </Свойство>
    <Свойство Имя="ПометкаУдаления">
        <Значение>false</Значение>
    </Свойство>
    <Свойство Имя="Родитель"/>
    <Свойство Имя="ЭтоГруппа">
        <Значение>false</Значение>
    </Свойство>
</Объект>
<Объект Нпп="2" Тип="СправочникСсылка.Направления" ИмяПравила="Направления"><Ссылка Нпп="2">
    <Свойство Имя="{КлючПоискаВИБИсточнике}">
        <Значение>{"#",0bd0deec-1479-4cdf-ae4b-f10e71f3205a,111:9ed000248cc4a20411e26f88824de173}</Значение>
    </Свойство>
    <Свойство Имя="{ИмяТипаВИБИсточнике}">
        <Значение>СправочникСсылка.Айсберг_Направления</Значение>
    </Свойство>
    <Свойство Имя="{ИмяТипаВИБПриемнике}">
        <Значение>СправочникСсылка.Направления</Значение>
    </Свойство>
    <Свойство Имя="Код">
        <Значение>000000014</Значение>
    </Свойство>
</Ссылка>
    <Свойство Имя="Наименование">
        <Значение>СМ</Значение>
    </Свойство>
    <Свойство Имя="ПометкаУдаления">
        <Значение>false</Значение>
    </Свойство>
    <Свойство Имя="Родитель"/>
    <Свойство Имя="ЭтоГруппа">
        <Значение>false</Значение>
    </Свойство>
</Объект>
</ФайлОбмена>
Для загрузки использую обработку из поставки КД 2.1.8.2: V8Exchan83.epf в режиме работы На сервере.
Получаю ошибки:
Ошибка формата файла обмена
    ИмяУзла                =  ДанныеПоОбмену
...

Ошибка при загрузке данных: {ВнешняяОбработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(5256)}: Ошибка при вызове метода контекста (Выполнить): {(1, 68)}: Синтаксическая ошибка "="
ВЫБРАТЬ Ссылка ИЗ Справочник.Направления ГДЕ {ИмяТипаВИБИсточнике} <<?>>= &{ИмяТипаВИБИсточнике} И Код = &Код И {ИмяТипаВИБПриемнике} = &{ИмяТипаВИБПриемнике} И {КлючПоискаВИБИсточнике} = &{КлючПоискаВИБИсточнике}
...

Загружено объектов: 0
(см. фото)

НО! это при выгрузке из УТ через настройку обмена. Ошибка исчезает если выгружать данные обработкой из поставки КД: V8Exchan82.epf (82 не смотря на то что платформа 83, т.к. в режиме Обычного приложения).
Привожу содержание "правильного" XML:
<?xml version="1.0" encoding="UTF-8"?>
<ФайлОбмена ВерсияФормата="2.0" ДатаВыгрузки="2015-09-30T09:26:42" НачалоПериодаВыгрузки="0001-01-01T00:00:00" ОкончаниеПериодаВыгрузки="0001-01-01T00:00:00" ИмяКонфигурацииИсточника="УправлениеТорговлей" ИмяКонфигурацииПриемника="Конфигурация" ИдПравилКонвертации="fc7e8361-6fbe-42bb-90d4-6ee69b6c1794" Комментарий="">
<ПравилаОбмена>
    <ВерсияФормата>2.01</ВерсияФормата>
    <Ид>fc7e8361-6fbe-42bb-90d4-6ee69b6c1794</Ид>
    <Наименование>СервисДляCRM --&gt; CRM</Наименование>
    <ДатаВремяСоздания>2015-09-28T12:18:38</ДатаВремяСоздания>
    <Источник>УправлениеТорговлей</Источник>
    <Приемник>Конфигурация</Приемник>
    <Параметры/>
    <Обработки/>
    <ПравилаКонвертацииОбъектов>
        <Правило>
            <Код>Направления</Код>
            <Источник>СправочникСсылка.Айсберг_Направления</Источник>
            <Приемник>СправочникСсылка.Направления</Приемник>
        </Правило>
    </ПравилаКонвертацииОбъектов>
    <ПравилаОчисткиДанных/>
    <Алгоритмы/>
    <Запросы/>
</ПравилаОбмена>
<Объект Нпп="1" Тип="СправочникСсылка.Направления" ИмяПравила="Направления"><Ссылка Нпп="1">
    <Свойство Имя="Код" Тип="Строка">
        <Значение>000000013</Значение>
    </Свойство>
</Ссылка>
    <Свойство Имя="Наименование" Тип="Строка">
        <Значение>СВЧ</Значение>
    </Свойство>
    <Свойство Имя="ПометкаУдаления" Тип="Булево">
        <Значение>false</Значение>
    </Свойство><Свойство Имя="Родитель" Тип="СправочникСсылка.Направления">
    <Пусто/>
</Свойство>
    <Свойство Имя="ЭтоГруппа" Тип="Булево">
        <Значение>false</Значение>
    </Свойство>
</Объект>
<Объект Нпп="2" Тип="СправочникСсылка.Направления" ИмяПравила="Направления"><Ссылка Нпп="2">
    <Свойство Имя="Код" Тип="Строка">
        <Значение>000000014</Значение>
    </Свойство>
</Ссылка>
    <Свойство Имя="Наименование" Тип="Строка">
        <Значение>СМ</Значение>
    </Свойство>
    <Свойство Имя="ПометкаУдаления" Тип="Булево">
        <Значение>false</Значение>
    </Свойство><Свойство Имя="Родитель" Тип="СправочникСсылка.Направления">
    <Пусто/>
</Свойство>
    <Свойство Имя="ЭтоГруппа" Тип="Булево">
        <Значение>false</Значение>
    </Свойство>
</Объект>
</ФайлОбмена>
И еще в Управляемом приложении не позволяет сформировать модуль отладки загрузки. При нажатии на любую из указанных кнопок ничего не происходит (см. фото)
Ответ: у тебя просто древние релизы конфигураций, в них встроенная обработка универсального обмена старой версии.
Вопрос: 1C розница вылетает с дампом при обмене с ккм офлайн

При этом заметил что сам файл обмена весит аж 200 метров
Касса Атол. 1С розница 2.1

При этом напонятно каким образом до этого та же ошибка была(файл был за все года работы) но потом файл обмена с 1С 1pos.rep сам стал небольшим. Хочу понять изначальную причину почему так. Может ктонить подскажет кто сталкивался уже?
Ответ:
dartlex
просто я имел ввиду файл обмена тот который по моему с кассы приходит. То есть .rep в котором все продажи. Может копать в сторону оборудования кассового?

ага..посмотри настройки кассы - сколько там хранится и за сколько выгружается
Вопрос: Планы обмена-механизм регистрации изменений

М.Г.Радченко - 1С Предприятие 8.1. Практическое пособие разработчика
Универсальный механизм обмена данными


Я переделал так, чтобы Центральная база только отсылала сообщения (Процедура ЗаписатьСообщениеСИзменениями()), а Филиал мог только читать (Процедура ПрочитатьСообщениеСИзменениями()). Обе процедуры расположены в модуле объекта План обмена.


Обмен запускаяется вручную из обработки. В модуле объекта обработки определена процедура:

Код:
 Процедура ОбменСФилиалами() Экспорт

ВыборкаУзлов = ПланыОбмена.Филиалы.Выбрать();

Пока ВыборкаУзлов.Следующий() Цикл

// Произвести обмен данными со всеми узлами,
// кроме текущего (ЭтотУзел)
Если ВыборкаУзлов.Ссылка <> ПланыОбмена.Филиалы.ЭтотУзел() Тогда
УзелОбъект = ВыборкаУзлов.ПолучитьОбъект();

// Получить сообщение
УзелОбъект.ПрочитатьСообщениеСИзменениями();

// Сформировать сообщение
УзелОбъект.ЗаписатьСообщениеСИзменениями();

КонецЕсли;

КонецЦикла;


КонецПроцедуры

У Плана обмена определена Форма Узла в которой расположены следующие обработки событий:

Код:
 Перем РегистрацияВНовыйУзел;


Процедура ПередЗаписью(Отказ)
РегистрацияВНовыйУзел=ЭтоНовый();
КонецПроцедуры

Процедура ПриЗаписи(Отказ)
Если РегистрацияВНовыйУзел Тогда
ПланыОбмена.ЗарегистрироватьИзменения(Ссылка);
КонецЕсли;
КонецПроцедуры

Модуль объекта План Обмена Центральная база:

Код:
 Процедура ЗаписатьСообщениеСИзменениями() Экспорт

Сообщить("-------- Выгрузка в узел " + Строка(ЭтотОбъект) + " ------------");
Каталог = КаталогВременныхФайлов();
// Сформировать имя временного файла
ИмяФайла = Каталог +?(Прав(Каталог, 1) = "\","", "\") + "Message"+   СокрЛП(ПланыОбмена.Филиалы.ЭтотУзел().Код)+ "_" + 
СокрЛП(Ссылка.Код) + ".xml";


// Создать объект записи XML
// *** Запись XML-документов
ЗаписьXML = Новый ЗаписьXML;
ЗаписьXML.ОткрытьФайл(ИмяФайла);
ЗаписьXML.ЗаписатьОбъявлениеXML();

// *** Инфраструктура сообщений
ЗаписьСообщения = ПланыОбмена.СоздатьЗаписьСообщения();
ЗаписьСообщения.НачатьЗапись(ЗаписьXML, Ссылка);
Сообщить("    Номер сообщения: " + ЗаписьСообщения.НомерСообщения);

// Получить выборку измененных данных
// *** Механизм регистрации изменений
ВыборкаИзменений = ПланыОбмена.ВыбратьИзменения(ЗаписьСообщения.Получатель, ЗаписьСообщения.НомерСообщения);
Пока ВыборкаИзменений.Следующий() Цикл
// Записать данные в сообщение
// *** XML-сериализация
ЗаписатьXML(ЗаписьXML, ВыборкаИзменений.Получить());
КонецЦикла;

ЗаписьСообщения.ЗакончитьЗапись();

ЗаписьXML.Закрыть();

Сообщить("-------- Конец выгрузки------------");

КонецПроцедуры 

Модуль объекта План Обмена База филиал:

Код:
Процедура ПрочитатьСообщениеСИзменениями() Экспорт

Каталог = КаталогВременныхФайлов();

// Сформировать имя файла
ИмяФайла = Каталог + ?(Прав(Каталог, 1) = "\", "", "\") + "Message" + СокрЛП(Ссылка.Код) + "_" + СокрЛП(ПланыОбмена.Филиалы.ЭтотУзел().Код) + ".xml";
Файл = Новый Файл(ИмяФайла);
Если Не Файл.Существует() Тогда
Сообщить("Файла нет!");
Возврат;
КонецЕсли;

// *** Чтение документов XML	
// Попытаться открыть файл
ЧтениеXML = Новый ЧтениеXML;
Попытка 
ЧтениеXML.ОткрытьФайл(ИмяФайла);
Исключение 
Сообщить("Невозможно открыть файл обмена данными.");
Возврат;
КонецПопытки;
Сообщить("-------- Загрузка из " + Строка(ЭтотОбъект) + "------------");
Сообщить(" - Считывается файл " + ИмяФайла);

// Загрузить из найденного файла
// *** Инфраструктура сообщений
ЧтениеСообщения = ПланыОбмена.СоздатьЧтениеСообщения();

// Читать заголовок сообщения обмена данными - файла XML
ЧтениеСообщения.НачатьЧтение(ЧтениеXML);

// Сообщение предназначено не для этого узла
Если ЧтениеСообщения.Отправитель <> Ссылка Тогда
ВызватьИсключение "Неверный узел";
КонецЕсли;

// Удаляем регистрацию изменений
// для узла отправителя сообщения.
// *** Служба регистрации изменений
ПланыОбмена.УдалитьРегистрациюИзменений(ЧтениеСообщения.Отправитель,ЧтениеСообщения.НомерПринятого);

// Читаем данные из сообщения
// *** XML-сериализация
Пока ВозможностьЧтенияXML(ЧтениеXML) Цикл
// Читаем очередное значение
Данные = ПрочитатьXML(ЧтениеXML);

// Не переносим изменение, полученное
// в главный из неглавного,
// если есть регистрация изменения
Если Не ЧтениеСообщения.Отправитель.Главный    тогда
// ПланыОбмена.ИзменениеЗарегистрировано(ЧтениеСообщения.Отправитель, Данные) Тогда
Сообщить("- Изменения отклонены от"+" "+Строка(ЧтениеСообщения.Отправитель));
Продолжить;
КонецЕсли;

// Записать полученные данные
Данные.ОбменДанными.Отправитель = ЧтениеСообщения.Отправитель;
Данные.ОбменДанными.Загрузка = Истина;
Данные.Записать();
КонецЦикла;

ЧтениеСообщения.ЗакончитьЧтение();
ЧтениеXML.Закрыть();
УдалитьФайлы(ИмяФайла);
Сообщить("-------- Конец загрузки------------");

КонецПроцедуры



Проблема заключается в том, что Центральная база каждый раз формирует изменения ВСЕХ объектов, которые определены в составе Плана обмена. В файле xml видно, что передаются все данные.
Насколько я понимаю, при создании нового узла в первом сообщении передается вся инфа. Последующие сообщения содержат уже те объекты, которые были изменены в Цетральной. Если объекты не изменялись, то сообщение от Центральной "пустое".

Я не понимаю, как работает механизм регистрации изменений. Я подозреваю, что в Центральной базе надо определить:
Код:
ПланыОбмена.УдалитьРегистрациюИзменений(ЧтениеСообщения.Отправитель,ЧтениеСообщения.НомерПринятого);
. Но у меня Центральная не принимает сообщения вообще.
Объясните, как система узнает, когда оправить все данные, а когда только измененные?
Ответ:
Может кто откликнется ! очень нужна помощь! делаю план обмена, по этому же примеру. даже код этот же самый.
столкнулся с проблемой:
выгрузка документов из двух баз. загрузка в Итоговую базу. но реквизит За!гружаемых документов "Организация" заменяется наименованием единым,из Итоговой базы. в итоге в едином журнале документов все доки под Одной единственной огранизацией.
Где можно это настроить/поправить ? может я что -то не то делаю, но обмен штатными средствами, и настроек никаких нет .... помогите пожалуйста!
Вопрос: Обмен данными

Здравствуйте.
Написала с помощью Конвертации данных правила обмена. При выгрузке из конфигурации Бухгалтерия государственного учреждения, редакция 1.0 (1.0.52.6) зарегистрированного документа Кассовое поступление в файле обмена появляется такая запись:

<ДанныеПоОбмену ПланОбмена="УИ_ЮИ" Кому="002" ОтКого="001" НомерИсходящегоСообщения="1666" НомерВходящегоСообщения="815" УдалитьРегистрациюИзменений="true" ВерсияОтправителя="1.0.52.6" /> 
  <УдалениеОбъекта СсылкаНаОбъект="{"#",02489a01-2b52-4e2c-a070-32329054c5f6,209:bc27001b11794f6c11e88af2913f2e84}" /> 


т.е. выгрузки дока не происходит. 
Прочитала, что такое может быть потому что что-то не так с правилами регистрации.

В конфигураторе в макете "ПравилаРегистрации" этот док есть.
В Регистре сведений "Правила для обмена данными" записи по моему плану встали.
Вот правила регистрации

ПравилаРегистрации>
    <ВерсияФормата>2.01</ВерсияФормата>
    <Ид>88dc7576-8722-11e8-9447-0030849e770a</Ид>
    <Наименование>ЮИ: У и ЮИ</Наименование>
    <ДатаВремяСоздания>2018-07-19T21:42:35</ДатаВремяСоздания>
    <ПланОбмена Имя="УИ_ЮИ">ПланОбменаСсылка.УИ_ЮИ</ПланОбмена>
    <Конфигурация ВерсияПлатформы="8.2" ВерсияКонфигурации="1.0.52.6" СинонимКонфигурации="Бухгалтерия государственного учреждения, редакция 1.0">БухгалтерияГосударственногоУчреждения</Конфигурация>
    <СоставПланаОбмена>
        <Элемент>
            <Тип>СправочникСсылка.Договоры</Тип>
            <Авторегистрация>false</Авторегистрация>
        </Элемент>
        <Элемент>
            <Тип>СправочникСсылка.Контрагенты</Тип>
            <Авторегистрация>false</Авторегистрация>
        </Элемент>
        <Элемент>
            <Тип>ДокументСсылка.ЗаявкаНаВозврат</Тип>
            <Авторегистрация>false</Авторегистрация>
        </Элемент>
        <Элемент>
            <Тип>ДокументСсылка.КассовоеПоступление</Тип>
            <Авторегистрация>false</Авторегистрация>
        </Элемент>
        <Элемент>
            <Тип>РегистрСведенийЗапись.СоответствиеОбъектовДляОбмена</Тип>
            <Авторегистрация>false</Авторегистрация>
        </Элемент>
    </СоставПланаОбмена>
    <ПравилаРегистрацииОбъектов>
        <Группа Отключить="false">
            <Код>000000002</Код>
            <Наименование>Документы</Наименование>
            <ТипГруппы>Документ</ТипГруппы>
            <Правило Отключить="false" Валидное="true">
                <Код>000000001</Код>
                <Наименование>Кассовое поступление</Наименование>
                <ОбъектНастройки>ДокументСсылка.КассовоеПоступление</ОбъектНастройки>
                <ОбъектМетаданныхИмя>Документ.КассовоеПоступление</ОбъектМетаданныхИмя>
                <ОбъектМетаданныхТип>Документ</ОбъектМетаданныхТип>
                <ОтборПоСвойствамПланаОбмена/>
                <ОтборПоСвойствамОбъекта/>
            </Правило>
            <Правило Отключить="false" Валидное="true">
                <Код>000000008</Код>
                <Наименование>Заявка на возврат</Наименование>
                <ОбъектНастройки>ДокументСсылка.ЗаявкаНаВозврат</ОбъектНастройки>
                <ОбъектМетаданныхИмя>Документ.ЗаявкаНаВозврат</ОбъектМетаданныхИмя>
                <ОбъектМетаданныхТип>Документ</ОбъектМетаданныхТип>
                <ОтборПоСвойствамПланаОбмена/>
                <ОтборПоСвойствамОбъекта/>
            </Правило>
        </Группа>
        <Группа Отключить="false">
            <Код>000000004</Код>
            <Наименование>Справочники</Наименование>
            <ТипГруппы>Справочник</ТипГруппы>
            <Правило Отключить="true" Валидное="true">
                <Код>000000003</Код>
                <Наименование>Договоры и иные основания возникновения обязательств</Наименование>
                <ОбъектНастройки>СправочникСсылка.Договоры</ОбъектНастройки>
                <ОбъектМетаданныхИмя>Справочник.Договоры</ОбъектМетаданныхИмя>
                <ОбъектМетаданныхТип>Справочник</ОбъектМетаданныхТип>
                <ОтборПоСвойствамПланаОбмена/>
                <ОтборПоСвойствамОбъекта/>
            </Правило>
            <Правило Отключить="true" Валидное="true">
                <Код>000000005</Код>
                <Наименование>Контрагенты</Наименование>
                <ОбъектНастройки>СправочникСсылка.Контрагенты</ОбъектНастройки>
                <ОбъектМетаданныхИмя>Справочник.Контрагенты</ОбъектМетаданныхИмя>
                <ОбъектМетаданныхТип>Справочник</ОбъектМетаданныхТип>
                <ОтборПоСвойствамПланаОбмена/>
                <ОтборПоСвойствамОбъекта/>
            </Правило>
        </Группа>
        <Группа Отключить="false">
            <Код>000000007</Код>
            <Наименование>Регистры сведений</Наименование>
            <ТипГруппы>РегистрСведений</ТипГруппы>
            <Правило Отключить="false" Валидное="true">
                <Код>000000006</Код>
                <Наименование>Соответствие объектов для обмена</Наименование>
                <ОбъектНастройки>РегистрСведенийЗапись.СоответствиеОбъектовДляОбмена</ОбъектНастройки>
                <ОбъектМетаданныхИмя>РегистрСведений.СоответствиеОбъектовДляОбмена</ОбъектМетаданныхИмя>
                <ОбъектМетаданныхТип>РегистрСведений</ОбъектМетаданныхТип>
                <ОтборПоСвойствамПланаОбмена/>
                <ОтборПоСвойствамОбъекта/>
            </Правило>
        </Группа>
    </ПравилаРегистрацииОбъектов>
</ПравилаРегистрации>


Почему док не выгружается нормально, а метит на удаление?
Может кто сталкивался с подобной проблемой
Ответ:
ответ дали в 2011 году)



У меня была проблема в том, что мой новый план обмена не цеплялся и его вручную пришлось в массив дописывать
Вопрос: v7: Ошибки при обмене УРБД

Добрый день.

Имеем распределенку 40 ПБ. Автообмен реализован с помощью *.bat файлов запускающих 1С 77 в пакетном режиме. Эти файлы висят в планировщике заданий на сервере.

Есть проблема - при загрузке в ЦБ достаточно часто возникает ситуация:
20171102;05:56:17;Администратор;C;Distr;DistUplBeg;1;\\ПутьКБазе\Import\0111.zip;;
20171102;05:56:18;Администратор;C;Distr;DistUplFail;1;;; 

конфигуратор по каким то причинам просто не может загрузить файл. Если была бы ошибка на стороне 1С - то в лог записалось примерно следующее - 20171102;05:56:29;Администратор;C;Distr;DistUplErr;5;Данные из указанного файла переноса данных уже загружались в текущую информационную базу.;;
Если бы такого файла нее было или не было бы доступа к ресурсу, то ошибка бы выглядела примерно так - 20171102;06:13:26;Администратор;C;Distr;DistUplErr;5;Не могу открыть файл: \\ПутьКБазе\Import\0361.zip;;
Но в моем случае в лог файл описание ошибки не пишется вообще никакое, просто fail и все. При повторной загрузке файл может загрузиться, а может и нет. Иногда требуется от 2 до 4 попыток загрузки.
Не загруженные файлы и время всегда разное. Данные задания включали в планировщики на разных серверах, выделили специально отдельный сервер где кроме заданий автообмена нет больше никаких, однако ситуация изо дня в день повторяется.

может есть у кого-нибудь мысли как решить данную проблему?

p.s. повторная загрузка в планировщике есть, но и она не всегда решает данный вопрос. Приходится утром глазами анализировать лог и если что-то не загрузилось запускать файл обмена вручную
Ответ: () Там где "конфигуратор по каким то причинам просто не может загрузить файл" есть антивирус?
Вопрос: Обмен УТ10.3->БП20

Я чего то не понимаю.

Односторонний обмен.
Обмен проходит без ошибок. Но файлы зарегистрированные для обмена не удаляются.

Т.е. отправляемые данные только копятся.

Так и должно быть? И что делать?

Пока вручную удалил зарегистрированные документы что уже не нужны. Но справочник так же на 7к объектов
Ответ: () ну это такое себе, ничто мне тогда не мешает очистить в базе отправителе после загрузку в другую базу все зарегистрированные объекты

() Ну само собой я пару раз прогнал обмен. Никакой файл-ответ не создается. Только 1 файл в папке файлами обмена.

Сейчас это работает так - ставится дата в УТ начиная с которой документы переносятся.
Вопрос: Обмен торговля 10.3 бухгалтерия 3

Добрый день
стоит Бухгалтерия 3 и торговля 10.3 (10.3.32.1) у торговли есть одна распределенная база
С распределенной базой настроен обмен с бухгалтерией 3
Обновил бухгалтерию 3 на последний релиз, хочу в торговлю загрузить новые правила конвертации, он мне
{Обработка.КонвертацияОбъектовИнформационныхБаз.МодульОбъекта(3038)}: Поле объекта не обнаружено (ТоварыНесырьевые)
Возврат Менеджер[Значение];

Подумал может добавили, чего нового в бухгалтерию, обновил торговлю на 10.3.34.2 да и на любую выше пишет
Ошибка при вызове метода контекста (ПрочитатьИзменения): Ошибка преобразования данных XML: [sfile://C:/Users/Vladislav/AppData/Local/Temp/Message_r02_r01.xml][1671561,22]
и не хочет переносить изменения
Подскажите ,что делать ? , Конечно можно выгрузить заново базу , но это полетит обмен с бух и многое другое вообщем крайний случай да и не факт , что конечно дело в старой версии торговли

Вложения:

  • Размер файла:
    144,7 КБ
    Просмотров:
    1
  • Размер файла:
    143,1 КБ
    Просмотров:
    1
Ответ:
еще такая ошибка бывает это я на 10.3.32.2 с 10.3.32.1 на одну версию всего
Ошибка при чтении изменений из файла обмена.
Ошибка при вызове метода контекста (ПрочитатьИзменения): Конфигурация узла распределенной ИБ не соответствует ожидаемой!
Чтение данных из файла обмена завершено с ошибками!
Вопрос: Обмен БП - БП (РИБ)

Всем привет!

Есть: 2 базы, обе бухгалтерии ред. 2, в обеих базах ведется учет одной организации, дополнительная база не образ основной базы.

На данный момент базы необходимо объединить данные из дополнительно базы загрузить в основою базу. Погуглив подумал что подойдет технология обмена РИБ, настройки простые сделал все как в инструкции за исключением создания образа периферийной базы (в моем случае данная база называется дополнительной ). Просто в дополнительную базу занес настройки по принципу что это и есть Периферийная база.
Из дополнительной базы данные выгрузились без проблем все с этим хорошо, а вот загрузка не как не идет выдает ошибку:
Вот у меня вопрос: когда база не создана из образа основной базы а используется обычная база можно обмениваться по технологии РИБ?
Если да, то из за чего выходит данная ошибка?
Если нет, какие еще есть стандартные способы объединить базы?

PS Написал своими словами, надеюсь все понятно
Ответ:
Красота. А что же каждому сотруднику по копии не сделали ?
Вопрос: Обмен 1С УНФ 1.5.1.4 – Бухгалтерия 2.1.3.5

Всем удачи и счастья! Пытаюсь настроить обмен 1С УНФ для Беларуси 1.5.1.4 – Бухгалтерия для Беларуси 2.1.3.5.

Настройку начинаю из УНФ. Выбираю синхронизацию через файл обмена данными.
При выгрузке из УНФ происходит следующее:

– Без выгрузки документов. В назначенной папке успешно создаётся файл "Message_УФ_БП.xml" 32806КБ.

– С выгрузкой документов. Процесс выгрузки завершается ошибкой. В журнале регистрации следующая запись:
Обмен данными.ОбменУправлениеНебольшойФирмойБухгалтерия30.Узел БП.Отправка данных
{Обработка.КонвертацияОбъектовИнформационныхБаз.МодульОбъекта(1662)}: Ошибка при вызове метода контекста (ЗаполнитьЗначенияСвойств)
ЗаполнитьЗначенияСвойств(СвойстваДляПереноса, Источник);
по причине:
Недопустимое значение параметра (параметр номер '2')
Подскажите, как решить данную проблему (или настроить обмен другими методами).
Ответ:
Необходимо разобраться с причиной возникновения ошибки, т.е. нужны навыки программирования 1С и понимания чужого кода.
Настройками это не исправить.