Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: Печать счета на оплату с подписями

День добрый. Раньше в процедуру печати счета передавался параметр "СПечатью = Истина" для того, чтобы на макете отображались росписи и факсимиле. После обновления БП, в эту процедуру передается структура "ПараметрыПечати", что должно быть в этой структуре, чтобы отображалось при печати факсимиле и росписи?
Ответ: Сейчас подписи и печать отображается, если стоит галочка "Подписи и печать", не могу найти в коде, где это условие
Вопрос: v7: ТиС, задвоение строк при печати счета-фактуры

база "Торговля+склад" 9.2
Оптово-розничная конфигурация 7.70.935

При печати счетов-фактур с длинным списком товара при предварительном просмотре список отображается полностью, без всяких задвоений. При выводе на принтер на втором листе печатается первая строка из всего списка и далее не поместившиеся на первом листе товары. Принтер HP LasarJet Pro MFP M-125M.
Как можно это исправить?
Ответ: () () Спасибо! ПовторятьПриПечатиСтроки() помогло: сократила повтор на одну строку, работает нормально.
Вопрос: Печать счета в БП 3.0

Подскажите как программно распечатать без пред. просмотра счет на оплату в БП 3.0? Там макета нет. Если можно пример кода пожалуйста
Ответ:
ОбъектыПечати = Новый СписокЗначений;
        КоллекцияПечатныхФорм = СформироватьКоллекциюПечатныхФорм("СчетЗаказ");
        ТаблицаСведенийСчетНаОплату = ПолучитьТаблицуСведенийСчетаНаОплату(МассивСчетов);
        УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "СчетЗаказ", "Счет на оплату", 
        ПечатьТорговыхДокументов.ПечатьСчетаНаОплату(ТаблицаСведенийСчетНаОплату, ОбъектыПечати),,"ОбщийМакет.ПФ_MXL_СчетЗаказ");

Сделал так, но наверное есть короче метод
Вопрос: Разные печатные формы счет-фактур по одной кнопке.

Добрый день.
Подскажите пожалуйста где найти или как сделать чтобы автоматически только одна печатная форма выдавалась.
Обнаружил что при печати счет-фактуры выдает разные печатные формы.
1. с ИНН / КПП
2. ИНН, без КПП

Где найти откуда берется эта печатная форма.
ИНН / КПП заполнены у контагентов и до вопроса.
Обнаружил давно, не спрашивал.
Счет-фактуры на реализацию товаров, изделий, услуг.
В любом варианте может быть КПП, а может не быть.

1С:Предприятие 8.3 (8.3.5.1248)
Управление производственным предприятием, редакция 1.3 (1.3.63.1)

Ответ:
Вариант 1. Просто в сф нажмите на гиперссылку КПП и потом на кнопку ОК, потом должно выводиться в ПФ
Вариант 2. при создании нового контрагента открывается форма элемента и реквизит юрфизлицо визуально видно "Юрлицо". Далее форму заполнили и сохранили, оставив этот реквизит без изменения. Однако при попытке сделать запрос и прочитать этот реквизит оказалось, что реквизит пуст, хотя визуально виден в карточке! При печати счет фактеры обработка проверяет является ли указанный контрагент юр лицом или нет. В результате, не определив, что мой контрагент юрлицо - обработка значении КПП оставляла пустым. Достаточно оказалось зайти в карточку контрагента и перевыбрать реквизит ютлицо. КПП стало выходить в счет фактуре. Вот так. (Спасибо все за содействие.)
Вариант 3. Перевыбрать данные КПП в карточке контагента.

Мне вариант 2 и 3 не помог.
Вопрос: Какое имя внешней обработки вызываемой при печати Счет на оплату покупателей

У меня УТ 10.3.
Вот функция печати:
Функция НапечататьВнешнююФорму(Ссылка, ИсточникМакета) Экспорт
        
    //*****БП*****// добавлена Попытка

    Попытка
        
    
    ДвоичныеДанные = ИсточникМакета.СсылкаНаВнешнююОбработку.Принадлежность[ИсточникМакета.НомерСтроки - 1].ХранилищеВнешнейОбработки.Получить();
    Если ДвоичныеДанные = Неопределено Тогда
        ДвоичныеДанные = ИсточникМакета.СсылкаНаВнешнююОбработку.ХранилищеВнешнейОбработки.Получить();
    КонецЕсли;
    ДополнительныеПараметры = ИсточникМакета.СсылкаНаВнешнююОбработку.Принадлежность[ИсточникМакета.НомерСтроки - 1].ДополнительныеПараметрыОбработки.Получить();
    
    Исключение
        ДвоичныеДанные = Неопределено
    КонецПопытки;
    //*****БП*****//

    
    Если ДвоичныеДанные = Неопределено Тогда
        Возврат Неопределено;
    КонецЕсли;
    
    ТабДокумент = Неопределено;
    
    ИмяФайла = ПолучитьИмяВременногоФайла("epf");
    Попытка
        ДвоичныеДанные.Записать(ИмяФайла);
        Обработка = ВнешниеОбработки.Создать(ИмяФайла);
        Обработка.СсылкаНаОбъект = Ссылка;



Вопрос: какое имя открываемой обработки?
Ответ: () в справочнике внешних обработок смотри
Вопрос: Печать счёт-фактуры из впф 1С 8.2 УТ 10.3

Приветствую спецы 1С, нашёл в инете нужную мне тему
Но она сначала выводит список печатных форм, а мне надо чтобы сразу печатался документ счёт-фактура из впф.
Можете подсказать как исправить, либо у кого-то есть готовый пример, кто делал? Сам только начинающий в 1С.

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
перем СсылкаНаОбъект экспорт;
перем НаПРинтер экспорт;
перем КоличествоЭкземпляров экспорт;
 
функция Печать() экспорт
 
Запрос = новый запрос;
Запрос.Текст = "ВЫБРАТЬ
| СчетФактураВыданныйДокументыОснования.Ссылка.Ссылка
|ИЗ
| Документ.СчетФактураВыданный.ДокументыОснования КАК СчетФактураВыданныйДокументыОснования
|ГДЕ
| СчетФактураВыданныйДокументыОснования.ДокументОснование = &ДокументОснование";
Запрос.УстановитьПараметр("ДокументОснование",СсылкаНаОбъект);
Выборка = Запрос.Выполнить().Выбрать();
Если Выборка.Следующий() тогда
СФ = Выборка.Ссылка.ПолучитьОбъект();
СФФорма = СФ.ПолучитьФорму("ФормаДокумента");
 
 
СтруктураВнутреннихПечатныхФорм = СФ.ПолучитьСтруктуруПечатныхФорм();
ДеревоМакетовПечати = УниверсальныеМеханизмы.ПолучитьДеревоМакетовПечати(СФ.Ссылка, СтруктураВнутреннихПечатныхФорм);
Для каждого Строка Из ДеревоМакетовПечати.Строки Цикл
 
 
Если Строка.ТипКнопки = ТипКнопкиКоманднойПанели.Разделитель Тогда
 
Продолжить;
КонецЕсли;
Если Строка.Расшифровка = Неопределено Тогда
Продолжить;
КонецЕсли;
Если СокрЛП(Строка.Текст) = "Счет-фактура" тогда
УниверсальныеМеханизмы.ОткрытьФормуВыбораПечатныхФормОбъекта(СФ, СФФорма);
КонецЕсли;
КонецЦикла;
 
КонецЕсли;
КонецФункции
Добавлено через 3 часа 49 минут
Экспериментирую с кодом:

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
Запрос = новый запрос;
Запрос.Текст = "ВЫБРАТЬ
| СчетФактураВыданныйДокументыОснования.Ссылка.Ссылка
|ИЗ
| Документ.СчетФактураВыданный.ДокументыОснования КАК СчетФактураВыданныйДокументыОснования
|ГДЕ
| СчетФактураВыданныйДокументыОснования.ДокументОснование = &ДокументОснование";
Запрос.УстановитьПараметр("ДокументОснование",СсылкаНаОбъект);
Выборка = Запрос.Выполнить().Выбрать();
Если Выборка.Следующий() тогда
СФ = Выборка.Ссылка.ПолучитьОбъект();
СФФорма = СФ.ПолучитьФорму("ФормаДокумента");
 
                ДеревоМакетовПечати = УниверсальныеМеханизмы.ПолучитьДеревоМакетовПечати(СФ.Ссылка, Неопределено); 
                СтрМакета = ДеревоМакетовПечати.Строки.Найти("Счет-фактура","Текст"); 
                ТабДокумент = УниверсальныеМеханизмы.НапечататьВнешнююФорму(СФ, СФФорма);
КонецЕсли;
Возврат ТабДокумент;
Выдаёт ошибку:
Не удалось сформировать внешнюю печатную форму!
Поле объекта не обнаружено (СсылкаНаВнешнююОбработку)

Я так понимаю затык из-за этой строки
ТабДокумент = УниверсальныеМеханизмы.НапечататьВнешнююФорму(СФ, СФФорма);



Если делаю так:

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
Запрос = новый запрос;
Запрос.Текст = "ВЫБРАТЬ
| СчетФактураВыданныйДокументыОснования.Ссылка.Ссылка
|ИЗ
| Документ.СчетФактураВыданный.ДокументыОснования КАК СчетФактураВыданныйДокументыОснования
|ГДЕ
| СчетФактураВыданныйДокументыОснования.ДокументОснование = &ДокументОснование";
Запрос.УстановитьПараметр("ДокументОснование",СсылкаНаОбъект);
Выборка = Запрос.Выполнить().Выбрать();
Если Выборка.Следующий() тогда
СФ = Выборка.Ссылка.ПолучитьОбъект();
СФФорма = СФ.ПолучитьФорму("ФормаДокумента");
 
                ДеревоМакетовПечати = УниверсальныеМеханизмы.ПолучитьДеревоМакетовПечати(СФ.Ссылка, Неопределено); 
                СтрМакета = ДеревоМакетовПечати.Строки.Найти("Счет-фактура","Текст"); 
                УниверсальныеМеханизмы.НапечататьДокумент(СФ, СФФорма);
                КонецЕсли;
То ошибка:
Не удалось сформировать внешнюю печатную форму!
Операции сравнения на больше-меньше допустимы только для значений совпадающих примитивных типов (Булево, Число, Строка, Дата)

Что делаю не так?
Ответ: И ваще, я не очень понимаю, зачем вам нужны вызовы 2 одинаковых печатных форм??? а вот если у вас изменения в стандартной форме, то у вас ваще не очень код
Вопрос: упп печать счета-фактуры выданного

Здравствуйте.
Подскажите а где в упп процедура печати сета фактуры выданного.
Обработчиком прошел модуль документа и менеджера ничего не отрабатывает ?
Ответ:
Без дебага. Все оттуда должно браться как написали выше
Вопрос: разные формы счета на оплату для 2-х орг в 1 базе

Доброго времени суток, форумчане!

Объясните, пожалуйста, можно ли не обладая опытом в программировании и никаким опытом в администрировании 1С8.3 БП3.0 без внешних обработок сделать 2 разных печатных макета для 2-х разных организаций в одной базе. Может я не верно вбиваю в поисковиках свой вопрос, потому как и поГуглил, и проЯндексировал, но ничего конкретного не нашел. Будьте добры, помогите советом - где галочку поставить)))) Обнаружилось как: у одной организации в базе уже был изменен печатный макет(вставлены лого и подписи с печатями - вставлены именно через подменю печать/счет на оплату/еще/изменить форму). А вторую недавно завели в этой же базе(дабы не заморачиваться с двумя). И вот дошло дело до печати счета со второй орг, а он печатается со всеми изменениями внесенными в форму. Как разделить то?
Ответ: () Есть конфигурация поставщика, т.е. в конфигурации хранятся все типовые объекты
Вопрос: Не изменяется факсимиле подписи и печати

Здравствуйте.
Сломал уже всю голову, а решить проблему не могу.
Бухгалтерия предприятия 3.0.43.240, платформа 8.3.9.1818.

Суть проблемы.
Сменился директор и главбух, назначили новых. Отсканировал, как предлагает сама 1с, подписи. В сведениях организации поменял, проверил. Все отлично.
Ответственное лицо сменил на новых директора и бухгалтера. Вроде бы все должно работать. А вот и нет.
В новой реализации (услуге), при печати "Акт с комментарием и с печатью", в подписях фамилии стоят правильные, а вот факсимиле печати и подписей старые.
Меняю "Реквизиты продавца и покупателя" на новых - результат тот же.
Вычитал, что нужно изменить "История ФИО" у физического лица на дату предшествующую назначению - результата нет.
Самое интересное, что в документе "Счета покупателям" факсимиле отображаются те, что нужно.

UPD:
В печатной форме "Акт с комментарием и с печатью", если нажать "Все действия" - "Изменить макет", выдает ошибку "Макет "ПФ_MXL_Акт" не найден. Операция прервана"
Ответ:
Да, вы правы. Конфигураций много, просто запутался.
Спасибо за отзыв.
Вопрос: Префикс в счёте на оплату покупателю БП 2.0

Здравствуйте, в организации появилась необходимость установить префикс на счетах оплаты в БП 2.0. Может кто-нибудь сталкивался с такой проблемой? Типовыми средствами эту проблему решить не получается...
Ответ:
Спасибо, попробую!