Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: Передача формы на сервер из модуля общей команды

Ситуация такая:
1. Есть общая команда, которая вызывается из 3-х типовых документов. В документах ни строчки кода.
2. При выполнении этой команды необходимо выполнить несколько серверных процедур, которые описаны в модуле каждого из документов.
3. Процедуры, которые необходимо выполнить - серверные.
4. Эти процедуры имеют параметры. Параметр - это строка табличной части.
5. Как известно такие вещи нельзя с клиента на сервер передать.

Задача: любой ценой выполнить эти процедуры не изменяя типовые документы.

Вопрос: Как передать на сервер из команды данные? через хранилище это не передается! или Форму передать на сервер. т.е. из клиентской процедуры команды, где форма есть, передать её в серверную процедуру команды. Это также не получается сделать.

ессно это всё управляемые формы.
Ответ: () если они менялись в форме, то они и будут изменены в форме. Покажи код.
Вопрос: Программное создание кнопки на общую команду

на сервере перед открытием формы хочу создать кнопку:

КнопкаФормы = Тип("КнопкаФормы");
Кнопка = Форма.Элементы.Добавить("Кнопка", КнопкаФормы);
Кнопка.ИмяКоманды = "ОбщаяКоманда.Кнопка";

создана общая команда с именем Кнопка, группа - Панель навигации.Важное.

при установке свойства имякоманды происходит ошибка:
Ошибка при установке значения атрибута контекста (ИмяКоманды)
по причине:
Недопустимое значение
Ответ: () может функциональной опцией и ролями отбиться можно?
Вопрос: Общая команда

Добрый день!
Добавил Общую команду поместил ее Панель навигации формы.Перейти в 3 документа.
В Модуле команды
Код:
&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
    //Вставить содержимое обработчика.
    //ПараметрыФормы = Новый Структура("", );
    //ОткрытьФорму("ОбщаяФорма.", ПараметрыФормы, ПараметрыВыполненияКоманды.Источник, ПараметрыВыполненияКоманды.Уникальность, ПараметрыВыполненияКоманды.Окно, ПараметрыВыполненияКоманды.НавигационнаяСсылка);
     
    ПараметрыОткрытия = Новый Структура(
            "Отбор, КлючНастроек, СформироватьПриОткрытии",
            Новый Структура("Контрагент", Объект.Контрагент),
           "Контрагент",
            ИСТИНА);
    ОткрытьФорму("Отчет.пмРеестрДокументов.Форма", ПараметрыОткрытия);
 
КонецПроцедуры
Ну естественно Объект.Контрагент ругается на Объект.
Как мне указать там текущий документ.контрагент ?
А такой код у меня работает на команде на кнопке в форме документа, а в общей команде не хочет..
Ответ:
Код так сразу не подскажу. Надо смотреть.
Примерный алгоритм такой: берете ссылку на Ваш отчет (в справочнике "Дополнительные отчеты и обработки"), у него есть реквизит типа "Хранилище значения", в котором содержится сам отчет. Этот отчет нужно сохранить во временный файл и потом открывать.
Как-то так.
Возможно (наверняка) в конфигурации где-то есть код, который это делает.
Вопрос: Раздельное объединение формы и модуля формы

Добрый день!

При сравнении/объединении есть возможность объединять отдельно форму и отдельно модуль формы. Первый скриншот по ссылке .

Пробую на платформе 8.3.10.2699, но и форма, и модуль имеют общую настройку объединения.

Как можно включить эту возможность?
Ответ: Режим совместимости стоит 8.3.10.

даже от хранилища отцепил, всё равно нельзя выбрать разные настройки объединения)
Вопрос: Управление элементами формы через модуль объекта

Как управлять элементами формы через модуль объекта?

Например, в модуле объекта можно так писать?

Функция СоздатьКолонки (ЭлементыФормы) Экспорт
 ЭлементыФормы.ТабПоле.СоздатьКолонки();
КонецФункции
Ответ: если клиент толстый тогда, например, для отчета
ЗЫСформа = ЭтотОбъект.ПолучитьФорму("ФормаОтчета",,НаименованиеОтчета);
ВариантФормирования = ЗЫСформа.ЭлементыФормы.ВариантФормирования.Значение;


можешь вместо НаименованиеОтчета написать "новый УникальныйИдентификатор"
Вопрос: Открыть форму из модуля сеанса

Так уж получилось что я пропустил занятие когда объясняли галочки общих модулей)
Проблема такая. В модуле сеанса, при установке параметров сеанса, мне нужно открыть форму с передачей Описания оповещения. Проблема уже возникла при Новый ОписаниеОповещения....
Прошу подсказать как правильно открыть форму в моем случае.
Ответ: () Спасибо. Оттуда вызываю а_ОбщегоНазначенияКлиент, там открываю форму и устанавливаю параметр а_ОбщегоНазначенияСервер через а_ОбщегоНазначенияКлиентСервер
Всем спасибо!
Вопрос: Передача клиент - сервер

Подскажите, от чего зависит скорость передачи между клиентом и сервером

Например массив из 1кк чисел передается туда-сюда примерно за 60 секунд, что мне кажется слишком долгим
(при этом фактически "Клиент" находится на том же самом сервере через рдп):

&НаКлиенте
Процедура Тест(Команда)
    
    к = 1000000;
    м = Новый Массив;
    р = Новый ГенераторСлучайныхЧисел;
    Для _ = 1 По к Цикл
        м.Добавить(р.СлучайноеЧисло(0, 65535));
    КонецЦикла;

    т = ТекущаяУниверсальнаяДатаВМиллисекундах();
    ТестНаСервере(м);
    Сообщить(ТекущаяУниверсальнаяДатаВМиллисекундах() - т);
    
КонецПроцедуры

&НаСервереБезКонтекста
Процедура ТестНаСервере(м)
    //ничего не делает

КонецПроцедуры
Ответ: сериализовал через сериализатор и посмотрел XML

Даже если явно указать тип для списка или таблицы, все равно в каждой строке так же указывается тип.

Быстрее передача не становится

<?xml version="1.0" encoding="UTF-8"?>
<ValueTable xmlns="; xmlns:xs="; xmlns:xsi=";
<column>
<Name>Число
</Name>
<ValueType>
<Type>xs:decimal
</Type>
<NumberQualifiers>
<Digits>10
</Digits>
<FractionDigits>0
</FractionDigits>
<AllowedSign>Any
</AllowedSign>
</NumberQualifiers>
</ValueType>
</column>
<row>
<Value xsi:type="xs:decimal">19930
</Value>
</row>
<row>
<Value xsi:type="xs:decimal">10300
</Value>
</row>
...
Вопрос: Панель управляемой формы

Добрый день. Возникла казалось бы простейшая задачка, но я не могу найти решение.
Есть общая команда. Команда включена в группу "Командная панель формы.ЭД". Панелька видна и из формы списка и из формы документа, а вот кнопка внутри только из формы документа. Права на просмотр и использование есть, программно кнопка нигде не режется.
Подскажите в какую сторону копать?
Ответ:
Буквально час назад разобрался. Все оказалось до обидного просто. В конфигураторе я смотрел на одну форму, а в предприятии открывалась другая форма. Вопрос в общем-то уже закрыт
Вопрос: Разные формы, а также передача формы с сервера

Встретил такую закономерность, если от ссылка пытаюсь получить форму:
Форма = СсылкаНаКонтактноеЛицо.ПолучитьФорму("ФормаЭлементаУправляемая");    
То возвращает управляемую, а если от объекта то обычную
Форма = СсылкаНаКонтактноеЛицо.ПолучитьОбъект().ПолучитьФорму("ФормаЭлементаУправляемая");    

И еще как правильно передать форму с сервера на клиент, ведь получать ее только на сервере?
Ответ: Нифига не понял. Зачем тебе форма на сервере?
Вопрос: [РЕШЕНО] Вызов процедуры модуля формы из модуля управляемой формы внешней обработки

Уважаемые эксперты, подскажите, пожалуйста:
8.3.9.2170
Как из клиентской процедуры модуля формы внешней обработки (УФ), привязанной к документу, вызвать процедуру модуля формы этого документа?
Спасибо
Ответ:
Получить форму документа и вызвать нужную экспортную функцию в модуле полученной формы.