Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: Перенос значения реквизита справочника в реквизит документа

Создал документ. В нем есть реквизит коэффициент К4. Он ссылается на справочник Коэффициент К4, в котором есть реквизит Коэффициент К4. Как мне перенести значение из справочника в документ. Все реквизиты не табличной части.
Помогите пожалуйста работаю над дипломом мозг уже кипит.
Ответ: Pa4ok, посмотрела вашу базу. Непонятно, зачем столько справочников? И куда вы собрались переносить значение реквизита К4 в документе?
Расскажите подробно про цель создания этой базы, что в ней должно быть и зачем. Думаю, всю структуру объектов надо изменять.

Сообщение от Pa4ok
Так а тогда что там писать?
Возврат ИмяЭлемента[ИмяРеквизита]; так же все остаить?
Оставить, это параметры функции, в которые мы передаем нужные значения при вызове.
Вопрос: Получение значения реквизита справочника в документ

Добрый день, есть вопрос
Как сделать чтобы реквизит табличной части документа получал данные из реквизита справочника.
Т.е. при изменении "ФИО" в табличной части документа подставлялись значения (ДатаРождения, Должность)из справочника (Сотрудники)

Есть справочник Сотрудники, реквизиты "Должность", "Дата рождения"

Есть документ в нем табличная часть "Налоги" и его реквизиты "ФИО" "Должность" "ДатаРождения"

если просто ссылаться через форму на значения справочника то в документе выводится визуально и ДатаРождения, и Должность, но на печати эти поля пустые и при установке условий они ни как не считываются, а как будто пустые

Прошу в поиск не посылать, т.к. пробывал уже много вариантов в т.ч. программно через функции

платформа 8.2
Ответ: Спасибо огромное!!! сделал!!!
Код 1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
&НаСервереБезКонтекста
Функция ПолучитьЗначениеРеквизитаНаСервере(ИмяОбъекта, ИмяРеквизита)
  Возврат ИмяОбъекта[ИмяРеквизита];
КонецФункции
 
&НаКлиенте
Процедура МатериалыМатериалПриИзменении(Элемент)
    СтрокаТабличнойЧасти=Элементы.Материалы.ТекущиеДанные;
    СтрокаТабличнойЧасти.ЕдиницыИзмерения=ПолучитьЗначениеРеквизитаНаСервере(СтрокаТабличнойЧасти.Материал,"ЕдиницыИзмерения");
КонецПроцедуры
 
&НаКлиенте
Процедура ФИОПриИзменении(Элемент)
    Объект.Должность = ПолучитьЗначениеРеквизитаНаСервере(Объект.ФИО,"Должность");
Объект.Подразделение = ПолучитьЗначениеРеквизитаНаСервере(Объект.ФИО,"Подразделение");
КонецПроцедуры
Добавлено через 2 минуты
Не подскажешь? Сделал конструктором печати форму, все нормально работало. Сейчас решил переделать, кнопка в форме стоит в конфе, а запускаю 1с ее нет в доке..
Вопрос: Изменение реквизитов справочника при проведении документа

Доброго времени суток! Прошу помочь, нужно изменить реквизиты элементов справочника "ОбъектыПроката" при проведении документа "ОприходываниеОбъектаПроката". Знаю что такой подход не приветствуется, но все же. У меня уже есть объекты проката в справочнике созданные в документе "ПоступлениеОбъектаПроката", а в документе "ОприходываниеОбъектаПроката" нужно дать каждому объекту инвентарный номер и другие характеристики. Вот задание:
На предприятии выполняются следующие бизнес процессы по учету объектов проката:
1. Поступление объекта проката на склад (точку проката) предприятия. Указывается номер документа поступления, дата документа поступления, контрагент – поставщик, договор контрагента – поставщика, склад (точка проката), перечень объектов проката, носитель, количество, цена, сумма. Документ должен выполнять движения с видом «приход» по регистрам накопления «ОстаткиОбъектовПрокатаПредприятия», «ВзаиморасчетыСКонтрагентами».
2. Оприходование объекта проката. На данной операции поступившему объекту проката присваивается инвентарный номер, определяется начальное качество объекта проката, задаются характеристики объекта проката (жанр, страна изготовитель, год изготовления, возрастные ограничения, предельно допустимое количество передач объекта в прокат). Документ должен записать значения в соответствующие реквизиты указанных в документе объектов проката.

пробовал так:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
Процедура ОбработкаПроведения(Отказ, Режим)
    
    Для Каждого ТекСтрокаХарактиристикиОбъекта Из ХарактиристикиОбъекта Цикл
        Оприходывание = Справочники.ОбъектПроката.ПолучитьОбъект(); 
        Оприходывание.ИнвентарныйНомер = ТекСтрокаХарактиристикиОбъекта.ИнвентарныйНомер;
                Оприходывание.Фильм = ТекСтрокаХарактиристикиОбъекта.Фильм;
        Оприходывание.Качество = ТекСтрокаХарактиристикиОбъекта.Качество;
        Оприходывание.ЦенаЗаСутки =ТекСтрокаХарактиристикиОбъекта.Цена;
        Оприходывание.КоличествоПередачВПрокат = ТекСтрокаХарактиристикиОбъекта.КоличествоПередачВПрокат;
                Оприходывание.Записать();
        КонецЦикла;
 
КонецПроцедуры
Но выдает ошибку, метод ПолучитьОбъект() не обнаружен
Ответ: Спасибо большое, заработало))
Вопрос: Как получить в документе значение реквизита справочника?

Есть Справочник Единицы Измерения с реквизитом коэффициент. В документе РасходНаклад я выбираю в табличной части для каждой номенклатуры единицу измерения, количество этих единиц. Есть еще один реквизит табличной части КоличествоВШтуках где я хочу получать количество в штуках. Вопрос в том что как получить реквизит Коэффициент, чтобы в дальнейшем умножить на него количество и получить значение в штуках. Единицы измерения Пачки с коэффициентом 10.
Ответ: GreenkO, в справочнике ЕдиницыИзмерения. Спасибо, все получилось
Вопрос: В запросе не выводится реквизит справочника

Помогите разобраться. В запросе по справочнику и документу не выводится реквизит справочника. Только начинаю программировать в 1 с.
    ТекстЗапроса = " 
    |Обрабатывать НеПомеченныеНаУдаление;
    |ОбрабатыватьДокументы Проведенные;
    |Номенклатура  = Справочник.Номенклатура.ТекущийЭлемент,
    |        Документ.ПоступлениеТМЦ.Номенклатура;
    |ДатаСозд      =Справочник.Номенклатура.ДатаСоздания;  
    |ДатаПервогоПоступления =Документ.ПоступлениеТМЦ.ДатаДок;
    |Группировка Номенклатура;
    |Условие (ДатаСоздания>ДатаС);
    |Условие ((ТекущаяДата() - ДатаПервогоПоступления)<31);";
Ответ: Не выводится реквизит дата создания, точнее выдает в этом поле пустое значение.
Вопрос: При изменении реквизита Группа ТЧ документа заполнить из ТЧ Справочника

Здравствуйте... Никак не могу разобраться с запросами 1С. У меня имеется справочник Группы с ТЧ СписокУчастников и документ Посещаемость с реквизитом Группа и ТЧ Отсутсвующие. Я хочу, чтоб при изменении реквизита Группа ТЧ документа заполнялась из ТЧ Справочника. Но у меня не получается. Буду рада помощи

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
&НаСервере
Процедура ЗаполнитьТабличнуюЧасть()
    Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |   ГруппыСписокУчастников.ИмяВоспитаника,
        |   Группы.Наименование
        |ИЗ
        |   Справочник.Группы.СписокУчастников КАК ГруппыСписокУчастников
        |       ЛЕВОЕ СОЕДИНЕНИЕ Справочник.Группы КАК Группы
        |       ПО ГруппыСписокУчастников.Ссылка = Группы.Ссылка
        |ГДЕ
        |   Группы.Наименование = &Наименование";
        
        Запрос.УстановитьПараметр("Наименование", Справочники.Группы.Выбрать().Наименование);
       РезультатЗапроса = Запрос.Выполнить().Выгрузить();
    Для каждого Стр из РезультатЗапроса Цикл
        НоваяСтрока = Объект.УчетПосещаемости.Добавить();
        НоваяСтрока.Учащийся = Стр.ИмяВоспитаника;
    КонецЦикла
КонецПроцедуры
Ответ: ivantsova93, Как не связан? У тебя в документе в одной строчке Воспитанник и галка. Запросом достать можно.
Вопрос: получить доп. реквизиты справочника партнеры

Добрый день.
Есть внешняя печатная форма "Накладная на отправку". Нужно вывести доп. реквизит созданный в самой программе 1с предприятие 8.3 УТ 11.4.
Код запроса ниже.
Код:
Функция РН_ПолучитьЗначениеДопРеквизита(Партнер,НаименованиеДопРеквизита,ЭтоДопСведение = Ложь)
Запрос = Новый Запрос;
Если ЭтоДопСведение Тогда
  Запрос.Текст =
  "ВЫБРАТЬ РАЗРЕШЕННЫЕ ПЕРВЫЕ 1
  | ДополнительныеСведения.Значение
  |ИЗ
  | РегистрСведений.ДополнительныеСведения КАК ДополнительныеСведения
  |ГДЕ
  | ДополнительныеСведения.Объект = &Ссылка
  | И ДополнительныеСведения.Свойство.Заголовок = &НаименованиеДопРеквизита
  | И НЕ ДополнительныеСведения.Свойство.ПометкаУдаления"
Иначе
  Запрос.Текст =
  "ВЫБРАТЬ РАЗРЕШЕННЫЕ ПЕРВЫЕ 1
  | ПартнерыДополнительныеРеквизиты.Значение КАК Значение
  |ИЗ
  | Справочник.Партнеры.ДополнительныеРеквизиты КАК ПартнерыДополнительныеРеквизиты
  |ГДЕ
  | ПартнерыДополнительныеРеквизиты.Свойство.Заголовок = &НаименованиеДопРеквизита
  | И ПартнерыДополнительныеРеквизиты.Ссылка = &Ссылка
  | И НЕ ПартнерыДополнительныеРеквизиты.Свойство.ПометкаУдаления";
КонецЕсли;
Запрос.УстановитьПараметр("НаименованиеДопРеквизита", НаименованиеДопРеквизита);
Запрос.УстановитьПараметр("Ссылка", Партнер);
Выборка = Запрос.Выполнить().Выбрать();            
Если Выборка.Количество() > 0 Тогда
  Выборка.Следующий();
  Возврат Выборка.Значение
Иначе
  Возврат "";
КонецЕсли;
КонецФункции
Код формирования строки
Код:
                Область = Макет.ПолучитьОбласть("Отправка");
                СтруктураДанныхОтправка = Новый Структура;
                    ТК = РН_ПолучитьЗначениеДопРеквизита(ВыборкаПоСкладам.Контрагент,"ТК",Ложь);
                СтруктураДанныхОтправка.Вставить("ОтправкаТК", ТК);       
                Область.Параметры.Заполнить(СтруктураДанныхОтправка);
                ТабличныйДокумент.Вывести(Область);
В итоге в печатной форме пусто
ВПФ прилагаю.

Вложения:

  • Размер файла:
    19 КБ
    Просмотров:
    0
Ответ:
Извините, просто я не правильно выразил вопрос. У меня в настройках везде указано, что контрагенты. Галочка "Независимо вести партнеров и контрагентов" не поставлена. Но почему то, если создаю доп реквизит для контрагентов, в справочнике ничего не появляется, а если для партнеров, то появляется.
--- Объединение сообщений, 30 май 2018 ---
Вопрос решил. Всем спасибо.
Нужно было делать так
Код функции:
Код:
Функция ПолучитьЗначениеДопРеквизита(Ссылка, Свойство) Экспорт

    ПараметрыОтбора = Новый Структура;
    ПараметрыОтбора.Вставить("Свойство",Свойство);
    Массив = Ссылка.ДополнительныеРеквизиты.НайтиСтроки(ПараметрыОтбора);

    Если Массив.Количество() = 0 Тогда
        Возврат Неопределено;
    Иначе
        Возврат Массив[0].Значение;
    КонецЕсли;

КонецФункции
Код обращения к функции
Код:
ТК = ПолучитьЗначениеДопРеквизита(ВыборкаПоСкладам.Ссылка.Партнер,ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ТК (Общие)"));
Вопрос: Получить реквизит справочника на дату (не периодический)

День добрый!
Как лучше получить значение реквизита справочника на дату?
Реквизит не периодический (и не предлагать).

Интересует сам алгоритм.

Спасибо.
Ответ: Срез последних по справочнику в 7.7?
Вопрос: Перенос данных из справочника в документ

В справочнике имеется поле цена за единицу товара. Как ее переносить автоматически в документ вместе с наименованием товара.Документ называется Приходная Накладная.
Ответ: Огромное вам спасибо
Вопрос: v7: Перенос значений из подчиненного справочника в форму документа.

Здравствуйте, уважаемые форумчане. Опыт прогроммировния в 1с-3 месяца поэтому просьба не судить строго. Итак Версия 1с 7.7 (7.70.025), конфигурация - Бухгалтерский учет. Типовая настойка для РБ.

Есть "Справочник.Материалы", "Справочник.ПартииМатериалов"(он подченинен "Справочнику.Материалы"), "Документ.АктВыпРабот". В таблицу документа "Акт.ВыпРабот" в реквизит "Работа(услуга)" выбираем значение из "Справочник.Материалы.Наименование". Реквизит таблицы "Партия материалов" связан с реквизитом таблицы "Работа(Услуга)". При клике по реквизиту таблицы "Партия Материалов" выскакивает "Справочник.ПартииМатериалов", который подчинен родительскому элементу "Справочника.Материалы" , выбранному в "Работа(Услуга)".

Сделаю уточнения. 1. Реквизит "Партия" Имеет тип "Справочник.ПартииМатериалов".  2. После того как кликаем на "Партии Материалов" в таблице , как я уже написал, выскакивает нужный подчиненный "Справочник.ПартииМатериалов" и из него нужно выбрать в таблицу документа 3 значения: а) В саму колонку "Партии Материалов" значение "Справочник.ПартииМатериалов.Партия", б) В колонку "Цена" значение "Справочник.ПартииМатериалов.Цена", в) В колонку "Код Партии" значение "Справочник.ПартииМатериалов.Код". Просьба обратить внимание на следущее 1. Реквизиты в "Справочник.ПартииМатериалов" - периодические. 2. Просьба обратить внимание на то, что в "Справочник.ПартииМатериалов" нет реквизита "Наименование", по которому обычно и происходит выборка, а как выбрать другие значения из справочника вот и не знаю. Для лучшего восприятия текста скриншот во вложении. Спасибо огромное заранее!

Ответ: Спасибо Uno-group и Злопчинскому. Особенно Злопчинскому за индивидуальную помощь! Все получилось! Еще раз спасибо ребята!