Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: Связывание двух табличных частей документа

Необходимо при нажатии на строчку первой табличной части, получать соответствующие данные во второй табличной части. Использовался код ниже, но тогда, при добавлении новой строки в во второй табличной части, она относится в первую табличную часть по номеру строки. Как переделать код, может надо создать какие нибудь дополнительные поля в обе табличные части?
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
&НаКлиенте
Процедура ТабличнаяЧастьПриАктивизацииСтроки(Элемент)
    ТекДанные = Элементы.ТабличнаяЧасть.ТекущиеДанные;
 
    Если ТекДанные <> Неопределено Тогда
        УстановитьОтборВТабличнаяЧасть1(ТекДанные.НомерСтроки);
    КонецЕсли;
КонецПроцедуры
&НаКлиенте
Процедура УстановитьОтборВТабличнаяЧасть1(НомерСтроки)
       ТекДанные1 = Элементы.ТабличнаяЧасть1.ТекущиеДанные;
    
 
    Отбор = Новый ФиксированнаяСтруктура("НомерСтроки", НомерСтроки);
    Элементы.ТабличнаяЧасть1.ОтборСтрок = Отбор;
КонецПроцедуры
Ответ:
Сообщение от valexab
А какое поле, например?
Например. Добавить реквизит "Реквизит1" в обе табличные части с типом УникальныйИдентификатор, и обеспечить одинаковое значение этих полей для связанных строк.
Вопрос: Как правильно ссылатся на табличную часть в документе?

Друзья! Мне нужно помочь с табличной часть,т.е у меня есть документ в котором есть табличная часть где вычисляется по Итогам активная мощность и Реактивная мощность(картинка прилагается), в другом документе я рассчитываю анализ электрических нагрузок и ссылаюсь на Объект.ТабличнаяЧасть1.ИтогАктивнаяМощность, но у меня выходит ошибка,пожалуйста помогите мне правильно ссылаться на эту строку в документе(прилагаю картинку), после выходит вот такая ошибка:
1C
1
2
{Документ.Анализ_электрических_нагрузок_промысловых_подстанци.Форма.ФормаДокумента.Форма(11)}: Поле объекта не обнаружено (ИзмеренныеАктивныеИРеактивныеМощности)
    Объект.Реквизит1= Объект.ИзмеренныеАктивныеИРеактивныеМощности.ИтогАктивныеМощности/48 ;
Ответ: Dethmontt, с ТС выяснили (в личке, диплом сюда выкладывать не хотела), что проблема была в следующем: были два абсолютно разные документа, никак не связаны. Табличная часть в одном документе, а итог по ней пыталась вывести в другом документе. Добавили реквизит-ссылку на документ с табличной частью и поправили вывод итога табличной части выбранного дока.
Вопрос: Выгрузка табличной части в таблицу значений

Ситуация такая,в документе имеется табличная часть Подписки (см. скрин), в ней есть колонка Подписка с типом Бизнес-процесс.Ссылка (см. скрин).
В бизнес-процессе, в свою очередь имеются реквизиты: Партнер, Клиент, ВидПодписки. Необходимо получить их и выгрузить в таблицу значений Итоги, в которой есть соответствующие колонки (см. скрин). Прошу помоши, заранее спасибо.
Ответ: В обработчике табличной части Подписки ПриИзменении(Элемент). Допустим, сделали выгрузку табличной части. А как получить нужные элементы не знаю.

1C
1
    ТаблицаЗначений = Объект.Подписки.Выгрузить();
Добавлено через 12 минут
В обработчике табличной части Подписки ПриИзменении(Элемент) вызывается процедура ВыгрузкаТабличнойЧасти(). Допустим, сделали выгрузку табличной части. А как получить нужные элементы не знаю.

&НаСервере
1C
1
2
3
4
5
6
    Процедура ВыгрузкаТаблицыЗначений()
 
    ТаблицаЗначений = Объект.Подписки.Выгрузить();
            
    
КонецПроцедуры 
Вопрос: Автозаполнение из табличной части справочника в табличную часть документа

Здравствуйте , помогите пожалуйста с кодом
Мне нужно чтобы автоматически заполнялась табличная часть документа из табличной части справочника.
При заполнении документа , автоматически заполнялось ОстановкиМаршрута на 2 скрине.
Из справочника "Маршруты" в ней табличная часть "ОстановкиМаршрута" в "Документ1" в форму элемента "ОстановкиМаршрута"
Ответ: А если ТЧ справочника изменится, нужно ли менять ТЧ документа?

Добавлено через 3 минуты
Так нужно заполнять табличную часть документа? Или выводит список остановок при позиционировании на строке документа?
Вопрос: 1с 8.3 Вывод картинок в табличной части документа

Имеется документ с табличной частью, с реквизитом Номенклатура (тип СправочникСсылка.Номенклатура ). Нужно при изменении Номенклатуры выводить соответствующую картинку из справочника.

Есть одна особенность картинки хранятся в отдельном справочнике ФотоБанк с реквизитом Фото (тип ХранилищеЗначения). На который и ссылается реквизит Изображение справочника Номенклатура.
(Добавление картинки в Справочник было рассмотрено в этой теме: )

Подскажите, пожалуйста, как все же реализовать вывод картинок в табличной части документа.
Ответ: После долгих мучений, картинка выводиться в табличную часть документа, но очень маленькая. А если в конфигураторе поменять высоту колонки, то картинка выводиться в ее реальном размере (но выходит со стороки - см. скрин 2), хотя стоит в свойстве АвтоРазмер. Как это исправить? И какое свойство надо изменить, чтобы картинка была по центру ячейки?
1C
1
2
3
4
5
6
7
8
9
10
11
12
&НаКлиенте
Процедура ТоварыНоменклатураПриИзменении(Элемент)
    СтрокаТабличнойЧасти = Элементы.Товары.ТекущиеДанные;
    Номенклатура = СтрокаТабличнойЧасти.Номенклатура;   
    СтрокаТабличнойЧасти.АдресФото = ПолучитьСсылкуКартинки(Номенклатура);
КонецПроцедуры
 
&НаСервереБезКонтекста
Функция ПолучитьСсылкуКартинки(Ссылка)
     АдресФото = ПолучитьНавигационнуюСсылку(Ссылка.Изображение,"Фото");
     Возврат АдресФото;
КонецФункции
Вопрос: Создание табличной части

Здравствуйте,форумчане! И это снова я,нубас!))
В общем пишу диплом,хочу сделать табличную часть,много видела примеров всяких,в итоге решила остановиться и создать его через обработчик(?),я на верном пути?
В общем прописала код,НО он не отображает колонки и значения,в чем может быть ошибка?
Прилагаю код:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
&НаКлиенте
Процедура ТаблицаЗначений(Команда)
    ТЗ();
КонецПроцедуры
 
&НаСервере
Процедура ТЗ();
    
    ТЗ = Новый ТаблицаЗначений;
    
    ТЗ.Колонки.Добавить("Реактивная мощность");
    ТЗ.Колонки.Добавить ("Активная мощность");
    
    НоваяСтрока = ТЗ.Добавить();
    
    НоваяСтрока.Сотрудник = "32000";
    НоваяСтрока.Оклад = "2580";
    КонецПроцедуры
И прилагаю приложение с этим обработчиком
Ответ: Alyua, что вы попробовали? опишите ваши действия.

Добавлено через 2 часа 24 минуты
Сообщение от Alyua
пишу диплом,хочу сделать табличную часть,много видела примеров всяких,в итоге решила остановиться и создать его через обработчик(?)
Опишите подробнее вашу задачу, цель создания табличной части, где вы ее хотите создать... И почему в итоге в коде таблица значений, а не табличная часть какого-либо объекта?
Вопрос: Автоподстановка номенклатуры в табличной части

Добрый день! При подборе номенклатуры автозапчастей ключевыми полями являются Артикул и Производитель, Наименование не важно. При добавлении строки с номенклатурой в табличной части наоборот по умолчанию предлагается заполнить поле Номенклатура, где, как раз, записано не ключевое поле Наименование. Нужно сделать так, чтобы продавец при добавлении новой строки вставил скопированный в буфер обмена Артикул, далее вставил значение в поле Производитель. Затем, если номенклатура с вставленными двумя ключами (Артикул и Производитель) существует, то она бы подставилась в строку табличной части. Если такой номенклатуры нет, то она бы создалась при определенном событии. Например, менеджер вставил Артикул и Производитель, номенклатура не подставилась, далее менеджер вставляет наименование в поле Номенклатура, при нажатии Enter или при переходе в другое поле (количество, например) номенклатура создается. Хотелось бы обойтись без внешней обработки. Возможно ли такое сделать? Спасибо!

Вложения:

  • Размер файла:
    17,8 КБ
    Просмотров:
    6
Ответ:
то есть сейчас при вставке артикула/производителя в соответствующее поле номенклатура не заполняется?
Вопрос: Запись первой строки табличной части в в реквизит

Подскажите пожалуйста как программно записать первую строку из табличной части документа в реквизит.
Ответ: Alexeyon, предположим, что имя табличной части документа - ТабличнаяЧасть1:
1C
1
2
3
Если Объект.ТабличнаяЧасть1.Количество() > 0 Тогда //табличная часть не пустая
 Номенклатура = Объект.ТабличнаяЧасть1[0].Номенклатура; //получаем значение Номенклатуры первой строки ТЧ
КонецЕсли;
Это для управляемых форм, для обычных - тоже самое, но убираем везде "Объект.".
Вопрос: v7: Конвертация данных: Нет табличной части

Добрый вечер!

Загрузил в КД 2.1.8 метаданные "Хлебозавод (7.7)" и БП (3.0)".
В метаданных табличные части документов присутствуют.
Однако в правилах обмена они автоматически не создались. Документы выгружаются, но без табличной части.

Подскажите, пожалуйста, как эту табличную часть в правила обмена вкорячить. Давно дело было, каюсь, подзабыл :)
Ответ: А вот и нет. В Правилах Конвертации Объектов внизу есть две конпки "Добавить" и "Добавить группу". Табличная часть, получается, добавляется группой. Логично, хотя и не очевидно. Как и всё в это чудесной адынэз :)
Вопрос: Бухгалтерия ред. 2.1(РБ) Заполнение табличной части

Не удаётся заполнить табличную часть.
Не знаю что делаю не так.
Помогите плиз.
Заранее благодарю.
--- Объединение сообщений, 6 авг 2017 ---
Всё вроде как работает но табличная часть с итогами не наполняется и выводиться.
--- Объединение сообщений, 6 авг 2017 ---
// Функция формирует табличный документ с Внешней печатной формой
//
// Возвращаемое значение:
// Табличный документ - печатная форма акта
//
Функция ПечатьВнешнейПечатнойФормы(МассивОбъектов, ОбъектыПечати) Экспорт

ТабДок = новый ТабличныйДокумент;

ТабДок.АвтоМасштаб = Истина;
ТабДок.ОтображатьСетку = Ложь;
ТабДок.Защита = Ложь;
ТабДок.ТолькоПросмотр = Ложь;
ТабДок.ОтображатьЗаголовки = Ложь;
ТабДок.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
ТабДок.ЭкземпляровНаСтранице= 1;

УстановкаМинимальныхПолейДляПечати(ТабДок);
Макет = ПолучитьМакет("СчетФактура_РФ");

ОбластьШапки = Макет.ПолучитьОбласть("Шапка");
ОбластьДанные = Макет.ПолучитьОбласть("Данные");
ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");

Запрос = Новый Запрос;
Запрос.УстановитьПараметр("МассивОбъектов",МассивОбъектов);
Запрос.Текст ="ВЫБРАТЬ
| РеализацияТоваровУслуг.АдресДоставки,
| РеализацияТоваровУслуг.ВалютаДокумента,
| РеализацияТоваровУслуг.ГлавныйБухгалтер,
| РеализацияТоваровУслуг.Грузоотправитель,
| РеализацияТоваровУслуг.Грузополучатель,
| РеализацияТоваровУслуг.Дата,
| РеализацияТоваровУслуг.ДоговорКонтрагента,
| РеализацияТоваровУслуг.Контрагент,
| РеализацияТоваровУслуг.Номер,
| РеализацияТоваровУслуг.Организация,
| РеализацияТоваровУслуг.Руководитель,
| РеализацияТоваровУслуг.СуммаВключаетНДС,
| РеализацияТоваровУслуг.СуммаДокумента,
| РеализацияТоваровУслуг.Товары.Номенклатура,
| РеализацияТоваровУслуг.Товары.ЕдиницаИзмерения,
| РеализацияТоваровУслуг.Товары.Количество,
| РеализацияТоваровУслуг.Товары.Цена,
| РеализацияТоваровУслуг.Товары.Сумма,
| РеализацияТоваровУслуг.Товары.СтавкаНДС,
| РеализацияТоваровУслуг.Товары.СуммаНДС,
| РеализацияТоваровУслуг.Товары.СтранаПроисхождения,
| РеализацияТоваровУслуг.Товары.Ссылка КАК Ссылка

| ИЗ
| Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
| ГДЕ
| РеализацияТоваровУслуг.Ссылка В (&МассивОбъектов)";

//Получаем область "Шапка"

ОбщаяВыборка = Запрос.Выполнить().Выгрузить();

Для Каждого СсылкаНаОбъект из МассивОбъектов Цикл

ОбластьШапки.Параметры.Номер = "Счет-фактура № "+СсылкаНаОбъект.ДоговорКонтрагента+" г.";
ОбластьШапки.Параметры.НомерИсправления = "Исправление № -- от -- ";
ОбластьШапки.Параметры.ПредставлениеПоставщика = "Продавец: "+СсылкаНаОбъект.Организация;
ОбластьШапки.Параметры.АдресПоставщика = "Адрес: "+" 210033, Витебская обл., г. Витебск, пр. ФРУНЗЕ, дом № 81";
ОбластьШапки.Параметры.ИННПоставщика = "ИНН/КПП продавца: 300237386 / 300237386 ";
ОбластьШапки.Параметры.ПредставлениеГрузоотправителя = "Грузоотправитель и его адрес: он же";
ОбластьШапки.Параметры.ПредставлениеГрузополучателя = "Грузополучатель и его адрес: "+СсылкаНаОбъект.Контрагент+", "+СсылкаНаОбъект.АдресДоставки;
ОбластьШапки.Параметры.ПоДокументу = "К платежно-расчетному документу №: от ";
ОбластьШапки.Параметры.ПредставлениеПокупателя = "Покупатель: "+СсылкаНаОбъект.Контрагент;
ОбластьШапки.Параметры.АдресПокупателя = "Адрес: "+СсылкаНаОбъект.АдресДоставки;
ОбластьШапки.Параметры.ИННПокупателя = "ИНН/КПП покупателя: ";
ОбластьШапки.Параметры.Валюта = "Валюта: наименование, код Российский рубль, 643";

ТабДок.Вывести(ОбластьШапки);

//Получаем область "Данные"

Отбор = Новый Структура;
Отбор.Вставить("Ссылка",СсылкаНаОбъект);
Выборка = ОбщаяВыборка.НайтиСтроки(Отбор);

ИтогоСумма = 0;
ИтогоСуммаНДС = 0;
ИтогоВсего = 0;


Для Каждого Стр из Выборка Цикл
ЗаполнитьЗначенияСвойств(ОбластьДанные.Параметры,Стр);

ИтогоСумма = ИтогоСумма + Стр.Сумма;
ИтогоСуммаНДС = ИтогоСуммаНДС + Стр.СуммаНДС;
ИтогоВсего = ИтогоВсего + Стр.Всего;

ТабДок.Вывести(ОбластьДанные);
КонецЦикла;

//Получаем область "Подвал"
ОбластьПодвал.Параметры.ИтогоСумма = ИтогоСумма;
ОбластьПодвал.Параметры.ИтогоСуммаНДС = ИтогоСуммаНДС;
ОбластьПодвал.Параметры.ИтогоВсего = ИтогоВсего;

ТабДок.Вывести(ОбластьПодвал);
ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
КонецЦикла;

Возврат ТабДок;
КонецФункции

Вложения:

  • Размер файла:
    4,6 КБ
    Просмотров:
    1
  • Размер файла:
    17,5 КБ
    Просмотров:
    1
Ответ:
Такой вопрос. Есть ВПФ:
--- Объединение сообщений, 6 окт 2017 ---
В документе "РеализацияТоваровУслуг" нет реквизита "КодТНВЭД".

Как его туда добавить?

Нужно чтобы он попал сюда:
--- Объединение сообщений, 6 окт 2017 ---
В базе он есть. ВПФ ссылается на табличную часть "ТОВАРЫ" документа "РеализацияТоваровУслуг".Нужно его как-то добавить чтобы заполнить макет

Вложения:

  • Размер файла:
    15,8 КБ
    Просмотров:
    2
  • Размер файла:
    19,5 КБ
    Просмотров:
    3