Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: Синхронизация Ут-БП. Разным заказам соответствуют разные договоры контрагентов

Настроил типовую синхронизацию Ут 11.3 и БП 3.0 через универсальный формат. В настройках УТ стоит "Разным заказам соответствуют разные договоры контрагентов".

Создаю 2 одинаковых заказа, делаю синхронизацию.
При сопоставлении объектов вижу только один договор(пустой).
В БП создаются счета на оплату. В договоре стоит "Основной договор".

Не пойму, как оно должно работать. Мне казалось, что в счетах будут новые разные договора, соответствующие номерам заказов.
У кого-то работает?
Ответ: () Курсы валют с авансов.
Вопрос: Основной договор контрагента в БП 3.0

Добрый день.
В последнем релизе БП 3.0 исчез реквизит "ОсновнойДоговорКонтрагента", заменили его на регистр сведений "основные договоры контрагентов", следовательно нужно поправить правила КД.
Скажите, есть способ добавить метаданные в КД не загружая всю структуру метаданных? Мне нужно добавить только регистр сведений.

Пробовал загружать метаданные с галкой, только добавлять новые, вываливается ошибка. В общем суть в том, что правила переписаны очень сильно и структуру метаданных никто давно не обновляет, а для решения проблемы нужен регистр сведений.
Ответ:
Спасибо огромное, вопрос решился.
Вопрос: не удаляется договор из-за привязки к контрагенту

Добрый день! заранее извиняюсь, если такой вопрос уже поднимался, нужну ветку не нашла
у нас есть две конфигурации БП и УНФ. между ними нетиповой обмен. недавно обнаружили несколько задвоенных договоров (были созданы в обеих конфигурациях), и решили удалить неиспользуемые.
удалить не получается, потому-что есть ссылки на запись в регистре соответствия объектов инф.баз и контрагенте.
в регистре соответствия объектов инф.баз запись можно удалить вручную. Но правильно ли это?
а как быть с контрагентом?

1С:Предприятие 8.3 (8.3.6.2237)
Бухгалтерия предприятия, редакция 2.0 (2.0.64.41)

Вложения:

  • Размер файла:
    149,3 КБ
    Просмотров:
    4
Ответ:
встроенной в конфигурацию в 2.0 её точно не было, она позже появилась в конфигурациях.

там на дисках ИТС в папке UNIREPS82 есть обработка ПоискИЗаменаЗначений.epf
через неё можно заменить в нужном на ссылки нужные объекты

ВНИМАНИЕ!!!! прежде проделать на копиях баз!!!!!!!!!!!!!!! и на них точно отработать, что именно, где и как менять !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Вопрос: Реквизит Основной договор контрагента - удален?

Добрый день.

Перестала работать обработка. Полез разбираться. В справочнике Контрагенты реквизит ОсновнойДоговор переименован в УдалитьОсновнойДоговор.
В справочнике ДоговорыКонтрагентов также нет соответствующего поля.
В конфигурации теперь можно отметить "Использовать как основной" произвольное количество договоров. Где это хранится, не нашел.

Не понятно и неудобно.

Поясните, пожалуйста, в чем логика и как теперь жить).
Как отметить договор программно "Основным", как выбрать основной договор?

1С:Предприятие 8.3 (8.3.7.1790)
Бухгалтерия предприятия, редакция 3.0 (3.0.43.29)
Ответ:
сегодня уже пришлось переписывать ПКО для контрагентов (конфигурации АвтоСервис-Бух30) с учетом этих нововведений
Вопрос: Привязка договора к контрагенту в СКД

Делаю отчет на СКД по регистру бухгалтерии по счету 60. Имею субконто1 = контрагент. Субконто2 = договор. Далее по этим полям делаю отбор. И СКД не привязывает договор к контрагенту по владельцу. Как это сделать с помощью СКД стандартными способами?
Ответ: () в скд, закладка Набор данных

Вопрос: Конвертация данных. Найти и подставить договор в документ-приемник.

Добрый день!

Нужен совет!

Платформа 8.2. Через "Конвертацию данных" настроен перенос документа из самописной конфигурации в "Бухгалтерию 2.0".

В документе-источнике есть реквизит "Контрагент", который благополучно передается в документ-приемник "Реализация товаров и услуг".
Но в документе-источнике (и вообще в самописке) отсутствует реквизит "Договор контрагента", который необходим для документа-приемника!
В "Бухгалтерии" у каждого "Контрагента" есть только один договор и он у всех называется "Основной договор".

Каким наиболее простым образом задать в Конвертации правило поиска и подстановки договора в документ-приемник?


Возможно, вопрос примитивен, но я с 1С сталкиваюсь лишь изредка.
Ответ:
wamaco
при загрузке:
Если ЗначениеЗаполнено(Приемник.Контрагент.ОсновнойДоговор) тогда
Значение = Приемник.Контрагент.ОсновнойДоговор.Ссылка;
КонецЕсли;


Спасибо за совет - навело на нужные мысли!

Удалось решить следующим образом:

В правиле конвертации объекта (ПКО), создающем Объект-приемник: "ДокументСсылка.РеализацияТоваровУслуг",
в обработчик события "После загрузки" внес следующий код:

"Объект.ДоговорКонтрагента = Объект.Контрагент.ОсновнойДоговорКонтрагента;"

т.е. уже после загрузки всего документа по контрагенту находится и подставляется договор.

Все получилось!

p.s. кстати пришлось пробежаться ручками по всем "Контрагентам" в "Бухгалтерии" и "влоб" указать, что "Основной договор" действительно является Основным.
Вопрос: Договора в БП3.0 при синхронизации с УТ11.2

Добрый день!
На данный момент используем последние актуальные версии УТ 11.2 и БП3.0. Двухсторонняя синхронизация по типовым правилам.
После перехода с УТ11.1 на 11.2 начались проблемы с договорами контрагентов в БП. В УТ работаем по соглашениям без использования договоров. в ут11.1 была настройка по формированию договоров в БП, а в 11.2 такой настройки нет. и сейчас, при создании нового контрагента и оформлении на него заказа клиента, после синхронизации с БП в БП создаётся Основной договор, причём "С поставщиком" . А после изменения и перепроведения заказа клиента в УТ и последующей синхронизации, в БП создаётся ещё один договор и тоже "С поставщиком", хотя клиент только покупатель.
Кто знает какой алгоритм формирования договора контрагента в БП при синхронизации с УТ11.2.? на линии консультаций говорят про настройку какая была в УТ11.1, но в УТ11.2 такой настройки нет. Или я не там смотрел?
И ещё, при загрузке выписок их клиент-банка, поступление БДС, по контрагентам которые вновь создаются, вид операции ставится "Возврат от поставщика", а всегда ранее у любого поступления на р/с вид операции был "Оплата покупателя".
Ответ:
Не может договор поручительства оформляться без присутствия самого поручителя.

Речь может вестись только о заключении такого договора представителем поручителя при наличии письменной доверенности.

Все, что Вы описываете - это противозаконные действия.
Вопрос: БП3, Основной договор контрагента

Добрый вечер.
В БП3 реквизит ОсновнойДоговорКонтрагента переехал в РегистрСведений, в принципе, для чего было сделано поняла, ок, привыкаем, под конец дня затык с вроде бы простейшим куском кода...
Пытаюсь проверить, есть ли у контрагента основной договор, если нет, создаю, помечаю что основной и тд.. Собственно, затык на проверке условия есть\нет. Не видит ни установленную программно пометку,что основной, ни вручную перещелкнутую неоднократно на форме. В сам регистр заглядывала, все имеется..

Отбор = Новый Структура;
                    Орг =Справочники.Организации.НайтиПоКоду("000000001"); 
                    Отбор.Вставить("Организация",Орг);
                    Отбор.Вставить("Контрагент",Док.Контрагент);
                    Отбор.Вставить("ВидДоговора",Перечисления.ВидыДоговоровКонтрагентов.СПокупателем);
                    
                    ДогВыборка= РегистрыСведений.ОсновныеДоговорыКонтрагента.Получить(Отбор);
                    
                    Док.ДоговорКонтрагента= ДогВыборка.Договор;
                    
                    Если Док.ДоговорКонтрагента=Дог.ПустаяСсылка() Тогда
Ответ: () а как же тогда все ваши предыдущие утверждения, что записи в регистре точно есть? то есть они были, но немножко с пустой организацией? :) а так да - есть
Вопрос: Конвертация данных: Установка основного договора в приемнике, если есть

Всем салют!
Есть задача, на которую пока не нашёл решения:
Рисую правила обмена в КД. Заказчик хочет, чтобы реквизиты договоров в объектах в приемнике (кроме владельца-контрагента) - заполнялись из контрагента (Контрагент.ОсновнойДоговор). А создавать и подставлять договор из данных источника только в том случае, если был создан новый контрагент в процессе конкретного обмена.

Опыта работы в КД маловато, хотелось бы получить совет, как это можно грамотнее реализовать.
Ответ: () А разве когда реквизит в параметр передаёшь он всё равно в базу пишется?

Мне в сам документ в на стороне приемника нужно подставлять основной договор контрагента. При этом создавать договор из источника нужно только тогда, когда заходит новый контрагент.
Если я воспользуюсь твоим вариантом, то договора к существующему контрагенту будут создаваться новые, т.к. поиск по ним возможен только по идентификатору, остальные поля в поиске не участвуют и не соответствуют равным значениям поиска, кроме владельца.
Вопрос: Копирование договора программно

Доброго времени суток! УТ 10.3. Стоит задача копировать документы реализации при создании (чтоб в дальнейшем редактировать только те, которые необходимы) с изменением организации... Создана рег. задание с методом
Процедура СкопироватьДокументыРеализации() Экспорт

Запрос = Новый Запрос;
Запрос.УстановитьПараметр("Орг",Справочники.Организации.НайтиПоКоду("УТ0000010"));
Запрос.УстановитьПараметр("ОргУпр",Справочники.Организации.НайтиПоКоду("УТ0000011"));
Запрос.УстановитьПараметр("Дата1",ТекущаяДата()-10);
Запрос.УстановитьПараметр("Дата2",ТекущаяДата()+10);
Запрос.Текст = "ВЫБРАТЬ
| РеализацияТоваровУслуг.Комментарий
|ИЗ
| Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
|ГДЕ
| РеализацияТоваровУслуг.Организация = &ОргУпр
| И РеализацияТоваровУслуг.Проведен = ИСТИНА
| И РеализацияТоваровУслуг.Дата МЕЖДУ &Дата1 И &Дата2";
Выборка = Запрос.Выполнить().Выбрать();
Список = Новый СписокЗначений();
Пока Выборка.Следующий() Цикл
Список.Добавить(Выборка.Комментарий);
КонецЦикла;

Запрос.УстановитьПараметр("Список",Список);
Запрос.Текст = "ВЫБРАТЬ
| РеализацияТоваровУслуг.Ссылка,
| РеализацияТоваровУслуг.Номер,
| РеализацияТоваровУслуг.Дата,
| РеализацияТоваровУслуг.Контрагент
|ИЗ
| Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
|ГДЕ
| НЕ РеализацияТоваровУслуг.Номер В (&Список)
| И РеализацияТоваровУслуг.Дата МЕЖДУ &Дата1 И &Дата2
| И РеализацияТоваровУслуг.Проведен = ИСТИНА
| И РеализацияТоваровУслуг.Организация = &Орг";
Выборка = Запрос.Выполнить().Выбрать();

Пока Выборка.Следующий() Цикл
Запрос.УстановитьПараметр("Контрагент",Выборка.Контрагент);
Запрос.Текст = "ВЫБРАТЬ
| ДоговорыКонтрагентов.Ссылка КАК Ссылка
|ИЗ
| Справочник.ДоговорыКонтрагентов КАК ДоговорыКонтрагентов
|ГДЕ
| ДоговорыКонтрагентов.Владелец = &Контрагент
| И ДоговорыКонтрагентов.Организация = &Орг";
ВыборкаДоговора = Запрос.Выполнить().Выбрать();
// ВыборкаДоговора.Следующий();

НовыйДокумент = Выборка.Ссылка.Скопировать();
НовыйДокумент.Дата = Выборка.Дата;
НовыйДокумент.Комментарий = Выборка.Номер;
НовыйДокумент.Организация = Справочники.Организации.НайтиПоКоду("УТ0000011");
НовыйДокумент.ДоговорКонтрагента = ВыборкаДоговора.Ссылка;

НовыйДокумент.Записать(РежимЗаписиДокумента.Проведение);
КонецЦикла;

КонецПроцедуры


Ошибка выдается, что заполнены не все обязательные реквизиты, в частности, договор... По ссылке скопировать как понимаю не получится...по такому запросу в консоли выдает такие данные...может как-то через код договора можно вставить в новый документ ?? Подскажите пожалуйста !!!! Заранее спасибо!!
Ответ:
посоветуйте пожалуйста что-нибудь ((( тот же прог.код работает на УТ 11....как быть с договором контрагента?(