Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: Проблема с подключением сканера штрихкода

Доброго времени суток коллеги.

Имеем УНФ 1.6 последний релиз, платформа последний релиз. Цепляем сканер штрихкода Datalogic 2100 с эмуляцией COM порта. В форме подключаемого оборудования тест проходит, в окте РМК товар сканирует.

Но !!!

Заходим другим пользователем и вуаля, в РМК сканер не видит, возвращаемся к прошлому пользователю видит. Загружаемся пользователем который не видит сканер идем в подключаемое оборудование делаем тест и ... он его видит, идем после теста в РМК и о чудо и там видит, закрываем программу и открываем заново ... опять не видит.

Может кто встречался с такой проблемой и подскажет в каком направлении с бубном скакать?
Ответ: Коллеги проблему решил частично.
Не работало на РМК кассира. Окно РМК было выбрано на главной странице для запуска автоматом.

Убрал с главной страницы и стали запускать вручную по команде РКМ и о чудо сканер всё читает.

В принципе не проблема так и оставим. Всем спасибо кто участвовал в обсуждении и плюсики в карму ;)
Вопрос: Проблема со сканером штрихкодов при переходе на 8.3 платформу

Здравствуйте.

Работаем на УТ 10.3, платформа 8.2 Хотим перейти на платформу 8.3, возникла проблема.

Сканер Honeywell 1450g USB-шный к 1С 8.2, подключается через 1С:Сканер Штрихкода версии 8.0.14.1 и выше (до 8.0.17.3), далее обработкой торгового оборудования 1CScanOPOSScan_v2.epf (стандартная 1С-ная), читает QR-коды.
При использовании платформы 1С 8.3 не воспринимаются 1С драйвера сканера - пишет "Драйвер не установлен", "Версия не определена".

Как побороть?

Заранее благодарен
Ответ: Понаставят 64-битных клиентов, а потом думают
Вопрос: Сканер штрихкодов

Всем доброго времени суток!
Платформа: 8.3.6.2390
Конфигурация: УТ 11.2.106

База находится на сервере. К этому серверу подключаются пользователи с разных мест.
Пользователи заходят в 1С, по "Аутентификация операционной системы"
Каждый пользователь прописывается в домене и заходит под своей доменной учетной записью.
Для каждого нового пользователя, приходится, каждый раз, проделывать, одну и туже операцию по добавлению возможности работать со сканером штрихкодов (COM разъем).
1.Приходится заходить в 1с, под администратором через CMD, доменная учётная запись при этом пользователя.
2.Запускаем обработку - "Подключение и настройка оборудования". Выбираем Сканер штрихкода -- Создать. Добавляем драйвер оборудования и настраиваем его.
Теперь заходим в 1С, под пользователем и сканер штрихкодов работает. Но стоит, на этом же компьютере, зайти под другим пользователем, как требуется всё это делать по новой, иначе сканер штрихкода не работает.
Кто-нибудь сталкивался с таким?
Как сделать, чтобы на данном компьютере, один раз поставив драйвер и настроив всё в 1С, под другими пользователями сканер штрихкодов, продолжал работать, без дополнительных манипуляций?
Ответ:
Можно попробовать настроить сканер в разрыв клавиатуры. Работа драйвера, вроде бы, никак не привязана к пользователю.
Вопрос: Сканер штрихкодов Symbol LS 1203

Всем привет! Подключаю к УТ 11 (11.1.9.61) сканер Symbol LS 1203 (USB). Сканер подключился, щтрихкод читает. Только одна проблема - порт сканера  определеился как клавиатура и для поиска штрихкода пользователю постоянно приходиться нажимать F7, потом сканировать штрихкод и нажимать ОК. Хочеться от этого уйти и добавлять товар в просто сканированием кода. Для это сканер нужно перевести в режим эмуляции ком-порта.
Вот отсюда скачал эмулятор ком-порта для этого сканера, установил, в описании дравера сказано, что для перевожда сканера в режим эмуляции ком-порта нужно отсканировать спец. штрихкод, идущий в руководстве, просмотрел все руководства по ссылке, ничего такого там не нашел. Сталкивался кто-нибудь? Как настроить этот сканер так, чтобы товар попадал в чек сразу после сканирования кода, без нажатия F7?
Ответ: () Я не знаю кто ты, но ты бог сканеров! Спасибо, все работает :)
Вопрос: Сканер штрихкода работает с задержкой 20 секунд

Добрый день!1с ут 11.3.4.47,после установки новых драйверов атол для работы ККМ атол 55ф, сканер штрихкода стал работать с 20секудной задержкой, прочитала что нужен платный драйвер атол для сканера. Подскажите, пожалуйста, какой именно драйвер нужен и сколько он стоит?Заранее спасибо.
Ответ: 1. Удаляются все драйвера
2. Устанавливается актуальный драйвер для ккм (расширенные настройки при установке, и снять галочку с "Драйвер устройств ввода") в отдельную папку
3. Устанавливается старый драйвер, только устройства ввода, в отдельную папку

А вообще почти со всеми современным сканерами УТ 11 работает с помощью родного драйвера 1С, без помощи атол
Вопрос: Подключение Сканера ШК (разрыв клавиатуры) к самописной конфе (упр.формы)

Доброго времени суток!!! Ребята, спасайте...

Есть самописная конфигурация на упр. формах и сканер ШК, который работает только в разрыв клавиатуры. Необходимо подключить к конфе.
Так, как метод подключения через назначение "Сочетание клавиш" по префиксу (")") не работает по РДП, пытаюсь подключить обработчик событий. Тестировал на стандартной конфигурации УТ3.1 украина(упр.формы, настройка сканера шк как клавиатуры), работало шикарно. Как сделать здесь, ума не приложу.
Что сделано:
В модуль Управляемого приложения добавлен следующий код.

"&НаКлиенте
Перем Драйвер;
ПриНачалеРаботыСистемы
Попытка 
        ПрогИД="AddIn.Scanner";
        ПодключитьВнешнююКомпоненту(ПрогИД);
        Драйвер = Новый (ПрогИД);
        Сообщить("Компонента для сканера штрих-кодов загружена!");
    Исключение
        Сообщить ("Невозможно подключить внешнюю компоненту!");
    КонецПопытки;
    
    Попытка 
        ВерсияИзДрайвера = Драйвер.ПолучитьНомерВерсии();
    Исключение
        Сообщить ("Невозможно определить версию драйвера!");
    КонецПопытки;
    
    Если Лев(СокрЛП(ВерсияИзДрайвера), 5) <> "8.0.8" Тогда 
        
        Сообщить("Версия драйвера "+ВерсияИзДрайвера+""); 
        
        //Сообщить ("Версия драйвера не поддерживается. Требуемая версия компоненты 1С:Сканер ШК - 8.0.8!");

    КонецЕсли;
    
    Если Драйвер.Подсоединить("Сканер штрихкода") <> 0 Тогда
        Сообщить ("Ошибка (1) при подключении устройства!");
    КонецЕсли;
    
    //при подключении USB-сканера с эмуляцией COM-порта указывать порт 5 в свойствах виртуального COM-порта в диспетчере устройств


    //сканер настроить - префикса нет, суффикс - CR


    Драйвер.БитДанных  = 8;
    Драйвер.Порт       = 0;
    Драйвер.Скорость   = 9600;
    Драйвер.СтопБит    = 0;
    Драйвер.СтопСимвол = 13//CR - carriage return

    
    Драйвер.Префикс = 40;
    Драйвер.ПрефиксСтрока = "(";      
    
    Драйвер.ИмяСобытия = "ПолученШтрихкод";
    
    Если Драйвер.Занять(1) = 0 Тогда
        Драйвер.УстройствоВключено = 1;
        Драйвер.ПосылкаДанных      = 1;
        Драйвер.ОчиститьВход();
        Драйвер.ОчиститьВыход();
        Сообщить("Сканер подключен и готов к работе!");
        Если Драйвер.УстройствоВключено <> 1 Тогда
            //Отключить();


            Драйвер.УстройствоВключено = 0;
            Драйвер.Освободить();
            Драйвер.Отсоединить();
            Сообщить ("Ошибка (2) при подключении устройства!");
        КонецЕсли;
    Иначе
        //Отключить();


        Драйвер.УстройствоВключено = 0;
        Драйвер.Освободить();
        Драйвер.Отсоединить();
        Сообщить ("Ошибка (3) при подключении устройства!");
    КонецЕсли;
"
Работает, пишет все ок.
далее в этом же модуле добавлены процедуры
"
Процедура ПередЗавершениемРаботыСистемы(Отказ)
    
    Если Драйвер <> Неопределено Тогда 
        Драйвер.УстройствоВключено = 0;
        Драйвер.Освободить();
        Драйвер.Отсоединить();
    КонецЕсли;
    
    
    Режим = РежимДиалогаВопрос.ДаНет;
    Текст = "Закрыть программу?";
    Ответ = Вопрос(Текст, Режим, 0);
    Если Ответ = КодВозвратаДиалога.Нет Тогда
        Отказ = истина;
    КонецЕсли;
КонецПроцедуры

&НаКлиенте
Функция ОбработатьСобытие(Данные) Экспорт
    ШтрихКод = Данные;
    Драйвер.ПосылкаДанных = 0;
    Возврат СокрЛП(ШтрихКод);
КонецФункции

&НаКлиенте
Функция СобытиеОбработано() Экспорт
    Драйвер.ПосылкаДанных = 1;
КонецФункции"
Фактически весь код модуля перечислен, но внешнее событие не работает в модуле документа
Ответ: а все оказалось банальнее, чем я думал...
В модуле управляемого приложения не было процедуры ОбработкаВнешнегоСобытия(Источник, Событие, Данные).

При сканировании, выполняется код этой процедуры, а потом переходит в модуль открытого документа в ВнешнееСобытие(Источник, Событие, Данные).

Спасибо всем за внимание и подсказки/советы.

За аналог была взята статья:
Вопрос: получит данные со сканера штрихкода (работа с com портом)

конфигурации нету, просто платформа.
написал внешнюю обработку, в которой есть диалоговое окно "ШтрихКОд"
хочется передать в него данные со сканера, а как не знаю...
поискал по просторам нашел пару строчек кода и внешнюю компонентку "MSCOMM32.OCX":

Процедура ПриОткрытии()

Попытка 
    Драйвер=СоздатьОбъект("MSCOMMLib.MSComm.1"); 
Исключение 
    Предупреждение("Не могу создать объект");    
    Возврат; 
КонецПопытки; 
Драйвер.CommPort = 5;  // COM1 

Драйвер.Settings = "9600,N,8,1"; 
Попытка 
    Драйвер.PortOpen=1; 
Исключение 
    Предупреждение("Не могу открыть порт");    
    Возврат; 
КонецПопытки; 
Если Драйвер.PortOpen=0 Тогда 
    Предупреждение("Не открыт порт");    
    Возврат; 
КонецЕсли;  
Сообщить("Создан объект "+Драйвер+" и включен");
КонецПроцедуры
//*******************************************

Процедура ПриЗакрытии()
    Драйвер.PortOpen=0; 
    Драйвер=0; 
КонецПроцедуры

процедуры отрабатывают без ошибок.
Подскажите как получить данные со сканера. что должно срабатывать при считывании сканером штрихкода, какая-то процедура или функция и пихать данные в переменную?
Ответ: () спасибо.
не все намеки понял, буду смотреть эту процедуру.
Вопрос: USB Сканер штрихкода не сканирует на улице

добрый день. Купили USB Сканер штрихкода Меркурий CL-600. Внутри помещения сканер работает, когда сканируем товар выложенный на улице он не видит штрихкод. Прикрываем рукой тоже не получается отсканировать.

это можно как-то исправить? товар обычно выгружаем и сразу же отправляем частями клиентам.
Ответ: Меркурии достаточно дешевые модели и возможно, что там ставят не очень хорошие чувствительные элементы, которые плохо работают при дневном свете. Хотя вообще это довольно странно. Выходит, вам обязательно нужно тестирование при покупке. Попадавшиеся мне ранее ТСД на андроиде с имидж-элементом прилично сканировали на улице, из недостатков отмечал только то что навестись на код трудно - светового пятна на ярком свету почти не видно.
Вопрос: Сканер штрихкода и обработка

Здравствуйте, есть сканер штрихкода китайский работает как клавиатура, переводит коретку на следующий строчку.
Обработка в ней ТЗ, мне нужно сканировать штрихкод и чтобы попадал в ТЗ, сейчас работает так нажимаешь добавить строчку сканируешь добавляется, еще раз сканируешь он на соседние поле переходит. а должен создавать следующию строчку.
Каким событием это дело отлавливать?

Ответ:
а где ответ на мой вопрос ?
Вопрос: Сканеры штрихкодов и маленький экран

Может кто знает, как в "Вопрос("",...);" перенести кнопки ответа?
У меня есть сканер штрихкодов, работающий по RDP с 1С 8.2 УПП. У сканера очень маленький экран и сам текст вопроса переносится, но вот у кнопок появляется скролл. Хотелось бы перенести одну из кнопок ниже и желательно увеличить их рамку.
Ответ: () Нууу, можно конечно, но выглядит не очень красиво. Поэтому хотелось бы использовать встроенную.