Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: КА 1.1.107.4 - проблемы с архивацией на СУБД Postgres Pro

Исходные данные :
КА 1.1.107.4 с мелкими доработками
Платформа 8.3.9.2170
СУБД Postgres Pro 9.4

Все работало стабильно почти 2 года, пока не обновил конфу на релиз 1.1.107.4 .
Заметил, что перестали восстанавливаться архивы созданные с помощью pg_dump.

Начал разбираться и выяснил, что pg_dump в процессе архивации выдает ошибки :

pg_dump: Ошибка выгрузки таблицы "config": сбой в PQgetResult().
pg_dump: Сообщение об ошибке с сервера: Р?РЁР?Р'Р?Р?:  invalid memory alloc request size 1174829507
pg_dump: Выполнялась команда: COPY public.config (filename, creation, modified,attributes, datasize, binarydata) TO stdout;

Переносил базу на другие сервера , менял версии Postgres (9.6 и 10.5), менял платформу (8.3.9.2309 и 8.3.10.2772) - результат тот же, pg_dump не может нормально создать архив.

При постановке конфы обратно на поддержку архивация начинает работать нормально.

Как можно решить проблему?
Ответ: () Но воспроизводится он только на демоконфигурациях версий 1.1.107.х.
Вопрос: Перенос данных по com соединению

Всем здравствуйте. Задача такая: Имеется 2 идентичные базы УПП. Необходимо перенести движения с Р.С.Работники организаций в Р.С.Работники (данный регистр не заполнялся, он пустой). Без создания документов. Есть аналогичная обработка, с переносом аналитики вроде.
Выгрузить набор регистраторов с базы источника вроде получилось. Загвоздка в том, чтоб загрузить теперь данные в приемник. Т.к. в данных регистрах есть такие реквизиты, как подразделения и должности. в которых используются 2 разных справочника: в первом Подразделения организаций и Должности организаций, во втором Подразделения и Должности. Данные справочники можно сравнить по коду и наименованию. Эти данные у них одинаковые. Только как можно это сделать???
Процедура по выгрузке регистраторов из исочника:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
Процедура ЗагрузитьДанныеВТаблицы(Кнопка)     
    ТаблицаРегистраторовКОМ.Очистить();//загрузка наборов движений РСРаботникиОрганизации
    ИндексТаблицаРегистраторовКОМ = 0;
    
    База = Неопределено;
    Соединение = Неопределено;
    
    Если Не ПроверкаПодключения(База, Соединение) Тогда
        Возврат;
    КонецЕсли;
    
    Попытка
        ЗапросКОМ = Соединение.NewObject("Запрос");
        ЗапросКОМ.Текст = 
        "ВЫБРАТЬ
        |   РаботникиОрганизаций.Регистратор.Ссылка КАК Регистратор,
        |   РаботникиОрганизаций.Регистратор.Представление КАК Представление
        |ИЗ
        |   РегистрСведений.РаботникиОрганизаций КАК РаботникиОрганизаций
        |ГДЕ
        |   РаботникиОрганизаций.Период МЕЖДУ &ДатаНачала И &ДатаОкончания
        |
        |УПОРЯДОЧИТЬ ПО
        |   РаботникиОрганизаций.Регистратор.Дата
        |АВТОУПОРЯДОЧИВАНИЕ";
    
    ЗапросКОМ.УстановитьПараметр("ДатаНачала", ДатаНачало);
    ЗапросКОМ.УстановитьПараметр("ДатаОкончания", ДатаОкончание);
    
    ВыборкаКОМ = ЗапросКОМ.Выполнить().выбрать(); 
 
        Пока ВыборкаКОМ.Следующий() Цикл
            НовыйРегистратор = ТаблицаРегистраторовКОМ.Добавить();
            НовыйРегистратор.Ссылка = ВыборкаКОМ.Регистратор;
        КонецЦикла;
        
    Исключение
        ТекстОшибки = СформироватьТекстСообщения(ОписаниеОшибки());
        Сообщить (ТекстОшибки);
        Предупреждение (ТекстОшибки);
        Отказ = Истина;
        Возврат
    КонецПопытки;   
    Если ТаблицаРегистраторовКОМ.Количество() > 0 Тогда
        
        СравнитьИсточникПриемник();
        ЭлементыФормы.Пропустить.Доступность    = Истина;
        ЭлементыФормы.Записать.Доступность      = Истина;
    Иначе
        Предупреждение ("Не обнаружено объектов для записи!");
        ЭлементыФормы.Пропустить.Доступность    = Ложь;
        ЭлементыФормы.Записать.Доступность      = Ложь;
    КонецЕсли;
    
КонецПроцедуры
Остальные процедуры взяты из похожей обработки, они не изменены, если необходимы просто для примера и ознакомления:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
Процедура СравнитьИсточникПриемник()  
    
    Регистратор = ТаблицаРегистраторовКОМ[ИндексТаблицаРегистраторовКОМ].Ссылка;        
    Представление = ТаблицаРегистраторовКОМ[ИндексТаблицаРегистраторовКОМ].Представление;
    Набор = Регистратор.Получитьобъект().Движения.Налоговый;
    Набор.Прочитать();
    
    ЭлементыФормы.ТаблицаДвиженийКОМ.Значение=ЗначениеИЗСтрокиВнутр(Соединение.ЗначениеВСтрокуВнутр(Набор.Выгрузить())); 
    ЭлементыФормы.ТаблицаДвиженийКОМ.СоздатьКолонки();
    
    Запрос = Новый Запрос;
    Запрос.Текст = 
    "ВЫБРАТЬ ПЕРВЫЕ 1
    |   НалоговыйДвиженияССубконто.СчетДт,
    |   НалоговыйДвиженияССубконто.СчетКт,
    |   НалоговыйДвиженияССубконто.Регистратор.Ссылка КАК Регистратор
    |ИЗ
    |   РегистрБухгалтерии.Налоговый.ДвиженияССубконто(&нПериода, &кПериода, Регистратор = &РегистраторКОМ, , ) КАК НалоговыйДвиженияССубконто";
    
    Запрос.УстановитьПараметр("кПериода", ДатаОкончание);
    Запрос.УстановитьПараметр("нПериода", ДатаНачало);
    Запрос.УстановитьПараметр("РегистраторКОМ", ЗначениеИзСтрокиВнутр(Соединение.ЗначениеВСтрокуВнутр(Регистратор)));
    
    Выборка= Запрос.Выполнить().Выбрать();
    
    Пока Выборка.Следующий() Цикл
        мДокумент=Выборка.Регистратор;
        мДокументКОМ=  ЗначениеИзСтрокиВнутр(Соединение.ЗначениеВСтрокуВнутр(Представление));
        ДокументКОМ= ЗначениеИзСтрокиВнутр(Соединение.ЗначениеВСтрокуВнутр(Представление));
        Сообщить(  Выборка.Регистратор);
        Сообщить( "в удален.базе"+мДокументКОМ)  ;
        Набор =  Выборка.Регистратор.Получитьобъект().Движения.Налоговый;       
        Набор.Прочитать();
        ЭлементыФормы.ТаблицаДвижений.Значение=Набор.Выгрузить();
        ЭлементыФормы.ТаблицаДвижений.СоздатьКолонки();     
    КонецЦикла; 
    
    ВизуальноеСравнение ();
    
КонецПроцедурЫ
Процедура загружает данные в приемник
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
Процедура  ЗагрузитьВсеНажатие(Элемент)
    
    Сообщить("Обработка запущена: "+ТекущаяДата()+", пожалуйста, дождитесь окончания. " );
                
    
    ТаблицаРегистраторовКОМ.Очистить();
    ИндексТаблицаРегистраторовКОМ = 0;
    
    База = Неопределено;
    Соединение = Неопределено;
    
    Если Не ПроверкаПодключения(База, Соединение) Тогда
        Возврат;
    КонецЕсли;
    
    Попытка
        ЗапросКОМ = Соединение.NewObject("Запрос");
        ЗапросКОМ.Текст = 
        "ВЫБРАТЬ РАЗЛИЧНЫЕ
        |   НалоговыйДвиженияССубконто.Регистратор.Ссылка КАК Регистратор
        |ИЗ
        |   РегистрБухгалтерии.Налоговый.ДвиженияССубконто(
        |           &нПериода,
        |           &кПериода,
        |           СчетДт.Ссылка = &СчетОтбора
        |               ИЛИ СчетКт.Ссылка = &СчетОтбора,
        |           ,
        |           ) КАК НалоговыйДвиженияССубконто
        |
        |УПОРЯДОЧИТЬ ПО
        |   НалоговыйДвиженияССубконто.Регистратор.Дата";
        
        ЗапросКОМ.УстановитьПараметр("СчетОтбора",Соединение.ПланыСчетов.Налоговый.НайтиПоКоду(Счет.Код));
        ЗапросКОМ.УстановитьПараметр("нПериода", ДатаНачало);
        ЗапросКОМ.УстановитьПараметр("кПериода",ДатаОкончание);  
        
        ВыборкаКОМ = ЗапросКОМ.Выполнить().выбрать();       
        
        Пока ВыборкаКОМ.Следующий() Цикл
            НовыйРегистратор = ТаблицаРегистраторовКОМ.Добавить();
            НовыйРегистратор.Ссылка = ВыборкаКОМ.Регистратор;
        КонецЦикла;
        
    Исключение
        ТекстОшибки = СформироватьТекстСообщения(ОписаниеОшибки());
        Сообщить (ТекстОшибки);
        Предупреждение (ТекстОшибки);
        Отказ = Истина;
        Возврат
    КонецПопытки;   
    
    //если регистраторов больше 0
    Если ТаблицаРегистраторовКОМ.Количество() > 0 Тогда
        
        СравнитьИсточникПриемникТЗ();
    Иначе
        Сообщить("Не обнаружено объектов для записи!");
    КонецЕсли;
    Сообщить("Обработка завершена:  "+ТекущаяДата());   
    
    
КонецПроцедуры
Ответ:
Сообщение от Nenaviju1C
Конвертация данных тебе в помощь.
причем и делается достаточно быстро
Вопрос: Форма с 2-мя динамическими списками

Есть форма журнала с динамическим списком собственно журнала (произвольный запрос к журналу банковских без параметров) и выпиской (произвольный запрос к журналу банковских с параметрами дата, р/счет). При открытии дата = текущая дата, р/счет по умолчанию, обе оба списка заполняются. При изменении параметров выписки журнал пропадает. Кто-нибудь сталкивался? Может, нельзя делать запросы к одной и той же таблице?
Ответ: кеширование одной таблицы двумя динсписками..
Вопрос: В движении Банковской выписки вместо списания с р/с ставит выдача из кассы ...

В движении Банковской выписки вместо списания с р/с ставится выдача из кассы при том, что в этом же движении корректно указана проводка Д70-К51

в КУДИР соотв. выдача из кассы и попадает.

Помогите кто знает ...
Ответ: Как вариант решения подобной проблемы без конфигуратора, здесь есть внешняя обработка:

Вопрос: БП 2.0, Поступление на р/с, проводка в кредит УСН.02 - откуда сумма?

Есть два Поступления, в одном из них какая сумма в документе, такая и в проводках в кредит 62 и УСН.02, и в 4 графу КУДиР.

А вот в другом - в кредит УСН.02 сумма больше на сумму агентского вознаграждения; и в 5 графе КУДиР эта разница появляется с минусом.

Второй вариант правильный.

Только за счет чего так получается и почему в первом случае не так?
Иными словами, откуда берется в УСН.02 другая сумма?

Документооборот одинаковый в обоих случаях, есть Реализации к этим оплатам, в них сумма бОльшая, плюс ручные операции на агентское вознаграждение.
Ответ: Возможно надо чтобы вообще все положенные документы были, "Отчет комитенту" и т.п., а их нет. Чтобы зачет аванса произошел (этого тоже нет).

Но если нет аванса то и без Отчета комитенту почему-то работает.
Вопрос: Виды операций Списание с р\с

Добрый день.
Вопрос в следующем. Есть база Бух 3.0.49.23 В ней 2 организации.
Зарплата ведется в другой программе (в настройках стоит флажок).
Если делаем списание с расчетного счета по первой организации в видах операций есть Перечисление заработной платы по ведомостям и Перечисление заработной платы работнику. Если выбираем другую организацию - этих видов операций нет.
Ответ: Завел новую организацию - нет этих видов операций...
Вопрос: БП 2.0 Учёт авиабилетов. Поступление ден. док. не берётся договор с поставщиком

При оприходовании авиабилетов документом Поступление денежных документов: Поступление от поставщика(!) не даёт выбирать договор с видом С поставщиком (даёт только Прочее) Это бага или фича? Если ставить договор Прочее, тогда не получится по нему оприходовать сервисный сбор(комиссию агента) ПТиУ, т.к. там можно только С поставщиком. Получается что и оплату двумя Списаниями с р/с делать с разными договорами?
Ответ:
Из справки

Контрагент - поставщик, от которого поступили денежные документы.
Договор - договор с контрагентом. Должен иметь вид "прочее".

Шиза же
Вопрос: Нарастающий итог с конца. Метод ЛИФО в запросе.

Здравствуйте.
Конфигурация Управление торговлей 10.3.
Необходим отчет на СКД со следующими условиями:
По контрагенту есть движения по по документам взаиморасчетов - реализации, возвраты, оплаты и т.д.
Взаиморасчеты ведутся по договору в целом. Т.к. учет ведется давно, то изменять ведение договоров по документам уже не вариант.
По контрагенту висит определенная сумма долга, например 312 500 р. При формировании отчета необходимо выделять последние неоплаченные реализации.
Метод ФИФО в запросе не подходит, т.к. для реализации отчета нарастающий итог по документам нужно суммировать не с начала, а с конца от самых последних документов.
Ответ:
Андрей, у ТС ведь суть не в том чтобы просто нарастающий итог посчитать, а в том чтобы выделить неоплаченные накладные (при том что первая накладная может быть не оплачена частично).
Вопрос: флажок "По документам расчетов с контрагентами" - зачем?

В контексте решения проблем на УПП 1.3.88.1, УСН(Д-Р) + ЕНВД с отнесением ПРЕДоплаты банковскими картами (и продаж через РТиУ) по договору эквайринга на ЕНВД, возник вопрос из прочтения:
  • Как восстановить взаиморасчеты с контрагентами в 1С 8.2 по ФИФО

    Цитирую:
    "Первое что нужно проверить это стоит ли галочка «По документам расчетов с контрагентами»
    Если галки нет (изображение №2) то хорошо, если есть то нужно убрать, иначе взаиморасчеты не восстановятся."
Блин, я что-то вообще туплю. А зачем, тогда, вообще эта галочка (в договоре контрагента), если, не убрав её, нельзя восстановить взаиморасчеты?
Ответ:
Вероятно, подразумевается, что автоматически не восстановятся, т.к., на сколько я помню, в УПП документы расчетов нужно было вручную указывать в документах: нажимать на кнопку заполнения авансов, либо указывать заказ/реализацию, в платежках.
Вопрос: БП 3.0, ЕНВД и УСН, реализация с оплатой картой заходит КУДиР как доходы УСН

Здравствуйте!
БП 3.0 , применяется ЕНВД и УСН(доходы-расходы)
При создании документа реализации товаров и услуг и оплате картой документ поступления на расчетный счет делает движение в КУДиР на доходы УСН, в настройках налогов и отчетов добавил ЕНВД на подразделение, в реализации, операции по платежной карте, поступлении на р/с указал подразделение, перепровел документы движения так же как доход УСН, вообще возможно настроить так чтобы поступления по карте от физлиц учитывались как доход ЕНВД?
Сам тему не нашел, везде пишут что нужно оформлять отчеты о розничных продажах, если можете, ткните пальцем)
Ответ: Я дорабатывал Поступление на РС анализируя документы Розничная продажа и Оплата платежной картой

Все довольны.....