Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: Выбирается не та организация при создании заказа((

В форме документа заказа клиента у нас сделано, чтобы при создании нового заказа всегда по-умолчанию выставлялось выбранное в настройках соглашение:
Код:
   Если Объект.Ссылка.Пустая() Тогда
     Объект.Соглашение = Константы.Соглашение.Получить();     
   КонецЕсли;
Но при этом почему-то организация всегда не соответствует той, что указана в соглашении.

Подскажите пожалуйста, что и куда дописать/изменить, чтобы организация тоже выставлялась по этому соглашению?

УТ 11,3 проф
Ответ:
Пожалуйста, "Решено" напишите в заголовке!
Это автор может сделать, но не другие рядовые участники

Вопрос: Решено Выбирается не та организация при создании заказа((

В форме документа заказа клиента у нас сделано, чтобы при создании нового заказа всегда по-умолчанию выставлялось выбранное в настройках соглашение:
Код:
   Если Объект.Ссылка.Пустая() Тогда
     Объект.Соглашение = Константы.Соглашение.Получить();     
   КонецЕсли;
Но при этом почему-то организация всегда не соответствует той, что указана в соглашении.

Подскажите пожалуйста, что и куда дописать/изменить, чтобы организация тоже выставлялась по этому соглашению?

УТ 11,3 проф
Ответ:
Пожалуйста, "Решено" напишите в заголовке!
Это автор может сделать, но не другие рядовые участники

Вопрос: 1c 8.2 - запретить создание документа на основании по условию

Добрый день!

Нужно чтобы если сумма документа > 1000 была возможность создавать документ на основании


Подскажите как в документе отключить возможность создавать на основании. Вот что у меня получилось:


Процедура ТоварыПриИзменении(Элемент)

		СуммаДокумента = Объект.Товары.Итог("Сумма");
		
		Если СуммаДокумента <1000 тогда
			
			
		Иначе
			
			
		Конецесли;
Заранее спасибо!

КонецПроцедуры
Ответ:
trew
[В подписке нет у документа ввода на основании.
В подписке есть событие обработка заполнения.
Вопрос: Создание номенклатуры на основании другой номенклатуры программно

8.3 ERP

Нужно создать такую же номенклатуры с такими же свойствами только немного изменить наименование. Как это можно сделать быстро?
Ответ: ага спасибо, ступил
Вопрос: [РЕШЕНО] При создании на основании не заполняются добавленные реквизиты

Уважаемые эксперты,
КА-2.2.2.199
В табличной части Товары документа ЗаказКлиента создал новые реквизиты (СрокГарантии, СрокДействияЛицензии, тип - Дата).
Как сделать, чтобы значения этих реквизитов переносились в ТЧ Товары документа РеализацияТоваровУслуг при создании РТУ на основании Заказа?
Если руками в ОбработкеЗаполнения добавляю эти реквизиты:
Код:
        Запрос.Текст = "ВЫБРАТЬ
                       |    ЗаказКлиента.Товары.(
                       |        СрокГарантииНач КАК НачалоГарантии,
                       |        СрокГарантииКон КАК КонецГарантии,
                       |        СрокДействияЛицензии КАК СрокЛицензии,
                       |        КоличествоПользователей КАК Пользователи
                       |    )
                       |ИЗ
                       |    Документ.ЗаказКлиента КАК ЗаказКлиента
                       |ГДЕ
                       |    ЗаказКлиента.Ссылка = &Заказ";
                   
           Запрос.УстановитьПараметр("Заказ",Заказ);
           Выборка = Запрос.Выполнить().Выбрать();
        Пока Выборка.Следующий() Цикл
            ВыборкаТовары = Выборка.Товары.Выбрать();
            Пока ВыборкаТовары.Следующий() Цикл
                Объект.Товары.СрокГарантииНач = ВыборкаТовары.СрокГарантииНач;
                Объект.Товары.СрокГарантииКон = ВыборкаТовары.СрокГарантииКон;
                Объект.Товары.СрокДействияЛицензии = ВыборкаТовары.СрокДействияЛицензии;
                Объект.Товары.КоличествоПользователей = ВыборкаТовары.КоличествоПользователей;
            КонецЦикла;
        КонецЦикла;
        
то страшно ругается: Поле объекта не обнаружено.
В чем моя ошибка?
Спасибо!
Ответ:
Сделал вот так в ОбработкеЗаполнения модуля документа РеализацияТоваровУслуг:
Код:
    Если ТипЗнч(ДанныеЗаполнения.ДокументОснование) = Тип("ДокументСсылка.ЗаказКлиента") Тогда
        Заказ = ЭтотОбъект.ЗаказКлиента;
        Запрос = Новый Запрос();
        Запрос.Текст = "ВЫБРАТЬ
                       |    ЗаказКлиента.Товары.(
                       |        СрокГарантииНач КАК НачалоГарантии,
                       |        СрокГарантииКон КАК КонецГарантии,
                       |        СрокДействияЛицензии КАК СрокЛицензии,
                       |        КоличествоПользователей КАК Пользователи,
                       |        Характеристика
                       |    )
                       |ИЗ
                       |    Документ.ЗаказКлиента КАК ЗаказКлиента
                       |ГДЕ
                       |    ЗаказКлиента.Ссылка = &Заказ";
                  
           Запрос.УстановитьПараметр("Заказ",Заказ);
           Выборка = Запрос.Выполнить().Выбрать();
        Пока Выборка.Следующий() Цикл
            ВыборкаТовары = Выборка.Товары.Выбрать();
            Пока ВыборкаТовары.Следующий() Цикл
                НайденнаяСтрока = ЭтотОбъект.Товары.Найти(ВыборкаТовары.Характеристика, "Характеристика");
                НайденнаяСтрока.СрокГарантииНач = ВыборкаТовары.НачалоГарантии;
                НайденнаяСтрока.СрокГарантииКон = ВыборкаТовары.КонецГарантии;
                НайденнаяСтрока.СрокДействияЛицензии = ВыборкаТовары.СрокЛицензии;
                НайденнаяСтрока.КоличествоПользователей = ВыборкаТовары.Пользователи;
            КонецЦикла;
        КонецЦикла;
    КонецЕсли;
Всё работает.
Спасибо!
Вопрос: (Внешняя обработка) Создание Отчета производства за смену на основании Реализации

Всем привет!.
Насколько знаю в типовом функционале БП 3.0 не предусмотрена процедура создания Отчета производства за смену на основании Реализации, но есть такая потребность. Может кто-нибудь помочь обработкой если таковая есть в наличии?

Заранее спасибо за помощь и комментарии!
Ответ:
Отправил.
Вопрос: Не могу создать заказ услуги поставщику на основании заказа клиента

Здравствуйте,
1С:Предприятие 8.3 (8.3.6.2332)
Управление торговлей, редакция 11.1 (11.1.10.185)
Имеется заказ клиента, который содержит товары и услугу (доставку).
В столбце "действие" можно выбрать только 2 варианта "отгрузить" и "не обеспечивать".
Как настроить возможность создания заказа услуги у поставщика, можно ли как-то включить вариант "обеспечивать"?
Ответ:
Остаток услуг посмотреть на складе нельзя. Речь не об этом. Заказ поставщику услуг можно сделать в ручном режиме, создаем заказ выбираем номенклатура "доставка" и проводим, далее оформляем приход товаров и услуг - услуга оказана, на складе эта операция не отражается. Вопрос - как сделать это на основании заказа клиенту (как для товаров).
Вопрос: Программное создание перемещения на основании заказа на перемещение в ут11

Подскажите. Делаю программно перемещение на основании заказа на перемещение. в подобных ситуациях передавал ссылку заказа. НовыйДок.Заполнить(Ссылка). Но это не работает. Посмотрел отладчиком  стандартный вариант там передается структура.  Как ее заполнить и чем заполнить. Склад ордерный.
Ответ: () Спасибо что подсказал где копать. все получилось
Вопрос: Как привязать оплату, полученную за заказ через агента, к заказу клиента

Подскажите, пожалуйста, как правильно отразить в 1С 8.3 УТ 11 следующую ситуацию. Есть заказ клиента-физического лица. Непосредственно заказ был доставлен клиенту агентом, который оказывает услуги доставки. Соответственно, деньги от клиента за заказ получил агент. Агент переводит нам деньги от клиентов за доставленные заказы по графику на наш счет. В 1С заведен клиент и агент. Заказ создан на клиента. Как теперь привязать полученные от агента деньги клиента к этому выполненному заказу. Стандартно 1С позволяет оформить входящее платежное поручение только непосредственно на клиента, выбрав в основании соответствующий заказ. А как привязать деньги, полученные от агента за заказ, к заказу клиента?
Спасибо заранее.
Ответ: Полностью ситуация выглядит так:

Клиент-физическое лицо, которое разместило заказ в интернет магазине.
Партнер-юридическое лицо, которое в качестве агента оказывает услуги по доставке заказа клиенту, получению от клиента оплаты за заказ и услуги доставки и перечислению оплаты от клиента со своего счета на счет интернет-магазина за вычетом своей комиссии.
Сумма заказа – 1000 руб.
Сумма за доставку, установленная в интернет-магазине, - 200 руб.
Фактическая стоимость услуг агента (комиссия) составила 220 руб., включая:
Услуги доставщика через агента 180 руб.
Непосредственно вознаграждение агента 40 руб. (это расчетная величина, поэтому сразу ее получить невозможно и может быть ситуация, когда цена за доставку в интернет-магазине будет меньше фактической суммы услуг агента: в магазине стоимость доставки 200 руб., а стоимость услуг агента по факту составила 220 руб.)
По факту получится следующий порядок расчетов:
Клиент заказал товаров на 1000 руб. + 200 руб. за доставку.
Агент получит от клиента после доставки заказа 1200 руб.
Агент перечислит доставщику 180 руб.
Из полученной суммы от клиента агент также удержит свою комиссию 40 руб.
По факту агент перечислит на счет магазина: 1200 руб. – 180 руб. – 40 руб. = 980 руб.
Вот, что сейчас заведено в 1С.
1)    Заведен клиент-физическое лицо
2)    Заведен партнер-агент
3)    Заведен заказ клиента с двумя позициями: 1) сам товар 1000 руб. 2) услуги доставки 200 руб. (из списка номенклатуры с видом номенклатуры «Услуга»)
4)    Заведен документ реализации товаров и услуг на основании заказа на сумму 1200 руб.
Вопрос: Производство из давальческого сырья под заказ клиента в ЕРП, КА

Коллеги, помогите разобраться, как обособить выпуск продукции переработчиком под заказ клиента. В заказе переработчику указано назначение (клиент, заказ клиента). В поступлении от переработчика поле "Назначение" не редактируемое. Как оформить получение продукции под заказ клиента?
Ответ: () а что у тебя в НСИ-Производство-Переработка на стороне - обособление сырья и материалов стоит ?