Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: 1С УТ11.4 Серии в списании недостач

Коллеги, день добрый.

Ввожу в работу УТ 11.4 (11.4.1.241) , и застрял на интересном моменте работы со списанием товара.
Включен в условно Склад 1 - ордерный склад. В условно Товар 1 - использовать серии и сроки годности, метод "Управление по FEFO остатками серий".
Делаю поступление, выбраю склад 1 и товар 1 - предлагает ввести серию. Ввожу.
Делаю реализацю части оприходованного товара, выбираю склад 1 и товар 1 , жму заполнить серии по FEFO, заполняет - списывает по остаткам правильно.
Делаю списания недостач товаров, выбираю склад 1 и товар 1, и тут понимаю что предложения списать серии - нет. Так же как и нет в "Видах запаса".
При проведении документа соответственно, со склада этот товар появляется отдельной строкой с остатком = -1, а тот что с серией - не трогается.

Думал что дело в ошибки релиза, но обновление до 11.4.2.109 результата не дало. Там так же списание уходит в минуса.

Кстати контроль остатков включен, но документ чудесным образом склад в красноту.
Может я где галочку какую забыл поставить?
Ответ: Нашел то, что документ ввода начальных остатков , делает в справочнике Ключей аналитики учета номенклатуры запись , где серия не указывается. Склад и номенклатура есть, а вот серия - пусто.
При этом при реализации я вижу по FEFO свободный остаток этой серии.
Однако судя по всему документ Списание недостач опирается на этот ключ, а в ключе соответственно нет серии.
Либо я запутался либо , либо копаю не туда, либо я где то ошибся в документе ввода начальных остатков. Может статус указания серий - 8 , это не то?
Вопрос: erp 2.2 Почему Списание недостач товаров не делает движ по РН.Партии товаров организации

Почему Списание недостач товаров не делает движ по РН.Партии товаров организации. Каким документом нужно списывать товары, чтобы их кол-во уменьшилось в Ведомости по партиям товаров?
Ответ: кстати в партионном учете 2.2 все партии только в регистре себестоимости
Вопрос: УТ 11.4 Списание недостач не работает

Только запустились на УТ, нужно списать просроченный товар.
Из справки "Если недостача товара обнаружена на неордерном складе, то оформляется финансовый документ Списание недостач товаров". Т.е. никаких актов или пересчётов товаров.

Если делаем отдельный документ, то остатки списываются только с организации. На складе продолжают висеть. Так же эти товары висят по регистру "Товары к оформлению излишков и недостач" и прделагается оформить по ним акты инвентаризации. Я блин просто списать хочу, а не провести инвентаризацию с пересчётом товаров...

Можно внутренним потреблением, но это же не по фен шую.
Ответ: () серий нет, есть партии на основе характеристик
Вопрос: Списание с ордерного склада с помещением

Доброго времени суток!
Платформа: 1С:Предприятие 8.3 (8.3.8.1652)
Конфигурация: Управление торговлей, редакция 11.2 (11.2.3.189)

Есть ордерный склад с помещениями. Необходимо с этого склада, с определенного помещения, списать товар. Создаю документ "Списание недостач товаров" провожу документ. И по регистру "ТоварыОрганизации" списание проходит, а вот по регистру "ТоварыНаСкладах" нет.
В документе списания ,помещение выбрать нельзя, только склад.
Ответ:
Остатки по складу надо двигать документом "Пересчёт товаров". Т.е. логика такая - сначала создаем документ "Пересчёт товаров", а уже потом, на основании пересчёта товаров, "Списание недостач товаров"
Вопрос: Неверный расчет суммы при списании материалов

Добрый день! Работаем в 1С: Комплексная автоматизация 1.1. Недавно ввели партионный учет. Делаем списание ГСМ требованием-накладной . В печатной форме документа видим неверный расчет суммы списания. Например, 262,27Л *37,42 = 9814,94 (ЭТО В ПРОГРАММЕ 1с) , а если на калькуляторе то 9814,14 получается, разница 0.80 коп. Где искать ошибку?
Ответ: () Посмотрите остаток по этой позиции. Возможно это окончательный остаток себестоимости по партии. Вот и списывает то, что осталось, а не то, что рассчитано. Чтобы в минус не уйти
Вопрос: Движение в регистре остатки при списании по среднескользящей стоимости(учет партийный)

Народ, нужно разобраться. Нужно организовать метод списания товаров по ФИФО и среднескользящей стоимости. По ФИФО разобрался нормально списывает. Не могу понять как списывать при среднескользящей.Как организовать движения в регистре Остатки при переходе списания с фифо на среднескользящую.

Добавлено через 3 минуты
Вот мой код
//Запрос ...

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
Если Не Средняя Тогда
         Пока Дерево.Следующий() Цикл 
             ОсталосьСписать = Дерево.Количество;
             Выборка = Дерево.Выбрать();
             Пока Выборка.Следующий() И ОсталосьСписать <> 0 Цикл
                 КСписанию = МИН(ОсталосьСписать,Выборка.КоличествоОстаток);
                         СуммаСписания = ?(Выборка.КоличествоОстаток = КСписанию, 
                         Выборка.СуммаОстаток,
                         Выборка.СуммаОстаток/Выборка.КоличествоОстаток*КСписанию);
                         
                    Движения.ОстаткиТоваров.Записывать = Истина;
                    Движение = Движения.ОстаткиТоваров.Добавить();
                    Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
                    Движение.Период = Дата;
                    Движение.Регистратор = Ссылка;
                    Движение.Товар = Выборка.Товар;
                    Движение.Склад = Склад;
                    Движение.Организация = Организация;
                    Движение.Количество = КСписанию;
                    Движение.Партия = Выборка.Партия;
                    Движение.Сумма = СуммаСписания;
                    ОсталосьСписать = ОсталосьСписать - КСписанию;
                КонецЦикла;
             
         КонецЦикла;                     
     Иначе 
         Пока Дерево.Следующий() Цикл
             СуммаСписания = Дерево.СуммаОстаток/Дерево.КоличествоОстаток*Дерево.Количество;
             Движения.ОстаткиТоваров.Записывать = Истина;
            Движение = Движения.ОстаткиТоваров.Добавить();
            Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
            Движение.Период = Дата;
            Движение.Регистратор = Ссылка;
            Движение.Товар = Дерево.Товар;
            Движение.Склад = Склад;
            Движение.Организация = Организация;
            Движение.Количество = Дерево.Количество;
            Движение.Сумма = СуммаСписания;
         КонецЦикла;
    КонецЕсли
Добавлено через 53 секунды
При такой реализации получаются отрицательные остатки и лишние движения в регистре остатков
Ответ: Ясно, благодарю)

Добавлено через 4 минуты
Еще вопрос, если не отвлекаю, списание по среднескользящей стоимости это одно и то же, что и списание по средней стоимости?
Вопрос: Розница 2 Акт списания ЕГАИС Помарочное списание

Здравствуйте!
С 01.01.2018 общепит обяжут списывать алкоголь с использованием сканера штрих кода.
В документе Акт списания ЕГАИС есть кнопка "Акцизные марки" нажимаю туда, там не чего нет, пусто.
Подскажите пожалуйста как в документе Акт списания ЕГАИС использовать сканер. В какой момент сканировать акцизу.
Спасибо!
Ответ: Общепит... Раньше списывали все через документ Списания без акцизы со 2 регистра и только по алкоду. Документ по версии 2. Сейчас пытаюсь все по документации добавить акцизу и выдает ошибку:
<A><error>org.xml.sax.SAXParseException; cvc-complex-type.2.4.a: Invalid content was found starting with element 'awr:MarkCode'. One of '{MarkCode}' is expected.</error><ver>2</ver></A>

Пытаюсь отправить:
<?xml version="1.0" encoding="UTF-8"?>
<ns:Documents Version="1.0" xmlns:xsi="; xmlns:ns= "; xmlns:pref="; xmlns:oref="; xmlns:awr= ";
<ns:Owner>
<ns:FSRAR_ID>0200ххх</ns:FSRAR_ID>
</ns:Owner>
<ns:Document>
<ns:ActWriteOffShop_v2>
<awr:Identity>1</awr:Identity>
<awr:Header>
<awr:ActNumber>1</awr:ActNumber>
<awr:ActDate>2017-12-20</awr:ActDate>
<awr:TypeWriteOff>Реализация</awr:TypeWriteOff>
<awr:Note>Розничная реализация продукции, не подлежащая фиксации в ЕГАИС</awr:Note>
</awr:Header>
<awr:Content>
<awr:Position>
<awr:Identity>1</awr:Identity>
<awr:Product>
<pref:Type>АП</pref:Type>
<pref:UnitType>Packed</pref:UnitType>
<pref:FullName>Российское шампанское полусладкое белое "Абрау-Дюрсо"</pref:FullName>
<pref:AlcCode>0012389000001423573</pref:AlcCode>
<pref:Capacity>0.75</pref:Capacity>
<pref:ProductVCode>450</pref:ProductVCode>
<pref:Producer>
<oref:UL>
<oref:ClientRegId>010000000146</oref:ClientRegId>
<oref:FullName>Закрытое акционерное общество "Абрау-Дюрсо"</oref:FullName>
<oref:ShortName>ЗАО "Абрау-Дюрсо"</oref:ShortName>
<oref:INN>2315092440</oref:INN>
<oref:KPP>231501001</oref:KPP>
<oref:address>
<oref:Country>643</oref:Country>
<oref:RegionCode>23</oref:RegionCode>
<oref:description>РОССИЯ,353995,КРАСНОДАРСКИЙ КРАЙ,,Новороссийск г,Абрау-Дюрсо с,Промышленная ул,19,, | здание завода шампанских вин, за исключением помещений 2 этажа №№ 97,98; цех минеральной воды, тоннель № 16, за исключением подземных помещений 1 этажа №№ 1, 4-20, 2 этажа №№ 35-48; тоннель № 13, Литер: Б1бб1; соединительный тоннель, Литер: В; тоннели, Литер: Б; строение 1, цех переработки винограда; строение 2, "Биохимкомплекс"</oref:description>
</oref:address>
</oref:UL>
</pref:Producer>
</awr:Product>
<awr:Quantity>2</awr:Quantity>
<awr:MarkCodeInfo>
<awr:MarkCode>22N000003DZJ812CHCL09K5708200010063213NEW0YHIJ7KSCIIZхххххххххххх</awr:MarkCode>
<awr:MarkCode>22N000003DZJ812CHCL09K5708200010063224UXAT6XLV1хххххххххххххххх</awr:MarkCode>
</awr:MarkCodeInfo>
</awr:Position>
<awr:Position>
<awr:Identity>2</awr:Identity>
<awr:Product>
<pref:Type>АП</pref:Type>
<pref:UnitType>Packed</pref:UnitType>
<pref:FullName>Водка "ЦАРСКАЯ ОРИГИНАЛЬНАЯ"</pref:FullName>
<pref:AlcCode>0378114000001323897</pref:AlcCode>
<pref:Capacity>0.5</pref:Capacity>
<pref:ProductVCode>200</pref:ProductVCode>
<pref:Producer>
<oref:UL>
<oref:ClientRegId>010054002523</oref:ClientRegId>
<oref:FullName>Общество с ограниченной ответственностью "Группа ЛАДОГА"</oref:FullName>
<oref:ShortName>ООО "Группа ЛАДОГА"</oref:ShortName>
<oref:INN>7810406643</oref:INN>
<oref:KPP>781001001</oref:KPP>
<oref:address>
<oref:Country>643</oref:Country>
<oref:RegionCode>78</oref:RegionCode>
<oref:description>РОССИЯ,196158,САНКТ-ПЕТЕРБУРГ Г,,,,Московское ш,д. 13,, | корп. 6, литера Б, Д | корп. 6,литера А, пом. 1 в 1Н (S=776,5 кв.м)</oref:description>
</oref:address>
</oref:UL>
</pref:Producer>
</awr:Product>
<awr:Quantity>1</awr:Quantity>
<awr:MarkCodeInfo>
<awr:MarkCode>22N00002VF285LMM35L83R671031001126080I2XGAO1V6HPZ5MUHXххххххххххххххххх</awr:MarkCode>
</awr:MarkCodeInfo>
</awr:Position>
</awr:Content>
</ns:ActWriteOffShop_v2>
</ns:Document>
</ns:Documents>



Что не так???
Вопрос: v7: УСН 15% - списание товаров на собственные нужды, момент признания расходов

Доброго времени суток! Насколько понимаю с 2009 года для отнесения стоимости материалов на расходы достаточным условием является факт их оприходования от Поставщика и оплаты Поставщику. Насколько оно обязательно? То есть имеем право отнести сразу после поступления и оплаты, а можем и позднее по факту списания. Или же обязаны отнести в момент поступления и оплаты, а относить позднее по факту списания права не имеем?
Речь про товары для собственных нужд, когда часть товаров используются организацией для себя, их переводят из товаров в материалы, и затем списывают как материалы на прочие затраты по торговой деятельности. Корректно ли будет принимать на расходы стоимость таких материалов-товаров после их списания на затраты? Или нужно в первичном документе поступления дробить товары, выделяя из них материалы? Но ведь поступление может быть в предыдущем отчетном периоде, и исправить его уже проблематично.
Ответ: то есть изначально закупается партия товара, потом спустя некоторое время часть этого товара используют на собственные нужды, то есть перевод товар в материал и списывают на затраты.
Вопрос: Реализация метода списания по фифо

Всем привет необходимо организовать метод писания фифо списание товара по партиям.
Есть код, который частично работает. Версия 8.2

Код 1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
Процедура ОбработкаПроведения(Отказ, Режим)
    
       Движения.Товары.Записывать = Истина;
 
    Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |   Реализация_товаров_услугТовар.НомерСтроки КАК НомерСтроки,
        |   ЕСТЬNULL(ТоварыОстатки.КоличествоОстаток, 0) КАК Остаток,
        |   Реализация_товаров_услугТовар.Номенклатура КАК Номенклатура,
        |   Реализация_товаров_услугТовар.Количество КАК Количество,
        |   ТоварыОстатки.СтоимостьОстаток,
        |   ТоварыОстатки.КоличествоОстаток,
        |   ТоварыОстатки.Партия
        |ИЗ
        |   Документ.Реализация_товаров_услуг.Товар КАК Реализация_товаров_услугТовар
        |       ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.Товары.Остатки(&МоментВремени, ) КАК ТоварыОстатки
        |       ПО Реализация_товаров_услугТовар.Номенклатура = ТоварыОстатки.Номенклатура
        |
        |УПОРЯДОЧИТЬ ПО Партия.Дата  ВОЗР
        |ИТОГИ
        |   МИНИМУМ(НомерСтроки),
        |   МИНИМУМ(Остаток),
        |   МИНИМУМ(Количество)                        
        |ПО
        | Номенклатура";
 
        Запрос.УстановитьПараметр("МоментВремени", МоментВремени());
    Запрос.УстановитьПараметр("Ссылка",Ссылка);
 
        Результат = Запрос.Выполнить();
        Выборка = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
                             
Пока Выборка.Следующий() Цикл
        Если Выборка.Количество > Выборка.Остаток  Тогда
               Сообщение = Новый СообщениеПользователю;
               Сообщение.Текст ="Не хватает товара" ""+ Выборка.Номенклатура
               +""", из необходимых " +
               Выборка.Количество + " в наличии осталось только" +
               Выборка.Остаток;
              Сообщение.Поле = "Товар[" + (Выборка.НомерСтроки-1)  + "].Количество";
               Сообщение.УстановитьДанные(ЭтотОбъект);
               Сообщение.Сообщить();
               
             Отказ = Истина;
             Движения.Товары.Записывать = Ложь;
 КонецЕсли;
КонецЦикла;
 
 
Если Отказ Тогда
         Возврат;
         КонецЕсли;
         
         Выборка.Сбросить();
         
Пока Выборка.Следующий()  Цикл
                   
        ОсталосьСписать= Выборка.Количество;        
        ВыборкаПартии=Выборка.Выбрать();
        
        
Пока  ВыборкаПартии.Следующий()  Цикл
            
        Списать = Мин (ОсталосьСписать, ВыборкаПартии.КоличествоОстаток);
        
        Себестоим = Списать / ВыборкаПартии.КоличествоОстаток*ВыборкаПартии.СтоимостьОстаток;       
        
        Движение = Движения.Товары.Добавить();
        Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
        Движение.Период = Дата;
        Движение.Номенклатура = Выборка.Номенклатура;
        Движение.Количество = Списать;
        Движение.Стоимость=Себестоим;
        Движение.Партия= ВыборкаПартии.Партия;
        
        ОсталосьСписать=ОсталосьСписать-Списать;
        
КонецЦикла;
    
КонецЦикла;
         
КонецПроцедуры
При попытки полностью продать первую партию он считает количество товара во второй но стоимость берет из первой. Провел 15 товаров рассчитал стоимость по 1 партии. Появилась непонятная пустая строка. Если попробовать продать другой товар то он его не продает, не хочет переходить на новую партию. В чем тут причина. Заранее спасибо.
Ответ: Первое. Параметр "Ссылка" вы в запрос передаете, а упомянуть об этом условии в запросе вы забыли =)
Второе. Зачем столько циклов? 1 раз получили результат запроса, зашли в группировку, проверили на общее количество (По всем партиям) - Если не хватает "Отказ = истина".
Далее если "НЕ Отказ" - сохраняем нужное для списания количество, идем в детальные записи по партиям:
1. Пока НЕ КСписанию = 0
2.Проверяем количество в партии, если больше чем надо - списываем все что надо, обновляем переменную КСписанию. Если меньше - списываем всю партию, обновляем переменную КСписанию, но так как она не равна 0 цикл поведет нас к след партии.
Вопрос: ЕГАИС. Ошибка передачи акта списания в ЕГАИС.

1С:розница 2.2. Выдает ошибку передачи в ЕГАИС актов списания,которые  формируются программой автоматически при закрытии смены. Информация об ошибке: " Не найдена продукция в торговом зале (код продукции "0036195000001238924"). Владелец ["030000062533"], акт списания ["a3d46218-5d92-4604-a238-99b47ffe7ca6"-"AWOS-0062501888"], позиция "1". Импорт содержимого акта списания из торгового зала." Как исправить? Некоторые акты проводит, некоторые нет,передачи в торговый зал никогда не было, при загрузке остатков торгового зала из ЕГАИС все по нулям,имеются остатки только на складе. Почему некоторые акты проводятся,а некоторые нет
Ответ: и списывать даёт, скорее всего пиво.