Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: Какие права в 1с8.3 бух чтобы отображались дополнительные отчеты и обработки?

Тема уже поднималась:


Решения там нет.
Кратко: БП 3.0.54.15 Пользователь входит в группу прав "Менеджер по продажам", дополнительно в настройках прав пользователю в группу в которую он входит выставила права на "Дополнительные отчеты и обработки", "Чтение дополнительных отчетов и обработок", этот пункт меню все равно не отображается.
Ответ: попробуй
Добавление и изменение дополнительных отчетов и обработок
Вопрос: Справка дополнительного отчета

Доброго дня, коллеги!
УТ11.3 перепиленная на половину. БСП ("доп. отчеты и обработки"), разумеется, не трогали.
Написал отчетик, добавил его как внешний, но справки нет! Хотя я её добавил. Подскажите, почему лыжи не едут? Мазь есть!
Ответ: Такое ощущение, что остальные просто не хотят встревать в твой диалог с собой)))
Вопрос: УТ11 Программный вызов дополнительного отчета

Уважаемые специалисты, подскажите пожалуйста, по какой причине программное открытие отчета из дополнительных отчетов и обработок в случае ограниченного пользователя может не работать? Неверно выполняется оператор Форма = ПолучитьФорму( "ВнешнийОтчет.КартаЛояльности.Форма" ); - возвращается Неопределено. У пользователя с полными правами в переменную Форма возвращается правильный объект. Перед этим происходит успешное выполнение ДополнительныеОтчетыИОбработкиВызовСервера.ПодключитьВнешнююОбработку( ВыполняемаяКоманда.Ссылка );

И еще - если открывать таким образом отчет на СКД, то проходит успешное открытие отчета. Ошибка валится, если мне надо во внешнем отчете открыть форму.
Ответ: Разобрался - чтобы открывалась моя форма (а не отчет) - надо было делать не ДополнительныйОтчет, а ДополнительнаяОбработка.
Вопрос: Некорректно подключается внешний отчет

Сделал внешний отчет на СКД, в модуле отчета добавил:

Функция СведенияОВнешнейОбработке() Экспорт

  ПараметрыРегистрации = Новый Структура;
  ПараметрыРегистрации.Вставить("Вид", "ДополнительныйОтчет");
  ПараметрыРегистрации.Вставить("Наименование", "Расчетсебестоимости");
  ПараметрыРегистрации.Вставить("Версия", 2.0);
  ПараметрыРегистрации.Вставить("БезопасныйРежим", Ложь);
  ПараметрыРегистрации.Вставить("Информация", "АльтернативныйРасчетСебестоимости на основе валовой прибыли");
  ПараметрыРегистрации.Вставить("ВерсияБСП", "1.2.1.4");
  ТаблицаКоманд = ПолучитьТаблицуКоманд();
  ДобавитьКоманду(ТаблицаКоманд, "Открыть", "ОткрытьОтчет", "ОткрытиеФормы", Истина);
  ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);
  Возврат ПараметрыРегистрации;

КонецФункции

Функция ПолучитьТаблицуКоманд()

  Команды = Новый ТаблицаЗначений;
  Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
  Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
  Возврат Команды;

КонецФункции

Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")

  НоваяКоманда = ТаблицаКоманд.Добавить();
  НоваяКоманда.Представление = Представление;
  НоваяКоманда.Идентификатор = Идентификатор;
  НоваяКоманда.Использование = Использование;
  НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
  НоваяКоманда.Модификатор = Модификатор;

КонецПроцедуры


Регистрирую отчет через Администрирование - Дополнительные отчеты и обработки.
Проблема в том, что после добавления отчета его не видно в указанном разделе.
Посмотрев имеющий другой внешний отчет заметил разницу в форме настройки отчета (см.скриншоты):

К сообщению приложен файл. Размер - 63Kb
Ответ: в справочнике внеш. обработок/отчетов всегда был хелп с описаловом что должно быть
Вопрос: Не меняется СКД после добавления отчета в справочник "Дополнительные отчеты и обработки"

Добрый день!
Помогите разобраться!
Платформа 8.3, создаю отчет на СКД, добавляю его в справочник.
Потом появляется необходимость изменить отчет, изменить СКД. Сохраняю его как внешний, пытаюсь менять, отчет не реагирует на изменения. Т.е добавляю поле, не добавляется, добавляю параметр, он в настройках появляется, но не учитывает его, даже ошибку не выдает, если его не задавать.
Кэш чистила, настройки отчета (на закладки настройки в СКД) полностью заменяла, удаляла - добавляла новые, заменяла настройки стандартными, сохраняла - загружала. Ничего не помогает.
Помогает только выгрузить схему в файл и затем загрузить в совершенно новый отчет.
Но такой метод, как вы понимаете, не очень красивый, да и пользовательские настройки полностью грохаются.
Кто сталкивался, что делаю не так?
Ответ: () спасибо!!
Вопрос: Разделение типоаого отчета Бух корп. с сохранением типовой расшифровки полей.

Вопрос по типовой конфигурации Бух. Корп. версии 8.3

Вкратце суть вопроса в следующем.

Есть типовой, встроенный в конфигурацию отчет. например "ВедомостьАмортизацииОСБухгалтерскийУчет".

Как сделать несколько внешних отчетов на базе данного отчета, поместив их в стандартное хранилище Дополнительные отчеты и обработки, но при этом, оставив типовой механизм расшифровки полей данного отчета, с помощью процедуры

Процедура РезультатОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка)
    
    БухгалтерскиеОтчетыКлиент.ОбработкаРасшифровкиСтандартногоОтчета(ЭтаФорма, Элемент, Расшифровка, СтандартнаяОбработка);

КонецПроцедуры.

Для того, чтобы поместить все созданные внешние отчеты в "дополнительные отчеты и обработки", надо задать уникальные имена.

Но чтобы отработал стандартный функционал расшифровки полей отчета

Общий модуль  БухгалтерскиеОтчетыВызовСервера
Функция ПолучитьПараметрыРасшифровкиОтчета(Адрес, ИдентификаторОбъекта, Расшифровка) Экспорт    
    ......
    ПараметрыИсполненияОтчета = Отчеты[ИдентификаторОбъекта].ПолучитьПараметрыИсполненияОтчета();

Имена отчетов необходимо оставить такими же, какими они были у исходного, иначе появляется ошибка.
Поле объекта не обнаружено. Например: {ОбщийМодуль.БухгалтерскиеОтчетыВызовСервера.Модуль(2103)}: Поле объекта не обнаружено (ВедомостьАмортизацииОСБухгалтерскийУчетСвернутая)
    ПараметрыИсполненияОтчета = Отчеты[ИдентификаторОбъекта].ПолучитьПараметрыИсполненияОтчета();

И не совсем понятно как правильно обойти данную ситуацию. Дорабатывать типовые модули, для подмены имени не хочется. Так как конфигурация обновляемая. Вносить все отчеты в конфигурацию, тоже не вариант.  

Может кто сталкивался уже с такой задачей.  Какие есть варианты решения?
Ответ: Спасибо большое. буду разбираться с расширением
Вопрос: УНФ внешний отчет как добавить в дополнительные

Доброе утро!

Управляемые формы, УНФ. Создала внешний отчет. Через Файл-Открыть открывается, все работает.

Добавляю в дополнительные отчеты, зарегистрировала, добавлен. При запуске пишет ошибку

{ОбщийМодуль.ОбщегоНазначения.Модуль()}: Значение не является значением объектного типа (Метаданные)
    Запрос.Текст =

подскажите, пожалуйста, в чем может быть проблема?
Ответ: () Перед НГ фото в профиле уже недостаточно. Необходимо участие в конкурсе
Вопрос: В отчет не выводятся данные

База УТ 11.1. Есть очень простой отчет на СКД. Он добавлен в дополнительные отчеты. Запрос использует данные только одного регистра - ВыручкаИСебестоимостьПродаж. Отчет нормально работает у пользователей с полными правами, у продавцов же - не выводится ничего (ну разве что только параметры сверху). Права на чтение регистра у продавца есть. Очевидно, это что что-то с правами - так я думал. Однако, всё вовсе не очевидно. Стал добавлять разные роли (через профили групп доступа, как это положено в УТ11), но ничего не менялось. Это немного надоело и я добавил в тестовой базе продавцу ВСЕ роли, что есть для профилей, кроме админских (а это всё, кроме ПолныхПрав). И... ничего не изменилось... Я в растерянности... В консоли запросов данные у продавца нормально выводятся. Хелп...
Ответ: окк
Вопрос: Глобальные изменения: внешние отчеты и обработки

Приветствую!

Есть задача по типу: раньше мы брали показатели так то а теперь нужно брать так-то - заменить везде )))

Ок. В конфигурации можно выполнить поиск (Ctrl+Shift+F), найти где используется и поменять.

Сложнее быть со внешними отчетами и обработками, хранимыми в конфигурации - как по ним искать?
Может есть у кого обработка которая выгружает все дополнительные отчеты и обработки из базы на диск? (тогда можно будет по файлам искать)
Ответ: За это время можно было сделать уже. Зайти в общий модуль, посмотреть как там сделано и на основе этого написать свою обработку. Там по сути все сводится к "ПолучитьФайл" ("НачатьПолучениеФайлов").

Не по теме:

Это при условии, что у вас нет личной жизни и вы по выходным тоже работаете ; )

Вопрос: Использование Веб-Сервисов в дополнительной обработке с использованием БСП

Добрый день!
Во фреше необходимо встроить дополнительную обработку, которая будет обращаться к веб-Сервису другой базы. Обработка конечно же в безопасном режиме, однако "допускается использование расширения безопасного режима библиотеки стандартных подсистем (возможность работать с файлами, с ресурсами сети Интернет и т.д.) через специализированный программный интерфейс с регистрацией разрешений, необходимых дополнительному отчету/обработке."

Однако не могу найти в текущей версии БСП как настроить это. помогите, пожалуйста

Версия базы во фреше:
Бухгалтерия предприятия, редакция 3.0 (3.0.59.45)
БСП 2.4.5.31
Ответ: oO