Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: Выборка из справочника списка дат без учета времени

Производство, конфигурация с нуля своя.
Есть некий справочник ТестЭлПрочности с реквизитом ДатаПрохождения (Дата и время) где хранятся результаты прохождения изделиями теста на прочность электрической изоляции. Из этого справочника надо сформировать список уникальных дат без учета времени. Ну, грубо говоря, если в справочнике есть три записи за одну дату с разным временем, в итоговый список должна попасть только одна дата.
Голову сломал, помогите, пожалуйста.
Ответ: Dimsson, Тип Дата всегда содержит время. Чтобы даты можно было сравнивать без учета времени их нужно привести к одинаковому времени, обычно это начало суток.

1C
1
ТекДата = НачалоДня(Выборка.ДатаПрохождения);
(Формат здесь лишнее).

Сообщение от Dimsson
Вопрос про где лучше хранить: в справочнике или в регистре сведений
Назначение справочника ТестЭлПрочности пока непонятно, но если это просто тупо набор выполненных тестов со временем их выполнения, то регистр сведений будет лишний, реквизита достаточно.
Вопрос: Выгрузка табеля учета посещаемости детей с формулами в Excel

Добрый день народ, Проблема такая пытаюсь сделать выгрузку из 1с БГУ 1.0 табеля учета посещаемости детей в файл excel с формулами, но не могу доделать до конца. Сделал следующее (имеется кнопка на форме табеля сохранить в Excel) выгружает в Excel и заполняет формулами три столбца( Пропущено дней(всего,в том числе засчитываемых) , Дни посещения, подлежащие оплате). Три формулы проходит циклом все нормально проставляет формулы. Но внизу где запись ( Всего отсутствует детей по каждому дню) не могу сделать формулу для расчета неявок то есть букву н.
Кусочек кода где не могу разобраться:

Для СчСтолбцов1=10 По 40 Цикл
Для Сч1=13 По ВсегоСтрок1 Цикл


Если СокрЛП(Лист.Cells(Сч1,3).Text)="Всего отсутствует детей" ТОГДА


Лист.Cells(Сч1,СчСтолбцов1).FormulaLocal = "=СЧЁТЕСЛИ(J"+Сч1+":J"+Сч1+";""н"")"; //вот тут надо думать

Иначе
Продолжить;
КонецЕсли;
Сч1= Сч1+1;
КонецЦикла;
КонецЦикла;
КонецЕсли;
Помогите пожалуйста разобраться и доделать садов много 70 учреждений в нашем районе.

Вложения:

  • Размер файла:
    24,9 КБ
    Просмотров:
    3
  • Размер файла:
    236,6 КБ
    Просмотров:
    7
Ответ:
Сам табель Ексель файл из 1С бгу 1.0 то что получилось

Вложения:

  • Размер файла:
    145,5 КБ
    Просмотров:
    4
Вопрос: Табель учета времени

Приветствую друзья!

Кто-нибудь сталкивался с такой проблемой. Работник заполнил табель

А при печати выгружает несуществующие дни


Как исправить эту ошибку?
Ответ: Верно F9, все исправил, спасибо!
Тему можно закрывать.
Вопрос: Табель учета рабочего времени, сводно в целом за период в ЗУП 3?

Доброго дня!

Перехожу с ЗУП 2.5 на 3.0/1. В ЗУП 2.5 есть Табель учета рабочего времени, сводно в целом за период, а в ЗУП 3 - не нашел. В ЗУП 2.5 через  
табель учета рабочего времени, сводно в целом за период, вводили данные об отработанных часах для расчета надбавок в зависимости от часов по графику рабочего времени сотрудника(с учетом отклонений)- часы явка.Добавляли колонки по своим видом времени и вводили в них часы. Расчетчику все было видно, наглядно.

Пожалуйста, посоветуйте, а как теперь в  ЗУП 3 можно реализовать такой функционал не меняя конфигурацию,не создавая свой объект?
Ответ: () если злоупотреблять им то да, Тора не рекомендует им пользоваться
Вопрос: ЗУП 2.5 табель учета рабочего времени, не заполняются ночные

Здравствуйте уважаемые. С зуп 2.5 хз, что творится. В табеле учета рабочего времени не проставляются ночные. На той неделе расчетчик делал по двум остальным подразделениям - все в порядке. Вчера вводит по последнему - ночных нет. Индивидуальные графики введены. В общем все как обычно. Причем я проверил, решил перезаполнить уже проведенные документы по остальные подразделениям, и там не заполнилось. Что могло слететь?
Ответ: Вообще ничего не понимаю. Настроек не меняли. По сути уже на 3 перешли, а тут надо то было сделать пару вещей. Уже мозг с утра взрывается.
Вопрос: Учет рабочего времени -вахтовый метод работы

Добрый день!
Подскажите пожалуйста, как настроить программу так, чтобы в табеле учета рабочего времени отражалась вахта, межвахтовый отпуск . Полазив на форумах, уже сделала:
1. По итогам месяца вахтовикам положена оплата за дни работы и время в пути, выплаты за междувахтовый отдых и надбавка за вахтовый метод работы. Чтобы задать алгоритм расчета этих выплат, в Основные начисления организации добавила:
- Оклад по часам (вахта); (вытеснением межвахтового отдыха и времени в пути)
- Оклад по часам (вахта в пути);
- Междувахтовый отдых;
- Надбавка за вахтовый метод.

2. Составила график работы сменный для примера (месяц, 6 дней в неделю по 11 часов за некотрым искл)

3. На закаладке "Расчет зп" ввела постоянные начисления" для примера по одному сотруднику рисунок (там есть и вахта в пути, и межвахта и вахта (работа). В плановых начмслениях ввела размер надбавки и кол-во дней надбавки


таким образом у меня график работы заданный (пункт 2) не совпадает с фактическим (пункт 3). Зарплата рассчитана верно. Но табель рабочего времени не верен . Межвахтовый отдых 1-3 число рассчитывается исходя из 8 часов (а в табеле указана вахта, как по графику работы, а не по факту) время в пути отражено буковй П, но по часам тоже не верно, почему-то 6 и 11) и далее... Подскажите, что я делаю не так?
Ответ:
1. Ну смотря на график у Вас в графике норма настроена на Шестидневку написано.
2. Да с 6 по 31 т.к время в пути они у Вас вытесняют Оклад. Если он должне получать одновременно и Оклад и Межвахту и Оклади и время в пути тогда убирайте вытеснения и ставьте на вкладке время ка дополнительное за уже оплаченое.
3. Я уже Вам написал что исходя из чего рассчитывается это все равно, программа делает вытеснение, сколько по графику. т.к ему по графику положено быть в это время а его нет.на работе
Т.е у него должна стоять была Я 11 часов но его не было он был в отпуске и стоит ОТ 11 часов так же и с важим меж вахтой должне был отрабоать 11 часов но нет у него межвахта, оплачиваема исходя из.... Либо тогда переовдите его на это день на 5 дневку.
Тросто вы не путайте Табель формы Т-13 Это табель учета Отработанного времени. Т.е как я писан он должен был отработать так вот стоит отработал сколько по факту
просто есть еще и табль формы Т-12 это немного другое.
Вопрос: Табель учета рабочего времени

Доброго времени суток!
Помогите, пожалуйста. С 16 января человек на больничном и не известно по какое число еще будет болеть, поэтому неявка еще не закрыта (в неявках и болезнях все проведено) и начисления по больничному соответственно нет. При начислении зп за январь ему начисляется оклад за полный месяц. Попробовала завести на него табель, но табель автоматически заполняется следующим образом: рабочие дни стоят - явка, а в выходные дни проставляет больничные... Что я делаю не так?
Заранее спасибо за ответ!
Ответ:
Спасибо большое, помогло. Просто когда считала зп за первую половину месяца табель закрывался нормально. Видимо обновление какое-то прошло...
Вопрос: Табель и состояние сотрудников

Доброго времени суток. Прошу помощи у Вас. Суть проблемы вот в чем - есть классификатор использования рабочего времени - там присутствуют такие записи как Больничный неоплачиваемый - Т, Простои по вине работника - ВП. Когда создаем документ - Неявки и болезни, и хотим выбрать один из данных вариантов использования рабочего времени, то таковых нет. Нашел где добавляются в коде (Общие модули - ПроцедурыУправленияПерсоналом) - сделал 2
записи в перечислениях (СостоянияРаботникаОрганизации) и в коде так же добавил 2 записи выбора из перечислений:

Код:
Функция ПолучитьСписокПрочихСостоянийРаботника() Экспорт
СписокСпособов = Новый СписокЗначений;

СписокСпособов.Добавить(Перечисления.СостоянияРаботникаОрганизации.Заболевание);
СписокСпособов.Добавить(Перечисления.СостоянияРаботникаОрганизации.Работает);
СписокСпособов.Добавить(Перечисления.СостоянияРаботникаОрганизации.ПоУходуЗаРебенком);
СписокСпособов.Добавить(Перечисления.СостоянияРаботникаОрганизации.Простой);
СписокСпособов.Добавить(Перечисления.СостоянияРаботникаОрганизации.ОтсутствуетПоНевыясненнойПричине);
СписокСпособов.Добавить(Перечисления.СостоянияРаботникаОрганизации.ОтпускПоБеременностиИРодам);
СписокСпособов.Добавить(Перечисления.СостоянияРаботникаОрганизации.ВынужденныйПрогул);
СписокСпособов.Добавить(Перечисления.СостоянияРаботникаОрганизации.ГосударственныеОбязанности);
СписокСпособов.Добавить(Перечисления.СостоянияРаботникаОрганизации.Прогулы);
СписокСпособов.Добавить(Перечисления.СостоянияРаботникаОрганизации.ДополнительныеВыходныеДниОплачиваемые);
СписокСпособов.Добавить(Перечисления.СостоянияРаботникаОрганизации.ТравмаНаПроизводстве);
СписокСпособов.Добавить(Перечисления.СостоянияРаботникаОрганизации.Протезирование);
СписокСпособов.Добавить(Перечисления.СостоянияРаботникаОрганизации.Карантин);
СписокСпособов.Добавить(Перечисления.СостоянияРаботникаОрганизации.ПоУходуЗаВзрослым);
СписокСпособов.Добавить(Перечисления.СостоянияРаботникаОрганизации.ПособиеПриДолечивании);
СписокСпособов.Добавить(Перечисления.СостоянияРаботникаОрганизации.БолезньБезОплаты);
СписокСпособов.Добавить(Перечисления.СостоянияРаботникаОрганизации.ПростойПоВинеРаботника);

Возврат СписокСпособов

КонецФункции // ПолучитьСписокПрочихСостоянийРаботника()
Теперь в документе я могу выбирать, но вот в чем весь затык - при формировании табеля учета рабочего времени, данные состояния не попадают со своим кодом - проставляется Я - Явка, вместо того что должно быть. Подскажите в каком направлении идти, чтобы табель стал брать верные состояния сотрудника.
Ответ:
Им надо объяснить, что табель существует не только для того, чтобы они его распечатали и красиво подшили, а еще и используется при расчете зарплаты. И, если в табеле будут неправильно проставлены часы и виды времени, то и зарплата может рассчитаться неправильно.
А т.к. табель строится на основе расчетных, а не кадровых документов, то перед заполнением табеля просто необходимо ввести именно расчетные неявки.

В общем, если они не хотят разбираться с рассерженными работниками по поводу неправильного начисления зарплаты, пусть вводят документы в положенном порядке, а не так как им нравится.
Вопрос: v7: ЗиК 7.7 - сверхурочные часы при суммированном учете рабочего времени, тройная оплата

Доброго времени суток! У сотрудника суммированный учет рабочего времени с повременно-премиальной по тарифу согласно табеля (по часам).
Если в Табеле задавать в строке "Всего отработано времени" общее количество отработанных часов, а в строке "Сверхур. часы (двойной размер оплаты)" количество сверхурочных часов, то получается тройной размер оплаты - час оплачивается по тарифу из строки всего отработано, и затем еще по строке сверхурочных часов этот-же час в двойном размере, итого получаем тариф*3.
Для получения корректного расчета можно уменьшить количество часов в строке "Всего отработано времени" на количество сверхурочных часов. Или не уменьшать "Всего отработано времени", но изменить значение константы "Коэффициент оплаты последующих сверхурочных часов" с 2 на 1. Но ведь ни то, ни другое не является верным. Почему ЗиК считает в тройном размере? Что не так заполняю?

Ну и собственно, если учет времени суммированный, то с какого перепугу бухгалтера считают сверхурочные помесячно? Если учетный период - полгода или год?
Ответ: отчет от victuan по ссылке показывает верно - доплату за сверхурочные в однократном размере, а вот ЗиК считает сверхурочные в двойном. или-же расчет сверхурочных для суммированного учета в ЗиК не предусмотрен?
Вопрос: Проблема в учете рабочего времени 8.3 ЗУП

Проблема в следующем. Работник по совмещению принят на ((Оплата по окладу (по часам)), график стандартная пятидневка, 0,5 ставки. Работает по графику составленному им же в начале месяца. Январь 3 число - 1,5 часа, 4 число - 1,5 часа, 8 число - 1,5 часа, 27 число - 1,5 часа и 28 число - 1 час остальные дни выходные В. Итого за январь (оклад 9900/ на норму часов 120 и * на 7 часов отработанных).
КАК оформить табель ( при изменении Я 8 на В даёт ошибку), если взять Индивидуальный график все остальные числа месяца кроме вышеперечисленных В - тогда, принимается за норму времени 7 часов и выплачивается полный оклад.
Дни каждый месяц разные. Как вообще данная ситуация может разрешиться. В 8.2 не было такой проблемы.
Пытался подобрать какой нибудь вариант по графику рабочего времени Суммарный учет времени - но как то не допетрил. Галку суммарный учет времени ставил . Результат такой же. Половина предприятия работает по совмещению, время и дни у всех всегда различны.
ПОМОЖИТЕ ЛЮДИ ДОБРЫЕ!!!!
Ответ:
А зачем Вы в индивидуальном графике ставите везде В (в смысле 0?)? График задает НОРМУ, а норма у вас 120 - вот и задавайте в инд.графике 120 часов, а в табеле 7 и будет вам щасьтье.