Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: Заполнение ТЧ одного документа ТЧ другого, заполнение тч из запроса

Код 1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
&НаСервере
Процедура ЗаполнитьНаСервере()
    Запрос = Новый Запрос;
    Запрос.Текст = 
    "ВЫБРАТЬ
    |   ТоварнаяНакладная.Ссылка
    |ИЗ
    |   Документ.ТоварнаяНакладная КАК ТоварнаяНакладная
    |ГДЕ
    |   ТоварнаяНакладная.Ссылка = &МассаБрутто";
    Результат = Запрос.Выполнить();
    Выборка = Результат.Выбрать();
    Пока Выборка.Следующий() Цикл
         НоваяСтрока = ОбъектМассаБрутто.Добавить();
         НоваяСтрока.МассаБрутто = Выборка.МассаБрутто;
    КонецЦикла;
    
КонецПроцедуры
 
&НаКлиенте
Процедура Заполнить(Команда)
        ЭтаФорма.Записать();
        ЗаполнитьНаСервере();
    КонецПроцедуры
Есть док ТоварнаяНакладная в нем тчНакладная в ней МассаБрутто и МассаНетто
есть докНакладнаяНаОтпуск в нем тчТовар в ней МассаБрутто МассаНетто
нужно организовать запрос на выбор массы и из запроса заполнить поля накладной
Ответ:
Сообщение от duk337
В разделе даже есть отдельная тема про литературу.
Далее.
Надо смотреть методы тч. Осознать, где док.приёмник, где док.источник. Какие реквы у них в тч.
Вы же тыкаете пальцем в небо, хотя осознаёте, что ВАШИ объекты и их структура для нас тайна.
Если с запросом не выходит - делайте просто циклом по тч источника. Прочухайте, где объект, а где ссылка.
я много читал и закипел уже помоги...чуть что не правильно?
Код 1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
&НаСервере
Процедура ЗаполнитьТД(Масса)
Запрос = Новый Запрос;
    Запрос.Текст ="ВЫБРАТЬ
                  | ТоварнаяНакладнаяНакладная.МассаБрутто КАК МассаБрутто,
                  | ТоварнаяНакладнаяНакладная.МассаНетто КАК МассаНетто,
                  | ТоварнаяНакладнаяНакладная.Товар.Наименование
                  |ИЗ
                  | Документ.ТоварнаяНакладная.Накладная КАК ТоварнаяНакладнаяНакладная"; 
                  
                РезультатЗапроса = Запрос.Выполнить();
                Масса = РезультатЗапроса.Выгрузить();
    Запрос2 = Новый Запрос;
    Запрос2.Текст ="ВЫБРАТЬ
                   |    НакладнаяНаОтпускТовар.Наименование.Наименование КАК Наименование,
                   |    НакладнаяНаОтпускТовар.МассаБрутто,
                   |    НакладнаяНаОтпускТовар.МассаНетто
                   |ИЗ
                   |    Документ.НакладнаяНаОтпуск.Товар КАК НакладнаяНаОтпускТовар";
                  РезультатЗапроса = Запрос2.Выполнить();
 
                   
            Для Каждого Товар Из Масса Цикл
            //  НоваяСтрока = Товар.Добавить();
            //  НоваяСтрока.МассаБрутто = ТабЗнач.МассаБрутто;
            //  НоваяСтрока.МассаНетто = ТабЗнач.МассаНетто;
            ЗаполнитьЗначенияСвойств(Товар, Масса);
            КонецЦикла;
 
КонецПроцедуры
 
    
    
&НаКлиенте
Процедура ТоварНаименованиеПриИзменении(Элемент)
    СтрокаТабличнойЧасти=Элементы.Товар.ТекущиеДанные;
    СтрокаТабличнойЧасти.Цена=РаботаСоСправочниками.РозничнаяЦена
    (Объект.Дата,СтрокаТабличнойЧасти.Наименование);
    
    ЗаполнитьТД(СтрокаТабличнойЧасти.МассаБрутто);
        
    СтрокаТабличнойЧасти.Сумма=СтрокаТабличнойЧасти.Количество
*СтрокаТабличнойЧасти.Цена;    
КонецПроцедуры
Вопрос: Бухгалтерия ред. 2.1(РБ) Заполнение табличной части

Не удаётся заполнить табличную часть.
Не знаю что делаю не так.
Помогите плиз.
Заранее благодарю.
--- Объединение сообщений, 6 авг 2017 ---
Всё вроде как работает но табличная часть с итогами не наполняется и выводиться.
--- Объединение сообщений, 6 авг 2017 ---
// Функция формирует табличный документ с Внешней печатной формой
//
// Возвращаемое значение:
// Табличный документ - печатная форма акта
//
Функция ПечатьВнешнейПечатнойФормы(МассивОбъектов, ОбъектыПечати) Экспорт

ТабДок = новый ТабличныйДокумент;

ТабДок.АвтоМасштаб = Истина;
ТабДок.ОтображатьСетку = Ложь;
ТабДок.Защита = Ложь;
ТабДок.ТолькоПросмотр = Ложь;
ТабДок.ОтображатьЗаголовки = Ложь;
ТабДок.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
ТабДок.ЭкземпляровНаСтранице= 1;

УстановкаМинимальныхПолейДляПечати(ТабДок);
Макет = ПолучитьМакет("СчетФактура_РФ");

ОбластьШапки = Макет.ПолучитьОбласть("Шапка");
ОбластьДанные = Макет.ПолучитьОбласть("Данные");
ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");

Запрос = Новый Запрос;
Запрос.УстановитьПараметр("МассивОбъектов",МассивОбъектов);
Запрос.Текст ="ВЫБРАТЬ
| РеализацияТоваровУслуг.АдресДоставки,
| РеализацияТоваровУслуг.ВалютаДокумента,
| РеализацияТоваровУслуг.ГлавныйБухгалтер,
| РеализацияТоваровУслуг.Грузоотправитель,
| РеализацияТоваровУслуг.Грузополучатель,
| РеализацияТоваровУслуг.Дата,
| РеализацияТоваровУслуг.ДоговорКонтрагента,
| РеализацияТоваровУслуг.Контрагент,
| РеализацияТоваровУслуг.Номер,
| РеализацияТоваровУслуг.Организация,
| РеализацияТоваровУслуг.Руководитель,
| РеализацияТоваровУслуг.СуммаВключаетНДС,
| РеализацияТоваровУслуг.СуммаДокумента,
| РеализацияТоваровУслуг.Товары.Номенклатура,
| РеализацияТоваровУслуг.Товары.ЕдиницаИзмерения,
| РеализацияТоваровУслуг.Товары.Количество,
| РеализацияТоваровУслуг.Товары.Цена,
| РеализацияТоваровУслуг.Товары.Сумма,
| РеализацияТоваровУслуг.Товары.СтавкаНДС,
| РеализацияТоваровУслуг.Товары.СуммаНДС,
| РеализацияТоваровУслуг.Товары.СтранаПроисхождения,
| РеализацияТоваровУслуг.Товары.Ссылка КАК Ссылка

| ИЗ
| Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
| ГДЕ
| РеализацияТоваровУслуг.Ссылка В (&МассивОбъектов)";

//Получаем область "Шапка"

ОбщаяВыборка = Запрос.Выполнить().Выгрузить();

Для Каждого СсылкаНаОбъект из МассивОбъектов Цикл

ОбластьШапки.Параметры.Номер = "Счет-фактура № "+СсылкаНаОбъект.ДоговорКонтрагента+" г.";
ОбластьШапки.Параметры.НомерИсправления = "Исправление № -- от -- ";
ОбластьШапки.Параметры.ПредставлениеПоставщика = "Продавец: "+СсылкаНаОбъект.Организация;
ОбластьШапки.Параметры.АдресПоставщика = "Адрес: "+" 210033, Витебская обл., г. Витебск, пр. ФРУНЗЕ, дом № 81";
ОбластьШапки.Параметры.ИННПоставщика = "ИНН/КПП продавца: 300237386 / 300237386 ";
ОбластьШапки.Параметры.ПредставлениеГрузоотправителя = "Грузоотправитель и его адрес: он же";
ОбластьШапки.Параметры.ПредставлениеГрузополучателя = "Грузополучатель и его адрес: "+СсылкаНаОбъект.Контрагент+", "+СсылкаНаОбъект.АдресДоставки;
ОбластьШапки.Параметры.ПоДокументу = "К платежно-расчетному документу №: от ";
ОбластьШапки.Параметры.ПредставлениеПокупателя = "Покупатель: "+СсылкаНаОбъект.Контрагент;
ОбластьШапки.Параметры.АдресПокупателя = "Адрес: "+СсылкаНаОбъект.АдресДоставки;
ОбластьШапки.Параметры.ИННПокупателя = "ИНН/КПП покупателя: ";
ОбластьШапки.Параметры.Валюта = "Валюта: наименование, код Российский рубль, 643";

ТабДок.Вывести(ОбластьШапки);

//Получаем область "Данные"

Отбор = Новый Структура;
Отбор.Вставить("Ссылка",СсылкаНаОбъект);
Выборка = ОбщаяВыборка.НайтиСтроки(Отбор);

ИтогоСумма = 0;
ИтогоСуммаНДС = 0;
ИтогоВсего = 0;


Для Каждого Стр из Выборка Цикл
ЗаполнитьЗначенияСвойств(ОбластьДанные.Параметры,Стр);

ИтогоСумма = ИтогоСумма + Стр.Сумма;
ИтогоСуммаНДС = ИтогоСуммаНДС + Стр.СуммаНДС;
ИтогоВсего = ИтогоВсего + Стр.Всего;

ТабДок.Вывести(ОбластьДанные);
КонецЦикла;

//Получаем область "Подвал"
ОбластьПодвал.Параметры.ИтогоСумма = ИтогоСумма;
ОбластьПодвал.Параметры.ИтогоСуммаНДС = ИтогоСуммаНДС;
ОбластьПодвал.Параметры.ИтогоВсего = ИтогоВсего;

ТабДок.Вывести(ОбластьПодвал);
ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
КонецЦикла;

Возврат ТабДок;
КонецФункции

Вложения:

  • Размер файла:
    4,6 КБ
    Просмотров:
    1
  • Размер файла:
    17,5 КБ
    Просмотров:
    1
Ответ:
Такой вопрос. Есть ВПФ:
--- Объединение сообщений, 6 окт 2017 ---
В документе "РеализацияТоваровУслуг" нет реквизита "КодТНВЭД".

Как его туда добавить?

Нужно чтобы он попал сюда:
--- Объединение сообщений, 6 окт 2017 ---
В базе он есть. ВПФ ссылается на табличную часть "ТОВАРЫ" документа "РеализацияТоваровУслуг".Нужно его как-то добавить чтобы заполнить макет

Вложения:

  • Размер файла:
    15,8 КБ
    Просмотров:
    2
  • Размер файла:
    19,5 КБ
    Просмотров:
    3
Вопрос: Иизменение данных табличной части по нескольким документам через запрос

Приветствую, Форумчане!

УТ 10.3, 1с8.2, обычное

Имеются несколько документов "Реализация Товаров и Услуг". В документе есть кнопка "Изменить", которая может изменить, например, сумму документа (типа скидка), распределив цены по всем номенклатурам.

Имеется ли возможность изменить цену номенклатуры по нескольким документам?

У меня несколько "Реализаций" собраны в одном нетиповом документе по определенному признаку. На основании этих Реализаций формируется итоговый счет на оплату. Нужно организовать "Скидку" на все реализации...

Пытаюсь через запрос внести изменения:

Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
                   |    РеализацияТоваровУслугТовары.Ссылка.ПроектПредприятия,
                   |    РеализацияТоваровУслугТовары.Номенклатура,
                   |    РеализацияТоваровУслугТовары.СуммаДок
                   |ИЗ
                   |    Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслугТовары
                   |ГДЕ
                   |    РеализацияТоваровУслугТовары.Ссылка.ПроектПредприятия = &ПроектПредприятия";

    Запрос.Параметры.Вставить("ПроектПредприятия", Ссылка);
    Выборка = Запрос.Выполнить().Выбрать();
    
    
     Пока Выборка.Следующий() Цикл
         
         Коэфф = Выборка.Сумма / СуммаЗаказов;
         Процент = Скидка * Коэфф;
         
         Выборка.СуммаДок = Выборка.Сумма - Процент; 
         
     
     КонецЦикла;


Но пишет "недоступен для записи". Как можно через запрос изменить данные табличных частей?
Ответ: Ukraina, сумма находится в табличной части документа, а не в самом документе. еще раз пишу, запросом получите только ссылку на объект, а суммы считайте в коде обходом табличной части вашего объекта.
Вопрос: Выборка данных из табличной части справочника в табличную часть документа

Здравствуйте, помогите с кодом, есть справочник "Договоры" с несколькими реквизитами и табличной частью и есть документ "Расходная накладная" в котором есть реквизит договор с ссылкой на справочник "Договоры", необходимо чтобы в документе, при выборе договора(например Договор 1), который уже создан в справочнике, и заполнена значениями табличная часть,нужно чтобы автоматически заполнялась табличная часть в документе "Расходная Накладная" из этого справочника
Ответ:
&НаСервере
Процедура ДоговорПриИзмененииНаСервере()

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| Договоры.УсловияПоставок.(
| Номенклатура,
| Серия,
| ЕдиницаИзмерения,
| Валюта,
| Количество,
| Цена,
| Сумма
| ),
| РасходнаяНакладная.Договор
|ИЗ
| Документ.РасходнаяНакладная КАК РасходнаяНакладная
| ЛЕВОЕ СОЕДИНЕНИЕ Справочник.Договоры КАК Договоры
| ПО РасходнаяНакладная.Договор = Договоры.Ссылка
|ГДЕ
| Договоры.Ссылка = &Договор";

Запрос.УстановитьПараметр("Договор", Объект.Договор);

РезультатЗапроса = Запрос.Выполнить();

ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

Для Каждого ВыборкаДетальныеЗаписи.Следующий() Цикл

НоваяСтрока = Объект.СписокНоменклатуры.Добавить();
НоваяСтрока.Номенклатура = ВыборкаДетальныеЗаписи.Номенклатура;
НоваяСтрока.Серия = ВыборкаДетальныеЗаписи.Серия;
НоваяСтрока.ЕдиницаИзмерения = ВыборкаДетальныеЗаписи.ЕдиницаИзмерения;
НоваяСтрока.Валюта = ВыборкаДетальныеЗаписи.Валюта;
НоваяСтрока.Количество = ВыборкаДетальныеЗаписи.Количество;
НоваяСтрока.Цена = ВыборкаДетальныеЗаписи.Цена;
НоваяСтрока.Сумма = ВыборкаДетальныеЗаписи.Сумма;

КонецЦикла

КонецПроцедуры

на это выдает ошибку поле объекта не обнаружено, помогите пожалуйста исправить
--- Объединение сообщений, 1 июн 2016 ---
Для каждого случайно написал, там стандартный Пока
Вопрос: Вывод в табличную часть справочника данных из регистра сведений

Здравствуйте!
Есть справочник и РС. Надо в табличную часть справочника вывести данные из РС, причем, он должен записывать только те данные, которые будут совпадать по фамилии.

Вот что у меня есть. Но он почему - то выводит только цифры в колонке №.

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
Процедура ПриОткрытииНаСервере()
    
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |   РегистрКонтактов.КонтактноеЛицо,
        |   РегистрКонтактов.ТипКонтакта,
        |   РегистрКонтактов.Описание
        |ИЗ
        |   Справочник.КонтактныеЛица КАК КонтактныеЛица
        |       ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.РегистрКонтактов КАК РегистрКонтактов
        |       ПО РегистрКонтактов.КонтактноеЛицо = КонтактныеЛица.Наименование";
    
    РезультатЗапроса = Запрос.Выполнить();
    
    Объект.Контакт.Очистить();  
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
 
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        НоваяСтрокаТабличнойЧасти = Объект.Контакт.Добавить();
        НоваяСтрокаТабличнойЧасти.Наименование = ВыборкаДетальныеЗаписи.ТипКонтакта;
        НоваяСтрокаТабличнойЧасти.Описание = ВыборкаДетальныеЗаписи.Описание;
    КонецЦикла;
 
КонецПроцедуры
Ответ: Добавляешь на форму реквизит "динамический список" и там пишешь запрос. Делал такую задачу на уп формах.
Вопрос: программное изменение табличной части при записи документа

Добрый вечер! Подскажите пожалуйста как мне правильно реализовать?
Есть обработка мобильное приложение в котором менеджер формирует заказ с планшета и выгружает в 1с, после выгрузки  в 1с создается документ заказ и записывается. Мне нужно именно при записи документа перезаполнить цены табличной части по определенному условию в моем случаи по виду цен который указан в договоре. Я прикрутил код в процедуру ПередЗаписью() в модуле объекта, когда документ падает в 1с он не перезаполняется, такие же цены как заполнил менеджер, но если этот созданный документ я  еще раз запишу он перезаполняет. Может мне использовать другой обработчик событий? кто сталкивался с такой проблемой?
Ответ: Пример запроса по таблице значений (чтобы видеть до записи документа содержимое табличной части в запросе; изменение табличной части в цикле по результатам запроса):

&НаСервере
Процедура ПересчитатьСуммыНаСервере(ИмяТч)

    // ДебиторскаяЗадолженность    

    Запрос = Новый Запрос;
    Запрос.Текст = 
    "ВЫБРАТЬ
    |    тзДок.Сумма,
    |    тзДок.ДокументВзаиморасчетов,
    |    тзДок.НомерСтроки
    |ПОМЕСТИТЬ тзДок
    |ИЗ
    |    &тзДок КАК тзДок
    |;
    |
    ////////////////////////////////////////////////////////////////////////////////

    |ВЫБРАТЬ
    |    тзДок.НомерСтроки,
    |    Акт.СуммаОплаты
    |ИЗ
    |    тзДок КАК тзДок
    |        ЛЕВОЕ СОЕДИНЕНИЕ Документ.АктВыполненныхРабот КАК Акт
    |        ПО тзДок.ДокументВзаиморасчетов = Акт.Ссылка
    |
    |УПОРЯДОЧИТЬ ПО
    |    тзДок.НомерСтроки";

    Запрос.УстановитьПараметр("тзДок", Объект[ИмяТЧ].Выгрузить());   
    сч=0;
    РезультатЗапроса = Запрос.Выполнить();
    вв = РезультатЗапроса.Выбрать();
    пОтбор=Новый Структура("НомерСтроки");
    Для Каждого стр из Объект[ИмяТЧ] Цикл
        пОтбор.НомерСтроки=стр.НомерСтроки;
        Если вв.НайтиСледующий(пОтбор) Тогда
            стр.СуммаОплаты = вв.Сумма;
            стр.СуммаВзаиморасчетов=стр.Сумма - стр.СуммаОплаты;
        Иначе
            ВызватьИсключение("Ошибка поиска суммы в строке "+ИмяТЧ+" "+стр.НомерСтроки+".");
        КонецЕсли;    
    КонецЦикла;    
КонецПроцедуры


Этот образец может использоваться для контроля правильности заполнения документа или для дозаполнения документа по результатам запроса, пока он еще не записан.
Вопрос: Условие на номенклатуру из табличной части документа в запросе 1с 77

Всем доброго дня!! Делаю отчет в 7ке - вывожу данные из документов (из шапки), и нужно условие - на номенклатуру из табличной части, подскажите синтаксис, заранее благодарю.
Ответ: Mixmaister666,

Если вам нужны агрегатные функции по реквизитам шапки, то не взлетит.
7ка, если в запросе у вас участвуют реквизиты табличной части, делает запрос к таблице табличной части документа с джойном к таблице шапки. Реквизиты шапки будут дублировать в каждой строке. Если в запросе нет агрегатной функции по реквизиту шапки - всё нормально, результат запроса свернётся по группировкам. Если есть, по каждому такому реквизиту шапки значение помножится на количество строк в документе.
Вопрос: Заполнение табличной части с выбором значений

Необходимо решить проблему, не могу дойти..
8.3 Клиент серверный вариант
Справочники: Абоненты, Тарифы, СтатусАбонента


&НаКлиенте
Процедура Заполнить(Команда)

ЗаполнитьТабличнуюЧастьСписокАбонентов();


КонецПроцедуры


&НаСервере
Процедура ЗаполнитьТабличнуюЧастьСписокАбонентов()
Запрос = Новый Запрос;
Запрос.Текст =
//"ВЫБРАТЬ
//| Абоненты.Ссылка
//|ИЗ
//| Справочник.Абоненты КАК Абоненты";
"ВЫБРАТЬ
| Абоненты.Ссылка,
| Абоненты.Статус
|ИЗ
| Справочник.Абоненты КАК Абоненты";
//
// "ВЫБРАТЬ
// | Сотрудники.Ссылка
// |ИЗ
// | Справочник.Сотрудники КАК Сотрудники";
//
РезультатЗапроса = Запрос.Выполнить().Выгрузить();

Для каждого Стр из РезультатЗапроса Цикл
НоваяСтрока = Объект.АбонентыСписком.Добавить();

НоваяСтрока.ФИО = Стр.Ссылка;
НоваяСтрока.АбонПлата = Объект.АбоненскаяПлата.СуммаТарифа;
НоваяСтрока.СтатусАбонента = Стр.Статус;
НоваяСтрока.СтатусТарифа = "Списание";

КонецЦикла
КонецПроцедуры

Обработка работа способна и все загружает, но нужно
Удаление строк из табличной части по отбору из справочника или жестко
Статус абонента нужно допустим поставить Активный чтоб в табличной части были только Активные по статусу.

Либо Лучше всего чтоб при заполнении табличной части можно было выбирать из группы Абонентов..

Скажите как проще сделать.. Уже все варианты переабрал ни чего не помогает, может изначально не в ту строну..ПОМОГИТЕ...
Ответ:
Все решил всем спасибо
Запрос.УстановитьПараметр("Статус", Объект.СтатусАбонента);
Вопрос: Перебор табличной части запросом

В документе есть табличная часть, необходимо перебрать все строки и внести изменения в справочнике. Все работает и получается, делаю все запросами, но в справонике есть не уникальные элементы (дубликаты) просто расположены в разных группах. Поэтому получается внести изменения во всех дублях, а надо именно в указанном в табличной части.
Код 1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
Для Каждого Строка Из ЭфирУтро Цикл
             
             Запрос = Новый Запрос;
             Запрос.УстановитьПараметр("Код", Строка.НомерМатУтро);
             Запрос.Текст = 
             "ВЫБРАТЬ
             |    ХудФильмы.Ссылка
             |   
             |ИЗ
             |    Справочник.ХудФильмы КАК ХудФильмы
             |ГДЕ
             |    ХудФильмы.Код = &Код";
             Результат = Запрос.Выполнить();
        
             Если Результат.Пустой() Тогда
                 
                  Сообщить ("Не найден элемент");
 
             Иначе
                 Выборка = Результат.Выбрать();
                 Пока Выборка.Следующий() Цикл
                                         
                    Если Выборка.Ссылка.Родитель.Родитель = Строка.СпрГруппа Тогда
                     // Сообщить(Выборка.Ссылка.Родитель.Родитель);
                    // Сообщить(Строка.СпрГруппа);
 
                ЭлементСпр = Выборка.Ссылка.ПолучитьОбъект(); 
                ЭлементСпр.ДатаЭфира = "№" + Номер + " от " + Формат(Дата, "ДЛФ=Д");
                ЭлементСпр.Записать();
                Иначе
                    Сообщить("Такого нет");
                КонецЕсли;
                                 КонецЦикла;         
                 
             КонецЕсли;
 
            КонецЦикла;
Ответ: М?
Код 1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
    Запрос = Новый Запрос;
    Запрос.Текст = 
    "ВЫБРАТЬ
    |    ХудФильмы.Ссылка
    |    ХудФильмы.Код
    |ИЗ
    |    Справочник.ХудФильмы КАК ХудФильмы";
    Результат = Запрос.Выполнить().Выгрузить();
    
    Для Каждого Строка Из ЭфирУтро Цикл
        
        ВыборкаХФ = Результат.НайтиСтроки(Новый Структура("Код", Строка.НомерМатУтро));
        Если ВыборкаХФ.Количество() = 0 Тогда
            Сообщить ("Не найден элемент");
            Возврат;
        КонецЕсли;
        
        Для Каждого Строка ИЗ ВыборкаХФ Цикл
            
            Если Выборка.Ссылка.Родитель.Родитель = Строка.СпрГруппа Тогда  
                ЭлементСпр = Строка.Ссылка.ПолучитьОбъект(); 
                ЭлементСпр.ДатаЭфира = "№" + Номер + " от " + Формат(Дата, "ДЛФ=Д");
                ЭлементСпр.Записать();
            Иначе
                Сообщить("Такого нет");
            КонецЕсли;
            
        КонецЦикла;         
        
    КонецЦикла;
Добавлено через 5 минут
А если еще отбор нужен, добавьте строки в запрос и в структуру: Новый Структура("Код, Родитель", Строка.НомерМатУтро, Строка.СпрГруппа) - так вроде, но лучше проверьте в синтакс-помощнике.

Добавлено через 59 секунд
Во вложенном цикле имя итератора повторил.
Вопрос: Работа с запросом

Добрый день! Не могу понять почему не заполняется табличная часть ТП
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
    Запрос = Новый Запрос;
    ТекстЗапроса = "ВЫБРАТЬ
    |   ЗаявкаЕдиноеОкно.Дата КАК Период,
    |   ЗаявкаЕдиноеОкно.ТипЗаявки,
    |   ЗаявкаЕдиноеОкно.Причина,
    |   ЗаявкаЕдиноеОкно.Статус,
    |   ЗаявкаЕдиноеОкно.Номер
    |ИЗ
    |   Документ.ЗаявкаЕдиноеОкно КАК ЗаявкаЕдиноеОкно
    |ГДЕ
    |   ЗаявкаЕдиноеОкно.Статус = &Статус";
    
    Запрос.УстановитьПараметр("ФИО",ЭтаФорма.ЭлементыФормы.Ответственный.Значение);
    Запрос.УстановитьПараметр("Статус",Перечисления.СтатусЕдиноеОкно.Открыта);
    Запрос.Текст=ТекстЗапроса;
    Вывод=Запрос.Выполнить().Выбрать();
    Пока Вывод.Следующий() Цикл
        Дата = Формат(Вывод.Период,"ДФ='дд.ММ.гггг'");
        Для Каждого Стр Из ТП Цикл
            Стр.Дата = Дата;
            Стр.Информация = " " + "Заявка:" + " " + "№" + Вывод.Номер + Символы.ПС + " " + "Тип заявки:" + " " + Вывод.ТипЗаявки + Символы.ПС + " " + "Причина заявки:" + " " + Вывод.Причина;
        КонецЦикла;
    КонецЦикла; 
Ответ: ​Тут такая идея была использовать обновление табличной части в каждую секунду, использовал такой способ
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
Процедура ПриОткрытии()
    
    ОповещениеЗаявки();
    
КонецПроцедуры
 
Процедура ОповещениеЗаявки()
    
    Запрос = Новый Запрос;
    ТекстЗапроса = "ВЫБРАТЬ
                   |    ЗаявкаЕдиноеОкно.Ссылка,
                   |    ЗаявкаЕдиноеОкно.Номер,
                   |    ЗаявкаЕдиноеОкно.Дата
                   |ИЗ
                   |    Документ.ЗаявкаЕдиноеОкно КАК ЗаявкаЕдиноеОкно
                   |ГДЕ
                   |    ЗаявкаЕдиноеОкно.Статус = &Статус";
    
    //Запрос.УстановитьПараметр("ФИО",ЭтаФорма.ЭлементыФормы.Ответственный.Значение);
    Запрос.УстановитьПараметр("Статус",Перечисления.СтатусЕдиноеОкно.Открыта);
    Запрос.Текст=ТекстЗапроса;
    Вывод=Запрос.Выполнить().Выбрать();
    Пока Вывод.Следующий() Цикл 
        Информ = " " + "Новая Заявка:" + " " + "№" + Вывод.Номер + " " + "от" + " " + Формат(Вывод.Дата,"ДФ='дд.ММ.гггг'");
        //Информ = " " + Вывод.Ссылка;
        новСтр = ТП.Добавить();
        новСтр.Информация=Информ;
    КонецЦикла;      
    
КонецПроцедуры
 
ПодключитьОбработчикОжидания("ОповещениеЗаявки", 1);
Теперь данные загружаются повторно в каждую секунду, нужно когда появился новый документ документ сразу же загружались данные Табличную часть