Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: Такси. Как получить положение каретки для строки ТаблицыФормы

Добрый день всем. Есть задача, надо получить положение каретки для строки Таблицы формы

Пробовал:
Элементы.ТаблицаКолонка1.ПолучитьГраницыВыделения(НачалоСтроки, НачалоКолонки, КонецСтроки, КонецКолонки);
Все время возвращает (1,1,1,1)

Пробовал:
Элементы.ТаблицаКолонка1.УстановитьГраницыВыделения(1, 1, 3, 1);
Ноль результата


Ответ: up
Вопрос: УФ как идентифицировать удаляемую строку ТаблицыФормы.

Всем привет.
Есть УФ форма, на ней ТаблицаФормы. Юзер удаляет строку этой ТаблицыФормы.
Подскажите, пожалуйста, как можно отследить какую строку он удаляет? Если точнее, то мне нужно получить одby из реквизитов этой строчки.
Что-то голову сломал уже. События ПослеУдаления, ПриИзменении и ПередУдалением возвращают Элемент и, при этом, ТекущиеДанные и ТекущаяСтрока для ТаблицыФормы в Элементах формы не доступны (Неопределено).
Ответ: () () () Спасибо большое. Ступил. Правильно, ВыделенныеСтроки. А текущиеДанные получается только передудалением доступны.
Спасибо, тема закрыта.
Вопрос: УФ как идентифицировать удаляемую строку ТаблицыФормы.

Всем привет.
Есть УФ форма, на ней ТаблицаФормы. Юзер удаляет строку этой ТаблицыФормы.
Подскажите, пожалуйста, как можно отследить какую строку он удаляет? Если точнее, то мне нужно получить одby из реквизитов этой строчки.
Что-то голову сломал уже. События ПослеУдаления, ПриИзменении и ПередУдалением возвращают Элемент и, при этом, ТекущиеДанные и ТекущаяСтрока для ТаблицыФормы в Элементах формы не доступны (Неопределено).
Ответ:
Да, не знаю как я смотрел, но потом я еще раз поотлаживал и обнаружил, что в ПередУдалением все на месте) Спасибо.
Вопрос: Разбор строки

Хочу получить правую часть строки : /opt/out/Ticket/115, но при изменении ip адреса на такой 192.168.0.2, съедается / и получает opt/out/Ticket/115
Как независимо от длины ip получить правую часть?

Код:
НашаСтрока = "http://192.168.0.21:8080/opt/out/Ticket/115";
    Позиция=Найти(НашаСтрока,":8080");
    НашаСтрока=Прав(НашаСтрока,Позиция-1); 
Ответ:
Приведите полностью код процедуры, которая выполняет то же самое, что и мой пример.
--- Объединение сообщений, 9 ноя 2016 ---
Про парсер Вы знаете, а про переменные нет. Есть к чему стремиться.
Вопрос: Как получить имя выведенной области табличного документа?

Вывожу табличный документ.
В зависимости от условия в некоторых из его строк необходимо объединить столбцы.
И вот тут не могу понять. Как мне просто определить позицию текущей выведенной области?

Т.е. например вывел я заголовок, шапку и 123 строки.
А в 124 мне надо объединить две из 5 колонок.
Т.е. по хорошему получается что то типа
ТабДок.Область(125,7,125,9);

Вот как мне получить что выведенная строка будет 125?
Сидеть считать количество строк в шапке и в заголовке не верно. Ведь если в макет внесут изменения придется переписывать код.
Ответ: () Бывают и динамические, но тут только счётчик.
Вопрос: Текущая строка (динамический список)

Всем привет.

Есть УФ. На ней есть два Динамических списка.
Список1 - который установлен как "Основной реквизит";
Список2

Мне нужно (НаСервере) получить значение текущей строки.
В Список1:
Код:
Элементы.Список1.ТекущаяСтрока
Всё супер.
В Список2:
Код:
Элементы.Список2.ТекущаяСтрока
Получаю число 1.
Есть такое подозрение, что в первом списке у меня всего одна колонка и я получаю данные по ней.
В Список2 три колонки и я не понимаю как мне получить данные по активной строке.
Ответ:
Ага, или ссылка не выбрана
Вопрос: v7: Запрос с поиском по строке в табличной части

Помогите, а то я не знал, да еще и забыл как получить нужную мне строку документа с поиском по подстроке.
Нужно найти строчку документа в котором серийный номер 123 уже встречался.
Запрос = СоздатьОбъект("Запрос");
СерийныйНомерС = "123" ;            
ТекстЗапроса = 
        "//{{ЗАПРОС(Сформировать)

        |Без итогов;
            |СерийныйНомер = Документ.ДокументСервиса.СерийныйНомер;
            |Картридж = Документ.ДокументСервиса.Картридж;
            |ТекущийДокумент = Документ.ДокументСервиса.ТекущийДокумент;
            |Условие(СерийныйНомер = СерийныйНомерС);
            |"//}}ЗАПРОС

            ;
            Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
                Возврат;
            КонецЕсли;
            Пока Запрос.Группировка() = 1 Цикл
                // Заполнение полей Сформировать

                Сообщить("КЖ "+Запрос.Картридж);
            
            КонецЦикла;
Ответ: 100 и заканчиваем :)
Вопрос: Условное оформление 8.3.Такси

Всем привет. Такси, 8.3.
В табличной части есть реквизиты, допустим, Количество1, Количество2 . Нужно, чтобы в случае, когда Количество1 (0 шт.) меньше Количество2 (1 шт.), строка подсвечивалась. Сделал условное оформление, но в такси строка выделяется по умолчанию желтым цветом и нужный цвет не устанавливается. Если строк больше 1й и между ними переключаться, тогда устанавливается нужный цвет, причем только в строке, которая в данный момент не активна. Например, нажал на строку 2 - строка 1 подсветилась, строка 2 - нет. Нажал на строку 1 - строка 2 подсветилась, строка 1 - нет. Кто-нибудь встречал подобную проблему? И если да, то как решал?
Ответ:
Это не проблема, это спицифика такая - выделять "активную" строку
Вопрос: Интерфейс "Такси" включается у всех пользователей

Добрый день!
1С бухгалтерия 8.3, работает на сервере. При переключении на интерфейс "Такси" одним пользователем у других пользователей интерфейс тоже переключается на "Такси".
Хотелось бы сделать настройки: что бы "Такси" включался для каждого пользователя по желанию.
Это возможно? И как это сделать?
Ответ:
Только обратите внимание на то, что при установке "Такси" в разделе "Администрирование", перестраивается командный интерфейс конфигурации. Например, вместо одного раздела "Покупки и продажи" появляются два раздела "Покупки" и "Продажи".
Так же появляются и другие разделы: "Операции", "Отчеты", "Справочники". Исчезают: "Учет, налоги, отчетность", "Справочники и настройки учета". Содержимое разделов тоже меняется.

Таким образом, фирма "1С" специально оптимизировала командный интерфейс под интерфейс "Такси". И именно такой интерфейс и рекомендуется использовать (т.е. переключать для всех пользователей в разделе "Администрирование").
Вопрос: Получить значения из ХранилищеЗначения

Есть регистр сведений с ресурсом табличная часть и типом хранилище значения. Как получить данные из хранилища и перенести их в таблицу значений?

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
        Для Каждого СтрокаДок из ДокументыНаСдачу Цикл
        Если СтрокаДок.Выбор = Истина Тогда
 
            Запрос = Новый Запрос;
            Запрос.Текст = 
            "ВЫБРАТЬ
            |   ДокументыНаСдачу.ТабличнаяЧасть
            |ИЗ
            |   РегистрСведений.ДокументыНаСдачу КАК ДокументыНаСдачу
            |ГДЕ
            |   ДокументыНаСдачу.Наименование = &Заголовок";
 
            Запрос.УстановитьПараметр("Заголовок", СтрокаДок.Наименование);
            
            Результат = Запрос.Выполнить();
            
            ВыборкаДетальныеЗаписи = Результат.Выбрать();
 
                         //.......
 
        КонецЕСли;
    КонецЦикла;
в хранилищезначений находится таблица значений с полями ШтрихКод, Номенклатура, ЕдИзмерения, Количество.
Ответ: Запрос в цикле - ?? забудь про это нехорошее дело
Сначала выполнение запроса (сбор всей необходимо информации), а потом если потребуется обработка результата в цикле. Еще лучше получить сразу результирующую таблицу одним запросом.

Данные хранилища можно получить по выборке с установкой отборов по измерениям. Пример:

1C
1
2
3
4
5
6
7
8
[B]Если регистр сведений периодический[/B]
СтруктураЗаписи = РегистрыСведений.ВерсииОбъектов.Получить(ТекущаяДата(), Новый Структура("Объект,НомерВерсии", Объект, НомерВерсии));
[B]Если регистр сведений не периодический[/B]
СтруктураЗаписи = РегистрыСведений.ВерсииОбъектов.Получить(Новый Структура("Объект,НомерВерсии", Объект, НомерВерсии));
 
ДанныеХранилища = СтруктураЗаписи.ВерсияОбъекта.Получить();
Если НЕ ЗначениеЗаполнено(ДанныеХранилища) Тогда Возврат; КонецЕсли;
....