Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: Как рассчитать данные за текущий месяц этого года и за прошлые года ?

У меня есть система учета информации о температуре по областям утром и вечером нужно сделать отчет позволяющий получить данные о изменении средней температуры текущего месяца за предыдущий и текущий года...Использую РС, как сделать не знаю ..может должна быть формула,помогите не понимаю как это можно реализовать
Ответ: Solitarius,
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
ВЫБРАТЬ
    Погода.Область.Ссылка КАК ОбластьСсылка,
    СРЕДНЕЕ(Погода.ТемператураУтро) КАК ТемператураУтро,
    СРЕДНЕЕ(Погода.ТемператураВечер) КАК ТемператураВечер,
    МЕСЯЦ(Погода.Период) КАК ТекущийМесяц,
    Погода.Регистратор.Область
ИЗ
    РегистрСведений.Погода КАК Погода
ГДЕ
    МЕСЯЦ(Погода.Период) = МЕСЯЦ(&ТекущаяДата) 
 
СГРУППИРОВАТЬ ПО
    Погода.Область.Ссылка,
    Погода.Регистратор.Область
 
УПОРЯДОЧИТЬ ПО
    ТекущийМесяц,
    ОбластьСсылка,
    ТемператураВечер,
    ТемператураУтро
в параметр СКД ТекущаяДата - выставить Начало сегодняшнего дня, например.
Вопрос: Розница 2.2 не сохраняет текущий магазин

Помогите уважаемые знатоки... после выгрузки данных из УТ11 в Розница 2,2 в рознице встал не тот "текущий магазин" через персональные настройки меняю но каждый раз при открытии он сбрасывается приходится каждый раз менять. В чем может быть дело? как исправить?
Ответ:
Да
--- Объединение сообщений, 2 май 2017 ---
Нашел. По запарке даже не увидел что у пользователя можно указать магазин. Через персональные настройки изменение текущего магазина не сохраняется, я так понимаю что имеется ввиду временное изменение текущего магазина, а вот если в карточке пользователя указать магазин тогда норм все
Вопрос: вызов клиентского метода из серверного

Всем доброго времени суток!
платформа:1С:Предприятие 8.3 (8.3.6.2390)

Господа знатоки, вопрос таков:
можно ли как-то во время выполнения серверной процедуры или функции, сделать паузу, вывести например сообщение пользователю и продолжить серверный вызов. Как это происходит например, при проведении нескольких документов, во время обработки пользователю выходит сообщение о состоянии, а это вроде бы как клиентский вызов и проценты постоянно обновляются.
Ответ:
Я в принципе так и думал. Принято, спасибо.
Вопрос: Вызов серверной процедуры при заполнении ТЧ из внешней обработки

Добрый день!
Пожалуйста, помогите разобраться:

Заполняю ТЧ документа из дополнительной обработки. После добавления строки нужно обработать ТЧ процедурой описанной в модуле формы документа(не тащить же ее в обработку. Проблема с вызовом этой процедуры.

1) Вызов в модуле формы
&НаСервере
Процедура Заполнить()
ОбщийМодуль.Заполнить(ЭтаФорма);
КонецПроцедуры

2) Как вызвать в модуле обработки заполнения? Передать форму документа  на сервер нет получается
Ответ: ВладелецФормы - доступен только на клиенте, требуется сообщить процедуре на сервере об УП.

Есть вызов в модуле формы документа:

&НаСервере
Процедура ЗаполнитьНаСервере
ОбщийМодуль.ЗаполнитьЧто-то(ЭтаФорма);
КонецПроцедуры

Можно ли из обработки заполнения документа вызвать эту же процедуру, передав ей объект Управ. форма документа?
Вопрос: ТекущийЭлемент формы после вызова сервера

Всем привет. Правлю чужую обработку, вкратце - на управляемой форме есть табличный документ, на который выводятся некие значения. При активизации ячейки ТД в расположенные рядом поля формы выводятся подробные данные о ней.
Так вот: если пользователь без полных прав, то в процессе получения этих данных(а именно - сразу после первого серверного вызова) с ТД пропадает фокус и устанавливается на ОсновнойЭлементФормы. То есть с клавиатуры перемещаться по ячейкам таблицы становится невозможно. С полными правами всё ок. По запросу ОсновнойЭлементФормы молчат как синтакс-помощник, так и гугл.
Вопрос: что это за ОсновнойЭлементФормы, и есть ли у кого идеи, почему без полных прав слетает ТекущийЭлемент у формы после серверного вызова?
Ответ: () Ничего, явное присвоение свойства ТекущийЭлемент отсутствует, оно меняется сразу по возвращении из первого серверного вызова на клиент.
Вопрос: Серверный вызов при завершении работы 1с.

добрего.
модуль управляемого приложения
1C
1
2
3
4
Процедура ПередЗавершениемРаботыСистемы(Отказ, ТекстПредупреждения)
    // перенести в самый верх при завершении
    ХХХ_Клиент.ПриЗавершенииРаботыСистемы();
КонецПроцедуры
мой модуль1- клиент(управляемое)
1C
1
2
3
4
Функция ПриЗавершенииРаботыСистемы() Экспорт 
    ХХХ_НВХ.ПриЗавершенииРаботыСистемы();
    Возврат Неопределено; 
КонецФункции //ПриЗавершенииРаботыСистемы();
мой модуль 2 ХХХ_НВХ ( сервер , вызов сервера)
1C
1
2
3
4
5
6
Функция ПриЗавершенииРаботыСистемы() Экспорт 
    // получаем идентификатор
    ИдентификаторКлиента = ХХХ_ПовторноеИспользование.ПолучитьИдентификаторКлиента();
    //обработка идентификатора 
    Возврат неопределено; 
КонецФункции //ПриЗавершенииРаботыСистемы
ххх_нвх - серверный модуль.
нужно его вызвать при завершении работы управляемого приложения.
как обойти ограничение 1с на невозможность серверных вызовов при и перед завершением работы системы?

режим совместимости не используется.
версия платформы 8.3.8 и выше
Ответ:
Сообщение от fsdfsgwergwrwh
Ребят все привет!
Это нововведение с какого года?
Просто где-то в видосе видел, что у человека получалось сделать серверный вызовы при завершении работы.

Не по теме:

всегда и работало, просто у ТС руки не из того места растут

Вопрос: Проверить какие наборы данных использована в текущих настройках СКД

В СКД есть несколько внешних наборов данных, которые собираются из различных источников по COM.
Каким образом можно проверить в "ПриКомпоновкеРезультата" используют ли текущий вариант настроек отчета (предопределенный) или измененный пользователем тот или иной набор данных, чтобы не делать лишнее их заполнение.
Сейчас пока сделано через проверку "ключтекущеговарианта", но недостаток в том что пришлось делать новый реквизит, собственную форму и это работает только для предопределенных вариантов отчета.
Ответ: () Для того чтобы получить настройки, сделанные пользователем, для сравнения ключ текущего варианта не нужен, они и так у меня есть. Вопрос есть ли готовый вариант чтобы сравнить все разделы настроек скд: выбранные поля, группировки, отборы, условное оформление и тд с полями в схеме СКД для определения используемых наборов?
Вопрос: Установить текущий элемент на странице управляемой формы

Здравствуйте,
помогите пожалуйста советом. Есть управляемая форма, на ней несколько страниц (вкладок).
Как при переходе на определенную вкладку (страницу) сделать текущим элементом кнопку на этой вкладке.
Ну нигде не могу найти решение.
Ответ:
Здравствуйте.
У меня были проблемы с фокусировании на элементе, если он входил в группу. Возможно в новых версиях платформы это уже поправили, но мне приходилось сначала делать текущей группу, а затем элемент в ней. Только так получалось.
Вопрос: Как во вводе на основании передать значение текущей строки табличной части на форме документа

Добрый день!
Подскажите пожалуйста.
Есть в УТП документ "Заказ покупателя" с табличной частью "Товары".
Можно ли , вводя на основании заказа другой документ при открытой форме Заказа и активной строчке табл части "товары", передавать в документ, значение "Количество" и "Номенклатура" выделенной строки?

Если ТипЗнч(Основание) = Тип("ДокументСсылка.ЗаказПокупателя") Тогда
Продукция=...Основание.ЭтаФорма... ;
Количество =
Нужно передать с формы заказа текущей строки реквизит Номенклатура и Количество
Ответ:
Я имел ввиду кнопку ввода на основании
Вопрос: Можно ли программно получить стек вызовов в 1с?

можно ли в 1с программно получить стек вызовов, для того чтобы понять из какой процедуры или функции вызван текущий код?
Ответ: 1c_user, врядли к ней есть доступ из вне процесса 1С