Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: УФ Некоторые значения ТЧ рассчитать по среднему

Продолжить тему не удалось, пишу снова.
В табличную часть документа пользователь вносит данные, число колонок - по числу дней в месяце (+ есть и другие колонки). Некоторые дни месяца могут считаться по среднему. Для этого пользователь этот день должен как-то пометить, а программа рассчитать среднее.
Как правильно решить такую задачу?
Ответ: () Можно хранить структуру. Но тогда таблицы должно быть две - бэкэнд со структурой и фронтэнд с данными на форме
Вопрос: 1с MSSQL - перевести VALUE в десятичное значение

Здравствуйте, вытаскиваю запросом цены из _1SCONST, некоторые из них представлены непонятно как..гугление намекнуло что используется что 36ричная система счисления, но перевод из 36 р в 10 не дает правильных результатов, к тому же в некоторых значениях есть русские буквы. Может кто то знает как все таки хранятся там данные?
23B = 5.94
T5 = 90.47
2YOЦО = 15.54
Ответ:
Тебе надо обращать внимание на поле ID и от него плясать. Если это ID константы у которой в значениях лежит число, тогда там число, если агрегатка, тогда надо смотреть что там за агрегатка.
Вопрос: ЗУП 2.5 Документ Оплата о среднему заработку. нет данных для расчета.?!

Добрый день!
ЗУП 2.5 (2.5.124.3) 

Есть сотрудник. С 01.09.2017 переведен на внешнее совместительство.
Далее его по основной и второй организации рассчитывали документом Оплата о среднему заработку, - за сентябрь и октябрь все рассчитывалось нормально.

А вот за ноябрь - не рассчитывается. т.е. по основной организации он рассчитался нормально, а по второй программа выдает ошибку - нет данных для расчета среднего заработка. Хотя до этого два месяца было все ок. В регистрах записи есть. С другими сотрудниками проблем нет.
Ответ: Вопрос снят. Как решили - хз магия 1C. Плюнули, начали рассчитывать руками, но пред этим последний раз нажали кнопку рассчитать - и алеееее-оооп!
Вопрос: Среднее значение по аттестату

Доброго время! мне нужно реализовать функцию расчета среднего значения для аттестата у Физического лица. Если в 1с какие то функции или нужно создавать массив?
Подскажите как реализовать? не могу представить. Есть физическое лицо и все сведение о образовании, но нужно чтобы был средний балл.


Ответ:
Сообщение от 77gg77gg
табличную часть в том же справочнике или создать документ
Лучше регистр сведений, ка можно его еще подчинить регистратору (документ - регистрирующий значения оценок в разрезе физ лица и предмета). Документ и справочник как то не так :/ добавление новой оценки = перезапись объекта, что не есть гут, этож все-таки операция добавления по сути оперативных данных. По хорошему документ (физик + предмет = оценка) регистрирует свои движения в регистре сведений за определенный день. Регистр сведений (периодичность день) по измерениям - Физик и предмет, по ресурсам - оценка
По среднему в запросе так:
1C
1
2
3
4
5
6
7
8
9
    Запрос = Новый Запрос("ВЫБРАТЬ СРЕДНЕЕ(Оценки.Оценка) КАК Оценка ИЗ РегистрСведений.Оценки КАК Оценки
                          |ГДЕ Оценки.ФизическоеЛицо = &ФизическоеЛицо");
    
    Запрос.УстановитьПараметр("ФизическоеЛицо", ФизическоеЛицо);
    
    ВыборкаРезультата = Запрос.Выполнить().Выбрать();
        ВыборкаРезультата.Следующий();
    
    СредняяОценка = ?(ЗначениеЗаполнено(ВыборкаРезультата.Оценка), ВыборкаРезультата.Оценка, 0);
Вопрос: С некоторых исполнительных листов не рассчитывается Вознаграждение платежного агента

ЗУП 3.1.7.87 С некоторых исполнительных листов не рассчитывается Вознаграждение платежного агента(с полной суммы перевода 30р)
Ответ: Нашел причину: по этим исполнительным листам почтовое вознаграждение было рассчитано ранее документом Отпуск или Больничный. Сделал отбор по сотруднику в регистре расчета Удержания
Вопрос: СКД: оформить итоговое значение по Задолженности

Приветствую, Форумчане!

1. Создал некий отчет в СКД. В принципе работает правильно и выдает правильные результаты. Но вызывает серьезное возмущение по выводу результата по сумарной задолженности.

Как видно на рисунке в последней графе "Задолженность" видна расшифровка по задолженности, а нужно чтобы на глаза попадалось только итоговое значение (обвидено черным). Все остальные (зачеркнуто красным) необходимо убрать с глаз.

Подскажите как это можно сделать...

2. В иделале хотелось бы получить 2-е колонки по задолженности: если минус, то задолженность Компании, если "+", то задолженность Клиента...

Подскажите, кто чем может...

К сообщению приложен файл. Размер - 39Kb
Ответ:
trew
Ukraina,

1. В СКД закладка Ресурсы
2. В СКД закладка Вычисляемые поля (в поле Рассчитать по - попробуй ничего не указывать)


К сожалению это не помогло, в вычисляемых полях также ведется расшифровка, а нужно чтобы их не было (зачеркнуто красным)

Как можно будет создать подобный отчет (на новом рисунке)?

Т.е. Над итоговыми значениями по каждому контрагенту выводится итоговые данные по итогам, но с учетом по задолженности по направлениям, ну типа Дебет/Кретит в Акте взаиморасчетов

К сообщению приложен файл. Размер - 22Kb
Вопрос: Учет премий в расчете среднего заработка

Добрый день! Возник вопрос по учету премий в расчете среднего заработка в ЗУП 3. Открываю форму расчета среднего заработка для отпуска у сотрудника, ввожу в поле "годовая премия, учитываемая частично" произвольную сумму - сумма среднего заработка вообще не меняется. Как это должно работать? И еще заодно вопрос, может кто подскажет, переношу данные из другой системы, для расчета среднего заработка для отпусков заношу данные в регистры накоплений "ДанныеОВремениДляРасчетаСреднегоОбщий" и "ДанныеОНачисленияхДляРасчетаСреднегоЗаработкаОбщий", этого достаточно? И в какие регистры надо пихать эти самые годовые премии, чтобы они учитывались в расчете среднего? Спасибо заранее.

Вложения:

  • Размер файла:
    63,4 КБ
    Просмотров:
    5
Ответ:
Переключил, ввел сумму премии по новой, ничего не изменилось, сумма среднего осталась той же.
Вопрос: Как убрать период из расчета среднего

Здравствуйте!

Конфигурация ЗУП 2.5.

Проблема такая. Бухгалтер хочет, чтобы при расчете отпуска по календарным дням (и прочей оплате по среднему) из расчетного периода выбрасывалось время кадровых перемещений "по статье 72" и дополнительных отпусков.
При кадровом перемещении пользователю временно вместо оклада по часам назначается копия оклада по часам - "Оклад по часам (ст 72)".
Вопрос: как сделать так, чтобы ДНИ И ЧАСЫ, оплаченные видом расчета, не учитывались при расчете отпуска?
Ответ: Не понял. Откуда выкидывать?
Если ты про табличную часть расчета среднего в документе начисления отпуска, то там нет разбивки по видам начисления, там средний заработок индексируемый, не индексируемый и т.д.
Вопрос: [Удалить]УФ некоторые вопросы

Здравствуйте!
Опять у меня проблема с Владельцем формы, но теперь уже с УФ.
Помогите пожалуйста.
Документ - ВводЗаданий, ТЧ - Задания, Реквизит ТЧ - Контракт - Справочник.НоменклатурныеГруппы.
Код:
&НаКлиенте
Процедура ЗаданияКонтрактНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    Список = ЗаданияКонтрактНачалоВыбораНаСервере();
    Отбор = Новый Структура;
    Отбор.Вставить("Ссылка", Список);
    ПараметрыФормы = Новый Структура;
    ПараметрыФормы.Вставить("Отбор", Отбор);
    ПараметрыФормы.Вставить("Отображение", ОтображениеТаблицы.Список);
    //ПараметрыФормы.Вставить("Ключ", Элемент.Родитель.Родитель.ТекущийЭлемент); //Элементы.Задания.ТекущиеДанные.Контракт
    //ПараметрыФормы.Вставить("Владелец", Элемент.Родитель.Родитель.ТекущийЭлемент);
   
    ОткрытьФорму("Справочник.НоменклатурныеГруппы.ФормаВыбора", ПараметрыФормы,Элементы.Задания.ТекущиеДанные.Контракт);
КонецПроцедуры

&НаСервере
Функция ЗаданияКонтрактНачалоВыбораНаСервере()
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    |    КонтрактыФилиаловСрезПоследних.Контракт
    |ИЗ
    |    РегистрСведений.КонтрактыФилиалов.СрезПоследних(&Дата, ) КАК КонтрактыФилиаловСрезПоследних
    |ГДЕ
    |    КонтрактыФилиаловСрезПоследних.Филиал = &Организация";
   
    Запрос.УстановитьПараметр("Дата", Объект.Дата);
    Запрос.УстановитьПараметр("Организация", Объект.Организация);
   
    РезультатЗапроса = Запрос.Выполнить();
    Список = Новый СписокЗначений;
    Список.ЗагрузитьЗначения(РезультатЗапроса.Выгрузить().ВыгрузитьКолонку("Контракт"));
    Возврат Список;
КонецФункции

&НаКлиенте
//
Процедура ЗаданияКонтрактНачалоВыбораИзСписка(Элемент, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    Список = ЗаданияКонтрактНачалоВыбораНаСервере();
КонецПроцедуры

&НаСервере
Процедура ЗаданияКонтрактОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
    // Вставить содержимое обработчика.
    а=0;
КонецПроцедуры
Не получается - выбрать значение из справочника в документ.
Не срабатывает ПараметрыФормы.Вставить("Отображение", ОтображениеТаблицы.Список), надо из спр отобразить только значения из списка, а открывается иерархический список.
Спасибо!
Ответ:
С этим разобралась. ОбработкаВыбора для УФ не надо.
Для спр сделала ФормуВыбора УФ.
Есть другой вопрос, как сделать ввод двух значений пользователю ?
Вот чтото типа этого
Массив = Новый Массив;
Массив.Добавить(Тип("СправочникСсылка.НоменклатурныеГруппы"));
ОписаниеТипов = Новый ОписаниеТипов(Массив, );
Если ВвестиЗначение(ВыбЗнач, "Введите значение контракта", ОписаниеТипов) Тогда
// // обработка введенного значения
Сообщить("Введенное значение: "+ВыбЗнач);
КонецЕсли;
но двух значений, т.е. еще один справочник к примеру.
и, можно ли на открытый СправочникСсылка.НоменклатурныеГруппы наложить мои условия, мне надо всего два значения из спр.
Вопрос: Расчет среднего для больничного

Перенесли данные из БП 2 в ЗУП 3.0
Перенесли не вводом остатков, а создали документы кадровые и по расчету з/п начиная с лохматого года. Больничные спихали в документ начисления. В итоге суммы учитываются,а  дни нет

Интересует где указать кол-во дней для расчета среднего заработка?
Если брать полный год, то средний заработок считает правильно.
Но у сотрудника были больничные, которые в ээтот расчет попасть не должны
Ответ: Дни в строках с начислениями, входящими в расчет среднего, в веденных документах указаны?