Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: Удаление помеченных

Уважаемое сообщество. Помогите принять решение. У нас есть проблема, ночью выполняется регламент по физическому удалению объектов, помеченных на удаление. База большая, помеченных очень много и они не удаляются из-за того, что есть ссылки в регистрах или документах. Утром перед началом рабочего дня регламент завершается принудительно. Таким образом новые помеченные на удаление объекты не могут удалиться из-за того, что до них просто не доходит очередь. Встала задача фильтровать поиск ссылок на объект по тем объектам, которые были уже проверены в прошлый раз и по ним есть ссылки. Какие у меня есть идеи. Нужно обязательно вести где-то список объектов, которые имеют ссылки и их не проверять. Т.е. в типовую обработку проверку внести изменения. Но вот где этот список вести? Файл мне не очень нравится. Регистр сведений можно или внешних источник данных. В регистром работа будет быстрее, а внешний источник не будет создавать сам по себе ссылку на этот же объект. Но в любом случае нужно предусмотреть вариант, когда пользователь избавляется от ссылки, тогда нужно оперативно вносить изменения в эту таблицу и удалять из нее этот объект. Через подписку конечно можно все это сделать, но вот вопрос как быть с регистрами. Допустим на документы и справочники я могу подписку сделать, а вот как отработать вариант, когда из независимого регистра сведений удаляется запись и в ней была ссылка на удаляемый объект, как отследить и удалить во внешнем источнике это событие? И не нагрузит ли это сильно систему, постоянно обращаться во внешний источник в процессе оперативной работы?
В общем если у кого-то были подобные задачи или есть у кого мысли, делитесь, буду признателен.
Ответ: () Если Вам ночи мало (что само по себе крайне удивительно) - то можно прихватить и день - РИБ; отдельный узел, без юзверей, только для удаления помеченных и обмен до и после удаления.

Но лучше Вам разобраться почему у вас база тормозит на больших объёмах. Я знаю почему, но лучше Вам самим разобраться.
Вопрос: Удаление проводки в документе

Нужно удалить проводки по счету УСН.01. Получаю набор проводок, перебеораю их нахожу ту что нужно, а вот как ее правильно удалить не понимаю или может я что-то делаю неверно. Дайте совет.
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
        ТекДанные = ЭлементыФормы.ТабличнаяЧастьДокументов.ТекущиеДанные;
                  //Регистратор = ТекДанные.Регистратор;
 
 
    
 
    РегистраторСсылка = ТекДанные.Регистратор;
 
       
    Корректировка = РегистраторСсылка.ПолучитьОбъект();
 
 
    НаборПроводок = Корректировка.Движения.Хозрасчетный;
 
   
    НаборПроводок.Прочитать();
 
    Для Каждого Проводка Из НаборПроводок Цикл
 
       
        Сообщить(
            "Кт " + Проводка.СчетКт + " (" + Проводка.КоличествоКт + " шт.) " 
        ); 
 
        Если 
            Проводка.СчетКт = 
            ПланыСчетов.Хозрасчетный.НайтиПоКоду("УСН.01")
        Тогда
         
          //Тут не ясно
        
КонецЕсли; 
        
        Сообщить("Удалил");
        КонецЕсли;
 
    КонецЦикла;
Ответ:
1C
1
2
НаборПроводок.Удалить(Проводка);
НаборПрободок.Записать();
Вот так заработало...
Вопрос: Пометка удаления при синхронизации УТ 11 - > БП 3.0

Всем привет.
Настроена синхронизация (типовыми правилами) между последними релизами УТ и БП. Все синхронизируется без проблем, за исключением одного: не переносится пометка удаления установленная в документе "Поступление услуг и прочих активов" в УТ. Документ загружается в список документов "Поступление доп. расходов" в БП.
Любые изменения в документе отражаются в БП, но пометка удаления не переносится.
После синхронизации в БП статус "данные получены - сейчас", но обработано объектов - 0(отправляем всего один, помеченный на удаление, объект).

Если выполнить синхронизацию через сетевой каталог - в XML файле информация о пометке удаления присутствует.

Сталкивался кто-нибудь с подобной проблемой? Это норма или так быть не должно?
Ответ: В данном случае документ "поступление товаров и услуг", но с ним проблема точно такая-же. В случае, если он заполнен услугами, он попадает в список документов "Поступление доп. расходов" в БП и пометка также не переносится.
Вопрос: С помощью запроса получить элементы табличной части документа-регистратора

Собственно вопрос в теме: Как с помощью запроса получить элементы табличной части документа-регистратора из вирт. таблицы регистра Бухгалтерии?
ВЫБРАТЬ
    ХозрасчетныйОстаткиИОбороты.Счет,
    ХозрасчетныйОстаткиИОбороты.Подразделение,
    ХозрасчетныйОстаткиИОбороты.Субконто2,
    ХозрасчетныйОстаткиИОбороты.СуммаНачальныйОстатокДт КАК СуммаНачальныйОстатокДт,
    ХозрасчетныйОстаткиИОбороты.СуммаНачальныйОстатокКт КАК СуммаНачальныйОстатокКт,
    ХозрасчетныйОстаткиИОбороты.СуммаКонечныйОстатокДт КАК СуммаКонечныйОстатокДт,
    ХозрасчетныйОстаткиИОбороты.СуммаКонечныйОстатокКт КАК СуммаКонечныйОстатокКт,
    ХозрасчетныйОстаткиИОбороты.СуммаОборотДт КАК СуммаОборотДт,
    ХозрасчетныйОстаткиИОбороты.СуммаОборотКт КАК СуммаОборотКт,
    ХозрасчетныйОстаткиИОбороты.Субконто1,
    ХозрасчетныйОстаткиИОбороты.ПериодСекунда,
    ХозрасчетныйОстаткиИОбороты.Регистратор,
    АвансовыйОтчетТовары.Номенклатура
ИЗ
    РегистрБухгалтерии.Хозрасчетный.ОстаткиИОбороты(, , Авто, , , , ) КАК ХозрасчетныйОстаткиИОбороты
        ЛЕВОЕ СОЕДИНЕНИЕ Документ.АвансовыйОтчет.Товары КАК АвансовыйОтчетТовары
        ПО ХозрасчетныйОстаткиИОбороты.Регистратор = АвансовыйОтчетТовары.Ссылка
ГДЕ
    ХозрасчетныйОстаткиИОбороты.Счет.Ссылка В ИЕРАРХИИ(&Счет)

АвансовыйОтчетТовары - искомая Таб.Часть документа АвансовыйОтчет. При выгрузке результат - NULL. В чем косяк?
Ответ: () Как этот трэш учитывает ручные корректировки движений документа и операции введенные вручную?
Вопрос: Закрытие периода,как запретить сохранение документа при выходе?

Добавил в базу константу - ДатаЗапретаРедактирования.Добавил в документ и глобальный модуль  проверку при проведении,записи,удалении,отмене удаления и если документ старше этой даты - использую оператор "Возврат;"
Все нормально работает, но если открыть старый документ, изменить там чтото, закрыть его, при закрытии оно спрашивает "сохранить документ?" Если ответить ДА,то документ остаеться типа проведенным(птичка есть) но его проводки исчезают
Ответ: () Не Возврат а СтатусВозврата(). Открой ТиС типовой
Вопрос: Загрузка из DBF-файла в табличную часть одного документа

Здравствуйте!

Возник вопрос: как можно в данном случае вывести данные из DBF-файла в одну табличную часть одного документа?

Получается так, что данные выводятся не в один документ, а в разный документ по одной строке (если в БД 5 строк, то выводится 5 документов и т.д.). И те поля, у которых значение "Дата", не выводятся никак.

Код:
Код:
Процедура ДействияФормыЗагрузить(Кнопка)
   //Определим путь файла загрузки

   Режим = РежимДиалогаВыбораФайла.ВыборКаталога;
   ДиалогОткрытия = Новый ДиалогВыбораФайла(Режим);
   ДиалогОткрытия.Каталог = "";
   ДиалогОткрытия.МножественныйВыбор = Ложь;
   ДиалогОткрытия.Заголовок = "Выберите каталог";

   Если ДиалогОткрытия.Выбрать() Тогда
   
       Путь = ДиалогОткрытия.Каталог;
   
   КонецЕсли;

   //Создаем переменную XBase
   ДБФ = Новый XBase;

   //Открываем файл
    ДБФ.ОткрытьФайл("D:\281117.DBF");

  //Проверка на наличие записей
  Если ДБФ.КоличествоЗаписей() = 0 Тогда
      Сообщить("Файл данных пуст");
      ДБФ.ЗакрытьФайл();
      Возврат
  КонецЕсли;

   //Переходим на первую строку файла
   ДБФ.Первая();

   Документ = Неопределено;
 
   Док = Неопределено;
   
   Пока Истина Цикл
   
   ЛицевойСчет = ДБФ.LS;
   ФИО = ДБФ.FIO;
   ПочтовыйИндекс = ДБФ.INDEX;
   УчастокОбслуживания = ДБФ.RAION;
   НаселенныйПункт = ДБФ.NASPUNKT;
   Улица = ДБФ.UL;
   НомерДома = ДБФ.DOM;
   НомерКвартиры = ДБФ.KV;
   НомерКомнаты = ДБФ.KOMNATA;
   ДатаЗаключенияДоговораНаПоставкуГаза = ДБФ.DDOG;
   НомерДоговораНаПоставкуГаза = ДБФ.NDOG;
   ДатаВыдачиДоговораНаРуки = ДБФ.DVID;
   НомерМобильногоТелефона = ДБФ.T_SOT;
   НомерДомашнегоТелефона = ДБФ.T_DOM;
   КодАдресаПоФИАС = ДБФ.KOD;

          Если НЕ ДБФ.NDOG = Документ Тогда

           //Записываем предыдущий документ
           Если НЕ (Док = Неопределено) Тогда
               Док.Записать();
          КонецЕсли;
         
         
           //Создаем новый документ
Док = Документы.ДоговорНаПоставкуГаза.СоздатьДокумент(); 
   
           //Заполняем реквизиты шапки
   Док.Дата = ТекущаяДата();
       КонецЕсли;
       
       // устанавливаете значения реквизитов ТЧ
   
   НоваяСтрока = Док.Реестр.Добавить();
   НоваяСтрока.ЛицевойСчет =  ЛицевойСчет;
   НоваяСтрока.ФИО = ФИО;
   НоваяСтрока.ПочтовыйИндекс = ПочтовыйИндекс;
   НоваяСтрока.УчастокОбслуживания = УчастокОбслуживания;
   НоваяСтрока.НаселенныйПункт = НаселенныйПункт;
   НоваяСтрока.Улица = Улица;
   НоваяСтрока.НомерДома = НомерДома;
   НоваяСтрока.НомерКвартиры = НомерКвартиры;
   НоваяСтрока.НомерКомнаты = НомерКомнаты;
   НоваяСтрока.ДатаЗаключенияДоговораНаПоставкуГаза = ДатаЗаключенияДоговораНаПоставкуГаза;
   НоваяСтрока.НомерДоговораНаПоставкуГаза = НомерДоговораНаПоставкуГаза;
   НоваяСтрока.ДатаВыдачиДоговораНаРуки = ДатаВыдачиДоговораНаРуки;
   НоваяСтрока.НомерМобильногоТелефона = НомерМобильногоТелефона;
   НоваяСтрока.НомерДомашнегоТелефона = НомерДомашнегоТелефона;
   НоваяСтрока.КодАдресаПоФИАС = КодАдресаПоФИАС;
       
       // Переходим на следующую запись
       Если не ДБФ.Следующая() Тогда
           //Если записей больше нет выходим из цикла
           Прервать;
       КонецЕсли;
   КонецЦикла;
 
   // записываем последний добавленный
   Если НЕ (Док = Неопределено) Тогда
       Док.Записать();
   КонецЕсли;
   
КонецПроцедуры
Ответ:
Всё, получилось! Я решил проблему путём удаления старой формы документа и создания новой.
Вопрос: Загрузка в табличную часть документа данных из DBF-файла

Здравствуйте!

Нужно вывести данные в табличную часть документа "ДоговорНаПоставкуГаза" из DBF-файла.
Имеются реквизиты в табличной части "Реестр": ЛицевойСчет, ФИО, ПочтовыйИндекс, УчастокОбслуживания, НаселенныйПункт, Улица, НомерДома, НомерКвартиры,  НомерКомнаты, ДатаЗаключенияДоговораНаПоставкуГаза, НомерДоговораНаПоставкуГаза, ДатаВыдачиДоговораНаРуки, НомерМобильногоТелефона, НомерДомашнегоТелефона, КодАдресаПоФИАС.

Сама база данных просчитывается с помощью подобного кода по нажатию кнопки "Загрузить":

Процедура ДействияФормыВыгрузить(Кнопка)
Таблица = Новый XBase;
    Таблица.ОткрытьФайл( 
        "D:\dogovor\выгрузка\281117.dbf",// путь к базе

        ,// путь к индексу

        Истина// только чтение

    );
 
    Сообщить("В таблице " + Таблица.КоличествоЗаписей() + " записей.");
    Сообщить("Таблица имеет кодировку: " + Таблица.Кодировка);
 
    Таблица.Первая();// перешли к первой записи

    Пока Не Таблица.ВКонце() Цикл
        Если Не Таблица.ЗаписьУдалена() Тогда
            Сообщить(
                Строка(Таблица.LS) + " " +
                Таблица.FIO + " " + 
                Таблица.INDEX + " " +
                Таблица.RAION + " " +
                Таблица.NASPUNKT + " " +
                Таблица.UL + " " +
                Таблица.DOM + " " +
                Таблица.KV + " " +
                Таблица.KOMNATA + " " +
                Таблица.DDOG + " " +
                Таблица.NDOG + " " +
                Таблица.DVID + " " +
                Таблица.T_SOT + " " +
                Таблица.T_DOM + " " +
                Таблица.KOD            
            );
        КонецЕсли;
        Таблица.Следующая();// переходим к следующей записи

            
            КонецЦикла;    

    Таблица.ЗакрытьФайл();

КонецПроцедуры
Ответ: Всё, получилось! Я решил проблему путём удаления старой формы документа и создания новой.
Вопрос: КА 2.2 корректировка поступления / изменение остатков

Здравствуйте!
В корректировке поступления изменения в меньшую сторону по количеству (и соответственно, суммам) одной номенклатуры. Фактически аналогично полному удалению строки поступления.
Документ в следующем месяце за поступлением в том же году. Выбрана "корректировка по согласованию сторон". Проводки по счетам 19.03, 60.01, 60.02, 90.02.1.
Документ не делает движений по регистрам товаров. И получается, что эта номенклатура на остатке все еще числится, а также на остатке бух.по 41 счету.
Вопрос - сделали что-то не так или нужно дополнительно делать какие-то еще документы, чтобы остаток ушел?
Ни в одном описании работы с этим документом не нахожу подсказок :(
Ответ: () спасибо!

вроде и понятно

нет варианта - "качественный и не принят" (или не доехало, договорились что поставщик пришлет корректировочные документы).
если считать, что полностью оформленное в комплексной поступление = "принят", т.е. как в последнем варианте, тогда описанное похоже на проводки документа "возврат поставщику", а у нас с корректировкой поступления (как в () ) оказался  из 90 задействован только субсчет «Себестоимость продаж»
Вопрос: УПП 1.2 (1.2.9.2) Списание себестоимости в док-те Корректировка поступления

Здравствуйте!
В прошлом году был сформирован документ Поступление товаров и услуг. На основании прихода , тоже в том году, был создан документ Реализация товаров и услуг. В документе реализуется номенклатура Дверь, в кол-ве 1 штука, с себестоимостью 1000 руб.
Далее после закрытия периода по каким-то причинам нужно было скорректировать сумму прихода в большую сторону на сумму: 100 рублей. Создали документ Корректировка поступления с видом операции "исправление в первичных документах". Проблема вот в чем: как списать себестоимость разницы нужна проводка Д 90.02.1 К 41.01
Нужно изменять конфигурацию или можно это сделать стандартными методами?
За ранее спасибо!
Ответ: () Вероятно Вы смотрели в книгу, а видели фигу. Посмотрите еще раз. Только на релизе, не являющемся ровесником мамонтов.

PS. В интерфейсе она появляется только когда документ поступления в одном налоговом периоде, а документ корректировки в другом.
Вопрос: Проводки в документе "Корректировка реализации"

Здравствуйте!
Бухгалтерия предприятия, редакция 2.0 (2.0.66.29)

Был создан документ "Корректировка реализации" за прошлый период, с отражением только в учете НДС. Период уже закрыт.

Вопрос: как можно сделать необходимые проводки автоматически
Ответ:
Документ провелся, но не сделал необходимых проводок по 19 счету и 62 счету и т.д.
по одной строчки из корректировки вот такие проводки А есть документы с большим списком оказанных услуг