Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: УФ выбор произвольного документа в поле ввода

Добрый день, уважаемые форумчане!

Мне необходимо выбрать произвольный документ из уже имеющихся в базе в диалоговом режиме.

Создаю реквизит формы "Док" с типом "ДокументСсылка". Помещаю на форму поле ввода с путем к данным "Док".

При запуске обработки вижу следующее: сначала появляется выбор вида документов, потом открывается соответствующий журнал документов, а дальше начинается засада: при попытке выбора любого документа он не выбирается в форму, а открывается для редактирования.

Подскажите пожалуйста, как можно заставить 1с выбрать документ, а не открывать его форму.
Ответ:
Там не так много вариантов. Значит у вас открывается не форма выбора, а форма элемента. Все просто.
Вопрос: Не вводятся значения в поле ввода формы

Есть две управляемые формы (произвольные). На первой форме элементы типа Поле надписи и кнопка, которая открывает вторую форму с теми же элементами, но с типом поле ввода.

При открытии второй формы, данные не вводятся в поля. Доступность стоит, курсор ставится в поле, но ничего туда не вводится.
Ответ:
Сообщение от polax
Maxon4ick, По всей видимости, вы пытаетесь присвоить разный Вид одному и тому же реквизиту документа/обработки (например, Объект.Наименование) Попробуйте использовать разные реквизиты и назовите во второй форме поле ввода по другому.
Спасибо, проблема решена.
Вопрос: Как при выборе значения в поле ввода ограничить список выбора для типа "Справочник"?

Одно из полей табличной части документа задано типом СправочникСтатьиЗатрат. При выборе элемента в соответствующем поле ввода по умолчанию появляется форма выбора, где можно выбрать любой элемент из этого справочника. А необходимо наоборот, ограничить список выводимых для выбора значений, наложив определенные условия. Как можно это реализовать?
Ответ:
Спасибо за информацию. У меня такая же задача, правда получилось немного по другому. Вместо ФормаВыбора.СправочникСписок.Отбор, ФормаВыбора.Отбор, на СправочникСписок ругается. И еще, когда открывается список справочника, установленный отбор зашит жестко, при этом другие отборы дополнительно, можно устанавливать, (что хорошо). Теперь новая задача, ищу как отсортировать элементы в открывшейся форме по коду, есть предложения?

Процедура ТПНоменклатураТипПоУлТипПоУЛПрисвоитьНачалоВыбора(Элемент, СтандартнаяОбработка)
СтандартнаяОбработка = Ложь;
пПВХТипПоУпаковочномуЛисту=ПланыВидовХарактеристик.СвойстваОбъектов.НайтиПоНаименованию("Тип по упаковочному листу");
ФормаВыбора = Справочники.ЗначенияСвойствОбъектов.ПолучитьФормуВыбора(,Элемент);
ФормаВыбора.Отбор.Владелец.ВидСравнения = ВидСравнения.Равно;
//(тут СправочникСписок - это название твоего табличного поля на форме выбора справочника, так что оно может быть другим в твоём случае)
ФормаВыбора.Отбор.Владелец.Использование = Истина;
ФормаВыбора.Отбор.Владелец.Значение = пПВХТипПоУпаковочномуЛисту;
ФормаВыбора.Открыть();
КонецПроцедуры
--- Объединение сообщений, 24 мар 2016 ---
Нашел
ФормаВыбора.Порядок.Установить("Код");
уже после открытия формы
Вопрос: Множественный выбор в поле ввода

Добрый день подскажите: есть обработка заполнения ТЧ: у нее форма: на ней поле ввода "Группа"с типом значений "Список значений" и тип значения справочник "номенклатура".

Нужно организовать множественный выбор родителей в этой поле в начало выбора пишу следующее:

Код:
 СтандартнаяОбработка = Ложь;
    мФорма = Справочники.Номенклатура.ПолучитьФормуВыбора("ФормаВыбораГруппы",ЭлементыФормы.Группа);
    мФорма.МножественныйВыбор    = Истина;
    мФорма.РежимВыбора          = Истина;
    мФорма.ОткрытьМодально();
что передать в обработку выбора: чтобы в полне Группа на форме появилось несколько выбранных значений ?
Ответ:
спасибо, попробую
Вопрос: Форма выбора с отбором для списка значений

Добрый день. Нужна Ваша помощь в решении простой задачки.

Конфа ЗУП 2.5.113.1

Есть внешний отчет, у отчета есть реквизит "список баз", тип список значений.
Есть форма отчета. На форме отчете поле "ввода список баз", ТипЗначения = "СписокЗначений", а типЗначенияСписка = "СправочникССылка.ЗначениеСвойствОбъектов".

Как открыть форму выбора с отбором по владельцу некоторого свойства?

Заранее спасибо!
Ответ: На закладке Параметры есть колонка Параметры редактирования. там можно попробовать настроить связи параметров выбора или параметр выбора
Вопрос: Такси. Поле ввода с данными составного типа.

Такси. У элемента справочника есть поле составного типа (два справочника). При начале выбора нужно наложить фильтры на список того справочника из которого будет выбор. Вопрос - как перед началом выбора элемента, выбрать тип справочника из которого будем выбирать?
Поскольку накладывают отборы, то в процедуре НачалоВыбора стоит
СтандантртнаяОбработка = Ложь.
Кнопки выбора типа в поле нет и приделать туда не знаю как.
Галка "Выбирать тип" установлена, но при СтандантртнаяОбработка = Ложь она не работает.
В общем не могу понять как выбрать тип перед выбором значения. Разве что, явно предварительно вызывать форму с выбором типа?
Туплю...
Может кто направит в нужном направлении?
Ответ: () при выборе типа отрабатывает событие ПриИзменении(). Там можно поиграться с Параметрами выбора элемента, при условии
ТвойРек<> Неопределено И НЕ ЗначениеЗаполнено(ТвойРек)
Вопрос: Программный выбор типа в поле ввода

Привет всем.
Хочу следующее (в такси 8.3):
Реквизит составного типа из пары справочников.
При нажатии на кнопку выбора чтобы тип не предлагался, но при этом чтобы открывался тот справочник к выбору, который согласно некоторых обстоятельств для этого подходит.

Галку выбора типа отключаю. Далее какой самый быстрый способ это разрулить?
Ответ: () ()
Спасибо.
Вопрос: Возможно ли сделать отбор в форме списка док? Поле - не реквизит документа.

Возможно ли сделать отбор в форме списка док? Поле - не является реквизитом документа. Заполняется с помощью запроса.
Ответ: У меня все уже получилось
        СписокДокРеал= новый списокЗначений;
        Построитель = Новый ПостроительЗапроса;
        Источник = Новый ОписаниеИсточникаДанных;
        Источник.ИсточникДанных = ДокументСписок;
        Построитель.ИсточникДанных = Источник;
        Построитель.Выполнить();
        ТаблицаДокументов = Построитель.Результат.Выгрузить();
        МасДок = ТаблицаДокументов.ВыгрузитьКолонку("Ссылка");
        СписокДокРеал.ЗагрузитьЗначения(МасДок);
        
        
        
        Запрос= новый Запрос; 
        Запрос.Текст= 
        "ВЫБРАТЬ
        |    ОригиналыДокументов.Документ
        |ИЗ
        |    Справочник.ОригиналыДокументов КАК ОригиналыДокументов
        |ГДЕ
        |    ОригиналыДокументов.Документ В(&ТекДок)"; 
        Запрос.УстановитьПараметр("ТекДок", СписокДокРеал); 
        
        СписокДокОриг= новый списокЗначений;
        ТЗ=Запрос.Выполнить().Выгрузить();
        Мас = ТЗ.ВыгрузитьКолонку("Документ");
        
        СписокДокОриг.ЗагрузитьЗначения(Мас);
        ЭтаФорма.ДокументСписок.Отбор.Ссылка.ВидСравнения = ВидСравнения.ВСписке; 
        ЭтаФорма.ДокументСписок.Отбор.Ссылка.Значение = СписокДокОриг; 
        ЭтаФорма.ДокументСписок.Отбор.Ссылка.Использование = Истина;
Вопрос: Создать программно список значений.

Необходимо программно создать немодальный аналог списка значений и предоставить пользователю выбрать из него значения.
Все что выдает гугл - не понимаю. Прошу пошагово разъяснить.
Ответ:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
&НаКлиенте
Процедура ПоказатьСписокЗначений(Команда)
    
    СписокЗначений = Новый СписокЗначений;
    
    СписокЗначений.Добавить("Значение1");
    СписокЗначений.Добавить("Значение2");
    СписокЗначений.Добавить("Значение3");
    
    СписокЗначений.ПоказатьОтметкуЭлементов(Новый ОписаниеОповещения("ЗавершитьОтметкуЭлементов", ЭтотОбъект));
    
КонецПроцедуры
 
&НаКлиенте
Процедура ЗавершитьОтметкуЭлементов(Список, ДополнительныеПараметры) Экспорт
    
    Если Список <> Неопределено Тогда
        Сообщить("Выполнена отметка элементов");
    КонецЕсли;
    
КонецПроцедуры
Вопрос: Где можно использовать список значений?

Подскажите какие-то наглядные примеры где бы удобно было использовать список значений?
Ответ:
Я бы даже сказал интерактивный массив с пометками.
Например сформировать отчет не по всему перечню, а только по тем элементам, у которых пометка = истина в списке
т.е. 1,3,5-8,11...