Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: Для выгрузки справочников, документов из сайта на базе 1с Битрикс в ут 11.3 стоит

Для выгрузки справочников, документов из сайта на базе 1с Битрикс в ут 11.3 стоит использовать "Модуль для: "Управление торговлей ред. 11.3" или есть другие методы?
Ответ: () От 2 часов и до бесконечности
Вопрос: Выгрузка данных из ТиС 7.7 в 8.3 ут 10.3

Здравствуйте, подскажите. Делаю перенос справочников, остатков и документов в ут 10.3.
Все вроде получается, все переносится. Единственный вопрос.
Мне нужны все документы(реализации, расходники, приходники и т.д.). Мне нужно, сначала выгрузить справочники, а потом документы и провести их? А то я сделал выгрузку справочников, остатков, а потом документов, провел документы, и номенклатура у меня не сходится.
Нужно ли выгружать остатки на складе? Или хватит одних документов?
Ответ:
Скажите, у вас с переносом контактной информацией получилось? Можете пример скинуть?
Вопрос: Выбор периода в выгрузке

Приветствую. Есть самописная обработка-выгрузка справочников и оборотов. Она не верно работает, точнее выгружает документы только до вчерашнего числа. Допустим сегодня сформировали автозаказ, так сегодняшние заказы обработка не выгружает. Глянул код и честно гвооря меня он смутил.

НастройкаПериода.УстановитьПериод(Период.ДатаНачала, ?(Период.ДатаОкончания='0001-01-01', Период.ДатаОкончания, КонецДня(Период.ДатаОкончания)));

Есть тут кодеры? подскажите?
Ответ: насколько я понимаю в приведенном коде ниже идет инициилизация данных для выгрузки

"ВЫБРАТЬ
        |    ТоварыНаСкладахОбороты.Номенклатура КАК Номенклатура,
        |    ТоварыНаСкладахОбороты.Регистратор,
        |    ЕСТЬNULL(ТоварыНаСкладахОбороты.Регистратор.Контрагент, ЕСТЬNULL(ПартииТоваровНаСкладах.ДокументОприходования.Контрагент, ЗНАЧЕНИЕ(Справочник.Контрагенты.ПустаяСсылка))) КАК Контрагент,
        |    ТоварыНаСкладахОбороты.Регистратор.Номер,
        |    ТоварыНаСкладахОбороты.Регистратор.Дата,
        |    ВЫБОР
        |        КОГДА ТоварыНаСкладах.ВидДвижения = ЗНАЧЕНИЕ(ВидДвиженияНакопления.Расход)
        |            ТОГДА ЕСТЬNULL(ТоварыНаСкладахОбороты.КоличествоРасход, 0) + ЕСТЬNULL(ТоварыНаСкладахОбороты.КоличествоПриход, 0)
        |        ИНАЧЕ ЕСТЬNULL(ТоварыНаСкладахОбороты.КоличествоРасход, 0) + ЕСТЬNULL(ТоварыНаСкладахОбороты.КоличествоПриход, 0)
        |    КОНЕЦ КАК Количество,
        |    ТоварыНаСкладах.ВидДвижения,
        |    ТоварыНаСкладах.НомерСтроки
        |ПОМЕСТИТЬ ВТ_Остатки
        |ИЗ
        |    РегистрНакопления.ТоварыНаСкладах.Обороты(&ДатаНачала, &ДатаОкончания, Регистратор, &УсловиеСклад) КАК ТоварыНаСкладахОбороты
        |        ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрНакопления.ТоварыНаСкладах КАК ТоварыНаСкладах
        |        ПО ТоварыНаСкладахОбороты.Регистратор = ТоварыНаСкладах.Регистратор
        |            И ТоварыНаСкладахОбороты.Номенклатура = ТоварыНаСкладах.Номенклатура
        |            И ТоварыНаСкладахОбороты.ХарактеристикаНоменклатуры = ТоварыНаСкладах.ХарактеристикаНоменклатуры
        |            И ТоварыНаСкладахОбороты.СерияНоменклатуры = ТоварыНаСкладах.СерияНоменклатуры
        |            И ТоварыНаСкладахОбороты.Качество = ТоварыНаСкладах.Качество
        |            И ТоварыНаСкладахОбороты.Склад = ТоварыНаСкладах.Склад
        |        ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрНакопления.ПартииТоваровНаСкладах КАК ПартииТоваровНаСкладах
        |        ПО ТоварыНаСкладахОбороты.Регистратор = ПартииТоваровНаСкладах.Регистратор
        |            И ТоварыНаСкладахОбороты.Номенклатура = ПартииТоваровНаСкладах.Номенклатура
        |            И ТоварыНаСкладахОбороты.ХарактеристикаНоменклатуры = ПартииТоваровНаСкладах.ХарактеристикаНоменклатуры
        |            И ТоварыНаСкладахОбороты.СерияНоменклатуры = ПартииТоваровНаСкладах.СерияНоменклатуры
        |            И ТоварыНаСкладахОбороты.Качество = ПартииТоваровНаСкладах.Качество
        |            И ТоварыНаСкладахОбороты.Склад = ПартииТоваровНаСкладах.Склад
        |;";
Вопрос: Проблема с выгрузкой характеристик при обмене с сайтом из Розница 2.2

Версия платформы: 8.3.9.2233
Версия конфигурации: Розница(базовая), 2.2.5.22
ВерсияСхемы="2.07"

------
Не знаю связано ли это с версией схемы, но при выгрузке через УТ10.3 (версия схемы 2.05) в файле добавлялся узел "ХарактеристикиТовара". В рознице такого элемента в дереве нет.

для наглядности приведу пример.
Было:
<Предложение>
    <Ид>89f665e5-1da4-11e6-81f9-94de80101acc#89f665ea-1da4-11e6-81f9-94de80101acc</Ид>
    <Штрихкод>123123123</Штрихкод>
    <Наименование>Куртка  с капишоном (140, Темно-синий)</Наименование>
    <БазоваяЕдиница Код="796 " НаименованиеПолное="Штука" МеждународноеСокращение="PCE">шт</БазоваяЕдиница>
    <ХарактеристикиТовара>
        <ХарактеристикаТовара>
            <Наименование>Цвет </Наименование>
            <Значение>Темно-синий</Значение>
        </ХарактеристикаТовара>
        <ХарактеристикаТовара>
            <Наименование>Размер</Наименование>
            <Значение>140</Значение>
        </ХарактеристикаТовара>
    </ХарактеристикиТовара>
    <Цены>
        <Цена>
            <Представление>1 500 руб. за шт</Представление>
            <ИдТипаЦены>b2d464dc-7cf4-11e2-8914-4c72b9558678</ИдТипаЦены>
            <ЦенаЗаЕдиницу>1500.00</ЦенаЗаЕдиницу>
            <Валюта>руб</Валюта>
            <Единица>шт</Единица>
            <Коэффициент>1</Коэффициент>
        </Цена>
    </Цены>
    <Количество>1.00</Количество>
</Предложение>

Стало:
<Предложение>
    <Ид>bb02ac20-eaf7-11e6-9b6b-74dfbf368352#b81d9eed-e520-11e6-b637-14dda98fb7b2</Ид>
    <Артикул>424124</Артикул>
    <Наименование>Платье с люрексом ( бордо ) (Размер L (40) )</Наименование>
    <БазоваяЕдиница Код="796" НаименованиеПолное="Штука" МеждународноеСокращение="PCE">
        <Пересчет>
            <Единица>796</Единица>
            <Коэффициент>1</Коэффициент>
        </Пересчет>
    </БазоваяЕдиница>
    <Цены>
        <Цена>
            <Представление> 4 499 RUB за шт</Представление>
            <ИдТипаЦены>b81d9ec7-e520-11e6-b637-14dda98fb7b2</ИдТипаЦены>
            <ЦенаЗаЕдиницу>4499</ЦенаЗаЕдиницу>
            <Валюта>RUB</Валюта>
            <Коэффициент>1</Коэффициент>
        </Цена>
    </Цены>
    <Количество>0</Количество>
</Предложение>
----

Отсутствие узла "ХарактеристикиТовара" связано с редакцией или с версией схемы? или может в настройках что то нужно поменять?



===========

И второй вопрос. Возможно ли включить в выгрузку, справочник с дисконтными картами (вроде "Информационные карты")? Или единственный способ - ручная выгрузка в файл через обработчики типа "ВыгрузкаЗагрузкаДанныхXML.epf" ? Есть ли в 1с какие нибудь еще варианты для автоматизации процесса с использованием расписаний?
Ответ: () там не не решение нужно а подсказка :).

>Отсутствие узла "ХарактеристикиТовара" связано с редакцией или с версией схемы? или может в настройках что то нужно поменять?
Вопрос: Чем сделать периодическую выгрузку из 1С 8.3 в SQL таблицу?

Подскажите нужно из базы 1С 8.3 настроить ежедневную выгрузку справочника в таблицу SQL в отдельную базу, какими инструментами это можно сделать?
Узнал что есть консоль запросов 1С, хотел бы узнать это 1С создала эту консоль запросов? ее можно с сайта 1С скачать?
И даже если в ней написать запрос, чем его ежедневное выполнение обеспечить?
Ответ:
ibx32
а как понять из каких таблиц выбирать данные?
слышал что 1С может каким-то образом выгрузить соответствие своих объектов и таблиц базы SQL
Вот есть
Вопрос: загрузка характеристик и свойств из Exel в 1с 8 10.3

Добрый день, подскажите, как подгружать характеристики и свойства в 1С 8 10.3 из Exel

загружается артикул, номенклатура, цена,

а мне нужны характеристики, свойства, производитель (бренд)

очень жду ответа
Ответ:
ок, сегодня попробуем своими силами, завтра опишусь

Уточните по срокам
Вопрос: Ошибка разбора XML при выгрузке базы 1С7.7 в 1С8.2

Здравствуйте. Прошу помочь. Есть база в 1с 7.7 Бухгалтерский учет для Казахстана 7.70.273 надо ее загрузить в 1с 8.2. (8.2.19.83) Управление торговым предприятием для Казахстана.
Делаю, все прогружается, кроме справочника "Номенклатура"
Делаю так:
1. Беру правила из типовой конв файл ACC77_277_81.xml
2. Обработкой V77exp77_81.epf открываю в 1с7 - "Универсальную выгрузку данных в формате XML"
3. Кладу v7plus.dll в каталог BIN (рядом с exe-файлом 1с) также пробовала и класть рядом с правилами и обработкой
4. Запускаю выгрузку - все выгружается
5. Загружаю в 8.2. на позиции 23 343 вылетает с ошибкой

Ошибка при загрузке данных: {Обработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(1132)}: Ошибка при вызове метода контекста (Прочитать): Ошибка разбора XML: - [3539,36111655]Фатальная ошибка: PCDATA invalid Char value 7SystemId: file://D:/_KUV/Конвертация_7_8/Выгрузка.xml

1.Пробовала менять dll на другие,
2.файл с правилами тоже пробовала другой.
3.делала тестирование и исправление ИБ

тестирование дало...
Проверка содержимого проводок. Проводка номер 1 документа Операция 00000000553. Изменено время
Проверка операций. Операция документа ЗакрытиеДтКтЗадолженности 00000000001. . Изменено время
Проверка операций. Операция документа Операция 00000000553. . Изменено время
4. Выгрузка и вновь загрузка ИБ тоже ничего не дала

Ошибка именно в справочнике? Справочник "Номеклатура" гружу отдельно от остальных объектов, все объекты загрузились справ "Номенклатура" - нет. Как ее найти? Опыта нет в этом.

Спасибо.
Ответ:
судя по ошибке - вероятно у какого-то элемента из справочника номенклатура в каком-то из полей введен символ, который 1С не может нормально выгрузить. Если принять что в сообщение об ошибке указывается этот символ - то видно, что это символ с кодом 0x07 (bel).
Ну таким образом поискать в одном из полей справочника номенклатура этот символ..
Вопрос: Помогите с сохранением выгрузки в сбербанк выписка квитанции

Добрый день народ! Помогите решить проблему с выгрузкой родительской платы в сбербанк. Ломаю голову не могу сохранить в отдельный файл значения в отдельности для каждого учреждения выписки квитанции. Сохраняет только по последнему выбранному учреждению в табличной части обработки во все файл. Если например я заполняю 3 учреждения МБДОУ № 9,МБДОУ № 11,МБДОУ № 13 то берет в три файла детишек именно МБДОУ № 13. Простите если что недопонимаю но мне кажется тут ошибка. На скриншоте видно.

Для Каждого СтрокаТаблицы ИЗ АнализВыгрузки Цикл;
Текст.Записать((СтрокаТаблицы.ИмяФайлаВыгрузки), "windows-1251");
КонецЦикла;

Вложения:

  • Размер файла:
    14,7 КБ
    Просмотров:
    1
  • Размер файла:
    37,2 КБ
    Просмотров:
    8
Ответ:
Перем СписокДок;
Перем мСписокВидовОпераций;
Перем мВалютаРегламентированногоУчета;

Процедура КнопкаНастройкаПериодаНажатие(Элемент)

ТиповыеОтчеты.НастроитьПериод(НастройкаПериода, ДатаНачала, ДатаОкончания);

КонецПроцедуры

Функция ВернутьУчреждение()
СтрокаТаблицы = ЭлементыФормы.АнализВыгрузки.ТекущиеДанные;
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
| яяСоответствиеУчреждений.КодУчреждения
|ИЗ
| РегистрСведений.яяСоответствиеУчреждений КАК яяСоответствиеУчреждений
|ГДЕ
| яяСоответствиеУчреждений.Учреждение В (&Учреждение)";
Запрос.УстановитьПараметр("Учреждение",СтрокаТаблицы.Учреждение);
Выборка = Запрос.Выполнить().Выбрать();
Если Выборка.Следующий() Тогда
РезультатВыборки= Выборка.КодУчреждения;
КонецЕсли;

//Сообщить("Не найдено соответствие учреждения по коду: "+СокрЛП(КодУчреждения));

Возврат РезультатВыборки;

КонецФункции

Функция ПолучитьИННУчрежденияДляВыгрузкиВФайл()
СтрокаТаблицы = ЭлементыФормы.АнализВыгрузки.ТекущиеДанные;

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| Организации.ИНН КАК ИННУчреждения
|ИЗ
| Справочник.Организации КАК Организации
|ГДЕ
| Организации.Ссылка В (&Учреждение)";

Запрос.УстановитьПараметр("Учреждение",СтрокаТаблицы.Учреждение);

РезультатЗапроса = Запрос.Выполнить();

ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
РезультатВыборки = ВыборкаДетальныеЗаписи.ИННУчреждения;
КонецЦикла;

Возврат РезультатВыборки;

КонецФункции

Процедура КнопкаВыгрузитьНажатие(Кнопка)


Текст = Новый ТекстовыйДокумент;
Запрос = Новый Запрос;

ТекстЗапроса = "ВЫБРАТЬ
| СоответствиеУчреждений.КодУчреждения КАК Код,
| РП_ВыпискаКвитанций.Учреждение.Наименование КАК Наименование,
| ВЫБОР
| КОГДА (ВЫРАЗИТЬ(РП_ВыпискаКвитанций.РеквизитыЛицевогоСчета.КорреспондентТекст КАК СТРОКА(1000))) = """"
| ТОГДА РП_ВыпискаКвитанций.Учреждение.НаименованиеПолное
| ИНАЧЕ РП_ВыпискаКвитанций.РеквизитыЛицевогоСчета.КорреспондентТекст
| КОНЕЦ КАК НаименованиеПолное,
| ВЫБОР
| КОГДА РП_ВыпискаКвитанций.РеквизитыЛицевогоСчета.КорреспондентИНН = """"
| ТОГДА РП_ВыпискаКвитанций.Учреждение.ИНН
| ИНАЧЕ РП_ВыпискаКвитанций.РеквизитыЛицевогоСчета.КорреспондентИНН
| КОНЕЦ КАК ИНН,
| ВЫБОР
| КОГДА РП_ВыпискаКвитанций.РеквизитыЛицевогоСчета.КорреспондентКПП = """"
| ТОГДА РП_ВыпискаКвитанций.Учреждение.КПП
| ИНАЧЕ РП_ВыпискаКвитанций.РеквизитыЛицевогоСчета.КорреспондентКПП
| КОНЕЦ КАК КПП,
| РеквизитыЛицевыхСчетов.БИК,
| РеквизитыЛицевыхСчетов.КоррСчет,
| РеквизитыЛицевыхСчетов.НаименованиеБанка,
| РеквизитыЛицевыхСчетов.РасчетныйСчет,
| РП_ВыпискаКвитанций.Учреждение.КодОКАТО КАК ОКАТО,
| РП_ВыпискаКвитанций.КБКСчетУчетаРП,
| РП_ВыпискаКвитанций.Ссылка
|ИЗ
| Документ.РП_ВыпискаКвитанций КАК РП_ВыпискаКвитанций
| ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
| РеквизитыЛицевыхСчетов.СчетКазначейства.КассовыйОрган.Код КАК БИК,
| РеквизитыЛицевыхСчетов.СчетКазначейства.КассовыйОрган.КоррСчет КАК КоррСчет,
| РеквизитыЛицевыхСчетов.СчетКазначейства.КассовыйОрган.Наименование КАК НаименованиеБанка,
| РеквизитыЛицевыхСчетов.СчетКазначейства.Код КАК РасчетныйСчет,
| РеквизитыЛицевыхСчетов.Ссылка КАК Ссылка
| ИЗ
| Справочник.РеквизитыЛицевыхСчетов КАК РеквизитыЛицевыхСчетов
| ГДЕ
| РеквизитыЛицевыхСчетов.Владелец.ТипЛицевогоСчета = ЗНАЧЕНИЕ(Перечисление.ТипыЛицевыхСчетов.Казначейский)
|
| ОБЪЕДИНИТЬ ВСЕ
|
| ВЫБРАТЬ
| РеквизитыЛицевыхСчетов.КассовыйОрган.Код,
| РеквизитыЛицевыхСчетов.КассовыйОрган.КоррСчет,
| РеквизитыЛицевыхСчетов.КассовыйОрган.Наименование,
| РеквизитыЛицевыхСчетов.Владелец.Код,
| РеквизитыЛицевыхСчетов.Ссылка
| ИЗ
| Справочник.РеквизитыЛицевыхСчетов КАК РеквизитыЛицевыхСчетов
| ГДЕ
| РеквизитыЛицевыхСчетов.Владелец.ТипЛицевогоСчета = ЗНАЧЕНИЕ(Перечисление.ТипыЛицевыхСчетов.Банковский)) КАК РеквизитыЛицевыхСчетов
| ПО РП_ВыпискаКвитанций.РеквизитыЛицевогоСчета.Ссылка = РеквизитыЛицевыхСчетов.Ссылка
| ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
| яяСоответствиеУчреждений.КодУчреждения КАК КодУчреждения,
| яяСоответствиеУчреждений.Учреждение КАК Учреждение
| ИЗ
| РегистрСведений.яяСоответствиеУчреждений КАК яяСоответствиеУчреждений) КАК СоответствиеУчреждений
| ПО РП_ВыпискаКвитанций.Учреждение.Ссылка = СоответствиеУчреждений.Учреждение.Ссылка
|ГДЕ
| РП_ВыпискаКвитанций.Дата >= &НачПериода
| И РП_ВыпискаКвитанций.Дата <= &КонПериода
| И РП_ВыпискаКвитанций.Проведен = ИСТИНА
| И РП_ВыпискаКвитанций.Учреждение В(&Учреждение)
|
|УПОРЯДОЧИТЬ ПО
| Код";

Запрос.Текст = ТекстЗапроса;


Для Каждого СтрокаТаблицы ИЗ АнализВыгрузки Цикл;

Запрос.УстановитьПараметр("Учреждение",СтрокаТаблицы.Учреждение);

КонецЦикла;

Запрос.УстановитьПараметр("НачПериода", НачалоДня(ДатаНачала));
Запрос.УстановитьПараметр("КонПериода", КонецДня(ДатаОкончания));

ВыборкаДокументов = Запрос.Выполнить().Выбрать();

ТекстЗапроса = "ВЫБРАТЬ
| РП_ВыпискаКвитанцийКвитанции.Ребенок.Код КАК ЛицевойСчет,
| РП_ВыпискаКвитанцийКвитанции.Ссылка.ГруппаДетскогоУчреждения.Наименование КАК Группа,
| ВложенныйЗапрос.ЗначениеХарактеристики КАК ДатаРождения,
| РП_ВыпискаКвитанцийКвитанции.Ребенок.Контрагент.Фамилия + "" "" + РП_ВыпискаКвитанцийКвитанции.Ребенок.Контрагент.Имя + "" "" + РП_ВыпискаКвитанцийКвитанции.Ребенок.Контрагент.Отчество КАК ФИО,
| РП_ВыпискаКвитанцийКвитанции.Сумма,
| РП_ВыпискаКвитанцийКвитанции.Ссылка.КБКСчетУчетаРП КАК КБК,
| яяСоответствиеУчреждений.КодУчреждения КАК КодУчреждения,
| яяСоответствиеУчреждений.Учреждение КАК УЧРЕЖДЕНИЕ
|ИЗ
| Документ.РП_ВыпискаКвитанций.Квитанции КАК РП_ВыпискаКвитанцийКвитанции
| ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
| ХарактеристикиКонтрагентов.ЗначениеХарактеристики КАК ЗначениеХарактеристики,
| Дети.Ссылка КАК Ссылка
| ИЗ
| Справочник.Дети КАК Дети
| ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ХарактеристикиКонтрагентов КАК ХарактеристикиКонтрагентов
| ПО Дети.Контрагент = ХарактеристикиКонтрагентов.Контрагент
| ГДЕ
| ХарактеристикиКонтрагентов.ВидХарактеристики = ЗНАЧЕНИЕ(ПланВидовХарактеристик.ВидыХарактеристикКонтрагентов.ДатаРождения)) КАК ВложенныйЗапрос
| ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.яяСоответствиеУчреждений КАК яяСоответствиеУчреждений
| ПО ВложенныйЗапрос.Ссылка.Учреждение = яяСоответствиеУчреждений.Учреждение
| ПО РП_ВыпискаКвитанцийКвитанции.Ребенок.Ссылка = ВложенныйЗапрос.Ссылка
|ГДЕ
| РП_ВыпискаКвитанцийКвитанции.Ссылка = &Ссылка";

СчетчикЗадолженностей = 0;

Пока ВыборкаДокументов.Следующий() Цикл

Запрос.Текст = ТекстЗапроса;

Запрос.УстановитьПараметр("Ссылка", ВыборкаДокументов.Ссылка);
ВыборкаДети = Запрос.Выполнить().Выбрать();
Пока ВыборкаДети.Следующий() Цикл

СчетчикЗадолженностей = СчетчикЗадолженностей + 1;

Текст.ДобавитьСтроку(СокрЛП(ВыборкаДети.ЛицевойСчет)+
";"+СокрЛП(ВыборкаДети.ФИО)+
";"+СокрЛП(СтрокаТаблицы.Учреждение)+
";"+СокрЛП("000"+ВыборкаДети.КБК)+
";"+СокрЛП("04701000")+
";"+Формат(ВыборкаДети.Сумма, "ЧГ=0; ЧН=0.00; ЧРД='.'; ЧЦ=15; ЧДЦ=2"));

КонецЦикла;


КонецЦикла;


Для Каждого СтрокаТаблицы ИЗ АнализВыгрузки Цикл;
Текст.Записать((СтрокаТаблицы.ИмяФайлаВыгрузки), "windows-1251");
КонецЦикла;


Сообщить("Выгрузка успешно выполнена",СтатусСообщения.Информация);

ОбработкаПрерыванияПользователя();

КонецПроцедуры

Процедура ОткрытьФайлДляПросмотра(Элемент, Заголовок)

СтандартнаяОбработка = Ложь;

ФайлНаДиске = Новый Файл(Элемент.Значение);
Если Не ФайлНаДиске.Существует() Тогда
Предупреждение("Не найден файл!");
Возврат;
КонецЕсли;

Текст = Новый ТекстовыйДокумент();
Текст.Прочитать(Элемент.Значение);
Текст.Показать(Заголовок,Элемент.Значение);

КонецПроцедуры



Процедура ПриОткрытии()

УдалятьФайлы = Истина;

КонецПроцедуры

Процедура АнализВыгрузкиУчреждениеПриИзменении(Элемент)
СтрокаТаблицыВыгрузки = ЭлементыФормы.АнализВыгрузки.ТекущиеДанные;
СтрокаТаблицыВыгрузки.КодУчреждения = ВернутьУчреждение();
СтрокаТаблицыВыгрузки.ИНН = ПолучитьИННУчрежденияДляВыгрузкиВФайл();
КонецПроцедуры

Процедура АнализВыгрузкиИмяФайлаВыгрузкиНачалоВыбора(Элемент, СтандартнаяОбработка)
//
СтрокаТаблицы = ЭлементыФормы.АнализВыгрузки.ТекущиеДанные;
СтандартнаяОбработка = Ложь;
ДиалогВыбораФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Сохранение);
ДиалогВыбораФайла.МножественныйВыбор = Ложь;
ДиалогВыбораФайла.Заголовок = "Укажите имя файла выгрузки";
ДиалогВыбораФайла.ПолноеИмяФайла = СокрЛП(СтрокаТаблицы.ИНН)+"_sberbank_RP_Plata";

ДиалогВыбораФайла.Фильтр = "Текстовые(*.txt)|*.txt";
Если ДиалогВыбораФайла.Выбрать() Тогда
СтрокаТаблицы.ИмяФайлаВыгрузки = ДиалогВыбораФайла.ПолноеИмяФайла;
КонецЕсли;

КонецПроцедуры

Процедура АнализВыгрузкиИмяФайлаВыгрузкиОткрытие(Элемент, СтандартнаяОбработка)
СтандартнаяОбработка = ложь;
ОткрытьФайлДляПросмотра(Элемент,"Файл выгрузки");
КонецПроцедуры

Процедура АнализВыгрузкиИННПриИзменении(Элемент)
СтрокаТаблицыВыгрузки = ЭлементыФормы.АнализВыгрузки.ТекущиеДанные;
СтрокаТаблицыВыгрузки.КодУчреждения = ВернутьУчреждение();
СтрокаТаблицыВыгрузки.ИНН = ПолучитьИННУчрежденияДляВыгрузкиВФайл();

КонецПроцедуры

Процедура АнализВыгрузкиУчреждениеОкончаниеВводаТекста(Элемент, Текст, Значение, СтандартнаяОбработка)
СтрокаТаблицыВыгрузки = ЭлементыФормы.АнализВыгрузки.ТекущиеДанные;
СтрокаТаблицыВыгрузки.КодУчреждения = ВернутьУчреждение();
КонецПроцедуры

Процедура АнализВыгрузкиПриОкончанииРедактирования(Элемент, НоваяСтрока, ОтменаРедактирования)
СтрокаТаблицыВыгрузки = ЭлементыФормы.АнализВыгрузки.ТекущиеДанные;
СтрокаТаблицыВыгрузки.КодУчреждения = ВернутьУчреждение();
КонецПроцедуры



СписокДок = Новый СписокЗначений;
НастройкаПериода = Новый НастройкаПериода;
мВалютаРегламентированногоУчета = Константы.ВалютаРегламентированногоУчета.Получить();
Вопрос: Конвертация строки в справочник

Всем привет.
Настраиваю обмен между базами в 7.7 и 8.2
Справочник.Сотрудники->Справочник.ФизическиеЛица
В справочнике Сотрудники реквизит Должность - типа Строка(П25)
В справочнике ФизическиеЛица реквизит Должность - типа СправочникСсылка.Должность
Для ПКС Должность (у ПКО ФизическиеЛица) задаю Правило конвертации - Должности. У ПКО Должности источник - пустой, приемник - СправочникСсылка.Должности
Но почему-то ПКО должности не вызывается. Для отладки в событие Перед выгрузкой добавил вывод - Сообщить("ПКО Должности"); - процесс сюда не заходит.
Что делаю не так?


Ответ: Всем спасибо, наконец-то разрешил проблему. Вкратце:
ПКО ФизическиеЛица, ПКС Должность. В событии Перед выгрузкой - Значение=Источник.Должность.Получить(ТекущаяДата());. Правило конвертации - Должности.
ПКО Должности, ПКС Наименование. Источник - пусто, Приемник - Наименование. В событии Перед выгрузкой - Значение=Источник;
Все просто, но убил два вечера пока дошло.
Вопрос: v7: Структура файла выгрузки .dat

Всем привет! подскажите где почитать о структуре файла .dat

дело в том что шифровальщик зашифровал выгрузку 
но архив мне удалось распаковать правда файл .md в нем был убит 

достать удалось только файл с юзерами и дат

md есть от этой конфиги но более свежий (то есть с обновлениями) какой релиз точно был в выгрузке не знаю!

залив новый мд 1с ругается не загружает, создав новую конфигу (чистую) затем произведя выгрузку чистой сравнил оба файла если не смотреть на данные заголовки и конец файла вроде сходятся

подменив заголовок файла затем произвожу загрузку 1с не ругается но отваливается по процессу

не могли бы дать описание данного файла что бы я мог написать обработку для загрузки данных из него либо привести его в нужный вид
Ответ: () я уж и не помню, пишет ли он в логах - на чем "споткнулся и упал"... но в принципе, вполне себе вариант: отрезать данные по "документы", всосать - не всосалось, резать справочники по одному. как всосутся константы и справочники - скармливать документы, можно по одному виду. ничего военного, просто долго и муторно.