Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: Поместить в область макета таблицу из документа Word

Здравствуйте Делаю внешнюю печатную форму для документа "Отпуск" 1С ЗУП 3.1. Форма должна выглядеть как бланк предприятия. На бланке есть шапка, которая в образце (документ Word) сделана как таблица с границами ячеек. Таких же границ для ячеек макета 1С я не нашел. Пытался вставить шапку как картинку, но при этом из за разницы масштаба картинка расплывается, что не устраивает Заказчика. Можно ли вставить в макет оригинальную шапку из документа-образца? помогите пожалуйста - как это сделать. Структура шапки во вложении.
Ответ:
Шапка логотипа статичная вещь, сделайте скриншот, вставьте в ПайнтБраш, вырежте нужную область, вставьте ее в шапку макета как картинку!
делов то!
Вопрос: 1c Табличая часть документа в одной строке (макет)как это сделать?

мне надо сделать чтобы перечисление адресов было в строчку в печатной форме!пример: (в одну ячейку 1)р. Казахстан, г.Астана по ТТН 2)г. Новосибирск ул. Ленина 18 и тог дальше). я нашло одно обсуждение тока че то у меня оно не работает!!!

Кликните здесь для просмотра всего текста
Код 1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
Процедура СчетФактура(ТабДок, Ссылка) Экспорт
    //{{_КОНСТРУКТОР_ПЕЧАТИ(СчетФактура)
    Макет = Документы.Счет.ПолучитьМакет("СчетФактура");
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    |   Счет.Водитель,
    |   Счет.Дата,
    |   Счет.Заказчик,
    |   Счет.Исполнитель,
    |   Счет.Номер,
    |   Счет.Сумма,
    |   Счет.СуммаНалога,
    |   Счет.Транспорт,
    |   Счет.ЦенаТарифа,
    |   Счет.товар.(
    |       НомерСтроки,
    |       Ссылка.Водитель,
    |       Ссылка.Транспорт,
    |       Ссылка.Дата,
    |       Ссылка.Сумма,
    |       Ссылка.Цена,
    |       Ссылка.КолВо,
    |       Ссылка.ЦенаТарифа,
    |       Ссылка.СтоимостьУслуги,
    |       Ссылка.СуммаНалога,
    |       Ссылка.Сумма КАК Сумма1,
    |       Адрес,
    |       Ссылка
    |   ),
    |   Счет.Исполнитель.Банк КАК испБанк,
    |   Счет.Исполнитель.Бик КАК испБик,
    |   Счет.Исполнитель.КорреспонденскийСчет КАК испКорреспонденскийСчет,
    |   Счет.Исполнитель.ИНН КАК иИНН,
    |   Счет.Исполнитель.КПП КАК иКПП,
    |   Счет.Исполнитель.Наименование КАК ИСП,
    |   Счет.Исполнитель.НомерСчета КАК оргНомерСчета,
    |   Счет.Исполнитель.ЮридическийАдрес.Страна КАК иСтрана,
    |   Счет.Исполнитель.ЮридическийАдрес.Индекс КАК иИндекс,
    |   Счет.Исполнитель.ЮридическийАдрес.Город КАК иГород,
    |   Счет.Исполнитель.ЮридическийАдрес.Улица КАК иУлица,
    |   Счет.Исполнитель.ТелефонФакс КАК иТелефонФакс,
    |   Счет.Заказчик.ИНН КАК зИНН,
    |   Счет.Заказчик.КПП КАК зКПП,
    |   Счет.Заказчик.ЮридическийАдрес.Наименование КАК зЮАдрес,
    |   Счет.Исполнитель.ФИОДиректор КАК иФИОДиректор,
    |   Счет.ПрописьЧисла1,
    |   Счет.ПрописьЧисла,
    |   Счет.СтоимостьУслуги,
    |   Счет.Адрес1
    |ИЗ
    |   Документ.Счет КАК Счет
    |ГДЕ
    |   Счет.Ссылка В(&Ссылка)";
    Запрос.Параметры.Вставить("Ссылка", Ссылка);
    Выборка = Запрос.Выполнить().Выбрать();
    
 
    Шапка1                 = Макет.ПолучитьОбласть("Шапка1");
    ОбластьтоварШапка      = Макет.ПолучитьОбласть("товарШапка");
    Областьтовар           = Макет.ПолучитьОбласть("товар");
    ТоварПодвал            = Макет.ПолучитьОбласть("ТоварПодвал");
    Подвал                 = Макет.ПолучитьОбласть("Подвал");
 
    ТабДок.Очистить();
    
    
    ВставлятьРазделительСтраниц = Ложь;
    Пока Выборка.Следующий() Цикл
        Если ВставлятьРазделительСтраниц Тогда
            ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
        КонецЕсли;
 
        Шапка1.Параметры.Заполнить(Выборка);
        ТабДок.Вывести(Шапка1, Выборка.Уровень());
 
        
        ТабДок.Вывести(ОбластьтоварШапка);
        Выборкатовар = Выборка.товар.Выбрать();
        //Пока Выборкатовар.Следующий() Цикл
        //  Областьтовар.Параметры.Заполнить(Выборкатовар);
        //  ТабДок.Вывести(Областьтовар, Выборкатовар.Уровень());
        //  КонецЦикла;
 
 
//  ???????????????????????????????????????????????????????????????????????????????
Пока Выборкатовар.Следующий() Цикл
             ДокСчет = Выборкатовар.Ссылка;
               //(реакция на пустую ТЧ по ситуации)
             Для каждого стр Из ДокСчет.Товар Цикл
                 Если стр.НомерСтроки = 1 Тогда
                    Областьтовар.Параметры.Заполнить(ДокСчет);
                    ТабДок.Вывести(Областьтовар);                
                 Иначе
                     Областьтовар.Параметры.Заполнить(стр);
                     
                     //Областьтовар.Параметры.Адрес ="";
                     
                     ТабДок.Вывести(Областьтовар); 
                 КонецЕсли
             КонецЦикла;   
        КонецЦикла
//  ???????????????????????????????????????????????????????????????????????????????????????????     
               
        
        ТоварПодвал.Параметры.Заполнить(Выборка);
        ТабДок.Вывести(ТоварПодвал, Выборка.Уровень());
 
 
        Подвал.Параметры.Заполнить(Выборка);
        ТабДок.Вывести(Подвал);
 
        ВставлятьРазделительСтраниц = Истина;
    КонецЦикла;
    //}}
КонецПроцедуры
Ответ: Все получилось! Огромное спасибо!!!
рабочая версия

Код 1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
Процедура СчетФактура(ТабДок, Ссылка) Экспорт
    //{{_КОНСТРУКТОР_ПЕЧАТИ(СчетФактура)
    Макет = Документы.Счет.ПолучитьМакет("СчетФактура");
    Запрос = Новый Запрос;
    Запрос.Текст =
          "ВЫБРАТЬ
          | Счет.Исполнитель,
          | Счет.Исполнитель.ЮридическийАдрес.Индекс КАК иИндекс,
          | Счет.Исполнитель.ЮридическийАдрес.Страна КАК иСтрана,
          | Счет.Исполнитель.ЮридическийАдрес.Город КАК иГород,
          | Счет.Исполнитель.ЮридическийАдрес.Улица КАК иУлица,
          | Счет.Исполнитель.ИНН КАК иИНН,
          | Счет.Исполнитель.КПП КАК иКПП,
          | Счет.Заказчик,
          | Счет.Заказчик.ЮридическийАдрес КАК зЮАдрес,
          | Счет.Заказчик.ИНН КАК зИНН,
          | Счет.Заказчик.КПП КАК зКПП,
          | Счеттовар.Ссылка,
          | Счеттовар.НомерСтроки,
          | Счеттовар.вид,
          | Счеттовар.Адрес,
          | Счет.ДатаПрихода,
          | Счет.Водитель,
          | Счет.Транспорт,
          | Счет.Транспорт.Полуприцеп,
          | Счет.Транспорт.ВидТс,
          | Счет.КолВо,
          | Счет.ЦенаТарифа,
          | Счет.СтоимостьУслуги,
          | Счет.СуммаНалога,
          | Счет.Сумма,
          | Счет.Заказчик.ФИОДиректор,
          | Счет.Исполнитель.ФИОДиректор
          |ИЗ
          | Документ.Счет.товар КАК Счеттовар
          |     ЛЕВОЕ СОЕДИНЕНИЕ Документ.Счет КАК Счет
          |     ПО Счеттовар.Ссылка = Счет.Ссылка
          |ГДЕ
          | Счет.Ссылка В(&Ссылка)";
    Запрос.Параметры.Вставить("Ссылка", Ссылка);
    Выборка = Запрос.Выполнить().Выбрать();
     
     НомерСтроки = (",  ");
    ВТ = Запрос.Выполнить().Выгрузить();
    МассивАдресов = ВТ.ВыгрузитьКолонку("Адрес");
    СтрокаАдресов = "";
    МассивНомеров = ВТ.ВыгрузитьКолонку("НомерСтроки");
    СтрокаНомеров = "";
    
    Для Каждого Адрес ИЗ МассивАдресов Цикл
        СтрокаАдресов = СтрокаАдресов  + Адрес + НомерСтроки;
    КонецЦикла;
 
 
    ВставлятьРазделительСтраниц = Ложь;
    Пока Выборка.Следующий() Цикл
          Если ВставлятьРазделительСтраниц Тогда
            ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
        КонецЕсли;
        Шапка                   = Макет.ПолучитьОбласть("Шапка");
        Шапка.Параметры.Адреса = СтрокаАдресов;// вместо "Адреса" пиши как параметр в макете зовется (если он в шапке)
        Шапка.Параметры.Заполнить(Выборка);
        ТабДок.Очистить();
 
        ТабДок.Вывести(Шапка, Выборка.Уровень());
        
        
       
 
        ВставлятьРазделительСтраниц = Истина;
    КонецЦикла;
        //}}
КонецПроцедуры
Вопрос: Почему не видит область макета

Приветствую уважаемые.

Подскажите что за чертовщина.

    Макет = УправлениеПечатью.МакетПечатнойФормы("Справочник.ДоговорыКонтрагентов.ПФ_MXL_ДоговорЗаймаФизлицо");
    ОбластьПредметДоговора = Макет.ПолучитьОбласть("ПредметДоговора20170101");

Получаю ошибку
Область не найдена: ПредметДоговора20170101.

Область есть:

Но её не видно

Ответ: () Сам спросил сам отвечу - задан пользовательский макет.
Вопрос: Изменение границы области макета отчета

Проблема следующая: в отчете недостаточно строк указано в области для того, чтобы уместить новые данные.

Как изменить количество строк в области - не могу понять.!!!

Когда просто удалил область и создал с таким же именем - перестал работать вывод на форму (регистры показывают, что значения есть, но они не передаются)
Ответ: () у тебя область из одной строки? тогда удаляй имя области, выделяй строки и задавай имя заново, такое же
Вопрос: Подсчитать Итог в области макета

День добрый. Имеется вот такая структура макета:

Данные из отчета берутся из запроса, но к нему не подобраться, поэтому спрашиваю: Как можно суммировать все значения которые будут в "Параметре1" и передать полученную сумму в "ПараметрИтог"?
Ответ:
Сообщение от Briolin
П.С.: ИтогЦена так же есть в макете в виде параметра, туда и выводятся данные из запроса.
а почему не поставить нужный формат ячейки???

Добавлено через 40 секунд
Сообщение от Briolin
Вообще можно ли в запросе округлить число?
ты количество скобочек посчитай, граматей!!!
Вопрос: Вывод ТЗ на уже созданный макет печати

На форме документа есть ТЗ СтоимостьУслуг, которая заполняется по кнопке из внешней базы. Данные с этой ТЗ нужно поместить на макет печати (он ранее создан) в определенную ячейку. На макете сделала параметр СтоимостьУслуг и пытаюсь туда засунуть данные.
Код 1C
1
2
3
4
5
6
7
8
9
10
11
12
 Форма = ЭтотОбъект.ПолучитьФорму("ФормаДокумента");
        СтоимостьУслуг = Форма.ЭлементыФормы.СтоимостьУслуг.Значение;
Обл   = Макет.ПолучитьОбласть("Оборотная");
 
 
 
Для каждого стр из СтоимостьУслуг Цикл
 
обл.Параметры.СтоимостьУслуг=стр;
ТабДокумент.Вывести(обл);
 
КонецЦикла;
на макете выводиться СтрокаТаблицыЗначений

пробовала еще создать в области Обл еще одну область Усл
Код 1C
1
2
3
4
5
6
7
8
9
10
11
  Форма = ЭтотОбъект.ПолучитьФорму("ФормаДокумента");
        СтоимостьУслуг = Форма.ЭлементыФормы.СтоимостьУслуг.Значение;
Усл   = Обл.ПолучитьОбласть("Усл");
 
 
Для каждого стр из СтоимостьУслуг Цикл
 
усл.Параметры.Заполнить(стр);
ТабДокумент.Вывести(усл);
 
КонецЦикла; 
так вообще на макете пусто
Ответ:
Сообщение от Swetlana521991
на метод ДобавитьОбласть() ругается
я его сам придумал
Сообщение от Swetlana521991
дублируется весь макет 3 раза
ну, это уж с циклами надо причесать
Вопрос: Печать Таблицы Значений

Есть ТЗ (ТЗБух) она состоит из трех колонок "Код" "Товар" и "ОстатокТовара", хочу вывести ее через Макет на печать (по аналогу 7,7), но не знаю что пихать в этот макет. Назначил переменную КодБух и прописал ее в качестве параметра при выводе строки в самом Макете. Выводит пустые значения, вот частичный код
Таб = Новый ТабличныйДокумент;
    Макет = ЭтотОбъект.ПолучитьМакет("Макет");
    ОбластьШапкаКод=Макет.ПолучитьОбласть("Шапка|Код");
    ОбластьШапкаБух=Макет.ПолучитьОбласть("Шапка|Бух");
    ОбластьСтрокаКод=Макет.ПолучитьОбласть("Строка|Код");
  
  Для Каждого ТекущаяСтрока из ТЗБух  Цикл
            КодБух=ТекущаяСтрока.Код;
            Таб.Вывести(ОбластьСтрокаКод);
   КонецЦикла;

Таб.Показать();
Ответ: () Это да, все просто НО без макета! У меня там дальше присоединяются колонки с данными из другой базы (ТЗ по ОЛЕ сформирована) и затем надо сравнить и найти разницу в остатках , примерно так. Поэтому мне через макет и руками проще . семерочник потомушто))
Вопрос: Заполнение областей макета, какой код работает быстрее

Всем доброго дня!
Какой код работает быстрее:
1)
ОбластьМакета  = Макет.ПолучитьОбласть("Поставщик");
СтруктураДанныхПоставщик = Новый Структура;
ПредставлениеПоставщика  = ФормированиеПечатныхФорм.ОписаниеОрганизации(ФормированиеПечатныхФорм.СведенияОЮрФизЛице(ДанныеПечати.Организация, ДанныеПечати.Дата), "ПолноеНаименование");
СтруктураДанныхПоставщик.Вставить("ПредставлениеПоставщика", ПредставлениеПоставщика);
СтруктураДанныхПоставщик.Вставить("Поставщик", ДанныеПечати.Организация);
ОбластьМакета.Параметры.Заполнить(СтруктураДанныхПоставщик);
ТабличныйДокумент.Вывести(ОбластьМакета);

2)
ОбластьМакета   = Макет.ПолучитьОбласть("Поставщик");
ОбластьМакета.Параметры.ПредставлениеПоставщика =  ФормированиеПечатныхФорм.ОписаниеОрганизации(ФормированиеПечатныхФорм.СведенияОЮрФизЛице(ДанныеПечати.Организация, ДанныеПечати.Дата), "ПолноеНаименование");
ОбластьМакета.Параметры.Поставщик =  ДанныеПечати.Организация;
ТабличныйДокумент.Вывести(ОбластьМакета);
Ответ: быстрее будет, если в качестве параметра "Поставщик" передавать нужное представление, полученное в запросе, вместо ссылки. Если идет групповая печать и тормозит именно в этом месте. Ну и кэшировать результаты ФормированиеПечатныхФорм.ОписаниеОрганизации, если оно не включено платформой, можно. Например создав свой общий модуль с повторным использованием значений на время вызова.
Вопрос: Правильный перенос текста в макете печати

Добрый день, прошу помочь с решением проблемы с переносом текста строки на следующую страницу.
Конфигурация УНФ 1.6, Документ Заказ покупателя - печатная форма Коммерческое предложение
В печатную форму выводится информация из описания номенклатуры - т.к. текста в описании много, часть текста не влазит на страницу и переносится на следующую. Но возникает проблема с тем что рвется текст пополам.
Приложил файл тест в котором показан разрыв текста на печати
и файл макета печатной формы

В коде для вывода строки описание используются следующие параметры:
ОписаниеНоменклатуры = ВыборкаСтрокПроверка.Комментарий;
ОбластьМакетаСтрока.Параметры.ОписаниеНоменклатуры = ОписаниеНоменклатуры;

Код формирования печатной формы:
Код:
ТабличныйДокумент = Новый ТабличныйДокумент;
    ТабличныйДокумент.ПолеСверху = 15;
    ТабличныйДокумент.ПолеСлева = 7;
    ТабличныйДокумент.ПолеСнизу = 0;
    ТабличныйДокумент.ПолеСправа = 7;
    ТабличныйДокумент.КлючПараметровПечати = "ПараметрыПечати_КоммерческоеПредложение";
Пока ВыборкаСтрокПроверка.Следующий() Цикл
            ФайлКартинкиНоменклатуры = ВыборкаСтрокПроверка.ФайлКартинки;
            ОписаниеНоменклатуры = ВыборкаСтрокПроверка.Комментарий;
            Если ЗначениеЗаполнено(ОписаниеНоменклатуры) ИЛИ ЗначениеЗаполнено(ФайлКартинкиНоменклатуры) Тогда
                ЕстьДанные = ЕстьДанные + 1;
            КонецЕсли;
        КонецЦикла;

        Если ЕстьДанные > 0 Тогда
            ТабличныйДокумент.ВывестиГоризонтальныйРазделительСтраниц();
            ОбластьМакетаПоставщик = Макет.ПолучитьОбласть("ПоставщикНоменклатура");
            ОбластьМакетаПоставщик.Параметры.Заполнить(Шапка);
            ДанныеКартинки = ПрисоединенныеФайлы.ПолучитьДвоичныеДанныеФайла(Шапка.Организация.ФайлЛоготип);
            ОбластьМакетаПоставщик.Рисунки.ЛоготипНоменклатура.Картинка = Новый Картинка(ДанныеКартинки);
            ОбластьМакетаПоставщик.Параметры.НаименованиеПоставщика = УправлениеНебольшойФирмойСервер.ОписаниеОрганизации(СведенияОбОрганизации, "Представление,");
            ОбластьМакетаПоставщик.Параметры.АдресПоставщика = УправлениеНебольшойФирмойСервер.ОписаниеОрганизации(СведенияОбОрганизации, "ЮридическийАдрес,");
            ОбластьМакетаПоставщик.Параметры.ТелефонПоставщика = УправлениеНебольшойФирмойСервер.ОписаниеОрганизации(СведенияОбОрганизации, "Телефоны,");
            ОбластьМакетаПоставщик.Параметры.ЭлектроннаяПочтаПоставщика = УправлениеНебольшойФирмойСервер.ОписаниеОрганизации(СведенияОбОрганизации, "ЭлектроннаяПочта,");
            Колонки = Справочники.Организации.ОсновнаяОрганизация.КонтактнаяИнформация.Выгрузить();
            Перечисление = Перечисления.ТипыКонтактнойИнформации.ВебСтраница;
            ОбластьМакетаПоставщик.Параметры.ВебСтраница = ВебСтраница;
            ОбластьМакетаПоставщик.Параметры.Отпустил = Шапка.Ответственный;
            ОбластьМакетаПоставщик.Параметры.ОтпустилТелефон = УправлениеНебольшойФирмойСервер.ПолучитьКонтактнуюИнформацию(Шапка.Ответственный.ФизЛицо, Справочники.ВидыКонтактнойИнформации.ТелефонФизЛица);
            ТабличныйДокумент.Вывести(ОбластьМакетаПоставщик);
            ОбластьМакетаЗаголовок = Макет.ПолучитьОбласть("ЗаголовокНоменклатуры");
            ОбластьМакетаЗаголовок.Параметры.ТекстЗаголовкаНоменклатуры = "Описание, фото и технические характеристики продукции.";
            ТабличныйДокумент.Вывести(ОбластьМакетаЗаголовок);
            ОбластьМакетаШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицыНоменклатуры");
            ТабличныйДокумент.Вывести(ОбластьМакетаШапкаТаблицы);
            Пока ВыборкаСтрокНоменклатура.Следующий() Цикл
                ФайлКартинкиНоменклатуры = ВыборкаСтрокНоменклатура.ФайлКартинки;
                Если ЗначениеЗаполнено(ФайлКартинкиНоменклатуры) Тогда
                    ОбластьМакетаСтрока = Макет.ПолучитьОбласть("СтрокаНоменклатуры");
                Иначе
                    ОбластьМакетаСтрока = Макет.ПолучитьОбласть("СтрокаНоменклатурыБезФото");
                КонецЕсли;
                    ОбластьМакетаСтрока.Параметры.Заполнить(ВыборкаСтрокНоменклатура);
                    ОписаниеНоменклатуры = ВыборкаСтрокНоменклатура.Комментарий;
                    ОбластьМакетаСтрока.Параметры.НаименованиеНоменклатуры = ВыборкаСтрокНоменклатура.Запас +":";
                    ОбластьМакетаСтрока.Параметры.ОписаниеНоменклатуры = ОписаниеНоменклатуры;
                    ЕстьДанныеНоменклатура = 0;
                    Если ЗначениеЗаполнено(ОписаниеНоменклатуры) ИЛИ ЗначениеЗаполнено(ФайлКартинкиНоменклатуры) Тогда
                        Если ЗначениеЗаполнено(ФайлКартинкиНоменклатуры) Тогда
                            ДанныеКартинки = ПрисоединенныеФайлы.ПолучитьДвоичныеДанныеФайла(ВыборкаСтрокНоменклатура.ФайлКартинки);
                            КартинкаНоменклатуры = Новый Картинка(ДанныеКартинки);
                            ОбластьМакетаСтрока.Рисунки["ФотоНоменклатуры"].Картинка = КартинкаНоменклатуры;
                        КонецЕсли;
                        НомерСтрокиНоменклатура = НомерСтрокиНоменклатура + 1;
                        ОбластьМакетаСтрока.Параметры.НомерСтрокиНоменклатура = НомерСтрокиНоменклатура;
                        ЕстьДанныеНоменклатура = ЕстьДанныеНоменклатура + 1;
                    КонецЕсли;
                    Если ЕстьДанныеНоменклатура > 0 Тогда
                           ТабличныйДокумент.Вывести(ОбластьМакетаСтрока);
                    КонецЕсли;
            КонецЦикла;
                ОбластьМакетаПодвал = Макет.ПолучитьОбласть("ПодвалНомеклатура");
                ТабличныйДокумент.Вывести(ОбластьМакетаПодвал)
        КонецЕсли;

        УправлениеПечатью.ЗадатьОбластьПечатиДокумента(ТабличныйДокумент, НомерСтрокиНачало, ОбъектыПечати, Шапка.Ссылка);
    КонецЦикла;

    ТабличныйДокумент.АвтоМасштаб = Истина;

Вложения:

  • Размер файла:
    427,9 КБ
    Просмотров:
    1
  • Размер файла:
    32 КБ
    Просмотров:
    1
Ответ:
Нашел такую интересную особенность, если выставить не стандартные поля - например 7 слева, 7 справа, 7 снизу и 15 сверху то макет кривой
если же вернуть все по 10 то все становится на место. теперь вопрос как заставить правильно масштабировать документ при нестандартных настройках
Вопрос: область макета в качестве колонтитула

Всем привет. Требуется чтобы шапка таблицы повторялась на каждом листе. Хочу это сделать с помощью колонтитула. Можно вообще задать область в качестве колонтитула?
Ответ: спасибо, взлетело