Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: Печать через ВЕБ интерфейс УТ 3.1 для Украины (УТ 11).

Добрый день дорогие форумчане! Есть проблема, возможно кому то она покажется до боли знакомой и сможет мне что то подсказать...
Задача состоит в подключении Торгового оборудования через ВЕБ клиент.
В список ТО входит Сканер ШК, Принтер этикеток, Принтер чеков (все для осуществления продаж через РМК). Проблемы, это то что много окон взаимодействия типо поиска ШК и прочее, являются модальными для типовой конфигурации, но этот момент я могу обойти путем проверки на ВЕБ клиент и переделывая модальные окна на не модальные.

А вот дальше стоят проблемы другого характера:
В РМК при нажатии Пробить чек не происходит печать, так как печать идет не напрямую, а запрашивается как печать в браузере. При этом не сохраняется шаблон и размерность чека. Такая же ситуация и при печати этикеток и ценников.

Собственно вопрос, можно ли как то сделать автоматическую печать без браузера, и как выполнить настройку с сохранением шаблона и размерности чека?

Буду рад любому пинку в направлении решения проблемы...
Ответ: () ну открыть обработку эту, печать этикеток и ценников, скопипастить к себе, немножко подрихтовать напильником
Вопрос: Как запретить печать документов без сохранения

Привет всем! Нужно некоторым пользователям запретить печать документов без сохранения. Чтобы не получилось так, что они распечатали документ а потом просто закрыли не сохранив.
В настройках прав пользователя нашел параметр "Печать документов без сохранения", но он не влияет на погоду, документ распечатывается без сохранения если галочка стоит и если не стоит.

Друзья, подскажите, можно ли это реализовать штатными средствами?

Сделать это нужно в 1С-Рарус:Магазин
Ответ: () И в чем же я не разобрался? В ветке был поставлен вопрос о запрете печати без сохранения, а не о контроле документооборота. У вас обсуждение свелось исключительно к последнему. Я привык отвечать на поставленный вопрос, а ты привык навешивать ярлыки без достаточных оснований...
Вопрос: Печать нескольких документов в одной ПФ (окне)

Доброе время суток!
Помогите пожалуйста разобраться не в простом для меня вопросе!
Как реализовать "Печать нескольких выделенных документов в одной Печатной Форме (одном окне)"
Имеется кнопка печати с кодом
Код:
    // Если в списке не выбрана текущая строка, то печатать нечего
    Если ЭтаФорма.ЭлементыФормы.Список.ТекущаяСтрока = Неопределено тогда
        Возврат
    КонецЕсли;
   
    Для каждого ДокументСсылка Из ЭтаФорма.ЭлементыФормы.Список.ВыделенныеСтроки Цикл
        УниверсальныеМеханизмы.НапечататьДокументИзФормыСписка(ДокументСсылка.ПолучитьОбъект());
    КонецЦикла;
Получается печать всех выделенных документов в отдельных окнах

Подскажите пожалуйста как можно сделать что бы по всем выбранным заказам, выводилась печатная форма в 1 (одном) окне?
Ответ:
Ну так раз она написана, то посмотрите, что в ней внутри.
Вопрос: v7: Печать актов по 2 экземпляра на листе с линией разрыва.

Добрейшего времени суток. Вот такой вопрос возник, можно ли программно узнать выставлена ли печать 2-х документов (актов оказания услуг) на одной страницы, и, если выставлена, печатать разделительную линию отрыва. А то говорят клиенты с курьерами нервенные все стали и рвут как ни попадя :)
Ответ: Чтобы вывести на печать секцию с линией отрыва, эту команду нужно прописать в процедуре печати.

Чтобы процедура печати выполняла эту строку кода в зависимости от установок, нужно их считывать.

Обратимся к СП.
ЭкземпляровНаСтранице(<?>)
Синтаксис:
ЭкземпляровНаСтранице(<Колво>)
Назначение:
Определить количество печатаемых экземпляров на странице. Возвращает: текущее числовое значение количества печатаемых экземпляров на странице (на момент до исполнения метода).
Параметры:
<Колво> - число печатаемых экземпляров на странице. Может принимать значения:
1 - один экземпляр на странице
2 - два экземпляра на странице
0 - автоматический режим размещения двух экземпляров на странице исходя из размеров документа.

Поскольку программно узнать значение параметра возможно, с этой стороны проблем нет.

Хуже другое- обычно печатные формы актов заточены для вывода на целой странице, поэтому печатную форму понадобиться доработать.

Можно обойтись и масштабированием, если клиенты согласны жрать такие акты.Команду на уменьшение масштаба можно выводить тоже по результатам считывания параметра ЭкземпляровНаСтраницу.
Вопрос: Как совместить лицо со спиной (двусторонняя печать)

Пришла ко мне задача, с виду простейшая, но есть одна мелочь.
Для понимания вопроса нарисовала картинку
на лицевой стороне листа располагаются два портрета (ориентация ландшафт) , на втором листе соответственно эти же портреты с ж... спины)
При печати формирование идет так: на одном листе лицо девочки ,в буфере на другом листе спина девочки, потом присоединяется лицо мальчика и в буфере к существующей спине девочки присоединяется спина мальчика и потом в табдок с лицами выводится область со спинами.
Задача - напечатать портреты двусторонней печатью так, чтобы лица совместились со спинами.
Всяко меняла настройки принтера - выходило либо обменяться спинами, либо эта самая спина перевернута вверх ногами.

Вложения:

  • Размер файла:
    48,6 КБ
    Просмотров:
    0
Ответ:
Проблема была решена изменением порядка вывода портретов на оборотной стороне
При печати формирование идет так: Выводим лицо девочки, запоминаем в массив спину девочки(0), присоединяем лицо мальчика , Запоминаем в массив спину мальчика(1)
затем выводим спину мальчика (1) из массива, присоединям спину девочки(0) из массива
Как перевернуть Табличный документ я так и не узнала.
Вопрос: Добавление команды "Печать" на УФ

Имеется документ на управляемой форме. Печатать из модуля менеджера получается, но не могу понять как сделать так, чтобы подтягивались печатки из дополнительных внешних отчетов и обработок. Подскажите, пожалуйста, а то по всем вопросам по печати пишут только о печати из модуля менеджера
Ответ: Разобрался. В общий модуль добавил функцию ОткрытьФормуВыбораПечатныхФормОбъекта, вызываю её с кнопки "печать" со своей формы.
Вопрос: Печать в РТиУ через комплект документов на принтер формы из внешней печатной формы

Добрый день!
Подключил внешнюю печатную форму и теперь при печати в РТиУ через стандартную обработку печати комплекта документов возникает ошибка "Метод объекта не обнаружен (Печать)". Когда делал ВПФ, то расположил функцию Печать() в модуле формы.
Код:
Функция Печать(ИдентификаторКоманды,ОбъектыНазначения) Экспорт
Все корректно отрабатывает, кроме этого.
Ответ:
Добрый день!

Переработал обработку и расположил Печать() в модуле объекта, но все-равно возникает ошибка:

Вот что в модуле объекта:
Код:
Функция СведенияОВнешнейОбработке() Экспорт
    ПараметрыРегистрации = Новый Структура;
    МассивНазначений = Новый Массив;
    МассивНазначений.Добавить("Документ.РеализацияТоваровУслуг"); //Указываем документ к которому делаем внешнюю печ. форму

    ПараметрыРегистрации.Вставить("Вид", "ПечатнаяФорма"); //может быть - ЗаполнениеОбъекта,
                                                           //ДополнительныйОтчет, СозданиеСвязанныхОбъектов...
   
   
    ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);
    ПараметрыРегистрации.Вставить("Наименование", "Бланк гарантии"); //имя под которым обработка
                                                            // будет зарегестрирована в справочнике внешних обработок
    ПараметрыРегистрации.Вставить("БезопасныйРежим", ЛОЖЬ);
    ПараметрыРегистрации.Вставить("Версия", "1.0");   
    ПараметрыРегистрации.Вставить("Информация", "Дополнительная печатная форма к документу РТУ");
   
    ТаблицаКоманд = ПолучитьТаблицуКоманд();
   

    ДобавитьКоманду(ТаблицаКоманд, "Бланк гарантии", "БланкГарантии", "ВызовКлиентскогоМетода", Истина, "ПечатьMXL");
    ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);
   
    Возврат ПараметрыРегистрации;
КонецФункции

Функция ПолучитьТаблицуКоманд()
  Команды = Новый ТаблицаЗначений;
  Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));//как будет выглядеть описание
                                                                           //печ.формы для пользователя

  Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка")); //имя макета печ.формы
  Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка")); //ВызовСерверногоМетода
  Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
  Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
  Возврат Команды;
КонецФункции

Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")

  НоваяКоманда = ТаблицаКоманд.Добавить();
  НоваяКоманда.Представление = Представление; 
  НоваяКоманда.Идентификатор = Идентификатор;
  НоваяКоманда.Использование = Использование;
  НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
  НоваяКоманда.Модификатор = Модификатор;

КонецПроцедуры

Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
   
    УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "БланкГарантии", "Бланк гарантии)", СформироватьПечатнуюФорму(МассивОбъектов[0], ОбъектыПечати));
   
КонецПроцедуры // Печать()


Функция ВернутьМакет()
   
    Макет = ЭтотОбъект.ПолучитьМакет("ГарантийныйТалон");
   
    Возврат Макет;
   
КонецФункции

Функция СформироватьПечатнуюФорму(МассивОбъектов, ОбъектыПечати) Экспорт
    ТабДок = Новый ТабличныйДокумент;
   
    ТекстЗапроса =
    "ВЫБРАТЬ
    |    ЕСТЬNULL(МЛ_ПринадлежностиАвтомобилей.Комплектация, """") КАК Применимость,
    |    ВложенныйЗапрос.Номенклатура.Наименование КАК Номенклатура,
    |    ВложенныйЗапрос.Номенклатура.Артикул КАК Артикул,
    |    ВложенныйЗапрос.НомерСтроки КАК НомерСтроки
    |ИЗ
    |    (ВЫБРАТЬ
    |        РеализацияТоваровУслугТовары.Номенклатура КАК Номенклатура,
    |        РеализацияТоваровУслугТовары.Ссылка КАК Ссылка,
    |        РеализацияТоваровУслугТовары.Характеристика КАК Характеристика,
    |        РеализацияТоваровУслугТовары.Склад КАК Склад,
    |        МИНИМУМ(РеализацияТоваровУслугТовары.НомерСтроки) КАК НомерСтроки
    |    ИЗ
    |        Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслугТовары
    |    ГДЕ
    |        РеализацияТоваровУслугТовары.Ссылка В(&МассивОбъектов)
    |   
    |    СГРУППИРОВАТЬ ПО
    |        РеализацияТоваровУслугТовары.Ссылка,
    |        РеализацияТоваровУслугТовары.Номенклатура,
    |        РеализацияТоваровУслугТовары.Характеристика,
    |        РеализацияТоваровУслугТовары.Склад) КАК ВложенныйЗапрос
    |        ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.МЛ_ПринадлежностиАвтомобилей КАК МЛ_ПринадлежностиАвтомобилей
    |        ПО ВложенныйЗапрос.Номенклатура.АртикулЧ = МЛ_ПринадлежностиАвтомобилей.АртикулЧ
    |
    |УПОРЯДОЧИТЬ ПО
    |    ВложенныйЗапрос.Ссылка,
    |    НомерСтроки
    |ИТОГИ
    |    МАКСИМУМ(Артикул)
    |ПО
    |    Номенклатура";
    Запрос = Новый Запрос;
    Запрос.Текст = ТекстЗапроса;
    Запрос.УстановитьПараметр("МассивОбъектов", МассивОбъектов);
   
    Выборка = Запрос.Выполнить().Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
   
    Выборка.Следующий();
    ВыборкаДетальныеЗаписи = Выборка.Выбрать();
    Сч = 1;
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        Если Сч>1 Тогда
            Если Ложь Тогда
                Строка = " ";
            КонецЕсли;
            Строка.Применимость = Строка.Применимость + "; " + Символы.ПС + Строка(ВыборкаДетальныеЗаписи.Применимость);
        Иначе
            ТЗ = Новый ТаблицаЗначений;
            ТЗ.Колонки.Добавить("Применимость");
            ТЗ.Колонки.Добавить("Номенклатура");
            Строка = ТЗ.Добавить();
            Строка.Применимость = Строка(ВыборкаДетальныеЗаписи.Применимость);
            Строка.Номенклатура = ВыборкаДетальныеЗаписи.Номенклатура;
        КонецЕсли;
        Сч = Сч+1;
    КонецЦикла;
   
    Макет = ВернутьМакет();   
    Шапка = Макет.ПолучитьОбласть("Шапка");
    Шапка.Параметры.Заполнить(ТЗ[0]);
   
    //Шапка.Параметры.СерийныйНомер = "";
    Шапка.Параметры.ДатаПроизводства = НачалоДня(ТекущаяДата())-86400*3;
    Шапка.Параметры.Дата = ТекущаяДата();
    ТабДок.Вывести(Шапка);
   
    ТабДок.ОтображатьСетку = Ложь;
    ТабДок.Защита = Ложь;
    ТабДок.ТолькоПросмотр = Ложь;
    ТабДок.ОтображатьЗаголовки = Ложь;

    Возврат ТабДок;
КонецФункции
--- Объединение сообщений, 9 янв 2017 ---
Спасибо, разобрался. Нужно было указать "ВызовСерверногоМетода".
Вопрос: Вывод на печать данных справочника

Добрый день, форумчане!
У меня в ходе выполнения работы возник вопрос. Поясняю, в чем он заключается:
Имеется заполненный справочник "Сотрудники". Задача состоит в следующем:
Составить документ, в котором 32 столбца, из них первые два выделяются для ФИО сотрудника, и для Структурного подразделения в котором он работает (это реквизиты справочника), остальные 30 - пустые. Как распечатать документ со всеми сотрудниками, которые есть в справочнике?
Для одного сотрудника вывод могу осуществить, для нескольких не знаю. Понимаю, что нужен цикл, но не понимаю, как его написать
Ответ: Dutenass, когда открываете Сотрудников - появилась кнопка "Печать сотрудников". Все операции сделаны в справочнике Сотрудники, в конфигураторе смотрите Макет там же, сама процедура печати в модуле менеджера спр Сотрудники.
Вопрос: Печать 2х экземпляров на одном листе

Здравствуйте! При использовании групповой обработки справочников и документов для печати есть функция печать с предварительным просмотром где можно указать количество экземпляров на одной странице. Нужно напечатать 2 экземпляра на одном листе. При выборе функции без предварительного просмотра по умолчанию он печатает один экземпляр на одной странице. Есть ли в 1С бухгалтерия 2.0 настройка печати без предварительного просмотра? Хотя когда отправляешь на печать без предварительного просмотра программа пишет, что будут использованы настройки предыдущей печати, но программа почему то их не использует.
Ответ: () Обычно "ярлык" или "набор параметров" или еще как там обозвано можно отредактировать и потом использовать при печати быстро меняя
Вопрос: БП2 печать из внешней ПФ

В БП2 добавлен нетиповой документ, установлен для него запрет Проведения.
В модуль формы добавлены стандартные процедуры кнопок печати:
// Процедура устанавливает подменю "Печать" и кнопку "Печать по умолчанию" при необходимости

//
Процедура УстановитьКнопкиПечати()
    
    мДеревоМакетов = УниверсальныеМеханизмы.ПолучитьДеревоМакетовПечати(Ссылка, Неопределено, Новый Действие("ОсновныеДействияФормыПечать"), Новый Действие("ОсновныеДействияФормыУстановитьПечатьПоУмолчанию"));

    УниверсальныеМеханизмы.УстановитьПодменюПечати    (мПодменюПечати, ЭлементыФормы.ОсновныеДействияФормы, мДеревоМакетов.Строки.Количество() > 0);
    УниверсальныеМеханизмы.УстановитьПечатьПоУмолчанию(мПечатьПоУмолчанию, ЭлементыФормы.ОсновныеДействияФормы, мДеревоМакетов, Метаданные().Имя,Новый Действие("ОсновныеДействияФормыПечатьПоУмолчанию"));

    Если НЕ мПодменюПечати = Неопределено Тогда
        УниверсальныеМеханизмы.СформироватьПодменю(мДеревоМакетов, мПодменюПечати, Истина, Истина);
    КонецЕсли;
    
КонецПроцедуры// УстановитьКнопкиПечати()


Кнопки печати на форме есть, но недоступны. Не подскажете, куда копать?
Ответ: () это ж надо было нарваться на СписаниеОС, где есть процедуры кнопок печати, но нет Процедур действий...

Спасибо,