Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: Запрет на редактирование макета внешней печатной формы

Здравствуйте!
Возможно ли установить запрет на редактирование макета внешней печатной формы (только одного объекта)? Т.е. чтобы у макета стояла Защита и ещё нельзя было включить возможность редактирования через Таблица -> Вид -> Редактирование
При этом чтобы не ограничивать права на редактирование вообще всех печатных форм?
Ответ:
Да, мне как раз и надо только печатать. Чтобы не изменить, не сохранить.
Спасибо!
Вопрос: Создание внешней печатной формы с возможностью передачи параметров

Пытаюсь переделать внешнюю печатную форму из 1С 8.2 под версию 8.3, в связи с чем возникают ошибки..
Помогите, пожалуйста, разобраться в коде. При присоединении отчета выдает ошибку "Метод объекта не обнаружен (Печать)".
Все дело в форме через которую передаются параметры, но я впервые программирую на 1С и не знаю что не так ...

Код 1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
#Если Сервер Или ТолстыйКлиентОбычноеПриложение Или ВнешнееСоединение Тогда
//ПОДГОТОВКА РЕГИСТРАЦИИ ГЛОБАЛЬНОГО ОТЧЕТА 
Функция ПолучитьНазначениеОбработки ()
    Массив = Новый Массив;
    Массив.Добавить("Документ.ТребованиеНакладная");
    Возврат Массив;
КонецФункции
 
Функция СведенияОВнешнейОбработке() Экспорт 
 
ПараметрыРегистрации = Новый Структура; 
ПараметрыРегистрации.Вставить("Вид", "ПечатнаяФорма"); //Варианты: "ДополнительнаяОбработка", "ДополнительныйОтчет", "ЗаполнениеОбъекта", "Отчет", "ПечатнаяФорма", "СозданиеСвязанныхОбъектов" 
ПараметрыРегистрации.Вставить("назначение", ПолучитьНазначениеОбработки ());
ПараметрыРегистрации.Вставить("Наименование", "Акт НА СПИСАНИЕ ПРОЧИХ МАТЕРИАЛОВ (фор. С-2)"); 
ПараметрыРегистрации.Вставить("Версия", "1.0"); //"1.0" 
ПараметрыРегистрации.Вставить("БезопасныйРежим", Истина); //Варианты: Истина, Ложь 
ПараметрыРегистрации.Вставить("Информация", "Акт на списание прочих материалов"); 
 
ТаблицаКоманд = ПолучитьТаблицуКоманд();
 
ДобавитьКоманду(ТаблицаКоманд, "Акт НА СПИСАНИЕ ПРОЧИХ МАТЕРИАЛОВ (фор. С-2)", "ПечатьАКТС2", "ВызовСерверногоМетода", Ложь, "ПечатьMXL");
ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);
 
Возврат ПараметрыРегистрации;
КонецФункции
 
 
Функция ПолучитьТаблицуКоманд()
Команды = Новый ТаблицаЗначений;
Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));//как будет выглядеть описание печ.формы для пользователя
Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка")); //имя макета печ.формы
Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка")); //ВызовСерверногоМетода
Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
Возврат Команды;
КонецФункции
 
Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")
 
НоваяКоманда = ТаблицаКоманд.Добавить();
НоваяКоманда.Представление = Представление; 
НоваяКоманда.Идентификатор = Идентификатор;
НоваяКоманда.Использование = Использование;
НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
НоваяКоманда.Модификатор = Модификатор;
 
КонецПроцедуры
        
&НаКлиенте
 
 
Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
 
УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "АКТ НА СПИСАНИЕ ПРОЧИХ МАТЕРИАЛОВ (форма С-2)", "Акт на списание", СформироватьПечатнуюФорму("Форма", МассивОбъектов[0], ОбъектыПечати));
 
КонецПроцедуры // Печать()
 
&НаСервере
Функция ПечатьАКТС2(ИмяМакета)
    
 
    Форма=ЭтотОбъект.ПолучитьФорму("Форма");
    Форма.ОткрытьМодально();
    ЭтотОбъект.Печать();
    
    
 
    
    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("Ссылка", СсылкаНаОбъект);
    Запрос.Текст = 
    "ВЫБРАТЬ
    |   ТребованиеНакладная.Ссылка,
    |   ТребованиеНакладная.ВерсияДанных,
    |   ТребованиеНакладная.ПометкаУдаления,
    |   ТребованиеНакладная.Номер,
    |   ТребованиеНакладная.Дата,
    |   ТребованиеНакладная.Проведен,
    |   ТребованиеНакладная.Организация,
    |   ТребованиеНакладная.Склад,
    |   ТребованиеНакладная.Ответственный,
    |   ТребованиеНакладная.Комментарий,
    |   ТребованиеНакладная.СчетЗатрат,
    |   ТребованиеНакладная.Субконто1,
    |   ТребованиеНакладная.ПодразделениеЗатрат,
    |   ТребованиеНакладная.Субконто2,
    |   ТребованиеНакладная.Субконто3,
    |   ТребованиеНакладная.ОтражениеВУСН,
    |   ТребованиеНакладная.НДСвСтоимостиТоваров,
    |   ТребованиеНакладная.Контрагент,
    |   ТребованиеНакладная.СчетСписанияНДС,
    |   ТребованиеНакладная.СубконтоСписанияНДС1,
    |   ТребованиеНакладная.СубконтоСписанияНДС2,
    |   ТребованиеНакладная.СубконтоСписанияНДС3,
    |   ТребованиеНакладная.ДляСписанияНДСиспользоватьСчетИАналитикуУчетаЗатрат,
    |   ТребованиеНакладная.СчетаУчетаЗатратВТаблице,
    |   ТребованиеНакладная.РучнаяКорректировка,
    |   ТребованиеНакладная.Материалы.(
    |       Ссылка,
    |       НомерСтроки,
    |       Номенклатура,
    |       Счет,
    |       КоличествоМест,
    |       ЕдиницаИзмерения,
    |       Коэффициент,
    |       Количество,
    |       СтранаПроисхождения,
    |       НомерГТД,
    |       ОтражениеВУСН,
    |       СчетЗатрат,
    |       ПодразделениеЗатрат,
    |       НоменклатурнаяГруппа,
    |       СтатьяЗатрат,
    |       ДокументОприходования,
    |       Себестоимость,
    //|       ПричинаВыбытия
    |   )
    //,
    //| ТребованиеНакладная.МатериалыЗаказчика.(
    //|     Ссылка,
    //|     НомерСтроки,
    //|     Номенклатура,
    //|     Счет,
    //|     КоличествоМест,
    //|     ЕдиницаИзмерения,
    //|     Коэффициент,
    //|     Количество,
    //|     СчетПередачи
    //| )
    |ИЗ
    |   Документ.ТребованиеНакладная КАК ТребованиеНакладная
    |ГДЕ
    |   ТребованиеНакладная.Ссылка = &Ссылка";
    
    Результат = Запрос.Выполнить();
    ВыборкаДетальныеЗаписи = Результат.Выбрать();
    ТабДокумент   = Новый ТабличныйДокумент();
    
       
    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        // Вставить обработку выборки ВыборкаДетальныеЗаписи
        Макет         = ПолучитьМакет("Макет");
        //Макет = Документы.РасходнаяНакладная.ПолучитьМакет("Основной");
        Область = Макет.ПолучитьОбласть("Шапка");
        //ОбластьМакета.Параметры.Заголовок    = "А К Т  №"+Строка(ВыборкаДетальныеЗаписи.Номер);
        //ОбластьМакета.Параметры.ДатаДок        = Формат( ВыборкаДетальныеЗаписи.Дата, "ДФ=dd.MM.yy");
        //ОбластьМакета.Параметры.Организация    = ВыборкаДетальныеЗаписи.Организация.Наименование;
        //ОбластьМакета.Параметры.подразделение  = ВыборкаДетальныеЗаписи.Склад.Наименование;
        //ОбластьМакета.Параметры.МОЛ            = МОЛ.Наименование;
        //ОбластьМакета.Параметры.МОЛД          =МОЛД;          
        //ОбластьМакета.Параметры.МОЛ               =МОЛ.Наименование;
        Область.Параметры.Член1Д=Член1Д;            
        Область.Параметры.Член1=Член1.Наименование; 
        Область.Параметры.Член2Д=Член2Д;            
        Область.Параметры.Член2=Член2.Наименование;     
    
 
 
        //ОбластьМакета.Параметры.Участок        = ВыборкаДетальныеЗаписи.ПодразделениеЗатрат.Наименование;
        //ОбластьМакета.Параметры.КорСчет        = ВыборкаДетальныеЗаписи.СчетЗатрат.Код;
        //ОбластьМакета.Параметры.Аналитика      = ?(ВыборкаДетальныеЗаписи.Субконто1=Неопределено,"",    ВыборкаДетальныеЗаписи.Субконто1.Наименование)+
        //?(ВыборкаДетальныеЗаписи.Субконто2=Неопределено,"","/"+ВыборкаДетальныеЗаписи.Субконто2.Наименование)+
        //?(ВыборкаДетальныеЗаписи.Субконто3=Неопределено,"","/"+ВыборкаДетальныеЗаписи.Субконто3.Наименование);
        //ОбластьМакета.Параметры.ДатаСоставления= Формат( ВыборкаДетальныеЗаписи.Дата, "ДФ=dd.MM.yy");
        
        ТабДокумент.Вывести(Область);
        //выведем область "Шапка" в табличный документ
        ТабДокумент.Вывести(Макет.ПолучитьОбласть("Шапка"));
        
        // Строчки    
        СтруктураПолей = Новый Структура;
        СтруктураПолей.Вставить("Материал",     "Номенклатура");        
        СтруктураПолей.Вставить("Наименование", "Номенклатура.НаименованиеПолное");
        СтруктураПолей.Вставить("Единица",      "Номенклатура.БазоваяЕдиницаИзмерения");
        СтруктураПолей.Вставить("Код",          "Номенклатура.Код");
        СтруктураПолей.Вставить("ЕдиницаИзмеренияКод",          "Номенклатура.БазоваяЕдиницаИзмерения.Код");
        
        СтруктураПолей.Вставить("Колво",        "Количество");
        
        
        
        ТаблицаМатериалов = ОбщегоНазначения.СформироватьЗапросПоТабличнойЧасти(СсылкаНаОбъект, "Материалы", СтруктураПолей).Выгрузить();
        ТаблицаМатериалов.Свернуть("Материал,Наименование,Единица,Код,ЕдиницаИзмеренияКод", "Колво");
        
        // Поиск сумм списания активов для заполнения Цены и Суммы
        ТаблицаСуммСписания = БухгалтерскийУчет.ПолучитьСуммуСписанияАктивов(СсылкаНаОбъект);
        
        НомерТекущий = 1;
        Для Каждого СтрокаТЧ Из ТаблицаМатериалов Цикл
            ОбластьМакета = Макет.ПолучитьОбласть("Строка");
            ОбластьМакета.Параметры.Заполнить(СтрокаТЧ);
            ОбластьМакета.Параметры.НомерТекущий = НомерТекущий;
            СтрокаСуммСписания =  ТаблицаСуммСписания.Найти(СтрокаТЧ.Материал, "Номенклатура");
            ////Если СтрокаСуммСписания = Неопределено Тогда
            ////    ОбластьМакета.Параметры.Цена = 0;
            ////    ОбластьМакета.Параметры.Сумма = 0;
            ////    //ОбластьМакета.Параметры.Причина = "";
            ////Иначе
            ////    Цена = ?(СтрокаСуммСписания.Количество = 0, 0, СтрокаСуммСписания.Сумма / СтрокаСуммСписания.Количество);
            ////    ОбластьМакета.Параметры.Цена  = Цена;
            ////    ОбластьМакета.Параметры.Сумма = Цена * СтрокаТЧ.Колво;
            ////    ОбластьМакета.Параметры.Причина = ВыборкаДетальныеЗаписи.комментарий ;
            //КонецЕсли;
            Область.Параметры.Причина = "";
             
            ТабДокумент.Вывести(Область);
             НомерТекущий = НомерТекущий + 1;
            
            
        КонецЦикла;
        Область = Макет.ПолучитьОбласть("Шапка");
            
        Область = Макет.ПолучитьОбласть("Подвал");
                
        ОбластьМакета.Параметры.Член1Д=Член1Д;          
        ОбластьМакета.Параметры.Член1=Член1.Наименование;   
        ОбластьМакета.Параметры.Член2Д=Член2Д;          
        ОбластьМакета.Параметры.Член2=Член2.Наименование;       
        ТабДокумент.Вывести(Область);
        Возврат ТабДокумент;
    КонецЦикла;
    
 
    
КонецФункции    //печатьАКТС2
 
    
     //получить таблицу команд (команды которые будут поставялться обработкой)
     
    
#КонецЕсли
В архиве обе печатные формы, под 8.2 и переделанная 8.3
Ответ: У вас внешняя печатная форма, Встречается ЭтотОбъект.Ссылка и СсылкаНаОбъект приведите все к ссылкенаобъект. Далее в запросе у вас параметр
Код 1C
1
 Запрос.УстановитьПараметр("Ссылка", СсылкаНаОбъект);
а вот ссылку лучше передавать в массивобъектов.
Код 1C
1
2
|ГДЕ
    |   ТребованиеНакладная.Ссылка = &Ссылка";
Вопрос: Внешняя печатная форма и ввод даты, на которую должна быть заполнена форма

Добрый день.
Задача к справочнику Сотрудники (ЗиК 3.1) сделать внешнюю печатную форму, которая заполняется кадровыми данными сотрудника НА УКАЗАННУЮ ДАТУ. Дата должна вводиться при формировании печатной формы. Пока было без запретам на модальные окна, все работало. Теперь не могу понять, как ввести дату отчета и затем сформировать отчет.
Ответ:
С сотрудни
--- Объединение сообщений, 9 окт 2017 ---
Вопрос: Печать в РТиУ через комплект документов на принтер формы из внешней печатной формы

Добрый день!
Подключил внешнюю печатную форму и теперь при печати в РТиУ через стандартную обработку печати комплекта документов возникает ошибка "Метод объекта не обнаружен (Печать)". Когда делал ВПФ, то расположил функцию Печать() в модуле формы.
Код:
Функция Печать(ИдентификаторКоманды,ОбъектыНазначения) Экспорт
Все корректно отрабатывает, кроме этого.
Ответ:
Добрый день!

Переработал обработку и расположил Печать() в модуле объекта, но все-равно возникает ошибка:

Вот что в модуле объекта:
Код:
Функция СведенияОВнешнейОбработке() Экспорт
    ПараметрыРегистрации = Новый Структура;
    МассивНазначений = Новый Массив;
    МассивНазначений.Добавить("Документ.РеализацияТоваровУслуг"); //Указываем документ к которому делаем внешнюю печ. форму

    ПараметрыРегистрации.Вставить("Вид", "ПечатнаяФорма"); //может быть - ЗаполнениеОбъекта,
                                                           //ДополнительныйОтчет, СозданиеСвязанныхОбъектов...
   
   
    ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);
    ПараметрыРегистрации.Вставить("Наименование", "Бланк гарантии"); //имя под которым обработка
                                                            // будет зарегестрирована в справочнике внешних обработок
    ПараметрыРегистрации.Вставить("БезопасныйРежим", ЛОЖЬ);
    ПараметрыРегистрации.Вставить("Версия", "1.0");   
    ПараметрыРегистрации.Вставить("Информация", "Дополнительная печатная форма к документу РТУ");
   
    ТаблицаКоманд = ПолучитьТаблицуКоманд();
   

    ДобавитьКоманду(ТаблицаКоманд, "Бланк гарантии", "БланкГарантии", "ВызовКлиентскогоМетода", Истина, "ПечатьMXL");
    ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);
   
    Возврат ПараметрыРегистрации;
КонецФункции

Функция ПолучитьТаблицуКоманд()
  Команды = Новый ТаблицаЗначений;
  Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));//как будет выглядеть описание
                                                                           //печ.формы для пользователя

  Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка")); //имя макета печ.формы
  Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка")); //ВызовСерверногоМетода
  Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
  Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
  Возврат Команды;
КонецФункции

Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")

  НоваяКоманда = ТаблицаКоманд.Добавить();
  НоваяКоманда.Представление = Представление; 
  НоваяКоманда.Идентификатор = Идентификатор;
  НоваяКоманда.Использование = Использование;
  НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
  НоваяКоманда.Модификатор = Модификатор;

КонецПроцедуры

Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
   
    УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "БланкГарантии", "Бланк гарантии)", СформироватьПечатнуюФорму(МассивОбъектов[0], ОбъектыПечати));
   
КонецПроцедуры // Печать()


Функция ВернутьМакет()
   
    Макет = ЭтотОбъект.ПолучитьМакет("ГарантийныйТалон");
   
    Возврат Макет;
   
КонецФункции

Функция СформироватьПечатнуюФорму(МассивОбъектов, ОбъектыПечати) Экспорт
    ТабДок = Новый ТабличныйДокумент;
   
    ТекстЗапроса =
    "ВЫБРАТЬ
    |    ЕСТЬNULL(МЛ_ПринадлежностиАвтомобилей.Комплектация, """") КАК Применимость,
    |    ВложенныйЗапрос.Номенклатура.Наименование КАК Номенклатура,
    |    ВложенныйЗапрос.Номенклатура.Артикул КАК Артикул,
    |    ВложенныйЗапрос.НомерСтроки КАК НомерСтроки
    |ИЗ
    |    (ВЫБРАТЬ
    |        РеализацияТоваровУслугТовары.Номенклатура КАК Номенклатура,
    |        РеализацияТоваровУслугТовары.Ссылка КАК Ссылка,
    |        РеализацияТоваровУслугТовары.Характеристика КАК Характеристика,
    |        РеализацияТоваровУслугТовары.Склад КАК Склад,
    |        МИНИМУМ(РеализацияТоваровУслугТовары.НомерСтроки) КАК НомерСтроки
    |    ИЗ
    |        Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслугТовары
    |    ГДЕ
    |        РеализацияТоваровУслугТовары.Ссылка В(&МассивОбъектов)
    |   
    |    СГРУППИРОВАТЬ ПО
    |        РеализацияТоваровУслугТовары.Ссылка,
    |        РеализацияТоваровУслугТовары.Номенклатура,
    |        РеализацияТоваровУслугТовары.Характеристика,
    |        РеализацияТоваровУслугТовары.Склад) КАК ВложенныйЗапрос
    |        ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.МЛ_ПринадлежностиАвтомобилей КАК МЛ_ПринадлежностиАвтомобилей
    |        ПО ВложенныйЗапрос.Номенклатура.АртикулЧ = МЛ_ПринадлежностиАвтомобилей.АртикулЧ
    |
    |УПОРЯДОЧИТЬ ПО
    |    ВложенныйЗапрос.Ссылка,
    |    НомерСтроки
    |ИТОГИ
    |    МАКСИМУМ(Артикул)
    |ПО
    |    Номенклатура";
    Запрос = Новый Запрос;
    Запрос.Текст = ТекстЗапроса;
    Запрос.УстановитьПараметр("МассивОбъектов", МассивОбъектов);
   
    Выборка = Запрос.Выполнить().Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
   
    Выборка.Следующий();
    ВыборкаДетальныеЗаписи = Выборка.Выбрать();
    Сч = 1;
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        Если Сч>1 Тогда
            Если Ложь Тогда
                Строка = " ";
            КонецЕсли;
            Строка.Применимость = Строка.Применимость + "; " + Символы.ПС + Строка(ВыборкаДетальныеЗаписи.Применимость);
        Иначе
            ТЗ = Новый ТаблицаЗначений;
            ТЗ.Колонки.Добавить("Применимость");
            ТЗ.Колонки.Добавить("Номенклатура");
            Строка = ТЗ.Добавить();
            Строка.Применимость = Строка(ВыборкаДетальныеЗаписи.Применимость);
            Строка.Номенклатура = ВыборкаДетальныеЗаписи.Номенклатура;
        КонецЕсли;
        Сч = Сч+1;
    КонецЦикла;
   
    Макет = ВернутьМакет();   
    Шапка = Макет.ПолучитьОбласть("Шапка");
    Шапка.Параметры.Заполнить(ТЗ[0]);
   
    //Шапка.Параметры.СерийныйНомер = "";
    Шапка.Параметры.ДатаПроизводства = НачалоДня(ТекущаяДата())-86400*3;
    Шапка.Параметры.Дата = ТекущаяДата();
    ТабДок.Вывести(Шапка);
   
    ТабДок.ОтображатьСетку = Ложь;
    ТабДок.Защита = Ложь;
    ТабДок.ТолькоПросмотр = Ложь;
    ТабДок.ОтображатьЗаголовки = Ложь;

    Возврат ТабДок;
КонецФункции
--- Объединение сообщений, 9 янв 2017 ---
Спасибо, разобрался. Нужно было указать "ВызовСерверногоМетода".
Вопрос: 8.3 Управляемые формы Печать внешних печатных форм УПП

Приветствую, подскажите, кто сталкивался. Есть необходимость печатать внешние печатные формы из тонкого клиента, через формы выбора печатной формы, аналогично тому как это реализовано через толстый клиент -
УниверсальныеМеханизмы.ОткрытьФормуВыбораПечатныхФормОбъекта(ЭтотОбъект, ЭтаФорма);

Подскажите, кто может кто сталкивался с подобной задачкой?

Спасибо.
Ответ: () Переводил печать документов с толстого клиента на тонкий. Подключил БСП 2.х, формирование печатных форм из модулей объектов ушло в модули менеджеров объектов. Дополнительно вместо печати документа по одной ссылке пришлось переделать запросы и формирование табличного документа на печать по массиву ссылок, но это уже чтобы задействовать все возможности БСП.
Вопрос: Внешняя печатная форма

Всем доброго времени суток!
Платформа: 1С:Предприятие 8.3 (8.3.8.1652)
Конфигурация: Управление торговлей, редакция 11.2 (11.2.3.168)

Обновил конфу с 11.2.2.106
Теперь нет команды на внешние печатные формы, в журнале "складские акты", хотя в списке документов "списание недостач товаров" и в самом документе, команда есть.
Кто сталкивался?
Ответ:
1. посмотри обработчик формы, там должен быть служебный вызов этой подсистемы для формы, типа такого
Код:
// СтандартныеПодсистемы.Печать
    УправлениеПечатью.ПриСозданииНаСервере(ЭтаФорма);
2. посмотри настройки типов в командах
3. в модуле менеджера документа смотри раздел печатных форм, типа такого
Код:
// Заполняет список команд печати.
//
// Параметры:
//   КомандыПечати - ТаблицаЗначений - состав полей см. в функции УправлениеПечатью.СоздатьКоллекциюКомандПечати
//
Процедура ДобавитьКомандыПечати(КомандыПечати) Экспорт
Вопрос: Внешние печатные формы ЗУП 3.1 клиент - серверный вариант

Всем здраствуйте! Работаю в ЗУП 3.1 последнего релиза. Недавно перешли с файлового варианта на клиент - сервер. Имеются печатные формы внешние в Word. Их пришлось переделать, так как заполнение происходит на клиенте. По команде на форме все заполняется корректно. Вопрос: Как реализовать внешнюю печатную форму на клиент - серверном варианте? Насколько я знаю, печать внешней печатной формы выполняется по наличию процедуры печать в модуле обработки и в нее передаются данные из серверной процедуры, но сейчас мы заполняем на клиенте. Или как по - другому можно встроить печатную форму? Заранее спасибо!
Ответ:
До этого я реализовывал через макет Active document, а тут через Двоичные данные. Так и сделал, шрифт меняется только. Скидываю результат обработки и макет

Вложения:

  • Размер файла:
    23,9 КБ
    Просмотров:
    0
  • Размер файла:
    63,5 КБ
    Просмотров:
    0
Вопрос: Печать из внешней печатной формы

Доброго времени суток!

Конфа: Управление торговлей, редакция 11.2 (11.2.2.106)

Подключил внешнюю печатную форму (во вложении) но при её выборе выскакивает ошибка:

{ОбщийМодуль.ДополнительныеОтчетыИОбработки.Модуль(238)}: В обработчике печати не был сформирован табличный документ для: ПФ_MXL_ПриходнаяНакладнаяВнешняя
ВызватьИсключение(ТекстСообщенияОбОшибке);

Вложения:

  • Размер файла:
    11,6 КБ
    Просмотров:
    3
Ответ:
Да, действительно! Спасибо.
Вопрос: Проблема с выводом таблицы из внешней печатной формы

Доработал чуток внешнюю печатную форму для УТ 11.1, добавил колонку для подписей, вроде бы и рамки добавил, но никак не могу заставить пропечатываться их при выводе таблицы. Вроде бы сущий пустяк, но что-то никак не получается. Понимаю, что дело в коде, подскажите, пожалуйста, как правильно оформить вывод этой пустой колонки. Вот скриншот (красная вертикальная черта - это непропечатываемая колонка)

Вложения:

  • Размер файла:
    14,9 КБ
    Просмотров:
    2
Ответ:
Всем спасибо, разобрался сам. Поместил присоединение не в то место цикла, вот и не работало.
Надо было сделать:
ОбластьКладовщики = Макет.ПолучитьОбласть("СтрокаТаблицы|Кладовщики");

И далее уже в цикле вывода просто добавить
ТабличныйДокумент.Присоединить(ОбластьКладовщики);

С утра все-таки голова намного лучше работает, вчера вечером не смог сразу понять в чем проблема
Вопрос: Как во внешней печатной форме прописать постраничный вывод ТабДока?

Можно ли во внешней печатной форме прописать возможность постраничного вывода ТабДока? Точней выбора страницы которую нужно напечатать? Или такая настройка есть уже в предприятии?
Ответ:
В унф так написано , если вы про это


ТабДокумент = Новый ТабличныйДокумент;
ТабДокумент.КлючПараметровПечати = "ПараметрыПечати_ПутевойЛист";

ПервыйДокумент = Истина;

Для Каждого ТекущийДокумент Из МассивОбъектов Цикл

Если Не ПервыйДокумент Тогда
ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц();
КонецЕсли;

___________________________________________________________
это из другого
___________________________________________________________

ПервыйДокумент = Ложь;
--- Объединение сообщений, 17 апр 2017 ---
Для стр=1 По 2 Цикл

Если стр=1 Тогда

ТабличныйДокумент.Вывести(Макет.ПолучитьОбласть("Разделитель"));

КонецЕсли;