Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: Путаница с КонтакнойИнформацией справочников Партнеры и Контрагенты

Поле имеет тип Справочник ссылка контрагенты. Проваливаюсь в контрагента черз 2 квадратика в поле. Заполняю фактический адрес запросм обращаюсь к справочнику КОНТРАГЕНТЫ к этому адресу. НЕТ ТАКОГО. Обращаюсь к справочнику ПАРТНЕРЫ. И получаю АДРЕС КОНТРАГЕНТА. Как так может быть?

Код:
ВЫБРАТЬ
    КонтрагентыКонтактнаяИнформация.Представление КАК Представление
ИЗ
    Справочник.Партнеры.КонтактнаяИнформация КАК КонтрагентыКонтактнаяИнформация
ГДЕ
    КонтрагентыКонтактнаяИнформация.Ссылка = &Ссылка
    И КонтрагентыКонтактнаяИнформация.Вид = ЗНАЧЕНИЕ(Справочник.ВидыКонтактнойИнформации.ФактАдресКонтрагента)
Ответ:
Подсказали в чем проблема. Оказалось что это больше по настойке программы вопрос.



Вот если бы была галка, то я бы таки попал в справочник Контрагенты натурально.

Я выбираю через все функции справочник Контрагенты. Он меня перенаправляет на справочник партнеры, и названии формы пишет "Справочник Контрагенты". Хоть бы название меняли на справочник партнеры при перенаправлении, сразу бы возник вопрос: "Почему так?". Это типа как в анекдоте купил мужик машину иномарку, пока гнал всю дорогу что-то торохтело. Приехал домой, не выдержал разобрал пол машины нашел гайку прикрученную на проволоке и записочку: "Нашел. Молодец"

Тему можно закрывать
Вопрос: получить доп. реквизиты справочника партнеры

Добрый день.
Есть внешняя печатная форма "Накладная на отправку". Нужно вывести доп. реквизит созданный в самой программе 1с предприятие 8.3 УТ 11.4.
Код запроса ниже.
Код:
Функция РН_ПолучитьЗначениеДопРеквизита(Партнер,НаименованиеДопРеквизита,ЭтоДопСведение = Ложь)
Запрос = Новый Запрос;
Если ЭтоДопСведение Тогда
  Запрос.Текст =
  "ВЫБРАТЬ РАЗРЕШЕННЫЕ ПЕРВЫЕ 1
  | ДополнительныеСведения.Значение
  |ИЗ
  | РегистрСведений.ДополнительныеСведения КАК ДополнительныеСведения
  |ГДЕ
  | ДополнительныеСведения.Объект = &Ссылка
  | И ДополнительныеСведения.Свойство.Заголовок = &НаименованиеДопРеквизита
  | И НЕ ДополнительныеСведения.Свойство.ПометкаУдаления"
Иначе
  Запрос.Текст =
  "ВЫБРАТЬ РАЗРЕШЕННЫЕ ПЕРВЫЕ 1
  | ПартнерыДополнительныеРеквизиты.Значение КАК Значение
  |ИЗ
  | Справочник.Партнеры.ДополнительныеРеквизиты КАК ПартнерыДополнительныеРеквизиты
  |ГДЕ
  | ПартнерыДополнительныеРеквизиты.Свойство.Заголовок = &НаименованиеДопРеквизита
  | И ПартнерыДополнительныеРеквизиты.Ссылка = &Ссылка
  | И НЕ ПартнерыДополнительныеРеквизиты.Свойство.ПометкаУдаления";
КонецЕсли;
Запрос.УстановитьПараметр("НаименованиеДопРеквизита", НаименованиеДопРеквизита);
Запрос.УстановитьПараметр("Ссылка", Партнер);
Выборка = Запрос.Выполнить().Выбрать();            
Если Выборка.Количество() > 0 Тогда
  Выборка.Следующий();
  Возврат Выборка.Значение
Иначе
  Возврат "";
КонецЕсли;
КонецФункции
Код формирования строки
Код:
                Область = Макет.ПолучитьОбласть("Отправка");
                СтруктураДанныхОтправка = Новый Структура;
                    ТК = РН_ПолучитьЗначениеДопРеквизита(ВыборкаПоСкладам.Контрагент,"ТК",Ложь);
                СтруктураДанныхОтправка.Вставить("ОтправкаТК", ТК);       
                Область.Параметры.Заполнить(СтруктураДанныхОтправка);
                ТабличныйДокумент.Вывести(Область);
В итоге в печатной форме пусто
ВПФ прилагаю.

Вложения:

  • Размер файла:
    19 КБ
    Просмотров:
    0
Ответ:
Извините, просто я не правильно выразил вопрос. У меня в настройках везде указано, что контрагенты. Галочка "Независимо вести партнеров и контрагентов" не поставлена. Но почему то, если создаю доп реквизит для контрагентов, в справочнике ничего не появляется, а если для партнеров, то появляется.
--- Объединение сообщений, 30 май 2018 ---
Вопрос решил. Всем спасибо.
Нужно было делать так
Код функции:
Код:
Функция ПолучитьЗначениеДопРеквизита(Ссылка, Свойство) Экспорт

    ПараметрыОтбора = Новый Структура;
    ПараметрыОтбора.Вставить("Свойство",Свойство);
    Массив = Ссылка.ДополнительныеРеквизиты.НайтиСтроки(ПараметрыОтбора);

    Если Массив.Количество() = 0 Тогда
        Возврат Неопределено;
    Иначе
        Возврат Массив[0].Значение;
    КонецЕсли;

КонецФункции
Код обращения к функции
Код:
ТК = ПолучитьЗначениеДопРеквизита(ВыборкаПоСкладам.Ссылка.Партнер,ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ТК (Общие)"));
Вопрос: v7: Как получить в запросе только группы справочника первого уровня?

Как получить в запросе только группы справочника первого уровня?
Ответ: и зачем запрос, когда 7-9 сделает это быстрее.
Сравнимо с прямым запросом
Вопрос: Поле Контрагент в списке справочника Партнеров

Добрый день.
У партнера несколько контрагентов. Можно ли в списке справочника партнеров вывести данные в несколько строк:

Партнер1   Контрагент1
Партнер1   Контрагент2

Я попробовал добавить поле контрагента, при чём в результате запроса динамического списка действительно 2 строки (проверил консолькой), но в режиме предприятия оно просто не выводится.

В типовой реализовано неудобной для поиска ссылкой, по которой просто открывается список контрагентов выделенного партнера.
Ответ: яснее не стало
Вопрос: [РЕШЕНО] Значение заполнения реквизита справочника в зависимости от контекста

Уважаемые эксперты, прошу подсказки.
КА-2.2.2.199
В зависимости от того, в каком разделе создается новый элемент справочника Партнеры, по умолчанию при открытии формы нового элемента устанавливается флажок "Клиент" (если в разделе Продажи) или "Поставщик" (в разделе Закупки).
При создании нового в разделе "Главное" - все флажки по умолчанию сняты, а мне надо, чтобы в этом случае автоматом устанавливался флаг "Прочие отношения".
Подскажите, пожалуйста, как надо это сделать. Никак не могу найти, где и как управляется заполнение этих флажков.
Спасибо!
Ответ:
Спасибо! То что надо!
Вопрос: Оптимизация запроса

Всем привет. Есть дин. список, поля из запроса убирать нельзя, но необходимо добавить поле ИНН для поиска по нему.
Код:
ВЫБРАТЬ
    СправочникПартнеры.Ссылка,
    СправочникПартнеры.ПометкаУдаления,
    СправочникПартнеры.Предопределенный,
    СправочникПартнеры.Родитель,
    СправочникПартнеры.Код,
    СправочникПартнеры.Наименование,
    СправочникПартнеры.БизнесРегион,
    СправочникПартнеры.ГруппаДоступа,
    СправочникПартнеры.ДатаРегистрации,
    СправочникПартнеры.Клиент,
    СправочникПартнеры.Комментарий,
    СправочникПартнеры.Конкурент,
    СправочникПартнеры.НаименованиеПолное,
    СправочникПартнеры.ОсновнойМенеджер,
    СправочникПартнеры.Поставщик,
    СправочникПартнеры.Перевозчик,
    СправочникПартнеры.ПрочиеОтношения,
    СправочникПартнеры.ОбслуживаетсяТорговымиПредставителями,
    Контрагенты.ИНН
ИЗ
    Справочник.Партнеры КАК СправочникПартнеры
        ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
            Контрагенты.ИНН КАК ИНН,
            Контрагенты.Партнер КАК Партнер
        ИЗ
            Справочник.Контрагенты КАК Контрагенты
        ГДЕ
            Контрагенты.Партнер <> ЗНАЧЕНИЕ(Справочник.Партнеры.ПустаяСсылка)
            И Контрагенты.ИНН <> ""
       
        СГРУППИРОВАТЬ ПО
            Контрагенты.ИНН,
            Контрагенты.Партнер
       
        ИМЕЮЩИЕ
            КОЛИЧЕСТВО(РАЗЛИЧНЫЕ Контрагенты.Партнер) = 1) КАК Контрагенты
        ПО СправочникПартнеры.Ссылка = Контрагенты.Партнер
Сам запрос предельно простой, но в конфе (УТ11) включена опция по раздельному ведению партнеров и контрагентов, поэтому просто слева присоединить таблицу контрагентов не вариант - получится дублирование ключевого поля в основной таблице - что критично для дин. списка.
Может у кого есть какие соображения - как можно получше написать такой запрос
Ответ:
Значит ошибка будет..
Ну или как-то сверните таблицу и если количество контрагентов на 1 партнера больше выводите в поле ИНН что-то типа <Несколько значений>.
Вопрос: УТ11 Свой поиск в форме списка партнеров

Уважаемые специалисты, скажите пожалуйста, как правильно сделать: потребовалось в форме списка партнеров организовать свой поиск по ИНН, для этого в форме добавлены 2 процедуры:

Функция СписокПартнеровПоИНН( ИНН )
    
    лТекст = "
        |ВЫБРАТЬ
        |    Контрагенты.Партнер КАК Партнер
        |ПОМЕСТИТЬ ВТ
        |ИЗ
        |    Справочник.Контрагенты КАК Контрагенты
        |ГДЕ
        |    Контрагенты.ИНН ПОДОБНО &ИНН
        |;
        |
        ////////////////////////////////////////////////////////////////////////////////

        |ВЫБРАТЬ
        |    Партнеры.Ссылка КАК Ссылка
        |ИЗ
        |    Справочник.Партнеры КАК Партнеры
        |ГДЕ
        |    Партнеры.Ссылка В ИЕРАРХИИ
        |            (ВЫБРАТЬ
        |                ВТ.Партнер
        |            ИЗ
        |                ВТ)
        |";

    лЗапрос = Новый Запрос(лТекст);
    лЗапрос.МенеджерВременныхТаблиц = Новый МенеджерВременныхТаблиц;
    лЗапрос.УстановитьПараметр("ИНН", "%" + ИНН + "%" );

    ТЗ = лЗапрос.Выполнить().Выгрузить();
    
    СписокПартнеров = Новый СписокЗначений;
    СписокПартнеров.ЗагрузитьЗначения( ТЗ.ВыгрузитьКолонку( "Ссылка") );
    
    Возврат СписокПартнеров;
    
КонецФункции

&НаКлиенте
Процедура ИННПоискаПриИзменении(Элемент)
    
    Если Не ЗначениеЗаполнено( ЭтаФорма.ИННПоиска ) Тогда
        
        ОбщегоНазначенияКлиентСервер.УстановитьЭлементОтбораДинамическогоСписка( ЭтаФорма.Список, "Ссылка", 0, ВидСравненияКомпоновкиДанных.Равно,, Ложь );    
        Возврат;
        
    КонецЕсли;
    
    СписокПартнеров = СписокПартнеровПоИНН( СокрЛП( ЭтаФорма.ИННПоиска ) );
    
    ОбщегоНазначенияКлиентСервер.УстановитьЭлементОтбораДинамическогоСписка( ЭтаФорма.Список, "Ссылка", СписокПартнеров, ВидСравненияКомпоновкиДанных.ВСписке,, Истина );    
    
КонецПроцедуры

проблема в том, что все работает правильно, если партнёр не является подчиненным другому партнёру, а подчиненный партнер - просто не выводится (дин список вообще пустой). Пробовал разные варианты ВидСравненияКомпоновкиДанных - не помогло.
Ответ: () смотри как реализован поиск по ИНН в модуле менеджера справочника контрагентов
ОбработкаПолученияДанныхВыбора
        |    Справочник.Контрагенты КАК Контрагенты
        |        ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрСведений.ИерархияПартнеров КАК ИерархияПартнеров
        |        ПО Контрагенты.Партнер = ИерархияПартнеров.Родитель
Вопрос: Переименовали и задублировали предопределенного партнера "Наше предприятие" - как исправлять?

УТ 11.4
Сопоставлением с демобазой пришёл к выводу, что в рабочей базе в пользовательском режиме переименовали предопределенный элемент справочника Партнеры "Нвше предприятие" в "Наименование Одной Из Организаций".
В конфигураторе он по прежнему зовется "Наше предприятие"

В пользовательском режиме два партнера с одинаковым наименованием "Наименование Одной Из Организаций".
На оба тысячи ссылок

Нутром чую, что это неправильно и надо что-то делать, а, вот, что - никак не могу правильно сообразить
Хелп

Да, и "Поиск и удаление дублей" не перебрасывает ссылки ни в одну, ни в другую сторону между "дублями"

Ответ:
на дисках ИТС есть обработка, под обычное приложение, в EXTREPS/UNIREPS82/SearchAndChange, называется ПоискИЗаменаЗначений.epf

пару лет назад, пользовал её на БП, когда там накуралесили с контрагентами и потом из банка выписки фиг знает как распредлелялись.

аналогичную и под 7.7 пользовал так же, когда чистили и в порядок справочники контрагентов и номенклатуры приводили в одной конторе.
Вопрос: УТ 11, справочник партнеры и контрагенты.

Всем добрый день!
Осваиваю УТ 11, наткнулся на нововведения платформы видимо. Делаю запрос:

ВЫБРАТЬ
    ДоговорыКонтрагентов.Контрагент,
    ДоговорыКонтрагентов.Партнер,
    ДоговорыКонтрагентов.Ссылка
ИЗ
    Справочник.ДоговорыКонтрагентов КАК ДоговорыКонтрагентов

И вывожу результат в отчет через СКД.
Если в настройках указать галочку «Независимо вести партнеров и контрагентов» то запрос отрабатывает нормаль, и все выводится в отчет. Если эту галочку убрать, то в отчете пропадает колонка Контрагент. Вопрос как это все работает?, т.е. как какая та настройка и через какие механизмы влияет на то какие колонки в моем отчеты выведены?

Спасибо!
Ответ: Спасибо большое VikingKosmo!!!, а то я все косился на них, и думал, зачем они нужны.
Нашёл хорошую статью про них.
)
Вопрос: права доступа для изменения справочника партнеров

Добрый день!

слетели права доступа в УТ 11 (11.3.3.196) на платформе: 8.3 (8.3.10.2252)

использую стандартный профиль: Ответственный за ведение партнеров (дополнительный)
а пользователю все одно не дает изменять партнера

посоветуйте где искать края. не хочется давать пользователю все функции.
Ответ:
проблема починилась
спасибо