Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: доступность кнопки

добрый день!по условию закрываю форму на просмотр и открываю только пару реквизитов.но кнопка ОК не активна внизу формы.В чем трабл?че не так?
Для каждого Элемент Из ЭтаФорма.ЭлементыФормы цикл
Имя_ = Элемент.Имя;
Если имя_="Название" ИЛИ  имя_="Комментарий" Тогда
//    продолжить

Элемент.Доступность= Истина; 
Иначе
Элемент.Доступность= Ложь; 
КонецЕсли; 
КонецЦикла;
                         элементыформы.ОсновныеДействияФормы.Кнопки.ОК.Доступность=Истина;
Ответ: () читать () до просвещения.
Вопрос: Доступность кнопок формы печати документов.

КА. Для типовых форм печати например ТОРГ-12, используется общая форма ПечатьДокументовУправляемая. На ней есть кнопки Отправить по почте, ПечатьПоКомплектно и другие. Под некоторыми пользователями этих кнопок не видно. При отладке в процедура ПриСозданииНаСервере этих кнопок нет - обращение к Элементы.ОтправитьПоПочте вызывает ошибку "Поле объектка не обнаружено", под пользователем с другими правами ошибки нет. Куда копать, чтоб отобразить кнопки и как их удалось скрыть до создания фомры на сервере?
Ответ: go to first line again
Вопрос: Не активна панель кнопок ДействияФормы

Доброго дня коллеги!
Платформа 8.3 Толстый клиент. УТ 10.3

Вопрос не раз уже поднимался, но всё же адекватного ответа не нашел.
Почему в любом документе в верней панели "ДействияФормы" не активны (не доступны для редактирования) такие кнопки как:
Проведение, Отмена проведения, Пересчитать, скопировать?
Где еще можно порыть, чтобы активировать "Редактирование".
Вопрос для чего?
Нужно ограничить доступ к этим кнопка определенной "Роли"

Такие процедуры как:
Если НЕ РольДоступна("ПолныеПрава") Тогда
ЭтаФорма.Элементыформы.ДействияФормы.Кнопки.Действие4.Доступность = Ложь;
КонецЕсли;

Не помогают.
Ответ: Можно конечно их замазать (эта самый просто вариант) :)
Нооо, а что делать в "подменю1", эта кнопка тоже есть
Вопрос: Ведомость по партиям товаров на складах и анализ доступности товаров на складах

Всем привет! Подскажите, чем отличаются данные? По ведомости остаток в ед.хранения остатков - 18 шт., а в другом (в анализе) конечный остаток 22 шт.
В Анализе доступности: Остаток в ед. хранения остатков - 18 шт., Зарезервировано в ед. хранения остатков 4 шт. Свободный остаток в ед. хранения остатков - 14.
В Ведомости Конечный остаток - 22.
Это по одному складу. А по другому в Анализе вообще нет товара, а в ведомости аж 27 штук. Не могу понять почему отличаются данные. Особенно интересна такая разница по второму складу, где по анализу вообще нет ни резервов ни остатков.
Ответ:
Ну Вам решать. Если хотите найти проблему то да. если нет То Вам тогда тупо надо выровнять корректировками записи по двум этим регистрам, а затем уже смотреть анализ доступности
Вопрос: Видимости кнопки

Разместил на форме кнопку, как ее сделать доступной только доступной для директора и администратора, и сделать недоступной и невидимой для других пользователей в системе? Можно ли как это в модуле формы прописать?
Ответ:
Код 1C
1
ПользователиИнформационнойБазы.НайтиПоИмени("ИмяПользователя").Роли;
Роли (Roles)
Использование:

Только чтение.
Описание:

Тип: РолиПользователя.
Содержит коллекцию ролей пользователя информационной базы.

Доступность:

Сервер, толстый клиент, внешнее соединение, мобильное приложение(сервер).
Примечание:

НО
Доступно только пользователю с административными правами.

Посему остаётся вариант перебора по РольДоступна()
Для Каждого Роль ИЗ Роли Цикл
Если РольДоступна(Роль) Тогда
или
Если РольДоступна(Роль.Имя) Тогда
Вопрос: Программное создание кнопки на форме документа

Надо на форме документа, чтобы появились кнопки с названиями групп справочника "Номенклатура"
Обычное приложение

Код:
НачалоЛево=1;НачалоВерх=4;
    Выборка=Справочники.Номенклатура.Выбрать();
    пока Выборка.Следующий() цикл
        если Выборка.ЭтоГруппа=Истина тогда
            а=а+1;
            Масс[а]=Выборка.Наименование;
            назКнопки=Выборка.Наименование;  //"Кнопка"+Сокрлп(а);
            НоваяКнопка = ЭлементыФормы.Добавить(Тип("Кнопка"), назКнопки);
      
            НоваяКнопка.Верх = НачалоВерх;
НоваяКнопка.Лево = НачалоЛево + (13 * (а - 1));
НоваяКнопка.Высота = 12;
НоваяКнопка.Ширина = 12;
НоваяКнопка.Шрифт = Новый Шрифт("Arial", 7);
НоваяКнопка.Заголовок = ВЫборка.Наименование;
        КонецЕсли;
    конецЦикла;
Может кто подскажет, почему кнопки не видны.
Ответ:
Написала так:
Код:
Процедура ПриОткрытии()
    НачалоЛево=70;НачалоВерх=360;   ширина=0;
 
    Выборка=Справочники.Номенклатура.Выбрать();
    пока Выборка.Следующий() цикл
        если Выборка.ЭтоГруппа=Истина тогда
            назКнопки=Выборка.Наименование;
            НоваяКнопка = ЭлементыФормы.Добавить(Тип("Кнопка"), назКнопки);
            НоваяКнопка.Шрифт = Новый Шрифт("Arial", 12);
            НоваяКнопка.Заголовок = Сокрлп(ВЫборка.Наименование);
            НачалоЛево=НачалоЛево+Ширина+200;  //сначало прибавим ширину предыдущ. кнопки если она  есть
            ширина=0;
            ширина=СтрДлина(ВЫборка.Наименование);
            НоваяКнопка.ГоризонтальноеПоложение = ГоризонтальноеПоложение.Центр;
            НоваяКнопка.Верх        = НачалоВерх;
            НоваяКнопка.Лево           = НачалоЛево;
            НоваяКнопка.Ширина         = Ширина+160;  
            НоваяКнопка.Высота         = 120;
            НоваяКнопка.ЦветФонаКнопки         = Новый Цвет(204,255,204);
            НоваяКнопка.ЦветТекстаКнопки         = Новый Цвет(0,0,128);
            НоваяКнопка.ЦветРамки = Новый Цвет(0,0,128);
         
            НоваяКнопка.УстановитьДействие("Нажатие", Новый Действие("Тест_ОбработкаНажатие"));
         
        КонецЕсли;
    конецЦикла;
 
 
КонецПроцедуры

Процедура Тест_ОбработкаНажатие(Элемент) Экспорт
        //Здесь пишем, что должно происходить при нажатии на кнопку
КонецПроцедуры
Вопрос: Документ "Приходный кассовый ордер", кнопка "Печать"

Добрый вечер!
Есть документ "Приходный кассовый ордер". На форме документа располагается кнопка для печати, по нажатию которой открывается макет (табличный документ) "Приходный кассовый ордер". В открытой кнопке данного сформированного табличного документа есть кнопка "Печать". Как поймать нажатие на эту кнопку?
Спасибо!

Вложения:

  • Размер файла:
    24,7 КБ
    Просмотров:
    2
  • Размер файла:
    36,7 КБ
    Просмотров:
    2
Ответ:
В общих формах ищите форму для печати. Это типовой механизм печати.
--- Объединение сообщений, 13 фев 2017 в 16:28 ---
И для чего вам "ловить" эту кнопку ? Требуется изменить в печатной форме ? Если так - то курите ВнешниеПечатныеФормы.
Вопрос: Кнопка на форме

Добрый день, как из кнопки текстовой сделать только картинку? УТ 11.2
Кнопка автоматически добавилась - Ввод на основании документа, она ввиде большой текстовой, а мне нужно ее сделать маленькой графической. Если я сам добавляю кнопку, тогда знаю как это делается, а тут как не пойму. Рис. прилагаю.

Вложения:

  • Размер файла:
    90,2 КБ
    Просмотров:
    13
  • Размер файла:
    72,6 КБ
    Просмотров:
    13
  • Размер файла:
    278,4 КБ
    Просмотров:
    13
Ответ:
Она появилась сама после того, как я сделал этот документ основанием для ввода другого документа.
Когда я отжимаю на панели Автозаполнение - она исчезает. Может быть подскажите, как ее в ручную добавить, т.е. какой программный код вставить для кнопки которую я бы вручную добавил для ввода на основании?
Вопрос: Обработчик кнопки

Вечер добрый.

Мой проект в универе подходит к логическому концу, сделал я его вообще без кода и вот уперся в потребность "немного покодить", но в синтаксисе 1с у меня ума-палата, даже не знаю с какой стороны подойти.

Суть вот в чем:
Есть перечисления "статус": Подтвердить; Отклонить; Новое;
Есть Документ, по-умолчанию в нем установил статус "Новое".
На форме документа есть поле "статус", ссылающееся на перечисление, конечно же. И должно быть две кнопки: Принять и Отклонить.
По нажатию кнопки статус должен меняться на соответствующий (Подтверждено\Отклонено) и форма документа должна закрыться.

Может кто-нибудь подсобит какой-нибудь информацией или кусочком кода? В гугле копался, ничего полезного не нашел... может плохо копался.

Заранее, спасибо.
Ответ: Вообще, вы какой-то бред пытаетесь сделать. Еще и не рабочий...
Если это все в документе, то проведение оставить лучше кнопке "Провести" иначе пользователь с ума сойдет, что документ проводится по ста кнопкам.
Если не хочется делать выбор перечисления, сделайте переключатель или тумблер (для "Такси"). В зависимости от значения присваивайте значение перечисления.

Сообщение от ПьяныйАнгел
Это было бы слишком просто
Согласен, вы пытаетесь сделать слишком сложно и слишком неправильно.

ЗЫ. Попросите одногруппника мозговать получше.

Код 1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
&НаКлиенте
Процедура Команда1()
    Вернули=ПодтвердитьНаСервере(); 
    //ЭтаФорма.Прочитать(); 
    ОповеститьОбИзменении(вернули); // какие динамические списки вы хотите оповестить?
    ЭтаФорма.Закрыть();
    //надо вызвать обновление или закрытие
    КонецПроцедуры
 
//&НаСервере
&НаСервереБезКонтекста 
Процедура ПодтвердитьНаСервере()
    // круто, а если это новый документ, какую ссылку хотите получить?
    // и вообще, из объекта получать ссылку, чтобы получить объект - сильно!
    Х= Объект.Ссылка.ПолучитьОбъект(); 
    Х.Статус = Перечисления.Статусы.Подтверждено;
    Х.Записать(РежимЗаписиДокумента.Проведение);
    //Записать(РежимЗаписиДокумента.Проведение);    
    //СтрокаДействийФормы = "Записать";  
     Возврат Х.Ссылка; // процедура не умеет возвращать значения, о чем вам система и пишет. Функция умеет
    КонецПроцедуры
Вопрос: Кнопка "ПЕЧАТЬ", управляемые формы

Добрый день, на управляемых формах есть кнопка печать, кнопка находится в командной панели документа, при нажатии на эту кнопку появляется список доступных печатных форм, подскажите где может формироваться этот список? На всякий случай, конфигурация Медицина. Больничная аптека, редакция 1.1 (1.1.8.1) , может кто сталкивался
Ответ: Добился такого результата, что на удаленном компьютере, на сервере(и в файловом и в клиент-серверном варианте), у пользователя с ограниченными правами, при нажатии кнопки печать выходит не весь список доступных печатных форм(выводятся только типовые). Скопировал базу к себе на компьютер развернул в файловом варианте, проверил, все печатные формы, типовые и не типовые у пользователя есть. С чем это может быть связано?