Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: Связь значений свойств объектов с регистратором рс. Работники

Нужно связать таблицу работники упр.учет с значениями свойств объектов, так,чтобы значение свойства <> 0 или пустое
Ответ: таблица - это простая таблица значений?
Вопрос: КД. Ошибка получения значения свойства объекта (по имени свойства источника)

Добрый день гуру 1С.
Прошу помощи в конвертации данных 1С.
Потребовалось перенести значение реквизита РКО (СубконтоКт2) из базы источника(Бухгалтерия предприятия, редакция 1.6) в дополнительный реквизит (Склады) базы приемника в (Бухгалтерия предприятия, редакция 1.6).

Запихнул вот такой код


Если Источник.ВидОперации = Перечисления.ВидыОперацийРКО.ИнкассацияДенежныхСредств Тогда
ВходящиеДанные = Новый Структура("Объект,Свойство,Значение");
ВходящиеДанные.Объект = Источник.Ссылка;
ВходящиеДанные.Свойство = "Склад";
ВходящиеДанные.Значение = Источник.СубконтоКт;
ВыгрузитьПоПравилу(,,ВходящиеДанные,,"ЗначенияСвойствОбъектов");
КонецЕсли;

в ОбработчикСобытий РКО После Выгрузки в Файл.

Но ничего не вышло. При выгрузки из базы источника возникает ошибка:


Ошибка получения значения свойства объекта (по имени свойства источника)
ПКО = ЗначенияСвойствОбъектов (Справочник: Значения свойств объектов)
ПКС = 1 (Владелец --> Владелец)
Объект = (Не определено)
СвойствоПриемника = Владелец (ПланВидовХарактеристикСсылка.СвойстваОбъектов)
ОписаниеОшибки = Получение элемента по индексу для значения не определено
ПозицияМодуля = Обработка.ОбменДаннымиXML.МодульОбъекта(8059)
КодСообщения = 13

Ошибка в обработчике события ПослеВыгрузки (свойства)
ПКО = РасходныйКассовыйОрдер (Документ: Расходный кассовый ордер)
ПКС = 59 (СубконтоКт2 -->)
Объект = Расходный кассовый ордер ЭКС00044293 от 26.10.2017 16:23:57 (Документ объект: Расходный кассовый ордер)
СвойствоПриемника = ()
КонвертируемоеЗначение = УПРАВЛЕНИЕ (Склады (места хранения))
Обработчик = ПослеВыгрузкиСвойства
ОписаниеОшибки = Ошибка получения значения свойства объекта (по имени свойства источника)
ПКО = ЗначенияСвойствОбъектов (Справочник: Значения свойств объектов)
ПКС = 1 (Владелец --> Владелец)
Объект = (Не определено)
СвойствоПриемника = Владелец (ПланВидовХарактеристикСсылка.СвойстваОбъектов)
ОписаниеОшибки = Получение элемента по индексу для значения не определено
ПозицияМодуля = Обработка.ОбменДаннымиXML.МодульОбъекта(8059)
КодСообщения = 13
ПозицияМодуля = Обработка.ОбменДаннымиXML.МодульОбъекта(1635)
КодСообщения = 57

Ошибка при выгрузке данных для узла плана обмена
ТипОбъекта = Документ объект: Расходный кассовый ордер
Объект = Расходный кассовый ордер ЭКС00044293 от 26.10.2017 16:23:57
ОписаниеОшибки = Ошибка в обработчике события ПослеВыгрузки (свойства)
ПКО = РасходныйКассовыйОрдер (Документ: Расходный кассовый ордер)
ПКС = 59 (СубконтоКт2 -->)
Объект = Расходный кассовый ордер ЭКС00044293 от 26.10.2017 16:23:57 (Документ объект: Расходный кассовый ордер)
СвойствоПриемника = ()
КонвертируемоеЗначение = УПРАВЛЕНИЕ (Склады (места хранения))
Обработчик = ПослеВыгрузкиСвойства
ОписаниеОшибки = Ошибка получения значения свойства объекта (по имени свойства источника)
ПКО = ЗначенияСвойствОбъектов (Справочник: Значения свойств объектов)
ПКС = 1 (Владелец --> Владелец)
Объект = (Не определено)
СвойствоПриемника = Владелец (ПланВидовХарактеристикСсылка.СвойстваОбъектов)
ОписаниеОшибки = Получение элемента по индексу для значения не определено
ПозицияМодуля = Обработка.ОбменДаннымиXML.МодульОбъекта(8059)
КодСообщения = 13
ПозицияМодуля = Обработка.ОбменДаннымиXML.МодульОбъекта(1635)
КодСообщения = 57
ПозицияМодуля = Обработка.ОбменДаннымиXML.МодульОбъекта(1635)
КодСообщения = 72
УзелПланаОбмена = ФИН_Иваново_New

Помогите пожалуйста.
Ответ:
А где ПКО "ЗначенияСвойствОбъектов"?
Вопрос: v7: Конвертация свойства НоменклатурныеГруппы справочника Номенклатуры (ТиС->БП 3)

Доброго времени суток!

Прошу помочь разобраться в конвертации свойства НомнклатурныеГруппы справочника Номенклатуры при передаче из ТиС -> БП 3.0.

Что сделано:
1. Создано правило (Пусто) - СправочникСсылка.НоменклатурныеГруппы
Источник - Приемник
(Пусто) - Наименование
(Пусто) - Код (ПриВыгрузке: Отказ = 1)

2. ПКС Номенклатуры добавлено:
Источник - Приемник
(Пусто) - НоменклатурнаяГруппа по правилу НоменклатурныеГруппы
Код:
Если Источник.ЭтоГруппа() = 1 Тогда
 Отказ = 1;    
Иначе
Если (Источник.ВидНоменклатуры = Перечисление.ВидыНоменклатуры.Услуга) 
 ИЛИ (Источник.ВидНоменклатуры = Перечисление.ВидыНоменклатуры.Работа) Тогда
 
 ИсходящиеДанные = СоздатьОбъект("СписокЗначений");
 ИсходящиеДанные.Установить("Наименование", "Услуга"); 

ИначеЕсли  Источник.ВидНоменклатуры = Перечисление.ВидыНоменклатуры.Прочее Тогда 
    
 ИсходящиеДанные = СоздатьОбъект("СписокЗначений");
 ИсходящиеДанные.Установить("Наименование", "Товар");    
 
КонецЕсли;
КонецЕсли;
Ответ: () А ларчик просто открывался. Установка данной галочки помогло. Спасибо!
Вопрос: Значения свойств объектов.

Всем доброго времени суток!

Подскажите пожалуйста, в РС "Значения свойств объектов" есть записи, а в одноимённом справочнике их нет по той причине, что раньше значения были строкой, а затем, для некоторых свойств их изменили на элементы справочника. Хочу написать обработку, которая будет искать элементы в справочнике, если находить, то подставлять в рс элемент, если нет, то заводить новый и подставлять его. Но хочу обходить свойства с типом, отличающимся от типа ЗначенияСвойствОбъектов. Что-то не пойму, как его определять? Получаю его в запросе:
	Запрос.Текст = "ВЫБРАТЬ
	               |	ЗначенияСвойствОбъектов.Свойство,
	               |	ЗначенияСвойствОбъектов.Значение,
	               |	ЗначенияСвойствОбъектов.Свойство.ТипЗначения
	               |ИЗ
	               |	РегистрСведений.ЗначенияСвойствОбъектов КАК ЗначенияСвойствОбъектов
	               |ГДЕ
	               |	ЗначенияСвойствОбъектов.Объект = &ном";

Но не понимаю, как его потом сравнить?
		Если Выборка.Свойство.ТипЗначения = Тип("СправочникСсылка.ЗначенияСвойствОбъектов") Тогда		
			...		
		КонецЕсли;

Почему-то не прокатывает. Подскажите, пожалуйста, что не делаю не так?

P.S. 8.2 УТ10.3
Ответ: Программист 1с,

Да, получила, правда на другом форуме. Но всё равно всем спасибо!
Вопрос: Отбор по значению свойств объекта в отчете на СКД

Здравствуйте,
необходимо реализовать возможность отбора по значению свойства объекта в отчете. Есть вот такой запрос:
Код:
ВЫБРАТЬ
ГруппировкаПоНоменклатурнымГруппам.Филиал КАК Филиал,
ГруппировкаПоНоменклатурнымГруппам.КоличествоФакт КАК КоличествоФакт,
0 КАК КоличествоПлан
ИЗ
(ВЫБРАТЬ
ВЫРАЗИТЬ(ЗначенияСвойствОбъектов.Значение КАК Справочник.ЗначенияСвойствОбъектов) КАК Филиал,
ГруппировкаПоНоменклатуре.КоличествоФакт КАК КоличествоФакт
ИЗ
(ВЫБРАТЬ
ПродажиОбороты.ДоговорКонтрагента КАК ДоговорКонтрагента,
ПродажиОбороты.КоличествоОборот КАК КоличествоФакт
ИЗ
РегистрНакопления.Продажи.Обороты(, , Авто, ) КАК ПродажиОбороты

ОБЪЕДИНИТЬ ВСЕ

ВЫБРАТЬ
ПродажиСебестоимостьОбороты.ДоговорКонтрагента,
0
ИЗ
РегистрНакопления.ПродажиСебестоимость.Обороты(, , Авто, ) КАК ПродажиСебестоимостьОбороты) КАК ГруппировкаПоНоменклатуре
ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ЗначенияСвойствОбъектов КАК ЗначенияСвойствОбъектов
ПО ГруппировкаПоНоменклатуре.ДоговорКонтрагента = ЗначенияСвойствОбъектов.Объект
ГДЕ
ЗначенияСвойствОбъектов.Свойство.Код = "000000004") КАК ГруппировкаПоНоменклатурнымГруппам
ОБЪЕДИНИТЬ ВСЕ
ВЫБРАТЬ
ПланыПродажОбороты.Филиал,
0,
ПланыПродажОбороты.КоличествоОборот
ИЗ
РегистрНакопления.ПланыПродаж.Обороты(, , Авто, ) КАК ПланыПродажОбороты
результат работы данного запроса на картинке:

Делаю отбор по Филиал, результат на следующей картинке

Результат правильный. Но проблема с отбором начинается, когда я этот же запрос помещаю во вложенный запрос. Вот так:
Код:
ВЫБРАТЬ
ВложенныйЗапрос.Филиал,
ВложенныйЗапрос.КоличествоФакт,
ВложенныйЗапрос.КоличествоПлан
ИЗ
(ВЫБРАТЬ
ГруппировкаПоНоменклатурнымГруппам.Филиал КАК Филиал,
ГруппировкаПоНоменклатурнымГруппам.КоличествоФакт КАК КоличествоФакт,
0 КАК КоличествоПлан
ИЗ
(ВЫБРАТЬ
ВЫРАЗИТЬ(ЗначенияСвойствОбъектов.Значение КАК Справочник.ЗначенияСвойствОбъектов) КАК Филиал,
ГруппировкаПоНоменклатуре.КоличествоФакт КАК КоличествоФакт
ИЗ
(ВЫБРАТЬ
ПродажиОбороты.ДоговорКонтрагента КАК ДоговорКонтрагента,
ПродажиОбороты.КоличествоОборот КАК КоличествоФакт
ИЗ
РегистрНакопления.Продажи.Обороты(, , Авто, ) КАК ПродажиОбороты

ОБЪЕДИНИТЬ ВСЕ

ВЫБРАТЬ
ПродажиСебестоимостьОбороты.ДоговорКонтрагента,
0
ИЗ
РегистрНакопления.ПродажиСебестоимость.Обороты(, , Авто, ) КАК ПродажиСебестоимостьОбороты) КАК ГруппировкаПоНоменклатуре
ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ЗначенияСвойствОбъектов КАК ЗначенияСвойствОбъектов
ПО ГруппировкаПоНоменклатуре.ДоговорКонтрагента = ЗначенияСвойствОбъектов.Объект
ГДЕ
ЗначенияСвойствОбъектов.Свойство.Код = "000000004") КАК ГруппировкаПоНоменклатурнымГруппам

ОБЪЕДИНИТЬ ВСЕ

ВЫБРАТЬ
ПланыПродажОбороты.Филиал,
0,
ПланыПродажОбороты.КоличествоОборот
ИЗ
РегистрНакопления.ПланыПродаж.Обороты(, , Авто, ) КАК ПланыПродажОбороты) КАК ВложенныйЗапрос
Результат работы этого запроса без отборов аналогичен результату с первой картинки, но если сделать отбор по Филиал, результат следующий:

Отбор не работает.

Этот запрос сильно упростил, чтоб разместить здесь. И он является частью сложного составного запроса, который пришлось разобрать, чтоб понять в каком месте глючит.
Типизировать пробовал на всех уровнях не помогает. Как сделать, чтобы отбор работал правильно?

Вложения:

  • Размер файла:
    25,4 КБ
    Просмотров:
    25
  • Размер файла:
    77 КБ
    Просмотров:
    33
  • Размер файла:
    82 КБ
    Просмотров:
    29
Ответ:
Огромное спасибо! Очень помогло)
Вопрос: Выгрузка Номенклатуры в Эксель с иерархией УТ 11.1

Добрый день. Подскажите пожалуйста
Есть Справочник номенклатура его нужно выгрузить в ексель, стандартная обработка выгрузка загрузка не подходит.
есть такой код:
&НаКлиенте
Процедура тест123(Кнопка);
Объект.ДанныеВыгрузки.Очистить();
ВыбратьНоменклатуру();
КонецПроцедуры

&НаСервере
Процедура ВыбратьНоменклатуру ();
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ ПЕРВЫЕ 500
| Номенклатура.Ссылка,
| Номенклатура.ВерсияДанных,
| Номенклатура.ПометкаУдаления,
| Номенклатура.Родитель,
| Номенклатура.ЭтоГруппа,
| Номенклатура.Код,
| Номенклатура.Наименование,
| Номенклатура.АлкогольнаяПродукция,
| Номенклатура.Артикул,
| Номенклатура.ВариантОформленияПродажи,
| Номенклатура.Вес,
| Номенклатура.ВестиУчетПоГТД,
| Номенклатура.ВестиУчетСертификатовНоменклатуры,
| Номенклатура.ВидАлкогольнойПродукции,
| Номенклатура.ВидНоменклатуры,
| Номенклатура.ГруппаДоступа,
| Номенклатура.ГруппаФинансовогоУчета,
| Номенклатура.ЕдиницаИзмерения,
| Номенклатура.ЕдиницаИзмеренияСрокаГодности,
| Номенклатура.ЕстьТоварыДругогоКачества,
| Номенклатура.ИмпортнаяАлкогольнаяПродукция,
| Номенклатура.ИспользованиеХарактеристик,
| Номенклатура.ИспользоватьИндивидуальныйШаблонЦенника,
| Номенклатура.ИспользоватьИндивидуальныйШаблонЭтикетки,
| Номенклатура.ИспользоватьУпаковки,
| Номенклатура.Качество,
| Номенклатура.КодДляПоиска,
| Номенклатура.Марка,
| Номенклатура.НаборУпаковок,
| Номенклатура.НаименованиеПолное,
| Номенклатура.НоменклатураМногооборотнаяТара,
| Номенклатура.Объем,
| Номенклатура.ОбъемДАЛ,
| Номенклатура.Описание,
| Номенклатура.ПодакцизныйТовар,
| Номенклатура.ПоставляетсяВМногооборотнойТаре,
| Номенклатура.Производитель,
| Номенклатура.ПроизводительИмпортерДляДекларацийАлко,
| Номенклатура.СкладскаяГруппа,
| Номенклатура.СрокГодности,
| Номенклатура.СтавкаНДС,
| Номенклатура.ТипНоменклатуры,
| Номенклатура.ТоварнаяКатегория,
| Номенклатура.ФайлКартинки,
| Номенклатура.ФайлОписанияДляСайта,
| Номенклатура.ХарактеристикаМногооборотнаяТара,
| Номенклатура.ЦеноваяГруппа,
| Номенклатура.ШаблонЦенника,
| Номенклатура.ЕдиницаДляОтчетов,
| Номенклатура.КоэффициентЕдиницыДляОтчетов,
| Номенклатура.ШаблонЭтикетки,
| Номенклатура.СезоннаяГруппа,
| Номенклатура.РошеЛиния,
| Номенклатура.РошеОбозначение,
| Номенклатура.РошеГруппа,
| Номенклатура.ДополнительныеРеквизиты.(
| Ссылка,
| НомерСтроки,
| Свойство,
| Значение,
| ТекстоваяСтрока
| ),
| Номенклатура.Предопределенный,
| Номенклатура.ИмяПредопределенныхДанных
|ИЗ
| Справочник.Номенклатура КАК Номенклатура";


РезультатЗапроса = Запрос.Выполнить();
Объект.ДанныеВыгрузки.Загрузить(РезультатЗапроса.Выгрузить());
Выводит на экран список номенклатуры и все реквизиты
Далее подключаю Ексель
&НаКлиенте
Процедура ВыгрузитьНоменклатуруВExcel(Кнопка)

Попытка
Попытка
// Загрузка объекта Microsoft Excel
Состояние("Выгрузка данных из 1С в Microsoft Excel...");
ExcelПриложение = Новый COMОбъект("Excel.Application");
Исключение
Сообщить("Ошибка при запуске Microsoft Excel."
+ Символы.ПС + ОписаниеОшибки(), СтатусСообщения.Внимание);
Возврат;
КонецПопытки;

// Создадим книгу, по умолчанию в ней уже есть листы

Книга = ExcelПриложение.WorkBooks.Add();

// Используем первый лист книги Excel

Лист = Книга.WorkSheets(1);

// Задание рабочему листу имени ИмяЛиста

Лист.Name = "Список номенклатуры";



// Сохраним созданную книгу в файл xls

Книга.SaveAs("d:\1c\СправочникНоменклатура.xls");




Попытка
ExcelПриложение.Quit();

Как выгрузить все это в Эексель файлик?
Ответ: сделай как 1 пишет, и не мучай(ся): 1С, форум и себя..
Вопрос: Ошибка при получении атрибута значения контекста (Номенклатура)

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
Процедура УдалениеСтрокНажатие(Элемент)
    
    Запрос = Новый Запрос;  
    Запрос.УстановитьПараметр("Номенклатура",Номенклатура);
    Запрос.Текст =
    "ВЫБРАТЬ
    |   РеализацияТоваровУслугТовары.Ссылка
    |ИЗ
    |   Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслугТовары
    |ГДЕ
    |   РеализацияТоваровУслугТовары.Номенклатура = &Номенклатура";
    
    Выборка = Запрос.Выполнить();
    МассивТоваров=новый Массив; 
    Значения= Выборка.Выбрать();
    Пока Значения.Следующий() Цикл
        ссылка = Значения.ссылка ;
        ДокументОбъект = ссылка.ПолучитьОбъект();
        i=0;
        Для каждого ТекСтрока Из ДокументОбъект.Товары Цикл
            Если ТекСтрока.Номенклатура = Номенклатура Тогда
                МассивТоваров.Добавить(ТекСтрока);
                Сообщить("Значение: "+ ТекСтрока.Номенклатура +" подходит!"); 
                i=i+1
            Иначе
                Сообщить("Значение: "+ТекСтрока.Номенклатура+ " не подходит!");
            КонецЕсли
        КонецЦикла;
        Для  каждого ТекСтрокаМас Из    МассивТоваров Цикл
            Если Вопрос("Удалить строку со значением  " + ТекСтрокаМас.Номенклатура + "?" ,РежимДиалогаВопрос.ДаНет,15)=КодВозвратаДиалога.Да Тогда
                
                
                ДокументОбъект.Товары.Удалить(ТекСтрокаМас);
                
                
                Сообщить("Строка удалена!");
            Иначе
                Сообщить("Отмена удаления!");
            КонецЕсли;
        КонецЦикла;
    КонецЦикла;
    
    
КонецПроцедуры


Сначала выполняется удалет строки из первого документа потом на втором документе вылетает ошибка,что это значит помогите плиииз ничего не пойму
Ответ: Konstantan, МассивТоваров не очищается перед обработкой следующего документа.
Вопрос: Обновление отображения свойств в карточке номенклатуры

Добрый день в карточке номенклатуры добавил кнопку, которая пробегает, так же добавленную, табличную часть и создает необходимые записи в свойства для дальнейшей выгрузки на сайт. проблема в том, что после того, как процедура отрабатывает на форме элемента не появляется изменений, приходится перезаходить в форму, чтобы увидеть изменения. Можете подсказать, как обновить на форме отображение свойств?
Ответ: это зачем:
1. план = ПланыВидовХарактеристик.СвойстваОбъектов.НайтиПоНаименованию("Совместимости").ПолучитьОбъект();

2. Запись.Прочитать();

+ в попытку можно и только записать.
смотри как у тебя обновляются (заполняется ТП свойств) свойства в ПриОткрытии
Вопрос: Получить и проверить значение с формы документа в вычисляемом поле

Здравствуйте. Обыскал многие форумы, не могу найти ответ. Необходимо проверить значение табличной части формы документы на заполненность, если в значении пусто, удалить всю строку табличной части документа. Проблема в том, что поле - вычисляемое, оно существует только на форме документа, в нем суммируется значения из других реквизитов. Как можно получить данные с формы документа, и после удаления пустых строк, записать их обратно. Изначально получаю документ с помощью выборки.
На эту строку ругается, говорит, что нельзя выполнять интерактивные операции:

ДокОбъект = Ведомость.ПолучитьФорму("Документ.ВедомостьНаВыплатуЗарплатыВБанк.Форма.ФормаДокумента");

Да, я нуб, но мне очень нужна помощь!
Ответ:
Сообщение от Andreytyr
поле - вычисляемое, оно существует только на форме документа, в нем суммируется значения из других реквизитов.
Повторить суммирование в своем алгоритме и проверить что получилось. Не удовлетворяет результат - удаляй

Добавлено через 21 секунду
Сообщение от Andreytyr
что нельзя выполнять интерактивные операции:
На сервере нельзя получить форму, не нужна она там!
Вопрос: Изменить значение реквизитов ТЧ документа по событию проведения другого документа

Здравствуйте.В собственной конфе 1С 8.3 есть документ "ОбъектныйГрафик" с ТЧ "Задания". Также есть документ "ИнформационныйЛистокОвыдачеЗадания" с реквизитами: График - ссылка на график.; ВыдающийОтдел, ПринимающийОтдел - СправочникСсылка.Подразделения;Задание -справочникссылка.задания;СрокФактический - Дата....В ТЧ "Задания" документа "ОбъектныйГрафик" те же реквизиты. Мне нужно сделать следующее: при выполнении команды "ПринятьЗадание" формы документа "ИнформационныйЛистокОвыдачеЗадания" найти в ТЧ графика задание, указанное в документе для выбранных выдающего и принимающего отдела и заполнить реквизиты найденной строки ТЧ графика реквизитами документа "ИнформационныйЛистокОвыдачеЗадания", затем конечно записать изменения в графике. Для этого сделал следующее в форме документа "ИнформационныйЛистокОвыдачеЗадания":
Код:
&НаСервере
Процедура ПриЗаписиНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
    // Вставить содержимое обработчика.
    ЗапросНомераЗадания=Новый Запрос;    //получение номера строки ТЧ графика с нужным заданием
    ЗапросНомераЗадания.Текст="ВЫБРАТЬ
                              |    ОбъектныйГрафикЗадания.НомерСтроки КАК НомерЗадания
                              |ИЗ
                              |    Документ.ОбъектныйГрафик.Задания КАК ОбъектныйГрафикЗадания
                              |        ЛЕВОЕ СОЕДИНЕНИЕ Документ.ОбъектныйГрафик КАК ОбъектныйГрафик
                              |        ПО ОбъектныйГрафикЗадания.Ссылка = ОбъектныйГрафик.Ссылка
                              |ГДЕ
                              |    ОбъектныйГрафик.Ссылка = &График
                              |    И ОбъектныйГрафикЗадания.ВыдающийОтдел.Ссылка = &ВыдающийОтдел
                              |    И ОбъектныйГрафикЗадания.Задание.Ссылка = &Задание
                              |    И ОбъектныйГрафикЗадания.ПринимающийОтдел.Ссылка = &ПринимающийОтдел";
    ЗапросНомераЗадания.УстановитьПараметр("График",ТекущийОбъект.ОбъектныйГрафик.Ссылка);
     ЗапросНомераЗадания.УстановитьПараметр("ВыдающийОтдел",ТекущийОбъект.ГруппаВыдающаяЗадание.Ссылка);
      ЗапросНомераЗадания.УстановитьПараметр("Задание",ТекущийОбъект.Задание.Ссылка);
       ЗапросНомераЗадания.УстановитьПараметр("ПринимающийОтдел",ТекущийОбъект.ГруппаПолучающаяЗадание.Ссылка);
    Результат=ЗапросНомераЗадания.Выполнить().Выбрать();
    Пока Результат.Следующий() Цикл
    НомерЗадания=Результат.НомерЗадания;   
КонецЦикла;   
График=Документы.ОбъектныйГрафик.НайтиПоНомеру(ТекущийОбъект.ОбъектныйГрафик.Номер).ПолучитьОбъект();
СтрокаТЧ = График.Задания[НомерЗадания - 1];
СтрокаТЧ.ХарактеристикаЗадания=ТекущийОбъект.ХарактеристикаПолнотыЗаданияПринимающейГруппы;
Если ТекущийОбъект.Статус=Перечисления.СтатусФормыВыдачиЗадания.Утверждена Тогда
СтрокаТЧ.СтепеньВыполнения=ТекущийОбъект.ОценкаПолнотыЗаданияПринимающейГруппы;
СтрокаТЧ.ДатаВыдачиФакт=ТекущийОбъект.СрокФактический;
СтрокаТЧ.СостояниеЗадания=Перечисления.СостояниеЗадания.Выдано;
СтрокаТЧ.Примечание=ТекущийОбъект.Ссылка;
КонецЕсли;
График.Записать();
Если ТекущийОбъект.ГруппаВыдающаяЗадание=Параметрысеанса.Сотрудник.Подразделение И ЗаполненыПоляВыдающейСтороны()=ложь и Не ЗначениеЗаполнено(Объект.ФайлЗадания) тогда
Сообщить("Проверьте заполнение оценки и характеристики полноты задания,комментария выдающей стороны и указание файла задания");
Отказ=Истина;
КонецЕсли;
Если ТекущийОбъект.ГруппаПолучающаяЗадание=Параметрысеанса.Сотрудник.Подразделение И ЗаполненыПоляПринимающейСтороны()=ложь тогда
Сообщить("Проверьте заполнение оценки и характеристики полноты задания и комментария принимающей стороны");
Отказ=Истина;
КонецЕсли;
КонецПроцедуры

команда "ПринятьЗадание":
Код:
&НаСервере
Процедура ПринятьЗаданиеНаСервере()
    // Вставить содержимое обработчика.
    Формазадания=Объект.ссылка.ПолучитьОбъект();
    Формазадания.ОценкаПолнотыЗаданияПринимающейГруппы=100;
    Формазадания.ХарактеристикаПолнотыЗаданияПринимающейГруппы=Перечисления.ХарактеристикаПолнотыЗадания.ВыданоВПолномОбъеме;
Формазадания.СрокФактический=ТекущаяДата();   
//Формазадания.ГлавныйСпециалистПринимающейГруппы=Параметрысеанса.Сотрудник;
    Формазадания.Статус=Перечисления.СтатусФормыВыдачиЗадания.Утверждена;
//ПриЗаписиНаСервере(Ложь,Формазадания,);
ФормаЗадания.Записать(РежимЗаписиДокумента.Проведение,РежимПроведенияДокумента.Неоперативный);
ОтправитьСообщениеОПринятииЗадания();
КонецПроцедуры


&НаКлиенте
Процедура ПринятьЗадание(Команда)
    ПринятьЗаданиеНаСервере();
    ЭтаФорма.Закрыть();
КонецПроцедуры
Если пользователь выполняет команду "ПринятьЗадание", система ругается: Данные были изменены.Сохранить изменения?(да/нет). Если нажимаешь "Да", следующее ругательство:"Данные были изменены или удалены другим пользователем." Что не так? как правильно сделать?
Ответ:
Ну я прочитал это всё.. и зацеплюсь за последнюю фразу "Как правильно сделать?"

А правильно сделать регистр накопления Остатков..

ОбъектныйГрафик будет в этот регистр делать движения с заданиями в приход.. это будут не разобранные задания.

А документ ИнформационныйЛистокОвыдачеЗадания будет делать в этот регистр движение расход.

1) Вы всегда сможете сделать срез по Заданиям которые ещё не приняты в исполнение
2) Вы можете построить отчет по Заданиям, документам их инициализирующим (ОбъектныйГрафик) и по документам которыми они были приняты .

А вы планируете в каждый документ ОбъектныГрафик заходить и смотреть ТЧ Задания и видеть принята задача или нет. А ещё хуже может и отчет по документам написать.