Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: v7: БухгалтерскиеИтоги как получить сумму документа ?

Из 8.2 подключаюсь к 7.7, ИтогиБухгалтерии = COMОбъект.

ИтогиБухгалтерии.ВыбратьПериоды();
Пока ИтогиБухгалтерии.ПолучитьПериод()=1 Цикл
Окр(ИтогиБухгалтерии.ДО(),2)
КонецЦикла;
Всё бы нечего, но мне нужно ещё сумма закупа, а она хранится в ТЗ документа, как достать ?
Не работать с БухИт, а просто перебирать документы ? Но так дольше.
Ответ: ()

1. Я так понимаю что периодика по "Операциям".
Док=ИтогиБухгалтерии.Операция.Документ;;
//Если в конфигурации по той колонке нет галки РасчитыватьИтог. То нужна строчка

//Док.ВыбратьСтроки();
//Если галка Итоги стоит то можно сразу

Док.Итог("СуммаЗакупа");


2. Если периодика не по операциям, то двумя путями
2.1 Перебирать документы + БухИтоги
2.2 Запросом к операциям. Тогда бухитоги не использовать
Вопрос: v7: Как получить текущий документ из Бух итогов?

Не работал с БИ 100 лет, в регистрах можно выбрать движение и текущий документ, а как тоже сделать с БИ ?

        БИ=СоздатьОбъект("БухгалтерскиеИтоги");
        БИ.ИспользоватьСубконто("Контрагенты");
        БИ.ВыполнитьЗапрос(ДатаНач,ДатаКон, СчетПоКоду("111.111"));
        БИ.ВыбратьСчета();
        Пока БИ.ПолучитьСчет()=1 Цикл
            // выводим итоги по счету

             БИ.ВыбратьСубконто(1);
             Пока БИ.ПолучитьСубконто()=1 Цикл
    
//*** как получить текущий документ и сумму движения по нему ?

                                  
             КонецЦикла;
        КонецЦикла;
Ответ: +3 Будет доступ к операции документа, а из неё вытянешь ссылку на документ. Аналогично с периодичностью Проводка.
Вопрос: Получить движения документа не проводя его

Здравствуйте, подскажите пожалуйста как получить движения документа по регистрам, как если бы он был проведен, но не проводить сам документ. Допустим при нажатии на кнопку печати.
Ответ:
Начать транзакцию
Провести документ
Сделать что нужно с движениями, они в базе
Отменить транзакцию

все вернется как было. но что-то делать надо быстро, чтобы не держать блокировки
Вопрос: Как получить сумму по дебету из периода

Добрый день. "Опер.Сумма" выводит сумму оборота по дебету и кредиту. Подскажите пожалуйста, как получить сумму оборота ТОЛЬКО по дебету? Код прилагаю ниже.


1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
БИ.ВыбратьПериоды(1,,,);    
ТЗДолг.УдалитьСтроки();                                                                                                                  
                Пока БИ.ПолучитьПериод(,) = 1 Цикл
                    Опер = БИ.Операция;                //проверяем, чтобы из периода выбирались только наши счета    Выбираем счета по которым есть движения. т.е. не с 62 на 62, а с 62 например на 51
                    Если ((Опер.Дебет.Счет = Сч58_3) и (Опер.Кредит.Счет = Сч58_3)) ИЛИ ((Опер.Дебет.Счет = Сч60) и (Опер.Кредит.Счет = Сч60))
                        ИЛИ ((Опер.Дебет.Счет = Сч62) и (Опер.Кредит.Счет = Сч62)) ИЛИ ((Опер.Дебет.Счет = Сч66) и (Опер.Кредит.Счет = Сч66)) 
                        ИЛИ ((Опер.Дебет.Счет = Сч67) и (Опер.Кредит.Счет = Сч67)) Тогда
                        Продолжить;   //Передача управление в начало цикла
                    КонецЕсли;
    
                    
                        ТЗДолг.НоваяСтрока();
                        ТЗДолг.Дата = Опер.ДатаОперации;    
                    
                        ТЗДолг.Оборот = Опер.Сумма;
                    
                        ТЗДолг.Сумма = БИ.СКД(); 
                        ТЗДолг.Субконто1 = БИ.Субконто(1);  
                        ТЗДолг.Субконто2 = БИ.Субконто(2);
                        ТЗДолг.Документ = Опер.Документ.Вид() + " " + Опер.Документ.НомерДок + " " + Опер.Документ.ДатаДок;    
                        ТЗДолг.Выплатили = Выплатили;    
                                
                КонецЦикла;
Добавлено через 1 час 32 минуты
Пробую Опер.ДО() . Выдает ошибку "Поле агрегатного объекта не обнаружено (ДО)"

Добавлено через 19 минут
Пробовал "Опер.Дебет.Сумма", "Опер.Субконто(2).ДО()" ты же ошибка. Народ ну подскажите кто знает
Ответ: Например так
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
    Ит.ВключатьСубСчета(1,1);
    Ит.ВыполнитьЗапрос(НачДата,КонДата,"90.1,90.5,90.3","50.3,62.3,68.2",,2,"Месяц");
    Ит.ВыбратьПериоды();
    while Ит.ПолучитьПериод()=1 do
        Ит.ВыбратьСчета();
        while Ит.ПолучитьСчет()=1 do
            Счет=Ит.Счет;
            Тбл.NewLine();
            Тбл.Пер=ПериодСтр(Ит.НачДата,Ит.КонДата);
            Тбл.Дат=Ит.НачДата;
            Тбл.Статья="Реализация";   
            Тбл.Гр="1. Реализация";   
            Тбл.ПВ=1;
            Тбл.Сум=Ит.КО()-Ит.ДО();
        enddo;
    enddo;
Вопрос: [РЕШЕНО]Сумма документа БП 3.0

Добрый день. Подскажите пожалуйста как поместить сумму документа в сумму справочника, с последующим добавлением? То есть если по счету 3-4 документа, то контрольная сумма должна суммироваться.
Ответ:
На практике и с тем и с тем проблемы(
Вопрос: v7: ЗиК. Получить сумму по ВР за период

Забывается...
напомните, какой функцией получить сумму по периоду неполного месяца
Например, ВР "оплата по табелю",получить сумму за период с 15.07.17 по 29.07.17.
Ответ: Догадку проверить.
С большим количеством сотрудников уже давно ушли с 7.7
Осталиьс только небольшшие контрки
Вопрос: v7: Получить последний документ по контрагенту

Как в самописной конфе получить последний документ по контрагенту?
Ответ: () я как 8ку запускают - скучать начинаю, медленно все...
Вопрос: Управляемые формы, получить реквизит документа в модуле формы

Добрый день!
Вопрос такой - как находясь в модуле произвольной формы, получить реквизит документа этой формы? Т.е как прописать сюда

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)    КонтрЗадачи.Параметры.УстановитьЗначениеПараметра("Контр",СсылкаКонтр);
КонецПроцедуры

вместо "СсылкаКонтр" некий прямой путь?(что-то вроде Объект.реквизиты и т.д.) Сейчас это параметр формы, который передается на нее при ее вызове. Реквизит "Объект" у формы отсутсвует.
Ответ: () тут важна не просто форма, а объект или хотя бы ссылка на объект, выбранного типа. Толку по доступа к реквизиту на форме, если у этого реквизита нет никакой связи с объектом?
Вопрос: УТ11. Программное создание документа ПоступлениеТоваровУслуг

Добрый день! С УТ11 дел раньше практически не имел. Из внешнего файла формирую документы ПоступлениеТоваровУслуг. Все получается кроме одного: в списке документов не отображается сумма документа. Реквизиты СуммаДокумента, СуммаВзаиморасчетов - заполняю. Если открыть форму и перевыбрать что-либо, вызывается пересчет документа (в параметре передается форма документа) и сумма отображается. Не могу сообразить, что я не заполнил. Искал функцию обработки табличных частей, не нашел. Помогите разобраться, заранее спасибо.
Ответ:
Gennadiy83
Добрый день! С УТ11 дел раньше практически не имел. Из внешнего файла формирую документы ПоступлениеТоваровУслуг. Все получается кроме одного: в списке документов не отображается сумма документа. Реквизиты СуммаДокумента, СуммаВзаиморасчетов - заполняю. Если открыть форму и перевыбрать что-либо, вызывается пересчет документа (в параметре передается форма документа) и сумма отображается. Не могу сообразить, что я не заполнил. Искал функцию обработки табличных частей, не нашел. Помогите разобраться, заранее спасибо.


табличная часть -> сумма
Вопрос: Иизменение данных табличной части по нескольким документам через запрос

Приветствую, Форумчане!

УТ 10.3, 1с8.2, обычное

Имеются несколько документов "Реализация Товаров и Услуг". В документе есть кнопка "Изменить", которая может изменить, например, сумму документа (типа скидка), распределив цены по всем номенклатурам.

Имеется ли возможность изменить цену номенклатуры по нескольким документам?

У меня несколько "Реализаций" собраны в одном нетиповом документе по определенному признаку. На основании этих Реализаций формируется итоговый счет на оплату. Нужно организовать "Скидку" на все реализации...

Пытаюсь через запрос внести изменения:

Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
                   |    РеализацияТоваровУслугТовары.Ссылка.ПроектПредприятия,
                   |    РеализацияТоваровУслугТовары.Номенклатура,
                   |    РеализацияТоваровУслугТовары.СуммаДок
                   |ИЗ
                   |    Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслугТовары
                   |ГДЕ
                   |    РеализацияТоваровУслугТовары.Ссылка.ПроектПредприятия = &ПроектПредприятия";

    Запрос.Параметры.Вставить("ПроектПредприятия", Ссылка);
    Выборка = Запрос.Выполнить().Выбрать();
    
    
     Пока Выборка.Следующий() Цикл
         
         Коэфф = Выборка.Сумма / СуммаЗаказов;
         Процент = Скидка * Коэфф;
         
         Выборка.СуммаДок = Выборка.Сумма - Процент; 
         
     
     КонецЦикла;


Но пишет "недоступен для записи". Как можно через запрос изменить данные табличных частей?
Ответ: Ukraina, сумма находится в табличной части документа, а не в самом документе. еще раз пишу, запросом получите только ссылку на объект, а суммы считайте в коде обходом табличной части вашего объекта.