Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: Нужна формула суммирования с условиями

Здравствуйте.Нужна формула суммирования с условиями,макрос не подходит.Есть в строке диапазон из 19 ячеек,например A1-S1.Ячейки могут принимать значения 1 или 0 .Задача в ячейке U1 нужна формула для суммирования значений 1 в ячейках начиная с ячейки A1 ,но с некоторыми условиями.если в ячейке А1 0 то сумма 0,если в ячейке А1 значение 1 а в следующей ячейке B1 0 и значит сумма 0.И ещё правило чтобы если после группы единичек в ячейках начиная от А1 будет 0 то суммируются только ячейки от А1 и до ячейки с 0 после любой ячейки со значением 0 учёт в диапазоне не ведётся,суммируются только группы ячеек со значением 1 начиная с А1 и до первой ячейки со значением 0...В файле с примерами,итоговые правильные результаты.
Ответ: Или так. Ячейка столбца Т пустая, этим можно воспользоваться
Код
=ПОИСКПОЗ(;-B1:T1;)*A1*B1
Получилась формула массива, ввод которых делается тремя клавишами Ctrl+Shift+Enter
Или не массивный вариант
Код
=ИНДЕКС(ПОИСКПОЗ(;-B1:T1;)*A1*B1;)
Вопрос: Нумерологический квадрат Пифагора, нужны формулы

Нужны формулы для нумерологического квадрата Пифагора

Задача1: в ячейке необходимо: 2 умножить на число из другой ячейки от 1 до 31, при этом именно на первую цифру из этого числа. Например число 31, то необходимо 2х3=6, а если число 07, тогда 2х7=14 (то есть если 0, то мы его пропускаем и умножаем на вторую цифру).

Задача2: подсчитать сумму цифр из числа, например дано число 25, нужну формула 2+5=7

Задача3: Необходимо, чтобы из определенных ячеек (А1,A2,A3,B1,B2,B3,B4) в другую ячейку копировались нужные совпадающие цифры. В первую ячейку копировались все единицы, во вторую двойки и тд. Дано - А1=23, A2=13, A3=07, B1=14, B2=16, B3=27, B4=08 Нужно в С1=111, С2=22, С3=33, С4=4, С5="нет" (так как пятерок нет), С6=6, С7=77, С8=8, С9=нет
Ответ:
Сообщение от fantastic33
только 0, нужно было закавычить.
Что это значит?
Плохо, что к этой задаче не приложили файл с примерами. По файлу можно было бы понять в каком формате числа от 1 до 31.
Подозреваю, что у чисел пользовательский формат с типом 00. В этом формате одноразрядные числа: 1,2,...9 отображаются 01,02,...09, но при этом остаются числами.
Формула для первой задачи OLEGOFF и AlexM возвращают одинаковые значения, но вторая короче и может быть еще короче
Код
=2*ЛЕВБ(A1)
Формулы для второй задачи при таком же формате значений (пользовательский формат) возвращают неодинаковые результаты для чисел от 1 до 9. Например у OLEGOFF сумма чисел левой и правой цифры для 1 равна 2, для 2=4. В моей формуле возвращается 1 и 2 соответственно.
Что правильно решаете вы или ваш преподаватель.

Другие результаты для первой задачи, если формат чисел от 1 до 31 в текстовом формате. Для значений с 0 впереди обе формулы будут возвращать 0, что будет неверно.
Формулу OLEGOFF и AlexM можно исправить так
Код
=ЕСЛИ(--ЛЕВСИМВ(A1;1)=0;2*ПРАВСИМВ(A1;1);2*ЛЕВСИМВ(A1;1))
=2*ЛЕВБ(--A1)
Короткая формула универсальная, отработает правильно при любом формате чисел от 1 до 31
Вопрос: Формула с условием =СЕГОДНЯ()-5

Подскажите пожалуйста правильность записи формулы с СУМПРОИЗВ
Необзодимо в столбце "дата отгрузки" использовать формулу с условием =СЕГОДНЯ()-5
Так формула не работает , а нужно именно чтобы знак был только строго =

Если пишу в условии <=Сегодня()-5 то формула все считает.
вот так все считает правильно
Код
=СУММПРОИЗВ(( Таблица_owssvr11[Цех]="Мебельный")*( Таблица_owssvr11[Линия]="3")*( Таблица_owssvr11[ФИО кладовщика]="Иванов")*(Таблица_owssvr11[Дата отгрузки]>=СЕГОДНЯ()-5))
А нужно вот так :
Код
=СУММПРОИЗВ(( Таблица_owssvr11[Цех]="Мебельный")*( Таблица_owssvr11[Линия]="3")*( Таблица_owssvr11[ФИО кладовщика]="Иванов")*(Таблица_owssvr11[Дата отгрузки]=СЕГОДНЯ()-5))
Но в последнем варианте не работает
Ответ: pashulka, спасибо все работает верно.
Вопрос: Логическая формула с условиями

Привет ребята! Слушайте, кто шарит в формулах Excel? я ваще дерево полное, но так получилось, что в итоге на меня упал груз до завтра срочно сделать гребаный отчет, что бы обязательно был на формулах!
В общем есть такой файлик
Кликните здесь для просмотра всего текста

в нем есть вкладка Приложение 17 и рудные зоны ж1 и Висячая.
Нужно что бы во второй вкладке заполнялась длина и метрограмма для соответсвующего пересечения рудной зоны. А еще нужно что бы бортовое содержание было
Формулы мне 0 выдают
Пытался так
Code
1
=СУММ(ЕСЛИ('приложение 17'!B6:B18='рудные зоны ж. №1 и Висячая'!A5;ЕСЛИ('приложение 17'!A6:A18="ж. № 1";'приложение 17'!F6:F18;ЧЕТ НЕ ТАК)))
и так
Code
1
=СУММЕСЛИМН('приложение 17'!F6:F834;'приложение 17'!B6:B834;'рудные зоны ж. №1 и Висячая'!A5;'приложение 17'!A6:A834;'рудные зоны ж. №1 и Висячая'!A6)
А на вба вщ хз как делать, сижу туплю..
Ответ: А не знаете как сделать, что бы при перетаскивании формулы, там +1 строка прибавлялась через 2 строки только
ну типо
есть три строки
я тяну формулу в низ
и в формуле к строкам+1 делается только через 2 ?
я думаю если это сделать то в принципе все будет работать как надо )

Добавлено через 5 часов 40 минут
все сделал)
Вопрос: Суммирование определенных чисел + вычитание с функцией Если

Здравствуйте!

Помогите решить задачу по нумерологии. Необходимо в ексэле автоматизировать 2 способа подсчета:

1 способ:
Дана - Дата рождения: 30.09.2016, каждое число расположено в своей ячейке, то есть 30;09;2016.
Необходима формула: 30+09=39 (число + месяц); (год) 2+0+1+6=9 Итого: 39+9=48 И, если итоговая сумма получается больше 22, то всегда отнимаем 22, то есть 48-22=6. Также, если сумма, например получится 70, то необходимо отнимать 22 до тех пор, пока итоговая сумма не станет меньше или равно 22, то есть 70-22=48, значит еще раз отнимаем 22, получается 48-22=26, значит еще раз минус 26-22=4.

2 способ:
Дана - Дата рождения: 30.09.2016, каждое число расположено в своей ячейке, то есть 30;09;2016.
Необходима формула: суммирование всех цифр 3+0+0+9+2+0+1+6=21
И, если итоговая сумма получается больше 22, то всегда отнимаем 22. Например получится 70, то необходимо отнимать 22 до тех пор, пока итоговая сумма не станет меньше или равно 22, то есть 70-22=48, значит еще раз отнимаем 22, получается 48-22=26, значит еще раз минус 26-22=4.

Добавлено через 15 минут
Еще 1 задача:
Дано: число, в котором количество цифр от 4 до 7. Например: 532170. Необходимо, каждую цифру по порядку расположить в ячейку, всего 7 ячеек.
Делаем это функцией =(--ПСТР(A3;1;1)). Но если в числе меньше 7 цифр, например 532170, то в 7-ю ячейку должен вставится 0. Как быть с 0? Что добавить в формулу?
Или пример 2015, в 7 ячейках должны быть цифры: 2; 0; 1; 5; 0; 0; 0
Ответ: Если число в А1
Код
=ОКРУГЛ(ОСТАТ(СУММПРОИЗВ(--ПСТР(A1;СТРОКА(A$1:ИНДЕКС(A:A;ДЛСТР(A1)));1))-1%;22);)
Формула автоматически подстраивается под количество разрядов в числе.
Вопрос: Использование имен диапазонов в формулах при условии

Друзья!!!
нужна Ваша помощь!
подскажите - возможно ли задать условие для использования имени диапазона в формулах??
у меня есть выгрузка по ряду месяцев с определенными затратами по определенным обособкам. я присвоил имена ряду диапазонам и вставил в формулу в отчет апреля. задача такая - есть ли возможность задать условие, чтобы изменяя месяц отчета (выделено зеленым) менялось имя диапазона для расчета (в формуле выделенной желтым).
форма отчета будет одна и я хотел бы ее переносить по листам простым копипастом (да-да, так банально). и хотелось бы меняя наименование месяца отчета получать сразу данные по этому месяцу. мне показалось, что "ВПР" тут не особо поможет, хотя и не уверен. просто хочется для ускорения времени найти более "быструю" формулу. Но, к сожалению, я не нашел на просторах сети решение моей задачи.
надеюсь у Вас смогу его найти. Или, по крайней мере, ответа что в данном варианте задача невыполнима и надо использовать впр или же что-то еще.
заранее крайне признателен и благодарен за помощь
Ответ: Pelena, спасибо. более сложный вариант, имеющий свои плюсы. правда вот не сразу получается его переносить дальше, местами выскакивает несчастное "н/д".
в общем, огромное спасибо, буду думать и разбираться что лучше использовать
Вопрос: Подсчет значений по двум условиям

Здравствуйте. Помогите пожалуйста с формулой. Вот условие: есть данные где напротив определенного товара поставлено значение по дням, были или нет его продажи в этот день - да или нет. Нужна формула которая находила бы нужный товар в столбце и считала количество да или нет в строке напротив товара. То есть будет две похожих формулы одна будет находить кол - да, другая кол - нет. Спасибо.
Ответ:
Цитата Сообщение от Czeslav Посмотреть сообщение
Код Code
1
=SUMPRODUCT((данные!$A$3:$A$29=$A2)*(данные!$B$3:$P$29=B$1))
Спасибо лучшая лучшая рабочая формула, для решения данной задачи.
Вопрос: Нужна формула с ЕСЛИ для расчета в таблице

Добрый день!
Помогите, пожалуйста, с формулой для таблицы.
Я прописала формулу, но не выводится результат, значит, есть ошибка.

Задача в следующем: нужно составить единую формулу, чтобы рассчитать L4 и L5 при условии:
условие 1: если С4=0, а D4>0.00, то L4=E4-(СУММ (F4:K4))
условие 2: если С5>0.00, а D5=0, то L5=C5-(СУММ(F5:K5))

я прописала так: =ЕСЛИ(C6="0", L6=E6-(СУММ(F6:K6)), L6=C6-(СУММ(F6:K6)))

Подскажите, пожалуйста.
Спасибо!
Ответ: =СУММ(C3;E3)-СУММ(F3:K3)
Вопрос: Подсчёт возврата инвестиций и прибыли за разные отрезки времени специальнй формулой

Здравствуйте! я тут впервые. подсказали ваш форум. Очень надеюсь на вашу поддержку.
До этого делала всё вручную. Пока не пришла мысль всё как то упростить и автоматизировать. Т.к. вручную уж больно тяжело и долго получается.

попробую описать суть того что мне требуется:
есть столбец с данными вложений инвестиций
есть столбец с удачной инвестицией или нет. т.е. была прибыль или потеря.
и 3 столбец: нужно подсчитать "Возврат инвестиций" на определённых отрезках времени(10 дней, месяц, 50 дней, 100 дней, год), с захватом предыдущего отрезка на n-кол-во дней.
1 строка =1день.
Так вот. Нужна формула, которую можно протянуть на весь диапазон от строки 31, до 510. Которая позволит изменяя параметр отрезка от 1 и выше, а также параметр захвата верхних строк(т.е. дней) от 1 и выше.
Прикрепила файл для примера.
Надеюсь на вашу помощь!
PS в файле 2 варианта очень похожих. на 2 варианте всё по аналогии с первым, только подсчитывать одну только прибыль
Ответ: SaniaA3, А если в нашем случае отрезками. Если там сделать условие, чтобы нули в расчёт не брались? Возможно это?
Вопрос: Нужна Формула для нахождении премии (MS EXCEL)

В общем ситуация такая . Есть список работников , сколько они работали (выработка) , сколько зарабатывают (зарплата) . Надо выдать им премию . а условия премии таковы: 1500 р,если выработка больше >25 . 0 р , если выработка меньше 20 . и 1000 в остальных случаях
Ответ:
Code
1
=СУММ(Ч(B4>{20;20;25}))*500
Считает как у AleksSid