Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: Ubuntu, LVM, Raid. Замена жестких дисков

Нужен совет.
Есть комп с двумя винтами. На нем организован зеркальный рейд и LVM. Хочу заменить винты на другие, большей емкости так, чтобы рейд и LVM расширились свободное пространство.
С чего начать? И можно ли вообще так сделать без переустановки.

С linux я на вы. Попробовал наивно клонировать диски на новые прогой HDClone (без каких-либо изменений).
Но с самого начала не срослось. На новых дисках Ubuntu Server не запускается.
Код Bash
1
2
error: no such disk
grub rescue>
Почему обычное клонирование не сработало? С виндой проходит все как по маслу...
Ответ:
Сообщение от kolin_k
Софтовый
Сообщение от kolin_k
А с какими знаком?
В данном случае для копии образа дисков достаточно dd.
Но коль скоро это зеркало, имеются собственные средства (утилита mdadm) удалять диски из рэйда, добавлять новые, перестраивать и расщирять рэйд.
Вопрос: Не могу установить Ubuntu на ноутбук

Доброго времени суток.
Возникла проблема при установке Ubuntu 18.04.1 LTS на новый ноутбук ACER Aspire A315-41 R8XR.
С самого начала на устройстве была предустановлена ОС без графической оболочки Linux Linpus. После нескольких часов знакомства с устройством (первый опыт использования ноутбуков) и знакомства с UEFI удалось установить и настроить Windows 10. (Оффтопом для справки - в биосе пункт Boot mode содержит только подпункт UEFI, т.е. переход в режим Legacy отсутсвует)
Причем, в ходе установке при редактировании разделов жесткого диска, я, по всей видимости, удалил тот самый Linpus (ошибок я совершил немало, как чувствую). После всей "персонализации" я имею раздел HDD формата FAT16 на ~100 МБ, на котором, как я понимаю, хранится информация для запуска ОС.

Имею загрузочную флешку с дистрибутивом Ubuntu. Делал ее и через UltraISO и через Rufus с предварительным форматированием в GPT - реакция компьютера одна и та же: при подключении флешки и переходе в BOOT меню (F12) имею только 3 пункта - из которых 2 предлагались с самого начала: Linux - просто запуск Linux Lnpus, и Generis Flash Disk - неведомый мне пункт, который доступен только при наличии подключенной флешки и при выборе которого я могу попасть в grub установочной флешки Ubuntu. (Простите за терминологию, надеюсь, что мысль доношу доступно).
При этом при выборе любого пункта из данного меню компьютер , вроде как, зависает, жалуясь на адреса некоторого ioapic.

Пы.Сы. - Данная проблема была и до установки Windows, т.е. и до удаления файлов изначальной ОС.
Пы.Сы.2 - При установке Windows 10 флешка виделась сразу, причем корректным пунктом USB-HDD и так далее.

Свои действия и суть проблемы описал в полной мере. Возникнут вопросы - дополню. Скриншоты по всему тому, что выше - прилагаю. Прошу помочь с этим разобраться - крайне привык к Ubuntu, а он нужен для учебы. Спасибо заранее.
Ответ: Можно только посочувствовать обладателям Acer. Ноуты Acer не дружат с Linux'сами. Есть конечно "вменяемые" модели, но есть и "невменяемые" и тогда обеспечены большие танцы с бубном.

Когда устанавливали 10-ку, разделы с диска удаляли? Судя по присутствию раздела FAT16 разделы не удалялись. Я бы предложил переустановить 10-ку, во время установки удалить все разделы и создать новые средствами установщика 10-ки. После установки 10-ки пробовать загружаться с установочной флешки Ubuntu.
Если установка Ubuntu пройдёт штатно, то загрузчика Ubuntu скорей всего видно не будет. Нужно поставить пароль BIOS (запишите пароль, чтобы не забыть), сохранить изменения, появится возможность включить Secure Boot и возможность добавить загрузчик Ubuntu через Select an UEFI file as trusted for executing. Это минимальный "набор" танцев, а дальше по результатам.
Вопрос: Usbip - проброс утсройства по сети (ubuntu 14.04 to windows)

Устанавливаю по инструкции, как на многих форумах:
Код
# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 14.04.3 LTS
Release: 14.04
Codename: trusty

Код
# uname -vr
3.16.0-30-generic #40~14.04.1-Ubuntu SMP Thu Jan 15 17:45:15 UTC 2015


1.1 Для начала требуется обновить систему.

Код
sudo apt-get update && sudo apt-get dist-upgrade -y
1.2 Добавим репозиторий с usbip. Пакет есть и в стандартном репозитории, но там он оказался не рабочим.
Код
sudo add-apt-repository ppa:whoopie79/ppa
1.3 Установим пакет usbip и включим нужные модули.

Код
sudo apt-get install usbip -y
modprobe usbip-core
modprobe usbip-host
1.4 Добавим нужные модули в автозагрузку. Для этого откроем файл /etc/modules в редакторе

Код
sudo nano /etc/modules
и в конец добавим

Код
usbip-core
usbip-host
1.5 Создадим init.d скрипт. Для этого скопируем /etc/init.d/skeleton

cp /etc/init.d/skeleton /etc/init.d/usbip
Далее отредактируем строки в /etc/init.d/usbip

Код
DESC="usbip"
NAME="usbipd"
DAEMON_ARGS="-D"
После этого дадим права файлу

Код
sudo chmod 755 /etc/init.d/usbipd
1.6 Добавим init.d скрипт в автозагрузку.

Код
sudo update-rc.d usbipd defaults
1.7 Пришло время запустить usbip на сервере, для этого запустим команду в консоли

Код
sudo /etc/init.d/usbipd start
Если команда не выдала ошибок, то все прошло удачно и можно приступать к пробросу usb устройства.

2. Проброс usb устройства.
выведем список всех usb устройств подключенных к серверу.

Код
usbip list -l
Выдало:
Код
usbip: error: failed to open /usr/share/hwdata//usb.ids
Local USB devices
=================
 - busid 1-8 (05e3:0723)
   unknown vendor : unknown product (05e3:0723)
         1-8:1.0 -> usb-storage

 - busid 4-1 (093a:2510)
   unknown vendor : unknown product (093a:2510)
         4-1:1.0 -> usbhid

посмотрим в списке устроств,
флешка у нас - Bus 001 Device 009: ID 05e3:0723 Genesys Logic, Inc. GL827L SD/MMC/MS Flash Card Reader

Код
# lsusb
Bus 006 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 009: ID 05e3:0723 [B]Genesys Logic, Inc. GL827L SD/MMC/MS Flash Card Reader[/B]
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 004: ID 093a:2510 Pixart Imaging, Inc. Optical Mouse
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
запомним : 05e3:0723 - это БАСАЙДИ 1-8

Расшариваем устройство в сеть :
Код
usbip bind -b 1-8
Получаем:
usbip: error: could not bind device to usbip-host

Пробуем понять причину:
Код
usbip --debug bind -b 1-8
usbip: debug: usbip.c:135:[run_command] running command: `bind'
usbip: debug: usbip_bind.c:162:[unbind_other] 1-8:1.0 -> unknown
usbip: debug: utils.c:65:[modify_match_busid] write "add 1-8" to /sys/bus/usb/drivers/usbip-host/match_busid
usbip: debug: usbip_bind.c:101:[bind_usbip] bind driver at 1-8:1.0 failed
usbip: error: could not bind device to usbip-host
usbip: debug: utils.c:65:[modify_match_busid] write "del 1-8" to /sys/bus/usb/drivers/usbip-host/match_busid

Ругается и не расшаривает ......
Прошу помощи.... кто знает в чем проблема ?
как расшарить ?

(Пробовал и так ставить: , со сборкой руками, тоже в этом же месте не расшаривает, так же ошибка)

Добавлено через 14 минут
Создал каталог /usr/share/hwdata (его не было)

скопировал в него файл
Код
cp /usr/share/misc/usb.ids /usr/share/hwdata/usb.ids
теперь отображает названия устройств)))
но проблему это не решило.

Отображает красивей:
Код
 usbip list -l
Local USB devices
=================
 - busid 1-8 (05e3:0723)
   Genesys Logic, Inc. : GL827L SD/MMC/MS Flash Card Reader (05e3:0723)
         1-8:1.0 -> unknown

 - busid 4-1 (093a:2510)
   Pixart Imaging, Inc. : Optical Mouse (093a:2510)
         4-1:1.0 -> usbhid
Добавлено через 3 минуты
Смотрим содержимое файла:
Код
# cat /sys/bus/usb/drivers/usbip-host/match_busid

1-8 4-1 [busID, 1-7
Добавлено через 41 минуту
порт открыт 3240
Код
# netstat -ltn;
Активні з’єднання з інтернетом (only servers)
Протокол Відіслано Отримано Локальна адреса Віддалена адреса Стан      
tcp        0      0 0.0.0.0:3240            0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:139             0.0.0.0:*               LISTEN     
tcp        0      0 127.0.0.1:5939          0.0.0.0:*               LISTEN     
tcp        0      0 127.0.1.1:53            0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN     
tcp        0      0 127.0.0.1:631           0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:445             0.0.0.0:*               LISTEN     
tcp6       0      0 :::3240                 :::*                    LISTEN     
tcp6       0      0 :::139                  :::*                    LISTEN     
tcp6       0      0 :::22                   :::*                    LISTEN     
tcp6       0      0 ::1:631                 :::*                    LISTEN     
tcp6       0      0 :::445                  :::*                    LISTEN
Ответ: переустановил программу USBIP
Код
usbip list -l
Local USB devices
=================
- busid 1-8 (05e3:0723)
Genesys Logic, Inc. : GL827L SD/MMC/MS Flash Card Reader (05e3:0723)
1-8:1.0 -> usb-storage

- busid 4-1 (093a:2510)
Pixart Imaging, Inc. : Optical Mouse (093a:2510)
4-1:1.0 -> usbhid


Код
usbip --debug bind -b 1-8
usbip: debug: usbip.c:135:[run_command] running command: `bind'
usbip: debug: usbip_bind.c:162:[unbind_other] 1-8:1.0 -> unknown
usbip: debug: utils.c:65:[modify_match_busid] write "add 1-8" to /sys/bus/usb/drivers/usbip-host/match_busid
usbip: debug: usbip_bind.c:101:[bind_usbip] bind driver at 1-8:1.0 failed
usbip: error: could not bind device to usbip-host
usbip: debug: utils.c:65:[modify_match_busid] write "del 1-8" to /sys/bus/usb/drivers/usbip-host/match_busid
Видимо драйвер тут не при чем (((

Добавлено через 22 часа 15 минут
Переустановил линуху наново.
Выполнил АПГРЕЙД и АПДЕЙТ системы (пакетов).
Установил СИНАПТИК (установщик пакетов)
С помощью СИНАПТИКА установил linux-tools-generic и linux-tools-3.13.0-24, думал поможет перед установкой USBIP
После этого начал установку USBIP из консоли.

Установил как обычно, начинаю запуск:
sudo /etc/init.d/usbipd start
и получаю ошибку:
usbip err: stub_driver.c: 33 (open_sysfs_stub_driver) usbip_common_mod.ko and usbip.ko must be loaded

** (process:3351): ERROR **: driver open failed
Trace/breakpoint trap (core dumped)


Решаю установить некоторые необходимые вещи (с другого форума прочитал)
apt-get install libncurses5-dev build-essential linux-source dh-autoreconf libsysfs-dev
В папке /usr/src
появляется файл-архив: linux-source-3.13.0.tar.bz2 и рядом папка: linux-source-3.13.0
В папке нет того, что мне надо - распаковываю архив.
В нем есть много чего:
Код
arch     
CREDITS  
debian.master  
dropped.txt  
include  
Kbuild   
lib                          
Makefile  
README          
scripts   
tools   
virt
block    
crypto   
Documentation  
firmware     
init     
Kconfig  
linux-source-3.13.0.tar.bz2  
mm        
REPORTING-BUGS  
security  
ubuntu
COPYING  
debian   
drivers        
fs           
ipc     
kernel   
MAINTAINERS                  
net       
samples        
sound     
usr
Перехожу в папку:
/usr/src/linux-source-3.13.0/drivers/staging/usbip/userspace
вижу файл: autogen.sh
запускаю на выполнение.
Проверяю наличие файла нужного мне (срочно): locate usbip_common_mod.ko - не нашло

Появились новые файлы, среди них появился: configure
Запускаю его тоже на выполнение....
После проверяю - файла "usbip_common_mod.ko" все еще нет.
При запуске службы ошибка осталась та же (((

Делаю:
make
make install

Файла пока нет .....


По совету с инпортного форума сделал:
apt-get install linux-tools-generic-lts-utopic
После этого в папке: /usr/lib/linux-tools/3.16.0-77-generic
нашел файлы: usbip and usbipd

Копирую их вместо старых (находясь в папке /usr/lib/linux-tools/3.16.0-77-generic):
Код
/usr/lib/linux-tools/3.16.0-77-generic# cp usbip /usr/sbin/usbip
/usr/lib/linux-tools/3.16.0-77-generic# cp usbipd /usr/sbin/usbipd
/usr/lib/linux-tools/3.16.0-77-generic# cp usbip /usr/local/sbin/usbip
/usr/lib/linux-tools/3.16.0-77-generic# cp usbipd /usr/local/sbin/usbipd
(в обе папки, потому как не уверен от куда запуск идет)
Запускаю опять злощастную службу ))))
sudo /etc/init.d/usbipd start

ииииииииииииии
КРАСОТИЩА !!!
ЗАПУСТИЛОСЬ )))

Проверяю, есть ли в памяти:
Код
ps aux | grep usbip*
root      6819  0.0  0.1   3000  1616 ?        Ss   19:57   0:00 /usr/sbin/usbipd -D
root      6860  0.0  0.1   6164  2012 pts/4    S+   20:03   0:00 grep --color=auto usbip*
Вау - есть !!!!!!
Типа запустилось ))))

Код
# usbip list -l
usbip: error: failed to open /usr/share/hwdata//usb.ids
 - busid 4-1 (093a:2510)
   unknown vendor : unknown product (093a:2510)

 - busid 1-8 (05e3:0723)
   unknown vendor : unknown product (05e3:0723)
ВИДИТ устройства, но не понимает их, пока....
Исправляем это:
Код
mkdir /usr/share/hwdata
cp /var/lib/usbutils/usb.ids /usr/share/hwdata/usb.ids

usbip list -l
 - busid 4-1 (093a:2510)
   Pixart Imaging, Inc. : Optical Mouse (093a:2510)

 - busid 1-8 (05e3:0723)
   Genesys Logic, Inc. : GL827L SD/MMC/MS Flash Card Reader (05e3:0723)
Получилось !!!!!

Пробуем расшарить устройство (скрещиваем пальцы)
Код
usbip bind -b 1-8
usbip: info: bind device on busid 1-8: complete
ВАУ --- получилось, расшарило без ошибки )))))

Дальше дело за КЛИЕНТОМ.
Клиент стоит на ВИНДОВСЕ, ухожу мучать его )))
Скоро отпишусь

Добавлено через 3 часа 18 минут
WINDOWS 7 x 64
Запускаю командную строку
набираю:
c:\USB_IP_2>usbip 192.168.1.5 -l -D

ПОЛУЧАЮ ОТВЕТ:
usbip dbg: usbip_network.c: 236 (tcp_connect ) trying

usbip dbg: usbip_network.c: 256 (tcp_connect ) connect
- 192.168.1.5
usbip dbg: usbip.c: 227 (query_exported_devices)
1-8: Genesys Logic, Inc. : unknown product (05e3:
: /sys/devices/pci0000:00/0000:00:1d.7/usb1/1-
: (Defined at Interface level) (00/00/00)

-- Видит расшаренное устройство.

Пробую присоединить к себе под виндой:
c:\USB_IP_2>usbip 192.168.1.5 --attach 1-8 -D

usbip dbg: usbip_network.c: 236 (tcp_connect ) trying 192.168.1.5 port 3240

usbip dbg: usbip_network.c: 256 (tcp_connect ) connected to 192.168.1.5:3240
usbip dbg: usbip_windows.c: 837 (query_interface0) exportable 1 devices
usbip dbg: usbip_windows.c: 854 (query_interface0) 1-8: Genesys Logic, Inc.
: unknown product (05e3:0723)
usbip dbg: usbip_windows.c: 855 (query_interface0) : /sys/devices/pci000
0:00/0000:00:1d.7/usb1/1-8
usbip dbg: usbip_windows.c: 856 (query_interface0) : (Defined at Interfa
ce level) (00/00/00)
usbip dbg: usbip_windows.c: 879 (query_interface0)
usbip err: usbip_windows.c: 899 (attach_device) cannot find device

ОБЛОМ ПОКА!!! (ушел рыдать)
Вопрос: Как в ubuntu подключать расширения для mercurial?

Товарищи линуксойды, выручайте) Собственно вопрос в заголовке. На юбунте стоит hg. Нужно подключить расширение largefiles, я создаю файл .hgrc в домашнем каталоге и подключаю там расширение:

[extensions]
largefiles=

[largefiles]
minsize=2
patterns=*.jpg *.rar *.zip *.pdf

Но эффекта ноль.

Пишу в консоле hg add --large, вылезает ошибка, что нет такой опции у команды.

Что самое интересное, на винде стоит тоже hg там в конфиге прописал все тоже самое и работает отлично.

PS Тему создал и в разделе систем контроля версий тоже.

Добавлено через 3 часа 1 минуту
Вроде понял в чем дело. У меня стоит ubuntu 11.10, и на ней почему-то ставится только mercurial 1.9 (древний релиз), в котором нет нужного расширения.

Я попробовал удалить старый релиз mercurial и поставить заново, но почему-то с репозитория качается только старая версия. Возможно это из-за старых репозиториев юбунты. Если принудительно писать apt-get install mercurial=3.9.2, пишет, что такая версия не найдена, хотя это последний релиз, который есть на сайте.

Можно ли вообще на ubuntu ставить новые пакеты софта или нужно уже саму ubuntu обновлять. обновлять на самом деле не хотелось бы. На сколько я наслышан, что в большинстве случаев обновление юбунты это смерть всему, что на ней есть в лучшем случае, а в худшем система сама приказывает долго жить)

Подскажите товарищи, как быть? Может просто архивом скачать и установить?
Ответ: Спасибо ребят)

Надеюсь запустится, не больно хочется все пересносить, потом файлы заливать и прочее. Жду уже часа 2 пока она переустановится)

Добавлено через 1 час 37 минут
Ubuntu переставил, при обновлении даже вежливо спрашивали, хочу ли я оставить текущие конфиги ) Расширение largefiles на сервере заработало вроде. Теперь осталась одна проблема. Нужно на хостинге подключить тоже расширение. В тех поддержке написали, что у них не стоит меркуриал, но стоит только hg. Тут я себя немного дураком ощущаю. Я всегда думал, что hg это просто оболочка для меркуриала. Как он у них по себе живёт? Такое вообще может быть? Как тогда я там создаю репозитории и комичусь?

Добавлено через 14 часов 41 минуту
После еще оного обращения, они написали:

Приносим свои извинения за некорректную консультацию. Действительно на тарифных планах виртуального хостинга установлено данное программное обеспечение.

Правда и я дурака включал долго, мнне к ним по сути и не нужно было обращаться. нужно было просто создать на их сервере файл .hgrc в корне репозитория (.hg), с нужными настройками. В общем все, как на локалке. Не знаю почему я сразу об этом не подумал.

Добавлено через 2 минуты
Еще, по теме:

Если под юбунтой, да и любой другой линухой работает сервер, то в общем файле конфигурации нужно подключать расширения с припиской hgext.

Например

[extensions]
hgext.filelarge=
Вопрос: Ubuntu 14.04.2 чёрный экран после обновления

Здравствуйте, помогите начинающему линуксоиду.
Установил Ubuntu 14.04.2 LTS на ноутбук HP Pavilion g6-2226sr.
Поскольку за линукс взялся впервые и после винды остались разделы с файлами, то немного неправильно разбил жесткий. Поэтому потренировался на первой установке, скопировал файлы и переустановил систему. При новой установке разбил диск так:
- / — 25000
- swap — 7500
- /home – 200000
- ntfs – ~500000
При первом включении после установки система как и до этого написала что вышли обновления, я нажал установит их. После установки перезагрузил пк, но при включении — черный экран, система грузится т.*к. слышно музыку при вводе пароля.
Если выключить пк (нажать и долго держать кнопку включения) — система грузится нормально. Если после включения вместо «Выключить» выбрать «Перезагрузить» - черный экран.
Набирал в консоле:
Код Bash
1
2
3
4
5
6
sudo apt-get update
sudo apt-get -f install
(написало что ещё 8 пакетов не обновлены)
sudo apt-get upgrade
(перезагрузка, черный экран, …)
sudo apt-get -f install
(обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.)
Думал что с драйверами на графику что-то, перехожу в Программы и обновления — Доп драйверы, выбираю проприоритарные, нажимаю «Применить изменения», система долго думает, но в итоге птичка всё равно перескакивает на свободные, при первой установке такого не было.
Подскажите, как это исправить?
Ответ:
Цитата Сообщение от NeoMatrix Посмотреть сообщение
Это в настройке репозиториев. Там нужно выбрать настройки источников обновлений.
Можно ещё добавить вручную в /etc/apt/sources.list строки с проприетарными источниками и обновиться
Код Bash
Код Bash
1
2
apt-get update
apt-get upgrade
после чего установить проприетарный драйвер видео.
там уже всё выбрано было.
Походу не в этом дело было, то что не устанавливался драйвер это скорей последствия.
Удалось решить установкой системы версии 14.04.1 и обновлением до 14.04.2, а не сразу 14.04.2.
Вопрос: Почему периодически падает интернет Ubuntu 16.04 x64?

Здравствуйте! Такой вопрос:
в интернет выхожу через WiFi, так как ПК стационарный, и в сетевой карте поддержки WiFi нет, то использую USB WiFi адаптер TP-Link TL-WN822N. На Windows 7 адаптер не глючил, всё работало стабильно. После перехода на Ubuntu 16.04 x64 интернет стал периодически пропадать (не загружаются страницы, ping тоже сообщает о том, что запрашиваемого ресурса нет). При этом индикатор показывает, что подключение к WiFi сети есть.Проблему решаю банально: извлекаю адаптер из USB разъёма, а затем вставляю заново. Проблема в том, что через 15-20 минут после этого всё повторяется, и указанную процедуру приходится проделывать снова и снова. Также заметил, что интернет (даже стабильный) чуть более тормозной, чем на Windows 7.
Ядро: Linux 4.4.0-45-generic #66-Ubuntu
Как настроить стабильный интернет, чтобы ничего не отваливалось?
Ответ: Поставить более новое ядро (с 4.4 есть некоторые проблемы)
Вопрос: [Ubuntu] Шрифты

По какой причине на Ubuntu другие шрифты(или их отображения) если сравнивать с Windows? У меня другое отображение начиная с шрифтов в приложениях заканчивая шрифтами в вики и другим шрифтом в код сниппетах с киберфорума. Это по-умолчанию другие шрифты в Ubuntu или я что-то не установил/не настроил?
Ответ: наковыриваем из винды любимые (недостающие) шрифты (ttf-файлы)
в бубунте запускаем команду перестройки кеша фонтов
Bash
1
fc-cache -f -v
и потом просто смотрим на ее вывод, в котором среди прочего наблюдаем
Код
/home/dmitry/.fonts
(где "dmitry" - логин пользователя, в показанном примере - мойлогин,в вашем случае будет ваш...)
помещаем в указанную папку (если её нет - создаем) выковырянные с виндовса ttf-файлы, и снова запускаем указанную выше команду - новые шрифты будут добавлены к уже имеющимся
Вопрос: При установке Ubuntu 16.04.2 LTS сбой на странице выбора разделов

Здравствуйте!
Устанавливаю на старое серверное железо десктопный вариант Ubuntu 16.04.2 LTS. Все идет хорошо до выбора варианта установки на диск. Эту страницу установщик пропускает и сразу показывает страницу с пустой таблицей подготовки разделов. При попытке нажать на плюсик (+) возникает сбой, установка прерывается.

GParted винчестеры и разделы на них видит хорошо. С его помощью очистил диск от старых разделов подготовил новые, все без проблем. lsblk тоже показывает как надо.

Мамка Supermicro с дурацким полусофтовым контролером Intel, который, правда, отключен. В биосе выставлен режим ACHI, без рейдов. После загрузки с флешки винчестеры определяются хорошо, как sda и sdb.

Первый раз такое, непонятно какое. Подскажите, пожалуйста, куда копать?
Ответ: Решил проблему установкой Ubuntu на другой сервер.
Вопрос: Ubuntu 16. грузится только после повторной перезагрузки

Доброго времени суток, я новичок в убунту и моих скромных знаний в данном вопросе недостаточно, суть проблемы в том что система ubuntu 16.04 lts 64 (celeron g3900+ msi z270a pro + 4 gb ddr4 +6x AMD RX 570 ) грузится только после повторной перезагрузки после неудачно старта выдается код ошибки
radeon 0000:04:00.0: Invalid PCI ROM header signature: expecting 0xaa55, got 0xffff
(скрин во вложение) после чего система вполне себе нормально грузится работает вместе со всем необходимым мне функционалом, вопрос к старожилам можно ли поправить данный баг если нет то как сделать чтобы система грузилась в "рекавери"(как при повторной перезагрузке) всегда? Добавление параметра nomodeset в grub проблему не решает, 1-я загрузка заканчивается черным экраном повторная окошком с запросом пароля после ввода которого окошко появляется вновь.
P.S. Питание, мать, память, gpu, райзеры, прочая периферия новые и в порядке, дрова через sudo apt update/upgrade обновлял, дрова AMD c сайта, другие не подходят ввиду новизны gpu, тоже самое касается и системы тк дрова от AMD (17.10) на эти gpu только под 16.04. после загрузки через танец с бубном система работает стабильно, таких систем на этой плате с одинаковым багом 2шт. Перерыл несколько форумов но так и не нашел решения как сконфигурировать на постоянной основе режим "аварийной"(повторной) загрузки при котором баг исправляется автоматом (на скрине).
Ответ: Работает как положено, точно, тк это ферма и после старта с бубнами загружается Claymore Dual miner (на основе amd SDK - если я ничего не путаю), который вполне себе нормально майнит. А вот какой драйвер грузится это вопрос, сейчас на одну из подопытных систем заливаю любунту ,установлю свободный драйвер и попробую запустить майер, по результатам отпишу.

Добавлено через 5 часов 11 минут
Судя по всему не в драйвере gpu дело, проблемы начинаются когда добавляешь 5-й и 6-й gpu и включаешь в биоз функцию 4g+ (4+ gpu , требуется 64 битная os), если к этому моменту в системе установлен драйвер AMD(не важно какой) то она уходит в черный экран и нормально заводится с второго раза, с логом ошибок на черном фоне (что меня в общем никак не смущает) , если же драйвер не установлен система ложится наглухо с разноцветной рябью на экране, повторный запуск ничего не дает, заводится только после отключения в биоз функции 4g+и 2-х крайних gpu, баг похоже в дебрях pci-e, тк у меня есть системы (те же 6gpu RX570) на других материнках (asrock h81 pro btc2) на той же ос 16.04.02 и с теми же дровами amd 17.10 для ubuntu 16.04 которые прекрасно стартуют с первого раза. Возвращаемся к тому же - как-то система повторно сама заводится и как это воспроизвести на постоянной основе?)

Добавлено через 10 минут
насколько я понимаю где-то в дебрях lubunt-ы есть тригер отвечающий за успешную загрузку, и его в теории можно заблокировать в одном положение чтобы система всегда грузилась аварийно, поправьте меня если я ошибаюсь.

Добавлено через 1 час 1 минуту
Вопрос с автозагрузкой в рекавери решен убиением содержимого etc/init.d/grub-common , тема закрыта.
Вопрос: Установка ubuntu -16.04.2-desktop-i386 и -amd64

не могу установить ubuntu-16.04.2-desktop-i386 и -amd64 , при загрузке с флешки , пишет : gfx boot.c32:not a com32R image boot , все другие образы без проблем ,ставятся легко и быстро
Ответ: Спасибо всем , кто читал мою галиматью , тема закрыта .повторюсь , причина банальна , моя не внимательность , впечатление о UBUNTU 16.04 TSL плохое , в отличии от винды (любой) полный сырец , ни чего не установлено( может и правильно , что бы каждый сам себе нужное устанавливал и всегда новые обновы загружал)но когда нет инета , это плохо ,на винде хр я лет десять играл и пытался программировать , вообще не знал об интернете.В селе связь плохая и поэтому с трудом , но обновляю по чуть , пакеты понял как распаковывать быстро. вообщем вопросов нет и ещё раз благодарю за помощь и внимание. да система всё равно пока подвисает , но я же говорю даже менеджер пакетов стоит допотопный в этой сборке, это я сравнивал с показанными в интернете, да и в управлении сетями , почти нет настроек,пока не обновились.