Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: Ubuntu proxy

Всем привет, подскажите как запустить исходящий трафик на ubuntu через прокси ? К примеру если просто в лисе прописать руками, то не работает...
Ответ: virpool
Тебе нужно перекомпилировать squid, т.к. он не фильтрует https протокол из коробки. А вообще вот ссылка Но это опят ь же это не безопасно, т.к. ты сам реализуешь атаку "человек по середине".
Вопрос: Не удаётся выполнить proxy-аутентификацию

Ubuntu Desktop 14.04.1 LTS.

Хостовая машина работает под управлением OS Windows и находится в домене организации. Установлен VirtualBox 4.3.20 r96997. Создал две виртуальные машины, работающие под управлением Ubuntu Desktop 14.04.1 LTS и Ubuntu Server 14.04.1 LTS. В настройках обоих виртуальных машин в качестве сетевых адаптеров назначены: сетевой мост и внутренняя сеть. Оба компьютера видны в доменной сети, успешно подключаюсь к ним при помощи putty.exe как с хостовой машины, так и из других физ. машин.

Проблема: обе виртуальные машины не имеют доступа к Интернету (хостовая машина имеет). Я пытался решить эту проблему путём редактирования двух конфигурационных файлов:

1. Файл /etc/environment у меня сейчас выглядит так:

/etc/environment
PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games"

https_proxy="https://domainName\myLogin:MyPassword@192.168.123.12:8080/"
http_proxy="http://domainName\myLogin:MyPassword@192.168.123.12:8080/"
ftp_proxy="ftp://domainName\myLogin:MyPassword@192.168.123.12:8080/"


Последняя строка в обозначенном файле была добавлена мною. Вместо domainName, myLogin и MyPassword, в реальном файле указана та информация, которую я использую при входе в систему в нашей организации.

2. Файл /etc/profile у меня сейчас выглядит так:

/etc/profile
# /etc/profile: system-wide .profile file for the Bourne shell (sh(1))
# and Bourne compatible shells (bash(1), ksh(1), ash(1), ...).

if [ "$PS1" ]; then
if [ "$BASH" ] && [ "$BASH" != "/bin/sh" ]; then
# The file bash.bashrc already sets the default PS1.
# PS1='\h:\w\$ '
if [ -f /etc/bash.bashrc ]; then
. /etc/bash.bashrc
fi
else
if [ "`id -u`" -eq 0 ]; then
PS1='# '
else
PS1='$ '
fi
fi
fi

# The default umask is now handled by pam_umask.
# See pam_umask(8) and /etc/login.defs.

if [ -d /etc/profile.d ]; then
for i in /etc/profile.d/*.sh; do
if [ -r $i ]; then
. $i
fi
done
unset i
fi
export https_proxy=https://domainName\myLogin:MyPassword@192.168.123.12:8080/
export http_proxy=http://domainName\myLogin:MyPassword@192.168.123.12:8080/
export ftp_proxy=ftp://domainName\myLogin:MyPassword@192.168.123.12:8080/


Две последние строки были добавлены мною. Вместо domainName, myLogin и MyPassword, в реальном файле указана та информация, которую я использую при входе в систему в нашей организации.

Однако обозначенные выше изменения, внесённые мною в конфигурационные файлы, к сожалению не помогли - доступа к Интернет по прежнему нет.

На скрине показано окно настроек proxy.

Картинка с другого сайта.

Администратор нашего домена утверждает, что у него на старой Ubuntu правее поля, в котором указан порт, имеется дополнительная кнопка, нажав на которую можно настроить proxy-аутентификацию (т.е. указать логин и пароль). В виду этого ему удалось получить доступ к Интернет из Ubuntu (физ. машина находится в домене организации). Однако в Ubuntu Desktop 14.04.1 LTS, как видим этого нет.

Настройки браузера такие (Firefox):

Картинка с другого сайта.

Переключался между первыми четырьмя вариантами - Интернет от этого не появлялся.

Однако при попытке открывать страницы в Интернете, получаю следующее:

Картинка с другого сайта.

Если запускаю Firefox через терминал, то вижу такие сообщения, прежде чем браузер открывается:

Firefox
(process:3434): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
1421418631040 addons.xpi WARN Exception running bootstrap method shutdown on webapps-team@lists.launchpad.net: ReferenceError: sss is not defined (resource://gre/modules/addons/XPIProvider.jsm -> file:///usr/share/mozilla/extensions/%7Bec8030f7-c20a-464f-9b0e-13a3a9e97384%7D/webapps-team@lists.launchpad.net/bootstrap.js:72:4) JS Stack trace: shutdown@resource://gre/modules/addons/XPIProvider.jsm -> file:///usr/share/mozilla/extensions/%7Bec8030f7-c20a-464f-9b0e-13a3a9e97384%7D/webapps-team@bootstrap.js:72:5 < XPI_callBootstrapMethod@XPIProvider.jsm:4232:9 < shutdownObserver@XPIProvider.jsm:1969:1
andrey@ubdt-1:~$


Пробовал и так:

root@ubdt-1:~# wget --proxy-user "MyDomain\MyLogin" --proxy-passwd "MyPassword" http://www.google.com


Однако получаю это:

автор
--2015-01-16 18:38:46-- http://www.google.com/
Connecting to 192.168.123.12:8080... connected.
Proxy request sent, awaiting response... 407 Proxy Authentication Required ( Для выполнения запроса компоненту Forefront TMG требуется авторизация. Доступ к фильтру веб-прокси запрещен. )
2015-01-16 18:38:46 ERROR 407: Proxy Authentication Required ( Для выполнения запроса компоненту Forefront TMG требуется авторизация. Доступ к фильтру веб-прокси запрещен. ).


Буду признателен за помощь в обозначенном вопросе.

Спасибо.
Ответ: По теме нашёл это. Однако я не могу выполнить обозначенные действия:
Первый шаг по созданию области Kerberos - это установка пакетов krb5-kdc и krb5-admin-server. Введите в терминале:
sudo apt-get install krb5-kdc krb5-admin-server

в виду того, что у меня нет доступа к Интернет. Замкнутый круг...
Вопрос: Установка Ubuntu 14.04 параллельно Win 8.1. Некорректно видит диски

Всем привет.

Помогите, пожалуйста, абсолютному новичку, ни разу не работавшему с линуксами установить Ubuntu 14.04 x64 параллельно существующей Win 8.1 x64. Устанавливать все пытаюсь по документации с этого ресурса с Live флешки. Проблема следующая:

У меня два ЖД: первый ССД (разбит на 40ГБ под винду + 200Гб), второй обычный (464Гб). Ubuntu их не видит, а точнее видит как-то криво. Установить Ubuntu хочу на ССД, конечно, освободил там для этого место, хочу через GParted создать из него раздел под установку. GParted показывает следующее сообщение при запуске:

/dev/sdb contains GPT signatures, indicating that it has a GPT table. However, it does not have a valid fake msdos partition table, as it should. Perhaps it was corrupted -- possibly by a program that doesn't understand GPT partition tables. Or perhaps you deleted the GPT table, and are now using an msdos partition table. Is this a GPT partition table?
Независимо от ответа дальше он показывает следующую инфу по дискам:
Кликните здесь для просмотра всего текста





При этом на самом деле дела обстоят вот так:
Кликните здесь для просмотра всего текста




А вот результат выполнения некоторых комманд (в которых я ничего не понимаю, но дошел до этого, пытаясь решить проблему, копаясь в англоязычных форумах):

Code
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
ubuntu@ubuntu:~$ sudo fdisk -l
 
WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.
 
 
Disk /dev/sda: 500.1 GB, 500107862016 bytes
256 heads, 63 sectors/track, 60563 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0xa5418978
 
   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1  4294967295  2147483647+  ee  GPT
Partition 1 does not start on physical sector boundary.
 
WARNING: GPT (GUID Partition Table) detected on '/dev/sdb'! The util fdisk doesn't support GPT. Use GNU Parted.
 
 
Disk /dev/sdb: 256.1 GB, 256060514304 bytes
255 heads, 63 sectors/track, 31130 cylinders, total 500118192 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xd4d085fa
 
   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *        2048      718847      358400    7  HPFS/NTFS/exFAT
/dev/sdb2          718848    84602872    41942012+   7  HPFS/NTFS/exFAT
/dev/sdb3        84602880   500115455   207756288    5  Extended
/dev/sdb5        84604928   500115455   207755264    7  HPFS/NTFS/exFAT
 
Disk /dev/sdc: 3926 MB, 3926949888 bytes
16 heads, 16 sectors/track, 29960 cylinders, total 7669824 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x37493382
 
   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1   *        8064     7669823     3830880    b  W95 FAT32
и еще:

Code
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
ubuntu@ubuntu:~$ sudo gdisk -l /dev/sda
GPT fdisk (gdisk) version 0.8.8
 
Partition table scan:
  MBR: protective
  BSD: not present
  APM: not present
  GPT: present
 
Found valid GPT with protective MBR; using GPT.
Disk /dev/sda: 976773168 sectors, 465.8 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): 7A57205F-6F0A-46B6-BB04-F477919D5BDC
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 976773134
Partitions will be aligned on 2048-sector boundaries
Total free space is 1697773 sectors (829.0 MiB)
 
Number  Start (sector)    End (sector)  Size       Code  Name
   1         1697792       976773119   465.0 GiB   0700  Basic data partition
 
=============
 
ubuntu@ubuntu:~$ sudo gdisk -l /dev/sdb
GPT fdisk (gdisk) version 0.8.8
 
Partition table scan:
  MBR: MBR only
  BSD: not present
  APM: not present
  GPT: present
 
Found valid MBR and GPT. Which do you want to use?
 1 - MBR
 2 - GPT
 3 - Create blank GPT
 
Your answer: -------------  тут я испугался и убил консоль :) ------------

Загрузка винды у меня в режиме Legacy, хотя есть UEFI, но я уже не помню, почему использую старый режим. И по этому поводу тоже вопрос: стоит ли поменять режим? На что это будет влиять? Ради этого ведь, я так понимаю, мне придется переустанавливать и винду тоже.
Ответ: Андрей1224,

текущую проблему я уже решил. Следующим образом:

Code
1
2
3
4
5
6
7
8
9
10
11
12
13
ubuntu@ubuntu:~$ sudo fixparts /dev/sdb
FixParts 0.8.8
 
Loading MBR data from /dev/sdb
 
NOTICE: GPT signatures detected on the disk, but no 0xEE protective partition!
The GPT signatures are probably left over from a previous partition table.
Do you want to delete them (if you answer 'Y', this will happen
immediately)? (Y/N): y
Erasing GPT data!
 
Warning: 0xEE partition doesn't start on sector 1. This can cause problems
in some OSes.
Скрин вот, на всякий случай .

Но теперь у меня новая проблема. Во время установки вылетает следующая ошибка:
grub-install /dev/sda failed - this is a fatal error

Пробовал менять на sdb - то же самое. Вообще куда должен устанавливаться GRUB? Ту да же, где виндовый MBR расположен?

Добавлено через 2 часа 14 минут
Люди, выручайте. Грохнул MBR виндовый. Что делать?

Сначала попробовал установить все заново. Та же ошибка rub-install /dev/sda failed - this is a fatal error. Пробовал sdb, все варианты - то же самое.
Тогда я выбрал continue without a bootloader. Установка завершилась.
Потом снова зашел через лайв-сд и сделал то, что делается в этом видео только выбирал sdb6 и sdb соответственно. Все прошло ок, ровно как на видео, GRUB установился. При этом виндовый загрузчик пропал. И убунта тоже не запускается. Хотя установить программу скриншотов Shutter я не смог, вылезали ошибки. Может дело в моих руках, тк я впервые это делал. В общем, это несущественно, наверно, на данный момент. Вот теперь то, что я вижу после включения ноута:


Еще вот фото моих разделов на всякий случай:

Запустил убунту снова с Live-cd. При этом все диски уже видны, сама убунта установилась, только не запускается автоматически. Виндовой флешки для загрузки нету больше, тк использовал ее для убунты. Что делать?

Добавлено через 15 минут
В общем, история продолжается ) Виндовый MBR я восстановил вот так
Code
1
2
sudo apt-get install lilo
sudo lilo -M /dev/sda mbr
теперь все вернулось в исходное состояние ) Загружается винда и все. Как установить загрузчик убунты?
Вопрос: Не запускается Windows 8.1 после установки Ubuntu

Здравствуйте!
Долго хотел вспомнить молодость и поставить Ubuntu. И, наконец-то, руки дошли. Убил один раздел на ноуте и поставил рядом с виндой. После этого не могу попасть в Windows. Когда я попадают в Grub, у меня есть выбор: при выборе Ubuntu, всё грузится нормально, но при выборе Винды - всё так же тухгет экран, но, просто его включения, на экране виден только фоновый цвет Grub'а и дальше ничего не происходит. Причём даже индикатор НамЛока не реагирует на нажатия данной клавиши.
Долее, под спойлером, подробнее, чтоб не пугать читающих обилием текста.
Кликните здесь для просмотра всего текста

Представляю сразу информации по максимуму.
1. Сейчас Windows и Ubuntu установлены из-под BIOS. Не UEFI!
2. Быструю загрузку, перед установкой Ubuntu, отключил. Защищённой загрузки в BIOS не нашёл вообще.
3. В ноуте 2 физических диска. Первым идёт SSD с Windows (sda)(MBR), второй - HDD с не малым количеством разделов, один из которых с Убунту (sdb)(GPT).
4. Ubuntu не видел мои разделы на sda выполнить, что он пуст.
В интернете нашёл, что нужно выполнить
Код Code
1
sudo gdisk /dev/sda
И этим, как я понял, затереть остатки GPT от старой разметки, но не вайпать MBR. Что я и сделал и это помогло.
4. Под загрузчик при установке выбрал sda.
5. После установки Ubuntu нормально стартует. Windows - не хочет.
6. update-grub не помогает. Выполняется с успехом, но на загрузку не влияет.
Подскажите, как мне их подружить. Если я восстановлю загрузчик видны - не будет убунты, если потом опять восстановлю Grub - опять, наверное, перестанет грузиться форточка.
Благодарю за внимание и терпение!
Ответ:
Цитата Сообщение от body90 Посмотреть сообщение
Но я потеряют загрузку Ubuntu.
Хотя, честно говоря, мне более приятен загрузчик от Windows
В комбинации Win 7 + Linux, я Linux добавлял в семёрочное бутменю с помощью EasyBCD. Правда у меня они установлены на одном диске. Выглядит так

Кликните здесь для просмотра всего текста
Не запускается Windows 8.1 после установки Ubuntu
Вопрос: Открывается Windows 8.1, после установки Ubuntu

Здравствуйте, я решил поставить Ubuntu второй системой, все установилось, диск разделил на несколько логических разделов, windows 8 и ubuntu стоят на разных. При запуске открывается выбор запустить ubuntu, или windows 8.1 и ещё 3 пункта. Если выбрать ubuntu, то она запускается и всё нормально работает, при выборе windows тут же вылазит ошибка и windows отказывается запускаться. Тогда я попробовал сбросить настройки BIOS, после этого просто запустилась винда и всё... Как вернуть тот экран с выбором системы?
Ответ: Я думаю, что Вы неправильно установили Ubuntu. Windows у Вас установлена в UEFI режиме, Ubuntu тоже нужно было устанавливать в UEFI режиме. А Вы как устанавливали?
На мой взгляд проще правильно переустановить Ubuntu. Если у Вас системы установлены в разных режимах, то двойную загрузку Вы не сделаете. Вот примерный порядок установки Ubuntu в UEFI режиме
ещё ссылка
Вопрос: Не могу установить Ubuntu на ноутбук

Доброго времени суток.
Возникла проблема при установке Ubuntu 18.04.1 LTS на новый ноутбук ACER Aspire A315-41 R8XR.
С самого начала на устройстве была предустановлена ОС без графической оболочки Linux Linpus. После нескольких часов знакомства с устройством (первый опыт использования ноутбуков) и знакомства с UEFI удалось установить и настроить Windows 10. (Оффтопом для справки - в биосе пункт Boot mode содержит только подпункт UEFI, т.е. переход в режим Legacy отсутсвует)
Причем, в ходе установке при редактировании разделов жесткого диска, я, по всей видимости, удалил тот самый Linpus (ошибок я совершил немало, как чувствую). После всей "персонализации" я имею раздел HDD формата FAT16 на ~100 МБ, на котором, как я понимаю, хранится информация для запуска ОС.

Имею загрузочную флешку с дистрибутивом Ubuntu. Делал ее и через UltraISO и через Rufus с предварительным форматированием в GPT - реакция компьютера одна и та же: при подключении флешки и переходе в BOOT меню (F12) имею только 3 пункта - из которых 2 предлагались с самого начала: Linux - просто запуск Linux Lnpus, и Generis Flash Disk - неведомый мне пункт, который доступен только при наличии подключенной флешки и при выборе которого я могу попасть в grub установочной флешки Ubuntu. (Простите за терминологию, надеюсь, что мысль доношу доступно).
При этом при выборе любого пункта из данного меню компьютер , вроде как, зависает, жалуясь на адреса некоторого ioapic.

Пы.Сы. - Данная проблема была и до установки Windows, т.е. и до удаления файлов изначальной ОС.
Пы.Сы.2 - При установке Windows 10 флешка виделась сразу, причем корректным пунктом USB-HDD и так далее.

Свои действия и суть проблемы описал в полной мере. Возникнут вопросы - дополню. Скриншоты по всему тому, что выше - прилагаю. Прошу помочь с этим разобраться - крайне привык к Ubuntu, а он нужен для учебы. Спасибо заранее.
Ответ: Можно только посочувствовать обладателям Acer. Ноуты Acer не дружат с Linux'сами. Есть конечно "вменяемые" модели, но есть и "невменяемые" и тогда обеспечены большие танцы с бубном.

Когда устанавливали 10-ку, разделы с диска удаляли? Судя по присутствию раздела FAT16 разделы не удалялись. Я бы предложил переустановить 10-ку, во время установки удалить все разделы и создать новые средствами установщика 10-ки. После установки 10-ки пробовать загружаться с установочной флешки Ubuntu.
Если установка Ubuntu пройдёт штатно, то загрузчика Ubuntu скорей всего видно не будет. Нужно поставить пароль BIOS (запишите пароль, чтобы не забыть), сохранить изменения, появится возможность включить Secure Boot и возможность добавить загрузчик Ubuntu через Select an UEFI file as trusted for executing. Это минимальный "набор" танцев, а дальше по результатам.
Вопрос: ISO образ Ubuntu

Скачал с сайта ubuntu.ru образ. разархивировал hamster(ом) в отдельную папку. Программой UltraISO попробовал записать образ на флешку, но не нашёл его. Такую же фишку пробовал через диск, но как я понял, причина моей не удачи в том, что мне надо записать iso образ. Где мне найти в папке?
Планирую ставить Ubuntu как вторую операционную систему.
Ответ:
Сообщение от Ice Cool
Скачал с сайта ubuntu.ru образ. разархивировал hamster(ом) в отдельную папку.
Во-первых, такие вещи надо качать с оф. сайта. Во-вторых, Ubuntu уже в ISO, её распаковывать не надо. Скачиваешь и сразу записываешь на носитель.
Сообщение от Ice Cool
Программой UltraISO попробовал записать образ на флешку, но не нашёл его.
Записывать образ Ubuntu надо, специализированными программами: либо , либо или dd.
Вопрос: Установить графический интерфейс на ubuntu server

Установил ubuntu server с флешки. А поставить графический интерфейс не могу. команда sudo apt-get update открывает две строки 1 строка игн: cdrom://ubuntu и т д про релиз яки як 16.10
2 строка сущ; cdrom://ubuntu тоже что и в первой , и обновление не происходит. команда sudo apt-get install ubuntu-desktop пишет что такого пакета не найдено.
Ответ: [QUOTE=Dmitry;9773139]мой вам совет - устанавливайте убунту, скачанную на сайте самой убунту

проверяйте контрольную сумму
и т.д. и т.п.
потому как nano устанавливается в убунте по умолчанию, а ответ означает, что какой-то умник его уже кастрировал[/QUOT

С помощья программы Rufus 2.11 сделал рабочую флешку и с неё и установил ubuntu. Всё поставилось, команды работают, файл sources.list смотрел, он вроде бы корректный. Теперь дождусь интернета и попробую обновиться и поставить всё что надо.

Спасибо за помощь.
Вопрос: Не запускается Ubuntu

После попытки установки Remix OS на жесткий диск, перестала запускается Ubuntu как вторая ОС. Вообще стоит две ос, это Ubuntu 16.04 LTS и Windows 8.1. При загрузке ноутбука, вместо grub'а выходит сообщение:

Unexpected return from initial read: Volume Corrupt, buffersize 19000
Failed to load image \EFI\ubuntu\grubx64.efi: Volume Corrupt
start_image() returned Volume Corrupt

После этого запускается Windows. Вообще Remix OS установился на диск :C, а значит в сам Windows. Думаю проблема с какими то файлами или с диском на котором установлена Ubuntu. Напишите хоть что нибудь, может я просто туплю, а может нужно заново ставить все ос. Заранее спасибо.
Ответ: Вы с установочной флешки Ubuntu загрузились правильно? В UEFI режиме? Попробуйте использовать Boot repair (ссылка выше), она сама всё сделает автоматом.
Вопрос: Установка Ubuntu рядом с Windows на одном жестком диске

Сейчас сижу на windows 8. Начитался про linux, решил начать с ubuntu. Записал образ, смотировал, посмотрел 100 видео по уставновке и т.д. Ближе к делу. Я разделил Жесткий диск(у меня ноутбук) на 2 тома. В запуске демо версии, при помощи консоли я увидил что ЖД имеет 2 тома. Пробывал через консоль установить папки, или директории - слабо получилось. Ну, начал обычную установку. Выбрал язык, согласился. И вот в чем беда. Он видит только ЖД без томов. но на ЖД у меня находятся жизненно необходимые файлы - снести все не могу. При уставке Ubuntu мне пишет что у меня все 750 гб свободны.

Из 750 ГБ, заполнено 400. Диск поделен на 2 тома (600 и 150 гб), Если я впишу что на /boot и прочие папки, и выделю под Ubuntu 100 ГБ, я не потеряю свои файлы?
Ответ:

Не по теме:

Информация о "неимоверных трудностях" безнадёжно устарела. Как, собственно, и большинство другой информации о потенциальных проблемах.
Gparted замечательно видит корректную разметку.

Сейчас Ubuntu, Mint или Debian проще в использовании чем венда. По крайней мере на типичной рабочей лошадке без топовых видюх. Мелкие козяблики на ноутах - решаемы.
Если есть неизлечимые проблемы, то это косяки со стороны железа (BIOS)