Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: Помогите прочитать xml

Есть вот такая строка:

<prices><price type="RRP" currencyId="KZT">109990</price><price type="Дилерская цена" currencyId="KZT">85117</price></prices>

Код в 1с такой:

Чт = Новый ЧтениеXML;
Чт.ОткрытьФайл(ИмяФайла);    
Пока Чт.Прочитать() Цикл

Если Чт.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда
ИмяРеквизта = Чт.Имя;

Если ИмяРеквизта = "price" Тогда
    Сообщить(Чт.ЗначениеАтрибута(0));
    Сообщить(Чт.ЗначениеАтрибута(1));
КонецЕсли; 

КонецЕсли;

КонецЦикла;

В сообщении выдает:
RRP
KZT
Дилерская цена
KZT

Как получить цену 85117?
Ответ: Все получилось через Чт.ТипУзла = ТипУзлаXML.Текс спасибо.
Вопрос: Прочитать/ записать данные в ресурс регистра с типом хранилище значения

Всем привет! Как записать/ прочитать данные в ресурс регистра с типом "ХранилищеЗначения" ? Я чайник. Если можно, подробный пример с кодом.
Ответ: Большое спасибо! Помогли разобраться!
Вопрос: Помогите настроить сканер ШК для нового документа

Конфигурация УТ 11. Имеется подключенный сканер ШК, работает нормально.

Дописал свой документ.
В форме документа написал обработчик событий Обработка оповещения и Внешнее событие.
Если открыть форму моего документа и прочитать сканером какой-нибудь  штрихкод, то ни одно из этих событий не происходит. Однако, если открыть мой документ и документ РеализацияТоваровИУслуг(одновременно), то начинают возникать оба события в моем документе. Причем не важно,  форма какого документа активна.
Явно что-то я не доделываю. Подскажите пожалуйста, что надо сделать, чтобы сканер работал нормально.
Спасибо.
Ответ: Большое спасибо. Очень помогли.

На всякий случай добавлю,может комк пригодится:

в реквизиты формы надо добавить два реквизита:

ИспользоватьПодключаемоеОборудование
и
ПоддерживаемыеТипыПодключаемогоОборудования
Вопрос: Помогите с сохранением выгрузки в сбербанк выписка квитанции

Добрый день народ! Помогите решить проблему с выгрузкой родительской платы в сбербанк. Ломаю голову не могу сохранить в отдельный файл значения в отдельности для каждого учреждения выписки квитанции. Сохраняет только по последнему выбранному учреждению в табличной части обработки во все файл. Если например я заполняю 3 учреждения МБДОУ № 9,МБДОУ № 11,МБДОУ № 13 то берет в три файла детишек именно МБДОУ № 13. Простите если что недопонимаю но мне кажется тут ошибка. На скриншоте видно.

Для Каждого СтрокаТаблицы ИЗ АнализВыгрузки Цикл;
Текст.Записать((СтрокаТаблицы.ИмяФайлаВыгрузки), "windows-1251");
КонецЦикла;

Вложения:

  • Размер файла:
    14,7 КБ
    Просмотров:
    1
  • Размер файла:
    37,2 КБ
    Просмотров:
    8
Ответ:
Перем СписокДок;
Перем мСписокВидовОпераций;
Перем мВалютаРегламентированногоУчета;

Процедура КнопкаНастройкаПериодаНажатие(Элемент)

ТиповыеОтчеты.НастроитьПериод(НастройкаПериода, ДатаНачала, ДатаОкончания);

КонецПроцедуры

Функция ВернутьУчреждение()
СтрокаТаблицы = ЭлементыФормы.АнализВыгрузки.ТекущиеДанные;
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
| яяСоответствиеУчреждений.КодУчреждения
|ИЗ
| РегистрСведений.яяСоответствиеУчреждений КАК яяСоответствиеУчреждений
|ГДЕ
| яяСоответствиеУчреждений.Учреждение В (&Учреждение)";
Запрос.УстановитьПараметр("Учреждение",СтрокаТаблицы.Учреждение);
Выборка = Запрос.Выполнить().Выбрать();
Если Выборка.Следующий() Тогда
РезультатВыборки= Выборка.КодУчреждения;
КонецЕсли;

//Сообщить("Не найдено соответствие учреждения по коду: "+СокрЛП(КодУчреждения));

Возврат РезультатВыборки;

КонецФункции

Функция ПолучитьИННУчрежденияДляВыгрузкиВФайл()
СтрокаТаблицы = ЭлементыФормы.АнализВыгрузки.ТекущиеДанные;

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| Организации.ИНН КАК ИННУчреждения
|ИЗ
| Справочник.Организации КАК Организации
|ГДЕ
| Организации.Ссылка В (&Учреждение)";

Запрос.УстановитьПараметр("Учреждение",СтрокаТаблицы.Учреждение);

РезультатЗапроса = Запрос.Выполнить();

ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
РезультатВыборки = ВыборкаДетальныеЗаписи.ИННУчреждения;
КонецЦикла;

Возврат РезультатВыборки;

КонецФункции

Процедура КнопкаВыгрузитьНажатие(Кнопка)


Текст = Новый ТекстовыйДокумент;
Запрос = Новый Запрос;

ТекстЗапроса = "ВЫБРАТЬ
| СоответствиеУчреждений.КодУчреждения КАК Код,
| РП_ВыпискаКвитанций.Учреждение.Наименование КАК Наименование,
| ВЫБОР
| КОГДА (ВЫРАЗИТЬ(РП_ВыпискаКвитанций.РеквизитыЛицевогоСчета.КорреспондентТекст КАК СТРОКА(1000))) = """"
| ТОГДА РП_ВыпискаКвитанций.Учреждение.НаименованиеПолное
| ИНАЧЕ РП_ВыпискаКвитанций.РеквизитыЛицевогоСчета.КорреспондентТекст
| КОНЕЦ КАК НаименованиеПолное,
| ВЫБОР
| КОГДА РП_ВыпискаКвитанций.РеквизитыЛицевогоСчета.КорреспондентИНН = """"
| ТОГДА РП_ВыпискаКвитанций.Учреждение.ИНН
| ИНАЧЕ РП_ВыпискаКвитанций.РеквизитыЛицевогоСчета.КорреспондентИНН
| КОНЕЦ КАК ИНН,
| ВЫБОР
| КОГДА РП_ВыпискаКвитанций.РеквизитыЛицевогоСчета.КорреспондентКПП = """"
| ТОГДА РП_ВыпискаКвитанций.Учреждение.КПП
| ИНАЧЕ РП_ВыпискаКвитанций.РеквизитыЛицевогоСчета.КорреспондентКПП
| КОНЕЦ КАК КПП,
| РеквизитыЛицевыхСчетов.БИК,
| РеквизитыЛицевыхСчетов.КоррСчет,
| РеквизитыЛицевыхСчетов.НаименованиеБанка,
| РеквизитыЛицевыхСчетов.РасчетныйСчет,
| РП_ВыпискаКвитанций.Учреждение.КодОКАТО КАК ОКАТО,
| РП_ВыпискаКвитанций.КБКСчетУчетаРП,
| РП_ВыпискаКвитанций.Ссылка
|ИЗ
| Документ.РП_ВыпискаКвитанций КАК РП_ВыпискаКвитанций
| ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
| РеквизитыЛицевыхСчетов.СчетКазначейства.КассовыйОрган.Код КАК БИК,
| РеквизитыЛицевыхСчетов.СчетКазначейства.КассовыйОрган.КоррСчет КАК КоррСчет,
| РеквизитыЛицевыхСчетов.СчетКазначейства.КассовыйОрган.Наименование КАК НаименованиеБанка,
| РеквизитыЛицевыхСчетов.СчетКазначейства.Код КАК РасчетныйСчет,
| РеквизитыЛицевыхСчетов.Ссылка КАК Ссылка
| ИЗ
| Справочник.РеквизитыЛицевыхСчетов КАК РеквизитыЛицевыхСчетов
| ГДЕ
| РеквизитыЛицевыхСчетов.Владелец.ТипЛицевогоСчета = ЗНАЧЕНИЕ(Перечисление.ТипыЛицевыхСчетов.Казначейский)
|
| ОБЪЕДИНИТЬ ВСЕ
|
| ВЫБРАТЬ
| РеквизитыЛицевыхСчетов.КассовыйОрган.Код,
| РеквизитыЛицевыхСчетов.КассовыйОрган.КоррСчет,
| РеквизитыЛицевыхСчетов.КассовыйОрган.Наименование,
| РеквизитыЛицевыхСчетов.Владелец.Код,
| РеквизитыЛицевыхСчетов.Ссылка
| ИЗ
| Справочник.РеквизитыЛицевыхСчетов КАК РеквизитыЛицевыхСчетов
| ГДЕ
| РеквизитыЛицевыхСчетов.Владелец.ТипЛицевогоСчета = ЗНАЧЕНИЕ(Перечисление.ТипыЛицевыхСчетов.Банковский)) КАК РеквизитыЛицевыхСчетов
| ПО РП_ВыпискаКвитанций.РеквизитыЛицевогоСчета.Ссылка = РеквизитыЛицевыхСчетов.Ссылка
| ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
| яяСоответствиеУчреждений.КодУчреждения КАК КодУчреждения,
| яяСоответствиеУчреждений.Учреждение КАК Учреждение
| ИЗ
| РегистрСведений.яяСоответствиеУчреждений КАК яяСоответствиеУчреждений) КАК СоответствиеУчреждений
| ПО РП_ВыпискаКвитанций.Учреждение.Ссылка = СоответствиеУчреждений.Учреждение.Ссылка
|ГДЕ
| РП_ВыпискаКвитанций.Дата >= &НачПериода
| И РП_ВыпискаКвитанций.Дата <= &КонПериода
| И РП_ВыпискаКвитанций.Проведен = ИСТИНА
| И РП_ВыпискаКвитанций.Учреждение В(&Учреждение)
|
|УПОРЯДОЧИТЬ ПО
| Код";

Запрос.Текст = ТекстЗапроса;


Для Каждого СтрокаТаблицы ИЗ АнализВыгрузки Цикл;

Запрос.УстановитьПараметр("Учреждение",СтрокаТаблицы.Учреждение);

КонецЦикла;

Запрос.УстановитьПараметр("НачПериода", НачалоДня(ДатаНачала));
Запрос.УстановитьПараметр("КонПериода", КонецДня(ДатаОкончания));

ВыборкаДокументов = Запрос.Выполнить().Выбрать();

ТекстЗапроса = "ВЫБРАТЬ
| РП_ВыпискаКвитанцийКвитанции.Ребенок.Код КАК ЛицевойСчет,
| РП_ВыпискаКвитанцийКвитанции.Ссылка.ГруппаДетскогоУчреждения.Наименование КАК Группа,
| ВложенныйЗапрос.ЗначениеХарактеристики КАК ДатаРождения,
| РП_ВыпискаКвитанцийКвитанции.Ребенок.Контрагент.Фамилия + "" "" + РП_ВыпискаКвитанцийКвитанции.Ребенок.Контрагент.Имя + "" "" + РП_ВыпискаКвитанцийКвитанции.Ребенок.Контрагент.Отчество КАК ФИО,
| РП_ВыпискаКвитанцийКвитанции.Сумма,
| РП_ВыпискаКвитанцийКвитанции.Ссылка.КБКСчетУчетаРП КАК КБК,
| яяСоответствиеУчреждений.КодУчреждения КАК КодУчреждения,
| яяСоответствиеУчреждений.Учреждение КАК УЧРЕЖДЕНИЕ
|ИЗ
| Документ.РП_ВыпискаКвитанций.Квитанции КАК РП_ВыпискаКвитанцийКвитанции
| ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
| ХарактеристикиКонтрагентов.ЗначениеХарактеристики КАК ЗначениеХарактеристики,
| Дети.Ссылка КАК Ссылка
| ИЗ
| Справочник.Дети КАК Дети
| ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ХарактеристикиКонтрагентов КАК ХарактеристикиКонтрагентов
| ПО Дети.Контрагент = ХарактеристикиКонтрагентов.Контрагент
| ГДЕ
| ХарактеристикиКонтрагентов.ВидХарактеристики = ЗНАЧЕНИЕ(ПланВидовХарактеристик.ВидыХарактеристикКонтрагентов.ДатаРождения)) КАК ВложенныйЗапрос
| ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.яяСоответствиеУчреждений КАК яяСоответствиеУчреждений
| ПО ВложенныйЗапрос.Ссылка.Учреждение = яяСоответствиеУчреждений.Учреждение
| ПО РП_ВыпискаКвитанцийКвитанции.Ребенок.Ссылка = ВложенныйЗапрос.Ссылка
|ГДЕ
| РП_ВыпискаКвитанцийКвитанции.Ссылка = &Ссылка";

СчетчикЗадолженностей = 0;

Пока ВыборкаДокументов.Следующий() Цикл

Запрос.Текст = ТекстЗапроса;

Запрос.УстановитьПараметр("Ссылка", ВыборкаДокументов.Ссылка);
ВыборкаДети = Запрос.Выполнить().Выбрать();
Пока ВыборкаДети.Следующий() Цикл

СчетчикЗадолженностей = СчетчикЗадолженностей + 1;

Текст.ДобавитьСтроку(СокрЛП(ВыборкаДети.ЛицевойСчет)+
";"+СокрЛП(ВыборкаДети.ФИО)+
";"+СокрЛП(СтрокаТаблицы.Учреждение)+
";"+СокрЛП("000"+ВыборкаДети.КБК)+
";"+СокрЛП("04701000")+
";"+Формат(ВыборкаДети.Сумма, "ЧГ=0; ЧН=0.00; ЧРД='.'; ЧЦ=15; ЧДЦ=2"));

КонецЦикла;


КонецЦикла;


Для Каждого СтрокаТаблицы ИЗ АнализВыгрузки Цикл;
Текст.Записать((СтрокаТаблицы.ИмяФайлаВыгрузки), "windows-1251");
КонецЦикла;


Сообщить("Выгрузка успешно выполнена",СтатусСообщения.Информация);

ОбработкаПрерыванияПользователя();

КонецПроцедуры

Процедура ОткрытьФайлДляПросмотра(Элемент, Заголовок)

СтандартнаяОбработка = Ложь;

ФайлНаДиске = Новый Файл(Элемент.Значение);
Если Не ФайлНаДиске.Существует() Тогда
Предупреждение("Не найден файл!");
Возврат;
КонецЕсли;

Текст = Новый ТекстовыйДокумент();
Текст.Прочитать(Элемент.Значение);
Текст.Показать(Заголовок,Элемент.Значение);

КонецПроцедуры



Процедура ПриОткрытии()

УдалятьФайлы = Истина;

КонецПроцедуры

Процедура АнализВыгрузкиУчреждениеПриИзменении(Элемент)
СтрокаТаблицыВыгрузки = ЭлементыФормы.АнализВыгрузки.ТекущиеДанные;
СтрокаТаблицыВыгрузки.КодУчреждения = ВернутьУчреждение();
СтрокаТаблицыВыгрузки.ИНН = ПолучитьИННУчрежденияДляВыгрузкиВФайл();
КонецПроцедуры

Процедура АнализВыгрузкиИмяФайлаВыгрузкиНачалоВыбора(Элемент, СтандартнаяОбработка)
//
СтрокаТаблицы = ЭлементыФормы.АнализВыгрузки.ТекущиеДанные;
СтандартнаяОбработка = Ложь;
ДиалогВыбораФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Сохранение);
ДиалогВыбораФайла.МножественныйВыбор = Ложь;
ДиалогВыбораФайла.Заголовок = "Укажите имя файла выгрузки";
ДиалогВыбораФайла.ПолноеИмяФайла = СокрЛП(СтрокаТаблицы.ИНН)+"_sberbank_RP_Plata";

ДиалогВыбораФайла.Фильтр = "Текстовые(*.txt)|*.txt";
Если ДиалогВыбораФайла.Выбрать() Тогда
СтрокаТаблицы.ИмяФайлаВыгрузки = ДиалогВыбораФайла.ПолноеИмяФайла;
КонецЕсли;

КонецПроцедуры

Процедура АнализВыгрузкиИмяФайлаВыгрузкиОткрытие(Элемент, СтандартнаяОбработка)
СтандартнаяОбработка = ложь;
ОткрытьФайлДляПросмотра(Элемент,"Файл выгрузки");
КонецПроцедуры

Процедура АнализВыгрузкиИННПриИзменении(Элемент)
СтрокаТаблицыВыгрузки = ЭлементыФормы.АнализВыгрузки.ТекущиеДанные;
СтрокаТаблицыВыгрузки.КодУчреждения = ВернутьУчреждение();
СтрокаТаблицыВыгрузки.ИНН = ПолучитьИННУчрежденияДляВыгрузкиВФайл();

КонецПроцедуры

Процедура АнализВыгрузкиУчреждениеОкончаниеВводаТекста(Элемент, Текст, Значение, СтандартнаяОбработка)
СтрокаТаблицыВыгрузки = ЭлементыФормы.АнализВыгрузки.ТекущиеДанные;
СтрокаТаблицыВыгрузки.КодУчреждения = ВернутьУчреждение();
КонецПроцедуры

Процедура АнализВыгрузкиПриОкончанииРедактирования(Элемент, НоваяСтрока, ОтменаРедактирования)
СтрокаТаблицыВыгрузки = ЭлементыФормы.АнализВыгрузки.ТекущиеДанные;
СтрокаТаблицыВыгрузки.КодУчреждения = ВернутьУчреждение();
КонецПроцедуры



СписокДок = Новый СписокЗначений;
НастройкаПериода = Новый НастройкаПериода;
мВалютаРегламентированногоУчета = Константы.ВалютаРегламентированногоУчета.Получить();
Вопрос: Помогите скачать с infostar

Доброго времени суток!
Помогите плиз скачать обработку с инфостар по расчету пени.
И вдруг у кого есть возможность скачать или есть такая обработка - но как я понял она платная.
Заранее большое спасибо!
почта

Ссылки - на сторние ресурсы будем рубить- в личку пишите если кто надумает помочь
Ответ:
Помогите скачать обработку с инфостарта. Спасибо!
Обработка:
и выслать на
еще раз большое спасибо!
Вопрос: помогите с обработкой

Здравствуйте, помогите найти и исправить обработку.
Работаю на платформе 8.3, конфигурации УТ 11.1
Я создала обработку для печати "товарной накладной торг-12" в документе "реализация товаров и услуг", в подвале которой добавилась подпись и фио менеджера который оформил сделку.
при добавлении внешней обработки и формировании документа выдает ошибку.

Вложения:

  • Размер файла:
    433,6 КБ
    Просмотров:
    15
  • Размер файла:
    325,2 КБ
    Просмотров:
    17
  • Размер файла:
    337,2 КБ
    Просмотров:
    16
  • Размер файла:
    31,2 КБ
    Просмотров:
    4
Ответ:
Поиск по форуму поможет, недавно только товарищ мучился с ВПФ.
Вопрос: Помогите подобрать конфигурацию

Здравствуйте. Помогите подобрать конфигурацию 1С8.
Необходимо: продажа, оказание услуг, ответственное хранение + распределенная база (1 центральный + 3 точки).
Спасибо.
Ответ:
Да это задача знакомого. Попросил помочь.
Он ИП, бухучет не нужен ему.
Но к сожалению оказалось что он уже Розницу купил. Жалко конечно. Хоть додумался профессиональную, а не базовую версию взять.
Вопрос: Помогите упорядочить запрос 1с 8.3

Добрый день!
Помогите, плис, упорядочить запрос по ПланируемаяДата, которая находится в таблице документа ПланыПоСобытию!!! Не выходит....
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| СобытиеКонтра.Ссылка КАК СобытиеКонтраСсылка,
| СобытиеКонтра.ПланыПоСобытию.(ПланируемаяДата КАК ПланируемаяДата)
|ИЗ
| Документ.Событие КАК СобытиеКонтра
|ГДЕ
| (СобытиеКонтра.ПланыПоСобытию.ПланируемаяДата между &НачПер и &КонПер)
|УПОРЯДОЧИТЬ ПО
| ПланируемаяДата";
Ответ:
Спасибо ! Мне помогли Ваши рекомендации
Вопрос: Не удается прочитать файл.

Доброго дня! 1с8.3 конфа самописная. Не удается вывести текст из файла тхт в поле ввода, вылетает
Не удалось прочитать файл: {Обработка.ОтправкаПисем.Форма.Форма1.Форма()}: Значение не является значением объектного типа (Прочитать)

Ума не хватает самому дойти до причины, подскажите пожалуста

Процедура ЗагрузитьТекстИзФайла()
    
   ДТФ = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
   ДТФ.Заголовок = "Выберите файл (*.TXT/.RTF.HTML*)";
   ДТФ.Фильтр = "Текстовый Документ (*.txt;*.doc;*.rtf)|*.txt;*.doc;*.rtf|";
   ДТФ.ПредварительныйПросмотр=Ложь;
   ДТФ.ПроверятьСуществованиеФайла=Истина;
   Если ДТФ.Выбрать() Тогда
       
   ПутьКТфайлу = ДТФ.ПолноеИмяФайла;
        КонецЕсли;
        Попытка
   ТекстПисьма.Прочитать(ПутьКТФайлу);
        Исключение
   Сообщить("Не удалось прочитать файл: " + ОписаниеОшибки(),СтатусСообщения.ОченьВажное);
   Сообщить(ДТФ.ПолноеИмяФайла,СтатусСообщения.ОченьВажное);
        Возврат;
        КонецПопытки;    
        
    КонецПроцедуры    

Процедура ОтправитьПисьма()
Ответ: Скажите кто нибудь, возможно ли из текстового файла записывать текст в поле ввода?
Вопрос: Метод прочитать() и РЛС

Здравствуйте

подскажите, метод прочитать() регистра накопления  считывает данные с учетом отработки рлса?
например в запросе, чтобы запрос отрабатывал с учетом рлса нужно добавлять "разрешенные", прочитать() отрабатывает с "разрешенные" или будет ошибка "у пользователя недостаточно прав" ?

Заранее благодарен
Ответ: ()
Почти в самом конце почитай.